Jump to content

[1.0.4] SteamGauges V1.7.2 - 27 July '15


Trueborn
 Share

Recommended Posts

I love the air gauge! EAS, mach, AOA, stall warning, and air intake efficiency, all consolidated in an easy-to-read format. Beautiful. :)

Ever considered a vertical speed indicator? When flying reentry in a plane I often find it useful to keep an eye on vertical speed, but the stock VSI lacks fine detail.

Link to comment
Share on other sites

I love the air gauge! EAS, mach, AOA, stall warning, and air intake efficiency, all consolidated in an easy-to-read format. Beautiful. :)

Ever considered a vertical speed indicator? When flying reentry in a plane I often find it useful to keep an eye on vertical speed, but the stock VSI lacks fine detail.

I have, but then I always keep coming back to the fact that there is a VSI right there in the stock UI. Same reason I've never done an altimeter. The HUD does have a VSI readout (two, actually).

And Thorbane, I found the offending line of debug code. I'll release a patch later today.

Link to comment
Share on other sites

Yeah, after writing the above post I started experimenting with the HUD, scaling it way down and moving it to one side like a standalone instrument. The VSI there works perfectly well.

Link to comment
Share on other sites

Click on the options button, which will bring up a menu with a toggle for unlocking the gauge positions. Click and drag them where you want, then lock the positions again. Note that toolbar will not initially display any of the buttons, so you might have to turn them on first.

Link to comment
Share on other sites

So how do I get the hud to work in Career mode? I have an already running save started in 1.02 and already unlocked the Aviation tech. I tried various things, ultimately leading to the creation of a new career, unlocking the Aviation tech, and it still doesn't work. Shows up just fine in Sandbox, but all the Kerbals are 5 stars. Is it linked to Kerbal xp? I just want it available no in game requirement fuss.

- - - Updated - - -

How do I get it to work in career mode? I have an existing save with Aviation already unlocked. I've tried several things all leading to creating a new save and, unlocking Aviation, and it still doesn't work. It works just fine in Sandbox, and the only other difference I can think of is pilot xp. I just want to use the hud free from ingame requirements.

Link to comment
Share on other sites

In version 1.7.1, Aviation is all that is required. Try pressing Alt-H, which toggles the HUD off and on. If you want to change which technology unlocks the HUD, find the name of the tech in the research building and put it in the steamgauges config file after "HUDtechnology".

Link to comment
Share on other sites

Sorry for the double post I thought it ate it the first time.

I've tried Alt-H, the tool bar button, and changing it to a different tech node. I even created a new save, used the cheat menu to get a bunch of science, and unlocked the entire tech tree, and yet it doesn't work. It works just fine in sandbox.

Link to comment
Share on other sites

Click on the options button, which will bring up a menu with a toggle for unlocking the gauge positions. Click and drag them where you want, then lock the positions again. Note that toolbar will not initially display any of the buttons, so you might have to turn them on first.

Left click or right click?

Link to comment
Share on other sites

  • 3 weeks later...

I just ran a quick check and there don't seem to be any compile level issues. I'll have to do a little bit of work with the new temperature model to determine what I should be displaying on the temperature gauge, but I'll hopefully have a test build out tomorrow.

Link to comment
Share on other sites

Just wanted to say "thank you" for keeping up with this mod. It's my #1 must have since WAY back ;)

PS how do you get the CKAN folks to include this?

You're welcome. As for your question, ask them would be my first thought. Haven't looked into it though.

Here is a link to SteamGauges 1.7.2a, a trial release for KSP 1.0.4 compatibility. The only change is that the temperature gauge now looks at both internal and skin temperatures, and still reports the highest (percentage) temperature.

Link to comment
Share on other sites

Umm... I got Toolbar and it's working but I still can't find SteamGauges... Anything I did wrong again...

(Sorry If I'm Being A Stubborn Guy)

In that case, you're going to have to be a little more specific. You can take a look though your KSP.log and see if anything pops up with Steamgauges in it, or just post it here.

Link to comment
Share on other sites

At the moment I cannot view the log but while I was on KSP, I chose to edit the folder (Toolbar Option) then I added HUD, it popped up, but... It gave me a small window with nothing inside it. The picture is the HUD Display Symbol. I tried a different gauge, nothing... I'm really sorry if I'm kind of being a really stubborn guy...

(Note: I'll be gone from my Computer so I won't be able to view/play anything)

Also, thanks for helping me so far :)

Edited by SERPERNTINE
Make it more clear
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...