Athlonic

[1.3.x] LCD - Launch CountDown v1.7.9 [28 May 2017]

Recommended Posts

Sure.

Let me just finish "South Park - The stick of truth" and I will get my hand back on it ^^

(Cartman voice) God dammit!!

Share this post


Link to post
Share on other sites

Hey, nice mod, im having a problem though, KSP lags alot on my computer, so the countdown is a lagged, and it looks so bad! Because of the background sound cuts every clip, yea, i know, there wouldn't really be any solution to this, other than running the game at 2x times acceleration... Anyways, awesome mod!

Share this post


Link to post
Share on other sites

Is the mission clock yellow? If so then it's the game slowing down to handle the physics load and thus the countdown slows as well. You can adjust this in the settings menu

Share this post


Link to post
Share on other sites

its the physics delta time slider in the main settings menu. Slide it to the left until you get better performance (at the loss of some physics calculations)

Share this post


Link to post
Share on other sites

Athlonic ,maybe you or someone else could make a kerbalized version of this

or something similar and maybe add it to this mod. Edited by mrsinister

Share this post


Link to post
Share on other sites
I think this here is what you want, see the sound overhaul project thread

uhmm.. maybe you misunderstand...that link you posted, links to this mod. I stated a kerbalized version of the shuttle launch meaning the countdown and spoken bits. not the actual sounds of engines and what not. lol I have the rcs by Nothke. we are talking countdown audio and maybe some "guidance go ,retro's go ,etc" audio during countdown, since that's what this thread is about.

like this one i quickly made (non-kerbalized): Control tower audio for shuttle (or anything really)

Edited by mrsinister
added dl link for my sound file

Share this post


Link to post
Share on other sites
uhmm.. maybe you misunderstand...

Yes, I really shouldn't try posting in the morning before coffee... :D

Share this post


Link to post
Share on other sites

V1.7 released

Changelog :

v 1.7 :

- Added back Kerbalized audio set (made it default)

- Plugin now clear audio collections on part unload to free up memory

;)

Share this post


Link to post
Share on other sites

I'd recommend these be added to the part.cfg file as well


@PART[FASAlaunchClamp125]
{
MODULE
{
name = LaunchCountDown
}
MODULE
{
name = LaunchUI
}
}
@PART[FASAlaunchClamp25]
{
MODULE
{
name = LaunchCountDown
}
MODULE
{
name = LaunchUI
}
}
@PART[FASA_Launch_Clamp_Atlas]
{
MODULE
{
name = LaunchCountDown
}
MODULE
{
name = LaunchUI
}
}

Share this post


Link to post
Share on other sites

@ Gaiiden

Here you go, thanks for the suggestion ;)

v 1.7.1 changelog :

- Recompiled for KSP 0.23.5 (to be on the safe side)

- Added frizzank's FASA launchclamps compatibility (ModuleManager cfg)

- Added a Debug option (spam the log with useless stuff)

- Audioclips stop when entering settings

Share this post


Link to post
Share on other sites

This looks quite exciting! It's definitely something that's missing from the vanilla game! And compatible with FASA launch clamps too, that's awesome! I'll be trying this out asap :D

Share this post


Link to post
Share on other sites

Can we have some Unmanned flight countdowns? I want to launch a rocket without it saying "Astronauts feel good" or something similar like that.

Share this post


Link to post
Share on other sites

This is an excellent idea Codey737.

I will have some free time in two weeks, finally.

I add this on the todo list.

Share this post


Link to post
Share on other sites

Athonic,What clamps specifically In the FASA Pack,I launched the ATLAS No window popped up,I cannot find those parts! Please reply,Thank you!

Share this post


Link to post
Share on other sites

Yeah, a countdown for unmanned launch would be great.

Share this post


Link to post
Share on other sites
Can we have some Unmanned flight countdowns? I want to launch a rocket without it saying "Astronauts feel good" or something similar like that.

"Probe feels good T-25 seconds!"

lol that'd be hilarious

Share this post


Link to post
Share on other sites

The mmConfig file is wrong. "FASA_Launch_Clamp_Atlas" has no effect, because the clamp name is "FASAlaunchClampAtlas".

But you can do it much simpler, using my mmConfig:

//> ADD LAUNCH COUNTDOWN PLUGIN TO ALL LAUNCH CLAMPS

@PART[*launchClamp*]
{
MODULE
{
name = LaunchCountDown
}
MODULE
{
name = LaunchUI
}
}

This is using wildcards (*) and means all parts with "launchClamp" in it's name gets the countdown stuff :)

Edited by acc

Share this post


Link to post
Share on other sites

Is there a fix for the "all engines running" bug I reported a while back? Summary of bug: on the FASA clamps, trying to use the launch countdown right away results in an "all engines running" message. If I use the launch towers, I do not get the message. If I use both clamps and towers, the message is there.

Share this post


Link to post
Share on other sites

@acc

Thanks for the wildcards tip, I will use this way for the next update.

@leops1984

Sorry I didn't have my expected free time last week to test FASA mod and to work on updates.

Still on my todo list though ;)

Share this post


Link to post
Share on other sites

I use the FASA clamps too. Had no issues

Share this post


Link to post
Share on other sites

@Athlonic: Sorry if I sounded demanding - it's just something that bugs me to hell.

@acc: Interesting, that means I'll have to look into my (many) installed mods to figure this out... has anyone else seen this problem with their setups?

Share this post


Link to post
Share on other sites
@acc: Interesting, that means I'll have to look into my (many) installed mods to figure this out... has anyone else seen this problem with their setups?

Not on the 125 clamps - but those are all I've ever used to date. Even when used with the tower (all latest versions) I have no countdown issues. What clamps are you using?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.