taniwha

[1.2-1.7] Blender (2.80) .mu import/export addon

Recommended Posts

2 hours ago, linuxgurugamer said:

Folder is another name for directory

So it should work? Please excuse my ignorance.

I resolved the problem myself. Thanks for the help.

Edited by Wolfair corp.

Share this post


Link to post
Share on other sites

This add-on wasn't showing up for me because when I downloaded the release it had . (dot) in the folder name.  I didn't put 2 and 2 together at first...

  1. Get the release from GitHub
  2. Extract it
  3. Rename the folder (directory) and REMOVE THE 1.0.0 (or whatever the current version number)
  4. Move the folder to "C:\Program Files\Blender Foundation\Blender\2.78\scripts\addons\" (or where ever your Blender install is)
  5. It should now appear in the add-ons tab of User Preferences
  6. Type "KSP" in the search box to find it.

(Author, you should add this to the OP)

Share this post


Link to post
Share on other sites
On 8/4/2013 at 5:05 AM, taniwha said:

For the blender addon, you just copy the entire directory into your addons directory, enable it like any other addon (there are tuts for this on places like blendercookie.com), and then File->Import->KSP Mu. Export is not working yet.

For using mu.py for creating utilities, it would probably be best to study the code and import.py.

I'm sorry I can't be of more help just now. This is very much a work in progress (I announced it now only because I used it to help fix the Extraplanetary Launchpads auger), and I'm a bit busy trying to help fix bugs in the mod.

Hey,But still i copied the files into the addons but when i open and try to File>Export there isn't any like KSP mu. like that can you please help

Share this post


Link to post
Share on other sites
15 hours ago, Kerbal Nerd123 said:

Hey,But still i copied the files into the addons but when i open and try to File>Export there isn't any like KSP mu. like that can you please help

You import the MU. in blender and export it has a DAE  and some think use OBJ and for animation parts FBX then import it into Unity and set things up

Share this post


Link to post
Share on other sites

No need to export to DAE unless you need animation features that aren't supported yet. You need to select the root object of the model's hierarchy in order to export using my addon.

Share this post


Link to post
Share on other sites
7 hours ago, techgamer17 said:

How on earth do you install this?

 

On 8/3/2013 at 7:35 PM, taniwha said:

For the blender addon, you just copy the entire directory into your addons directory, enable it like any other addon (there are tuts for this on places like blendercookie.com), and then File->Import->KSP

 
 
Edited by TheRagingIrishman

Share this post


Link to post
Share on other sites
On 1/5/2017 at 0:11 AM, TheRagingIrishman said:

 

@TheRagingIrishman Can you be a little more helpful?  Copying the files to the addon directory does nothing and googling "how to install blender addon" tells me to open the file in User PReferences, but that also doesn't do anything.  Can you give us a step-by-step?

Share this post


Link to post
Share on other sites
21 minutes ago, marchingknight11 said:

@TheRagingIrishman Can you be a little more helpful?  Copying the files to the addon directory does nothing and googling "how to install blender addon" tells me to open the file in User PReferences, but that also doesn't do anything.  Can you give us a step-by-step?

  1. Download the latest release from Github
  2. Unzip the file.
  3. Rename the folder from "io_object_mu-1.0.0" to "io_object_mu"
  4. Copy the "io_object_mu" folder to the Blender addons folder (path should look like /Scripts/addons/io_object_mu/(a bunch of .py files))
  5. Open up Blender
  6. Open "User Preferences" (in the file tab)
  7. Go the "Add-ons" tab
  8. Go to the "User" category
  9. Make sure that "Import-Export: Mu model format (KSP) is ticked on

Just did this on my computer and it worked. If you have any problems with it let me know where in the process it doesn't seem to work.

Share this post


Link to post
Share on other sites
2 minutes ago, TheRagingIrishman said:
  1. Download the latest release from Github
  2. Unzip the file.
  3. Rename the folder from "io_object_mu-1.0.0" to "io_object_mu"
  4. Copy the "io_object_mu" folder to the Blender addons folder (path should look like /Scripts/addons/io_object_mu/(a bunch of .py files))
  5. Open up Blender
  6. Open "User Preferences" (in the file tab)
  7. Go the "Add-ons" tab
  8. Go to the "User" category
  9. Make sure that "Import-Export: Mu model format (KSP) is ticked on

Just did this on my computer and it worked. If you have any problems with it let me know where in the process it doesn't seem to work.

There is nothing listed in the User category.

Share this post


Link to post
Share on other sites
10 minutes ago, marchingknight11 said:

There is nothing listed in the User category.

Sorry but I really don't know how to help you. I just went throught the instructions exactly and got it to work. The only ideas I can offer are

  1. Are you sure you're putting it in the right Add-on folder?
  2. Did you restart Blender after adding the files?

Share this post


Link to post
Share on other sites

When I copy the folder to the main app directory C:\Program Files\Blender Foundation it appears under All. I believe it would appear under User if it was copied to the user blender directory in C:\Users\YourUsername\AppData\Roaming\Blender Foundation.

That's how it worked for me. And yeah, the dot matters. That's where I was stuck at too.

 

Edited by Kerbital

Share this post


Link to post
Share on other sites

A bit of an update as there are some new developments since 1.0.0:

  • .mu version 4 support works better (fixed the NRE when loading certain models that have been through an import/export cycle: caused by generating Renderers without materials).
  • Exported lights support layer 31 (would cause a python exception previously)
  • Attach node (both stack and attach) support. This is a little complicated, but it makes life much easier for cfg creation...
    • Place an empty where you want the node.
    • Orient the empty such that its Z-axis is pointing in the desired direction of the attach node (eg, for node_stack_bottom, it would be pointed down). The X-axis and Y-axis do not matter, so it might be reasonable to set the empty's display type to single arrow.
    • Name the empty such that it starts with "node". When exported, the nodes will be sorted such that node_stack_top, node_stack_bottom and node_attach will come after any other node_stack_* nodes.
    • Create a part config file named modelname.cfg.in that has all config items except the nodes: when the model is exported, the file name of the model will be used as a basis (modelname.mu -> modelname.cfg.in), the nodes will be added automatically and the resulting part configuration written to modelname.cfg (all in the same directory as where modelname.mu is written).

Note that the cfg parse/generation mentioned above is fully optional: if modelname.cfg.in does not exist, the process will be skipped.

Share this post


Link to post
Share on other sites

it's pushed to github. Since I've never really released the addon (installable zip), I don't know what to call it.

Share this post


Link to post
Share on other sites

@taniwha That's one big sensation for the modelling community! I could finally import every stock model of KSP 1.2

Meow! :3

Share this post


Link to post
Share on other sites
On 10/13/2016 at 2:19 PM, zlsa said:

I'm having a problem with normals in my exported model:

http://imgur.com/a/vjr56

It only affects the visuals when the part has the "mouseover" effect. Has anyone seen this, or better yet, found a solution? Thanks in advance for the help!

@taniwha  I seem to be having trouble getting normals to export correctly. I can import a model without doing anything to it, export it and the normals are wrong .  same problem ^ he was having.

no matter how much I try i can not get them to work.

Share this post


Link to post
Share on other sites

@Arcturusvfx (and @zlsa): I'm sorry, but that picture is pretty much meaningless to me. My best guess is you have inverted normals in blender. Go into edit mode, select all, then hit ctrl-n to recalculate the normals. Then re-export.

Share this post


Link to post
Share on other sites

Quick tip for those on OS X:

Right Click the Blender app and select "Show Contents" then navigate to "Contents>Resources>2.7.8>Scripts>Addons and drop the downloaded file in there. Be sure to remove any dots in the name.

Then restart blender and go into user preferences and search for Mu and activate the plugin.

Looks great!! (just need to learn blender now ;-)

 

Share this post


Link to post
Share on other sites

Trying to export a very simple mesh out of blender with this, and getting this huge message of errors:

Spoiler

jsoSxRc.png

Doesn't really seem like it's all related to even the same thing, so I'm wondering if I just installed wrong or something. Thanks in advance.

 

Edit: Think I fixed it. It was the UV mesh problem. Weird how every object needs a map even if there's no textures with them.

Edited by smokytehbear

Share this post


Link to post
Share on other sites

@smokytehbear: It's because your mesh does not have any UV data. You need to unwrap it. Unfortunately, this applies to mesh colliders too, but since they never get rendered, any mess will do.

Share this post


Link to post
Share on other sites

I have updated the github repository with a new feature: convex hull creation. This takes an existing mesh and creates a new optimal mesh that fully encloses the source mesh vertices. This is accessible via Add->Mesh->Convex Hull. Also, when using the "Selected Meshes" feature in the Mu Tools panel, the created mesh collider will optionally (default) be the convex hull of the source mesh.

 

Note that blender's primitives (except the torus) are all convex so testing the feature on them will not produce anything particularly noticeable (other than the tris).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.