Jump to content

(KSP 1.10 + 1.12 ) Mission Controller 3.2.0 (Final Version) (Updated 6/25/2021)


malkuth
 Share

Recommended Posts

On 3/24/2018 at 11:03 PM, Apollo13 said:

I'm doing nothing in MCE.  I don't even have any MCE contracts; none have been offered since I reinstalled it.

Hmmm ok. 

Getting rid of this next update so should be gone.  Hopefully.  Not sure if anyone actually used it.

Link to comment
Share on other sites

Please note there is a bug in 1.4.2 thats adding Contract Spam.  This is not connected to Mission Controller or any other mod.  It happens it Vanilla too.  Please don't report these to me because your sending me on a wild goose chase I can't fix, nor have time for.. Thanks.

Thread its been reported in.

Edited by malkuth
Link to comment
Share on other sites

OK, then thanks for the update.  I was seeing only MCE contract spam.  It's the only contract mod I use.  In that case, my F-F-S is aimed squarely at KSP and Squad.

Squad was so damned proud about putting out their money-milking DLC, while fouling-up something this basic.  I wish Squad would concentrate on fixing what's broken, such as the crappy physics and idiotic bugs like this.  How did 1.4.2 pass QA?  Jeesh...  If the core game wasn't so good (and the modding community so great), I would have uninstalled this steaming PoS a long time ago.  KSP has always been loaded with bugs.  If it was any more buggy, you'd have to spray your computer with Raid every time you played.

Squad's motto:  Bugs?  Bugs?  We don't care.  We don't have to.  We're Squad.

Meanwhile; re-enabling MissionControllerEC.dll, because this is one of my favorite mods.  I'll deal with Squad's incompetence to make a quick fix to a serious problem.  Given that Squad seldom creates fixes beyond X.X.2 for a given release, we'll all be stuck with this problem for the next six months until KSP 1.5.0.

Edited by Apollo13
Link to comment
Share on other sites

Version 2.0.1 Released.

 

1. Removed Orbit helper from Mission Controller.  This feature is available in other mods like Kerbal Engineer, and MechJeb.. No need for any more spam.

2. Updated for KSP 1.4.2. 

3. Fixed links in the AVC module for this forum page.

Please note there is a bug in 1.4.2 thats adding Contract Spam.  This is not connected to Mission Controller or any other mod.  It happens it Vanilla too.  Please don't report these to me because your sending me on a wild goose chase I can't fix, nor have time for.. Thanks.

 

You can download the new version from the front page.

Link to comment
Share on other sites

23 minutes ago, Gordon Dry said:

... and another guy coming by the way and asking if this actually is compatible with latest ContractConfigurator (1.24.2 1.24.3) ?

Yes.  It works beside it.  Mission Controller has no conflicts and does not use Contract Configurator in anyway for its contracts.

Edited by malkuth
Link to comment
Share on other sites

Running KSP 1.4.2: Had an issue with the Tiro 1 mission; it wants me to have an "Antenna Device" on my vessel.

I've attached every comms device I've unlocked in career so far, but it doesn't check the box in the VAB, or on launch. Am I missing something?

Link to screenshots here: https://imgur.com/a/zqyMP

Edited by Rohaq
Link to comment
Share on other sites

1 hour ago, Rohaq said:

Running KSP 1.4.2: Had an issue with the Tiro 1 mission; it wants me to have an "Antenna Device" on my vessel.

I've attached every comms device I've unlocked in career so far, but it doesn't check the box in the VAB, or on launch. Am I missing something?

Link to screenshots here: https://imgur.com/a/zqyMP

This is a known issue if your using a Mod that adds a different type of communication module.. Like remote tech.  Mission controller is looking for the vanilla version.  If this is the case your going to have to just cheat the contract done for that particular contract.  I believe there are only maybe 3 total contracts that have that requirement now for the historic versions.

 

Also If I remember correctly I would have to double check, I believe it doesn't do the check until you get to orbit.  Only mentioning this since both pics were still on the ground Pre-Launch.

Edited by malkuth
Link to comment
Share on other sites

8 hours ago, malkuth said:

This is a known issue if your using a Mod that adds a different type of communication module.. Like remote tech.  Mission controller is looking for the vanilla version.  If this is the case your going to have to just cheat the contract done for that particular contract.  I believe there are only maybe 3 total contracts that have that requirement now for the historic versions.

 

Also If I remember correctly I would have to double check, I believe it doesn't do the check until you get to orbit.  Only mentioning this since both pics were still on the ground Pre-Launch.

It'll be RemoteTech then - dangit.

Link to comment
Share on other sites

23 hours ago, leatherneck6017 said:

@malkuth FYI the version file didn't get updated. KSP AVC nags about an update from 2.0 to 2.0.1 even though I've updated it both through CKAN and manually.

Oh dang forgot to update it sorry. 

 

EDIT:

Added the newer AVC version file in my github page for current version of Mission Controller 2.  

 

Edited by malkuth
Link to comment
Share on other sites

On 2018-04-08 at 4:12 AM, malkuth said:

Oh dang forgot to update it sorry. 

 

EDIT:

Added the newer AVC version file in my github page for current version of Mission Controller 2.  

 

okay, but which of the files am I supposed to download and replace? I downloaded the zip folder from github and I still get a popup that I can download a new version. Is it the version file that is 583 bytes size that Im supposed to download? :) thanks :)

Link to comment
Share on other sites

7 hours ago, Schmelge said:

okay, but which of the files am I supposed to download and replace? I downloaded the zip folder from github and I still get a popup that I can download a new version. Is it the version file that is 583 bytes size that Im supposed to download? :) thanks :)

Need to delete the .Version File in the zip file and replace it with the new one posted above the .zip file called MissionController2.0.version

Edited by malkuth
Link to comment
Share on other sites

40 minutes ago, malkuth said:

Need to delete the .Version File in the zip file and replace it with the new one posted above the .zip file called MissionController2.0.version

You should update the zip itself, or just come out with a new version, otherwise you will keep getting these sorts of questions

Link to comment
Share on other sites

  • 2 weeks later...

I went into the designated orbit with the frecuency and module set correctly and I didn't complete the mission when I started the date linkup and I'm guessing it's because of the core type. Am I correct? If so, how do you change it to Research type?

EDIT: Nevermind. I was trying to change the module type from right clicking and it's a whole different type of module.

Y9oiOPw.jpg

Edited by 1990eam
Link to comment
Share on other sites

13 hours ago, 1990eam said:

I went into the designated orbit with the frecuency and module set correctly and I didn't complete the mission when I started the date linkup and I'm guessing it's because of the core type. Am I correct? If so, how do you change it to Research type?

EDIT: Nevermind. I was trying to change the module type from right clicking and it's a whole different type of module.

Y9oiOPw.jpg

3 Main criteria for Mission success.  1. Correct Satellite core. 2. Correct Frequency 3. correct Module Type.

Link to comment
Share on other sites

  • 4 weeks later...

**EDIT** - I got it working!  I'm not sure how, but after updating all of my mods to current version for 1.3.1 everything works! fantastic!

 

has anyone had any success with the custom satellite contracts? I still can't get them to show in my mission list.  I've enabled them, removed all other contract mods but still can't get them to show in the mission control list of available missions. @malkuth - do you know of any mods that are out right in compatible with the missions in v1.3 ?  i'd update to 1.4, but most mods are only compatible up to 1.3 :(

Edited by bojangles9999
working!
Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
  • 2 weeks later...
On 3/9/2018 at 11:37 AM, malkuth said:

New Version for KSP 1.4 is up.  This fixes Contract issues with Heights in Modded worlds that a bigger than Vanilla KSP IE RSS, 10X Kerbin etc.

 

New Version Download.

The problem with rescale mods seems to have gotten itself un-fixed in this version. :(

I've opened issue #27 on your GitHub for it.

Spoiler

Okay, I opened it BEFORE I realized you'd previously fixed it. But hey, I opened the issue!

 

Link to comment
Share on other sites

  • 2 weeks later...
On 6/10/2018 at 2:05 AM, DarkSlimus said:

Hi,

Just to know, how many time it take to a custom contract appear in the mission control ?

 

Its random and at the mercy of KSPs weight system.  the more contracts it has to work with, the longer it takes to show up etc.  Vanilla without any other mods adding contracts usually shows up right away.

On 7/19/2018 at 7:42 AM, LuciferZ25 said:

Hi. Can u make a military version too? I mean just add vehicles at spawn points? Like 5dim? Plzzzzz

Won't be able to do it, mostly for time constraints, but I usually don't play with any type of military type mods in KSP, my personal opinion is that Kerbals are not military like. :)  But thats just me.

On 7/29/2018 at 3:25 AM, etmoonshade said:

The problem with rescale mods seems to have gotten itself un-fixed in this version. :(

I've opened issue #27 on your GitHub for it.

  Reveal hidden contents

Okay, I opened it BEFORE I realized you'd previously fixed it. But hey, I opened the issue!

 

Gah, I see what I do, going to release a version today but won't have this fix in it.  So hard for me to test because I don't play the Mods that do this.. Maybe I can add a little multiplier for you guys can manually adjust the numbers.. Ill see what I can do before I release todays version.

Link to comment
Share on other sites

newest Version of MCE mostly just updated Recompiled for KSP 1.4 and 1.5.

1.Recompiled for KSP 1.4 and 1.5.
2.Updated MINI AVC with Linuxgurugamers newest version.

Normal Links Front page.. As always Cursforge will take a bit to release.  But my Github is always updated.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...