Jump to content

(KSP 1.10 ) Mission Controller 3.1.3.0 (Apha Update New Cool UI) (Updated August 22 2020)


Recommended Posts

If my profits are 115,609.00 then why do I have a bank loan for 139,391 ? Shouldn't that be 23,782 in loans? Or does it only pay-off the loan once you've profited the full amount of the loan?

As you can also see i've had zero in recycling, which I haven't figured out yet either.

Not sure why your in dept, could be a number of reason, If you launched a vessel that was way to expensive and you went over a thresh hold of being in dept more then 60,000 then mission payouts are reduced to reflect paying back interest. The whole point of a budget is to not drop below 0. When you do you start having penalties.

Now that I think about the budget screen the penalties are not included in the actual budget window. Because the budget thinks you got paid say 200,000 for a mission.. But with a reduction to payout it might of been say only 75,000 payout. which explains the discrepancies. MCE is not perfect in all respects in cases like these and most the time people tend to control their budgets enough for things like this to happen.

With .24 somewhere on horizon fixing this issue would be pointless at this time. But if you want you can just edit the .sp file and set your budget to something more reasonable. Next time don't go into dept. ;)

Anyway this is the Dept % for going into dept. They are stored in the MCsettings.cfg file if you want to change them.

- 1 to -25000 in dept get reduction of 25% in mission payouts.

-25001 to -60000 reduction of 50% in mission payouts.

anything under -60000 is 75% reduction.

These numbers are given to you when you finish a mission and are in dept.

And how the loans work is like this.. If your in debt for 50,000 then your loan loan is for 50,000. When you do a mission and get a payout of say 75,000 you pay interest out of that payout for the loan for 50% of payout meaning you only actually get paid 37500. So your dept now becomes 12500. Now your loan is 12500. And your payment is reduced for mission payout next time to 25%. until you get out of debt. Getting hit with the 75% part of interest is tough indeed. But was added to make people rethink about just launching a vessel for 500,000 when you only have 50,000. Of course this does not include the actual ship cost. usually when you go into dept with MCE its pretty unforgiving.

Edited by malkuth
Link to post
Share on other sites
You're using a version of RealChute after v1.1 right? That's probably the issue. The MCE Real Chute recovery code was based off what I did for Kerbal Construction Time. Starting with the 1.1 update to Real Chute, Stupid_Chris removed most of the things I was referencing to get the drag from the parachutes and I had to come up with a new way to extract the information.

Malkuth, the code for KCT is on my GitHub if you want to look at it again, or in this spoiler tag


if (p.partRef.Modules.Contains("RealChuteModule"))
{
Debug.Log("[KCT] Found realchute module on " + p.partInfo.name);
PartModule realChute = p.partRef.Modules["RealChuteModule"];
Type rCType = realChute.GetType();
if ((object)realChute != null)
{
System.Reflection.MemberInfo member = rCType.GetMember("deployedDiameter")[0];
float area = (float)KCT_Utilities.GetMemberInfoValue(member, realChute);
area = Mathf.PI*Mathf.Pow(area/2, 2); //Determine the area manually since the "deployedArea" parameter no longer exists in RC
Debug.Log("Chute area: " + area);

member = rCType.GetMember("material")[0];
string mat = (string)KCT_Utilities.GetMemberInfoValue(member, realChute);
Debug.Log("Material is "+mat);

Type matLibraryType = AssemblyLoader.loadedAssemblies
.SelectMany(a => a.assembly.GetExportedTypes())
.SingleOrDefault(t => t.FullName == "RealChute.Libraries.MaterialsLibrary");

System.Reflection.MethodInfo matMethod = matLibraryType.GetMethod("GetMaterial", new Type[] { mat.GetType() });
object MatLibraryInstance = matLibraryType.GetProperty("instance").GetValue(null, null);
object materialObject = matMethod.Invoke(MatLibraryInstance, new object[]{mat});

float dragC = (float)KCT_Utilities.GetMemberInfoValue(materialObject.GetType().GetMember("dragCoefficient")[0], materialObject);
Debug.Log("dragC: " + dragC);
isParachute = true;
realChuteInUse = true;
totalDrag += (1 * 100 * dragC * area / 2000f);
}


public static object GetMemberInfoValue(System.Reflection.MemberInfo member, object sourceObject)
{
object newVal;
if (member is System.Reflection.FieldInfo)
newVal = ((System.Reflection.FieldInfo)member).GetValue(sourceObject);
else
newVal = ((System.Reflection.PropertyInfo)member).GetValue(sourceObject, null);
return newVal;
}

The GetMemberInfoValue function was because I couldn't get the data by casting to what I thought it was and I found that method online and it just worked, so I kept it. You could probably figure out whether it needs to be FieldInfo or PropertyInfo and forgo that function.

dang, didn't know it changed. :( I will see what I can come up with, still not a lot of time to work on MCE and doing Realchute stuff takes a lot of testing and re testing, and testing.. LOL.

Must be the reason Im getting a lot of complaints that things don't seem to be working anymore. Gah.

Link to post
Share on other sites
dang, didn't know it changed. :( I will see what I can come up with, still not a lot of time to work on MCE and doing Realchute stuff takes a lot of testing and re testing, and testing.. LOL.

Must be the reason Im getting a lot of complaints that things don't seem to be working anymore. Gah.

Well, the good news is that I did a decent amount of the work for you :D The only things that changed is that you can't get the deployed area directly anymore and accessing the material to get the drag coefficient is more difficult since you have to use the Materials Library directly instead of referencing the one that is contained in the module. It gave me headaches for a few days after the 1.1 release. I just made a couple more changes to fix a bug that a few people were having where the Tracking Station goes totally haywire after crashing a ship, so you may want to take a look at the dev branch on GitHub, but the only issues were with using the ProtoPartSnapshot's partRef to get the part directly (but the issue was that the partRef no longer existed on scene change while the parts are crashing through the terrain). If you aren't using the ProtoPartSnapshot then I don't think you need to worry about it.

Ah... OK, I'll have to do without realchute for a while then ;)

Older versions of Real Chute (pre-1.1) should still work. And stock parachutes (without real chute installed) should always work. Real chute has some module manager configs that overwrite stock behavior but they are optional. If you don't install them, then stock chutes I think will still work even with real chute installed (since it doesn't apply the new module that real chute uses). If that made any sense...

Edited by magico13
Link to post
Share on other sites
Yes, put both folders in GameData.

Cool, thanks.

In regards to the actual mod, do you not get the value of the vehicle if it's recovered without the pilot on board? That's pretty harsh for early Kerbin explortion missions when you don't even have ladders. I performed a couple of water sample missions, couldn't get back into the capsule (so I just recovered the pilot and capsules separately) and next thing I know I'm down 30,000$. Is that what's happening, or is my money disappearing through some other means?

EDIT:

Well so much for my theory, I just preformed the basic mission, flew up, came back down, landed perfectly, never stepped out of the rocket, recovered, and it didn't give me back the cost of the rocket. Does the vehicle only properly recover (monetary value returned and all that) if you land it right on the launch pad?

Edited by PTNLemay
Link to post
Share on other sites

Completely understand about not updating yet, your absolutely correct in waiting. I'll go ahead and voice my opinion now that I don't see your mod going away because Squad comes up with contracts, on the contrary, I expect you're going to get insanely popular very fast!!

That said, I greatly appreciate your time in spelling out how the mod is working when you get into debt. For those a little older: Dave Ramsey would be SUPER MAD at me! ;) lol

The MM configs thing makes perfect sense, thanks!

Link to post
Share on other sites

There must be another dll that messes with the recycling... I completely removed realchutes and I'm still not getting $ credits for recovery of a vessel or putting chutes on boostars...

I'm trying to think of what might be messing with it, but I'm not sure, I have way too many mods to list, but the usual (FAR, DREC, TAS LS, KAC, KAS, Kethane, FASA, the list goes on)... I'll probably start over anyway since .24 is around the corner anyway.

Link to post
Share on other sites
Cool, thanks.

In regards to the actual mod, do you not get the value of the vehicle if it's recovered without the pilot on board? That's pretty harsh for early Kerbin explortion missions when you don't even have ladders. I performed a couple of water sample missions, couldn't get back into the capsule (so I just recovered the pilot and capsules separately) and next thing I know I'm down 30,000$. Is that what's happening, or is my money disappearing through some other means?

EDIT:

Well so much for my theory, I just preformed the basic mission, flew up, came back down, landed perfectly, never stepped out of the rocket, recovered, and it didn't give me back the cost of the rocket. Does the vehicle only properly recover (monetary value returned and all that) if you land it right on the launch pad?

Hmmm not understanding the issue. Lets try to figure this out.

When you launch a vehicle you charged a certain amount of money. When you land the capsule and doing a mission you get paid for doing that mission - the cost of the vessel to launch.

If your playing career mode, the recycling only comes into play when you research it. If in sandbox then you always have recycling.

Once you get recycling you get back 75% if you land on Land, 60% back if you land on water. If you have a Plane with wings and Jet engines then its possible to get back 95% of cost if landed on runway.

If your launching you own missions without doing any contract or pre made missions then yes your going to lose money, because your not making any. But its totally possible once you get out of the First Early years stages to do a few Contract missions and these can literally fund many of your own missions. Also there is a Custom Mission Builder that you can try that also pays out very well.

I don't mind scott doing a review of MCE. But he missed a huge amount of details in the mod that are important. Mission Controller is not the Mission Controller he first reviewed last year. Basically a totally different mod that in my opinion is much easier to play with then the original.

Contracts are hard to do in the beginning because you don't have the tech yet to do them, which makes sense. But custom contracts can be done any time any time period of your game.

And the random missions are meant for early campaign play to get your money situation of the road. Hell the very first mission scott did in his video from random missions alone can net you a huge amount of payouts. ;)

Link to post
Share on other sites
Any idea what will happen to this mod in the future when 0.24 comes out and (supposedly) has its own money game mechanic?

Not sure at this time, If the money system is done well enough and I enjoy it I will most likely let MCE go away.

But if the budget system is like the science system. I might make MCE into a more complicated Budget system for KSP and beyond. It all matters how much time I have to work on it when this all happens.

Link to post
Share on other sites

@ malkuth

Oh it wasn't really an issue, I was just confused on how it worked exactly. I was able to get the full cost of the capsule back when I left it on the launch pad and didn't go anywhere (aside for taking surface samples). I assumed this meant that if I did something right I could get the vehicle back (minus the cost of the spent fuel). I didn't realize I had to research it to be able to do that.

I'm assuming the only time you get the vehicle back (without that research thing) is when you don't actually leave the launch pad.

Link to post
Share on other sites
Not sure at this time, If the money system is done well enough and I enjoy it I will most likely let MCE go away.

But if the budget system is like the science system. I might make MCE into a more complicated Budget system for KSP and beyond. It all matters how much time I have to work on it when this all happens.

Well if it does go away I have to say it was a fun thing to use as a stopgap in the meantime and I liked it. Thanks for all the hard work on it.

One thing MCE might continue to have that 0.24 might not is user-supplied content. But like you said, we have to wait and see what 0.24 turns out to be.

Link to post
Share on other sites
@ malkuth

Oh it wasn't really an issue, I was just confused on how it worked exactly. I was able to get the full cost of the capsule back when I left it on the launch pad and didn't go anywhere (aside for taking surface samples). I assumed this meant that if I did something right I could get the vehicle back (minus the cost of the spent fuel). I didn't realize I had to research it to be able to do that.

I'm assuming the only time you get the vehicle back (without that research thing) is when you don't actually leave the launch pad.

Yes once you press space bar to launch your vessel you are charged. You not charged for just being on the launch pad.

Link to post
Share on other sites

I have an issue and I am not quite sure what is at fault here. I have restarted a new .23.5 carrer with MCE. Have been doing the kerra I, II and III missions. Kerra I went fine, Kerra II mostly and I can't complete Kerra III.

The issue I had with Kerra II , which is the same related with Kerra III is that when I landed my capsule, MCE didn't prompt for mission completion even tho evrything was done fine. I decided to exit the capsule and have jeb take some ground samples, then I got the completion message.

Now with Kerra III, landed the capsule again after doing a stable orbit. No completion message, the MCE mission screen shows all objectives green tho. I decided to try and recover the vessel and still no mission completion.

Am I doing something wrong???

Edit: Running MCE .66 (not yet updated to .67, changelog didn't seem to mention anything that would have an effect for me)

Link to post
Share on other sites

nvm, I found what the problem was. (brain fart). Totally forgot about the vessel ID related to a specific mission. I had planned for the correct amount of fuel for the mission but some unplanned "turbulences" on launch ;-) had made me run short a bit but not by much. I decided to finish the few hundred meters missing in EVA. I was then mislead by the objective being flagged as complete and thought everything was fine, heh guess not :-).

I re-did the mission and it completed fine.

Suggestion: Since MCE tracks for vessel ID to be able to complete a mission, maybe give a warning and prevent sub-objectives to be completed when not in the required vessel??

Thanks again for a great mod, KSP is certainly alot more fun with it!!

Link to post
Share on other sites

Wow, let me just say that Im not impressed one bit with curseforge at all! One whole day so far that I can't update my Mission controller Download on Curse because I keep getting a time out! Seriously? Pulling the link for Mission Controller on curse. MCE is available at this point only on my DropBox!

Link to post
Share on other sites
Wow, let me just say that Im not impressed one bit with curseforge at all! One whole day so far that I can't update my Mission controller Download on Curse because I keep getting a time out! Seriously? Pulling the link for Mission Controller on curse. MCE is available at this point only on my DropBox!

You're not alone in that decision and I don't blame you. I used to make Minecraft server mods and getting them to transfer to Curse was a pain, especially as it was not well documented what you were supposed to do, and how long is normal to expect it to take to get approved, and so on.

When you need to hotfix something, it's very annoying that there's a day's delay in putting it up on the download site.

Link to post
Share on other sites

I'm not sure if this is a bug or what. I tried to do one of the BSP - Planet orbitals missions namely the one where you put up a command module for a space station around Kerbin. I launched it with all the necessary parts, put it into a good orbital and hid those two goals. I undocked it and the little window popped up saying that I finished the mission and would get 200,000 krones. I click "finish and save" and nothing happens. (The window goes away, but I don't get the money and the mission doesn't count as being finished (I can't do the next one)). Is this a known issue? Is there some kind of work around? I'm still on .23 and using that version if it helps any.

Link to post
Share on other sites

My apologies if this has been covered, I browsed the thread and didn't see anything... On KSP 23.5 I installed MCE, then changed the Mechjeb2 cfg file to .001 mass. That worked for MCE but it broke mechjeb, i.e. all the mechjeb windows are gone. I removed MCE (and the 000_toolbar) and reinstalled mechjeb, but it's still broken.

Any ideas for me to get mechjeb back without doing a clean install of KSP 23.5? I use like 25 mods.... Ugghh...... ;.;

Link to post
Share on other sites

I've had troubles completing missions sometimes. Somestimes when I complete them, everything seems to be in order - but as I land the popup does not show up. Any idea how to solve this?

Just now I did a random mission, which was to land on Mün and return.

see picture after landing here

Is this a bug, or is there a method to complete the mission I am not awere of?

Link to post
Share on other sites
I've had troubles completing missions sometimes. Somestimes when I complete them, everything seems to be in order - but as I land the popup does not show up. Any idea how to solve this?

Just now I did a random mission, which was to land on Mün and return.

see picture after landing here

Is this a bug, or is there a method to complete the mission I am not awere of?

Actually, I ran into the same thing and couldn't figure it out, that's why I went to uninstall MCE and discovered it broke mechjeb. (See post above.)

Kudos out btw to the MCE devs, I know its hard to keep up with all the compatibilities . :)

Link to post
Share on other sites

Mechjeb should not be broken by mce. Mce does nothing to mechjeb and the pricing problem was fixed a few versions ago. I suggest you uninstall all mods from your game data folder and start over. You should not have to reinstall ksp because no mod in ksp messes with the install at all. All files reside inside game data folder and is loaded by ksp from that folder.

For the people doing missions you have to use the same vehicle throughout the missions. It's a limitation of ksp and mce. Mce tracks vehicle I'ds to keep track of what objectives have been done. When you switch vehicles or do Apollo type missions it's possible ksp will assighn a new I'd to your lander. Which will confuse mce in thinking you did not do other objectives with that vessel.

This can be overcome if the mission in question uses the vessel independent for landing on say mun. But the person making the mission has to write them that way.

Bsm missions are not.

But you can use the custom contract maker and use the vessel indepent for landing on mun to make your own Apollo type mission.

Should take less minute make mission Apollo style.

1. Vessel has crew (select number)

2. Orbit kerbin select apa and pea

3. Orbit mun select spa and pea.

4. Land mun and choose vessel independent.

5. Land kerbin.

Exactly that order will give you the max payout you can get.

Edited by malkuth
Link to post
Share on other sites

That doesn't seem like that's the problem I'm getting. I get the window for finishing the mission (I completed all the goals) and I click finish and save, but it does not give me the advertised rewards). Do you know what would cause this or how to fix it? (I've completed and gotten rewards for other missions so I'm assuming this is a problem just with this one mission).

Link to post
Share on other sites
That doesn't seem like that's the problem I'm getting. I get the window for finishing the mission (I completed all the goals) and I click finish and save, but it does not give me the advertised rewards). Do you know what would cause this or how to fix it? (I've completed and gotten rewards for other missions so I'm assuming this is a problem just with this one mission).

Not sure are you in debt? Going into dept in mce is bad and means you will lose a big percent of your payouts.

Link to post
Share on other sites

Thanks for the response. I'm not in debt. I know when I first undocked (by decoupling the node) nothing happened, so I redocked and undocked and got the pop up. Finish and save -> nothing happens (except window closes). I've tried that a few times now. Undock, window pops up, "finish and save" button, nothing happens except the window closes. I get 0 money and I still can't do the next mission (it's a prerequisite mission).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...