Fractal_UK

[0.25]KSP Interstellar (Magnetic Nozzles, ISRU Revamp) Version 0.13

Recommended Posts

I should also state that when I remove WarpPlugin it will boot without a problem

Edited by sirged

Share this post


Link to post
Share on other sites

d3d: failed to create vertex buffer of size 2214816 [out of memory]

You must be out of graphics memory.

ERROR: Error while initializing dbghelp.dll, GetLastError: 'The operation completed successfully.' (Address: 00000000)

This is a real classic though.

Share this post


Link to post
Share on other sites

I decided to design a grand tour around my warp tug... this is what I came up with:

The 60 K-Day (15 Earth Days) KSP Interstellar Grand Tour... helps if you know what you're doing (I mostly do, when sober and not tired).

Take off from Kerbin, touch down on every planet and moon... then land back at KSC.

46.5t, 58 parts (+10 struts), used about 2k fuel, 7k AM, and <50 Monoprop used. This leaves you with about a 15% margin of LFO and about a 40% margin of AM (a TON of dV with the plasma).

This is the very slightly revised craft... after having completed the mission.

screenshot125.png

[spoiler=Grand Tour Walk through (in 1080p)

A TON of pics! You've been warned.]

First a couple disclaimers: In a tired and/or drunken state I decided to doubt my original math and doubled the drop tank size. I still don't know wtf I was thinking. It was supposed to be a 720 LFO (1/4 rockomax) size and discarded into Gilly.

Second, I've been playing KSP for AGES! I also prefer to be more of a builder than a pilot. Unfortunately, MechJeb doesn't like to do a lot of things properly when it comes to KSP Interstellar rockets... so, I actually had to do the VAST majority of the maneuver nodes and final landings by hand. I've done these things so many hundreds of times in the past... I usually just let MJ take care of it anymore. If it can. Docking is one thing I would never trust MJ to do... it just sucks at it.

Third, Those blue lines in the VAB are Quantum Struts. They're pretty vital for a tug ship like I fly. Basically its like having a real set of struts every time you dock. I really wish someone would pick up and support this simple mod again. Until then, I'll keep editing it for my own use.

Filling up AM on the launch pad

screenshot46.png

Circularizing with the plasma thruster... ALL orbital maneuvers should be done with the plasma!

screenshot47.png

G'bye Kerbin, I'm off to Eve! Bee back in 60 K-Days! (15 Earth Days)

screenshot48.png

About to Aerobrake into Eve atmo... only 129 Gs. EASY!

screenshot49.png

Jeb on Eve shores.

screenshot50.png

The long atmo climb begins!

screenshot51.png

Almost nothing left in this too-large can!

screenshot52.png

Linking up with the 'mother ship' over Eve.

screenshot53.png

Matching planes with Gilly

screenshot54.png

Hohmann transfer to Gilly

screenshot55.png

Establishing orbit of the smallest moon in the system

screenshot56.png

Jeb decides to do something silly

screenshot57.png

Coming in a bit fast? Can't really tell. Jeb is sure he'll be fine

screenshot58.png

Jeb landed.... Come back, ship!

screenshot59.png

Jeb some how has a map in his helmet and can easily plan a close encounter with his craft

screenshot60.png

Extreme EVA on Gilly complete!

screenshot62.png

At this point I ran into a few problems. The primary issue was that I was either too drunk or too tired to be playing. After finding an odd bug that would cause me to exit warp still going 150,000 m/s when I entered from Gilly, I had to first return to Eve. THEN I spent 5 K-days and about 600AM trying to use Kerbol gravity to brake for a soft encounter with Moho... completely forgetting both my current state and how annoyingly hard it was to get the vector perfect for such a soft approach to Moho. I gave up and just went to Duna. Figured I'd go back to Moho last when I was sober and awake.

Pretty mild aerobrake planned

screenshot64.png

You can almost touch the hilltops from this height

screenshot65.png

Setting down on Duna

screenshot66.png

Jeb loves red rocks?

screenshot68.png

This damn can still isn't empty yet?

screenshot69.png

Successful docking... again

screenshot71.png

Landing on Ike

screenshot72.png

Jeb loves a good tidal locking

screenshot73.png

I don't care if it isn't empty... this can has to go!

screenshot74.png

Link up over Ike

screenshot75.png

All levels look good...

screenshot76.png

So long red planet! I'm off to Dres!

screenshot77.png

Nice, long braking burn into orbit of Dres

screenshot78.png

Jeb doesn't seem too impressed on this boring rock

screenshot79.png

Standard link-up over Dres

screenshot80.png

Buh bye boring, grey rock!

screenshot81.png

Hello giant, exciting Jool!

screenshot82.png

Jeb popping out to admire the size of it

screenshot83.png

And we're off to Laythe!

screenshot84.png

Laythe braking

screenshot85.png

Touching down on the shores

screenshot86.png

Jeb enjoying the view

screenshot87.png

This is almost becoming boringly commonplace

screenshot88.png

Tylo is in a great spot to hop up to it from Laythe directly

screenshot89.png

Touchdown on the largest moon in the system

screenshot90.png

Sunsets last for AGES on Tylo

screenshot91.png

Easily made it back to the 'mother ship' with 1/3 LFO to spare

screenshot92.png

Another direct moon hop. This time a drop down to Vall

screenshot93.png

Interesting color down here

screenshot94.png

...yet another orbital link-up

screenshot95.png

A fancy drop down from Vall and swing out to Pol

screenshot96.png

Jeb doing something stupid again

screenshot97.png

So spikey! Here comes Jeb's ride!

screenshot98.png

Made it back with plenty EVA juice to spare

screenshot99.png

Had to drop back down to Jool to connect with the heavily inclined Bop

screenshot100.png

After yet ANOTHER EVA to the surface of a moon... Jeb plans a connection with his craft

screenshot101.png

Jeb's having too much fun to care about being low on Juice

screenshot103.png

Made it back with a little less 'fuel' than is safe

screenshot104.png

G'bye Jool... I've been here quite a while!

screenshot105.png

Touching down on Eeloo

screenshot107.png

Jeb admires the brown streak he landed in

screenshot108.png

I swear I've lost count of these routine link-ups

screenshot109.png

Away from Eeloo and off to one last planet... Moho

screenshot110.png

Total braking burn time was almost an hour... with plasma. Jeb complained the whole time about wanting to turn on the BIG engines

screenshot111.png

Jeb gets the science slaves to all pose for a picture

screenshot112.png

This will be the last link-up I do on this mission! I don't care!

screenshot113.png

Back to Kerbin SOI!

screenshot114.png

only 140g aerobrake... good thing Jeb is made of diamonds

screenshot115.png

Almost forgot the moons! Jeb swings by the Minmus mining base

screenshot116.png

Tries to get fancy and does a Minmus return - Mun Hohmann transfer combo

screenshot118.png

Jeb shows off again by landing under the equatorial Arch on Mun

screenshot119.png

Last non-Kerbin land he's going to touch for a while

screenshot120.png

For his LAST trick, on this mission, Jeb plans a DIRECT return to the KSC launch pad!

screenshot122.png

Missed it by about 75m... Jeb is too tired to care. Here he is waiting for his AM to be emptied before having his vehicle recovered

screenshot124.png

It was pretty fun... if a bit routine. The hardest part about the entire mission? Having to constantly change the thrust levels on the thermal nozzles to get between 5 and 7.5 T:W for landing maneuvers. Too low and you can't safely/quickly slow your descent. Too high and you can't fine tune enough for a soft landing.

~Steve

time to design something fancy and new

Edited by NeoAcario

Share this post


Link to post
Share on other sites

I'm having a weird issue and I have no idea if it's new with the current version or not...

(Firstly: I have all tech nodes except for the final warp drive node researched. I'm not using beamed power. There is fuel for all engines. The same results apply when switching the thermal rocket to Liquid instead of LFO, save for the usual changes to its thrust and ISP figures. The reactor is in Deuterium/Tritium fuel mode.)

The 3.75m thermal rocket nozzle under my 3.75m Tokamak seems to be eating charged particles as well as thermal power. The direct-conversion generator attached above the reactor can produce up to 9.75 GW, and yet when throttle is at max with no thrust limiter on the thermal nozzle, MJ supply is only 2.32 GW. (Not even enough for one DT Vista, much less the two that are mounted on this ship.)

I've carefully examined the interactions between the reactor and thermal nozzle (with the vessel launch-clamped on the surface), and it seems that while at approx. 80% reactor activity (throttle about halfway between max and the 2/3 tick) it produces 1.1 GW_cp (the minimum it ever seems to produce) and 43 GW_th, with the rocket nozzle producing 1884 kN of thrust. If I set it higher, the thermal power output stays the same (as expected) but the charged particles go up, and the thrust from the rocket nozzle increases toward a maximum of 2298.4 kN (ISP of 1650.5 using LFO), although it varies slightly over time as the amount of stored TP approaches zero. At max throttle the reactor shows production of 9.0 GW_cp, out of 11.5 maximum.

The power management display shows a theoretical supply of 9.75 GW (which seems slightly off, since 11.5 * 0.85 = 9.775 actually) with a demand and current supply of 185 MW (for the cryostats and antimatter storage tanks on the vessel) for 1.896% utilization. If I shut down the thermal rocket and activate the vistas, this becomes 5.18 GW demand and 53.154% utilization, while the reactor shows 19% activity, 4.3GW_th and 6.1GW_cp. As soon as I activate the thermal rocket though, the generator shows a power output of only 2.32 GW, leaving net power at -2.86 and the supply of stored MJ quickly runs out.

At idle, the reactor runs at 10%, outputting 4.3GW_th and 1.1 GW_cp. If I use a thrust limiter setting on the thermal rocket, I can run it at up to 93.5% (2149 kN) without the charged particle supply decreasing (the reactor shows 99.987% activity) but any higher and I eventually lose power, causing one of the Vistas to shut down and send the ship into a tumble.

I'm almost as confused that the thermal rocket can use most of the reactor's CP supply but not all of it (as evidenced by the 9.0 out of 11.5 CP output at full thrust), but really, why it is using ANY of it at all? In D/T mode, 10% of this reactor's energy output is in a form that it shouldn't be able to use at all...

Share this post


Link to post
Share on other sites

Sorry bit this package is making me very frustrated! How do I tell if something is upgraded? How do I know what I need to upgrade something? Every time I try to use something I find it does not work because I need something else that was not clearly documented. Unfortunately this is starting to upset me because it's after I spend the better part of a day making something (usually huge) and then find I just have to deorbit it and watch it burn up!

Share this post


Link to post
Share on other sites

I tried the mod, but it keeps getting shut down when i try to enter hanger

mono.dll caused an Access Violation (0xc0000005)

in module mono.dll at 0023:10118d2a.

Share this post


Link to post
Share on other sites
I tried the mod, but it keeps getting shut down when i try to enter hanger

mono.dll caused an Access Violation (0xc0000005)

in module mono.dll at 0023:10118d2a.

That's just a standard out of memory error. You need to use some texture reduction or something.

Share this post


Link to post
Share on other sites

Trial and error has shown that this mod is incompatible with engineering redux, which makes me sad

Share this post


Link to post
Share on other sites
Trial and error has shown that this mod is incompatible with engineering redux, which makes me sad

Incompatible in what way?

Share this post


Link to post
Share on other sites
Incompatible in what way?

Max thrust info and anything that depends on it like TWR is always wrong in the VAB and inflight unless the engines are on. As soon as you cut to 0% throttle the info is wrong again.

Share this post


Link to post
Share on other sites

Heya guys!

I was wondering about the thermal turbojets : what decides their thrust? Because although it has a much higher core temp, the upgraded antimatter initiated AIM reactor seems to have a much lower thrust than the same size Tokamak reactor.

Thanks for the amazing mod by the way!

Share this post


Link to post
Share on other sites
Heya guys!

I was wondering about the thermal turbojets : what decides their thrust? Because although it has a much higher core temp, the upgraded antimatter initiated AIM reactor seems to have a much lower thrust than the same size Tokamak reactor.

Thanks for the amazing mod by the way!

For thermal rockets, core temperature determines Isp, and thermal power determines thrust by determining how much propellant you can heat. Because of the way kinetic energy and momentum are related, a fixed amount of thermal power actually gives you more thrust when your Isp is lower.

The wiki isn't as clear about the formulas for thermal turbojets, but it seems obvious that their thrust would be limited by available wattage in the same way.

Now, looking at the reactor stats on the wiki, the upgraded 3.75m fusion reactor is about 10 GW more power than the upgraded antimatter initiated reactor. The higher wattage and lower core temp will give you more thrust, although the lower temperature will cost you some Isp.

Share this post


Link to post
Share on other sites

I recently noticed that under the radiation dose indicator a new rad status indicator was added. One of my stations in orbit has it as elevated. Should I be worried about this, or does it not mean anything?

Share this post


Link to post
Share on other sites

Hey guys. I just flew an Impactor Experiment Module (Core with 6x lander probes with transmitters and impact sensors and 6x impact probes) to the Mun... long story short,

after landing the first sensor probe I realized that the seismic sensor has reverted to its original role. (not the impact sensor role) I did plenty of impact experiments before 23.5

so I was wondering if this is the issue... I do have the most recent update for interstellar, I do not have any idea how to see, open, or otherwise edit cfg's or dll's... about all I

can do with this game is add/subtract mods... thanks in advance.

Share this post


Link to post
Share on other sites
Hey guys. I just flew an Impactor Experiment Module (Core with 6x lander probes with transmitters and impact sensors and 6x impact probes) to the Mun... long story short,

after landing the first sensor probe I realized that the seismic sensor has reverted to its original role. (not the impact sensor role) I did plenty of impact experiments before 23.5

so I was wondering if this is the issue... I do have the most recent update for interstellar, I do not have any idea how to see, open, or otherwise edit cfg's or dll's... about all I

can do with this game is add/subtract mods... thanks in advance.

Look in your warpplugin folder (the mod folder you added to your gamedata folder) there should be a file named "science.cfg" Open it up in a text editor and confirm that this line is in that file

!MODULE[ModuleScienceExperiment]

If that line is removed from the file the accelerometer reverts to its default functionality.

Share this post


Link to post
Share on other sites

Thank merendel... it is there...

@PART[sensorAccelerometer]

{

!MODULE[ModuleScienceExperiment]

{

}

MODULE

{

name = FNSeismicProbe

experimentID = FNSeismicProbeExperiment

rerunnable = true

deployEventName = Collect Impact Data

reviewEventName = Review Impact Data

resetEventName = Reset Impact Data

}

Any other ideas??

part definitely only asks to log seismic data... not record events...

Share this post


Link to post
Share on other sites
Thank merendel... it is there...

@PART[sensorAccelerometer]

{

!MODULE[ModuleScienceExperiment]

{

}

MODULE

{

name = FNSeismicProbe

experimentID = FNSeismicProbeExperiment

rerunnable = true

deployEventName = Collect Impact Data

reviewEventName = Review Impact Data

resetEventName = Reset Impact Data

}

Any other ideas??

part definitely only asks to log seismic data... not record events...

Do you have module manager installed?

Share this post


Link to post
Share on other sites
Do you have module manager installed?

I'd think he'd have alot more problems than just the science not working if he didnt have that installed and it normaly comes packaged with KSPI as I recall. Still could be possible. Might also be possible there are two versions in his gamedata folder, cant see that doing you any favors although never tried that before.

Actualy along that line of thought flip are you sure you installed KSPI properly? are the KSPI parts showing up in the tech tree/VAB? No common mistakes such as placeing a gamedata folder inside a gamedata folder.

Share this post


Link to post
Share on other sites
Do you have module manager installed?

wouldn't seem so as its still in my staging folder (download location prior to ksp integration)... where do I put it? gamedata or warplugin??

Share this post


Link to post
Share on other sites
I'd think he'd have alot more problems than just the science not working if he didnt have that installed and it normaly comes packaged with KSPI as I recall. Still could be possible. Might also be possible there are two versions in his gamedata folder, cant see that doing you any favors although never tried that before.

Actualy along that line of thought flip are you sure you installed KSPI properly? are the KSPI parts showing up in the tech tree/VAB? No common mistakes such as placeing a gamedata folder inside a gamedata folder.

actually I'm not sure if everything is correct but here is the situation... game broke on 23.5 update so I removed all mods and installed current versions after researching compatibilities (so bummed infernal robotics is broken) I did the gamedata in a gamedata folder the first time I tried kethane so im sure that's not it. basically what I do is extract the .zip into a folder called KSPMODS on my desktop and copy the files inside the mod gamedata file into the ksp gamedata file. not sure what to do with anything else as some mods have other stuff in them,

i.e. in my mod folder interstellar still has modulemanager1-5-6-.dll in it, realchutes still has a modulemanager file that has another gamedata file that has another realchute and a modulemanager1-5-6.dll in it...I wouldn't know how to use these things ATM.

also as a side note and of no consequence, when I run the game on start up the loading screen always locks on romfarer/romfarer or something from KW rocketry but doesn't crash. itll stay there for hours but if I start the task manager and then cancel, the game continues loading with no problem... I do get a "write to location 00400000 caused an access error" crash about once a day...

learning new things evey day, thanks for your help guys... ps if anyone know an alternate location these problems are addressed id appreciate a point in the right direction. a lot of info to sift through on this forum... thanks again

Share this post


Link to post
Share on other sites

EDIT> found out where to put modulemanager... anyone know where I can look to learn about how to use it (it seems to me that it enables you to edit .cfg files without overwriting stock files.?.?.. do I read this as is or what... id like to tweak things to make them more viable, i.e. the nuke engine is 2.5 tons but KW has an engine that is half the weight and half the isp but twice the thrust. so why use two nukes when one KW engine seems to be a far lighter version of 'two nukes'... 120 thrust/400 isp does equal two nukes running at 60/800 respectively doesn't it??)

Share this post


Link to post
Share on other sites
wouldn't seem so as its still in my staging folder (download location prior to ksp integration)... where do I put it? gamedata or warplugin??

put the DLL directly in the game data folder. It not being there would definitely cause the problem with the accelerometer. It would also break alot of other mod mechanics hence why I assumed you'd have more issues if it was missing but its possibly you've just not noticed any of them yet.

Most of the time you can get away with simply merging the game data folders when installing mods. AKA drop the mods gamedata from the zip into the main KSP folder and tell it to merge/replace as needed. Personaly I tend to open both game data folders (main one and modpack) and copy the files over from there. This is only so I'm more likely to catch something like a mod comeing packaged with an out dated module manager DLL or one of the other common mods that come bundled. This also makes it easier to delete old folders before copying the new one in.

This is as good a place as any for the questions you've asked as most pertained to your KSPI issue. If your haveing specific issues with other mods its better to ask in that mods thread or over in the general addon affairs subforum.

Share this post


Link to post
Share on other sites

I was wondering, What would I need to add to the default behaviour to the science.cfg so that I can have both the default and the impact test. I know people have done it...but for my manned missions I am doing just the default...but later with larger ships I would also like to drop impactors. Thoughts?

Share this post


Link to post
Share on other sites

I've been able to replicate the issue @Diashi had with being unable to drop out of warp on an almost clean install. There's no button available through the right-click menu, and triggering that function through action groups has no effect. Hitting "Activate Warp" once again further boosts my speed.

EDIT: On the verge of pinning this down to a conflicting pluggin.

FURTHER EDIT: Kerbal Joint Reinforcement

Edited by SufficientAnonymity

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.