Fractal_UK

[0.25]KSP Interstellar (Magnetic Nozzles, ISRU Revamp) Version 0.13

Recommended Posts

The version in the OP is not compatible with the latest version of ksp. You'll need to stay with .23 or update your interstellar version. There is a working version in my sig, use the release version.

Oh, awesome. That works great, thanks.

Share this post


Link to post
Share on other sites

So how are we all feeling so far about the costs in the experimental version?

~Steve

EDIT:

No costs assigned yet to nuke fuels?

Edited by NeoAcario

Share this post


Link to post
Share on other sites

PS: We're still supposed to load the "KSP Interstellar Tree" at the beginning when it asks us to choose which Tech Tree to load...right?

That is correct

Share this post


Link to post
Share on other sites
So how are we all feeling so far about the costs in the experimental version?

~Steve

EDIT:

No costs assigned yet to nuke fuels?

Been too busy putting out fires. Changing stuff does require work, both in code and testing. I have development branch up now, so it should be easier for me to just let people try fixing stuff and see what breaks without messing up the "stable" build.

Share this post


Link to post
Share on other sites

@WaveFunctionP are you planing on adding any features, or is this just temporary untill Fractal_UK comes back?

Share this post


Link to post
Share on other sites
That would be a type. The basic idea is that each tier is equal in cost to that of the size below, but one tier above.

So something like 3.75 fission/2.5 fusion/1.25 antimatter all should be roughly the same cost. And each size is roughly 5 times the cost of the size below. I was assuming each size is 4 times the output, which left a progressive increase in cost up the sizes and tiers. I had a lot of values to edit and I was mostly doing it in my head as I went along.

It's rough because I know that soon I will be flattening the power progression soon, while also cutting a good bit of part and functionality bloat, and I didn't want to waste effort balancing against numbers that are going to be very different soon.

u mean chenging values of power? its not good becouse all parts are balanced to be power compatibile so changing cost its ok but if u lower power output on any part it will broke balance and make some parts unusable pepole who make this mod have a lots of work with balancing it so please work only with prices or u could mess it up

Share this post


Link to post
Share on other sites

for me on fresh 24.0 instal still no power productjon and since lab generators and reactors fall throu ground

Share this post


Link to post
Share on other sites
for me on fresh 24.0 instal still no power productjon and since lab generators and reactors fall throu ground

Same for me, unfortunately.

Share this post


Link to post
Share on other sites
Same for me, unfortunately.

@WafeFunctionP's experimental build fixes this. The link is in his sig. Make sure you Replace the folders, don't just merge.

Share this post


Link to post
Share on other sites
@WafeFunctionP's experimental build fixes this. The link is in his sig. Make sure you Replace the folders, don't just merge.

i tryed today i dont replaced i do it on fresh instal so i dont have nothing NOTHING befor ading it and its dont work

Share this post


Link to post
Share on other sites

@WaveFunctionP

I have a bug that I should probably report. When you are going 20c and time warp through an SOI, your velocity gets super messed up so that even when you turn it off, you are going far too fast (like millions of m/s). It is so bad that even if you warp at 20c retrograde to this weird velocity, you barely even cut into it.

Share this post


Link to post
Share on other sites
@WaveFunctionP

I have a bug that I should probably report. When you are going 20c and time warp through an SOI, your velocity gets super messed up so that even when you turn it off, you are going far too fast (like millions of m/s). It is so bad that even if you warp at 20c retrograde to this weird velocity, you barely even cut into it.

This happened to me by quicksaving while in warp, then loading.

Share this post


Link to post
Share on other sites

Made me think of that episode of Star Trek: The Next Generation: Season 1 Episode 5: Where No One Has Gone Before.

Share this post


Link to post
Share on other sites
@WafeFunctionP's experimental build fixes this. The link is in his sig. Make sure you Replace the folders, don't just merge.

Got it figured out! Thanks

Share this post


Link to post
Share on other sites
Got it figured out! Thanks

What did you do? Deleted all folders that come with the mod. Reinstalled the devbuild and my generators are still falling to the ground during launch.

Share this post


Link to post
Share on other sites
What did you do? Deleted all folders that come with the mod. Reinstalled the devbuild and my generators are still falling to the ground during launch.

Do you use modular fuel tanks? I was having a problem where everything mounted above any sort of fuel tank would fall through on launch. Removing MFT until an update comes out fixed the problem for me.

Share this post


Link to post
Share on other sites

For those who have the pass-throught-parts-and-ground bug: the experimental build of WaveFunctionP effectively fix it (there: https://github.com/WaveFunctionP/KSPInterstellar/releases). Didn't tried with my full bundle of mods, but clearing the GameData folder (leave Squad and NASAmission or verifify cache integrity after deleting everything) and installing this build fix it for 0.24.2.

Thanks to WaveFunctionP!

Share this post


Link to post
Share on other sites
For those who have the pass-throught-parts-and-ground bug: the experimental build of WaveFunctionP effectively fix it (there: https://github.com/WaveFunctionP/KSPInterstellar/releases). Didn't tried with my full bundle of mods, but clearing the GameData folder (leave Squad and NASAmission or verifify cache integrity after deleting everything) and installing this build fix it for 0.24.2.

Thanks to WaveFunctionP!

i have a lots of mods( staying at 24.0 rigth now) and dont work for me

even if i instalinng on new copy better work for me "original" one rigth now

i will try on 24.2

Edited by sober667

Share this post


Link to post
Share on other sites
i have a lots of mods( staying at 24.0 rigth now) and dont work for me

even if i instalinng on new copy better work for me "original" one rigth now

i will try on 24.2

The current experimental build is for 0.24.2. It will not work for 0.24.0 because of api changes implemented by squad in 0.24.1.

You can generally expect mods to only support the version which they are compiled for, which is usually the most recent version of ksp.

Edited by WaveFunctionP

Share this post


Link to post
Share on other sites

Running the experimental version right now. So far nothing is falling through the ground or parts breaking off. The only issue I have currently is beamed power does not seem to be working for my ship. My main ship in Laythes orbit can receive beamed power via the transceivers but my ground ship on Laythes surface can't pick up enough energy to fire it's DT engine. It's worked fine before the updates as I was able to fly around to different parts of Laythe to explore. Now the engine gives 0 thrust. It's almost like it doesn't see the ship in orbit beaming power down and is instead only picking up power from my main generator back at Kerbin.

Share this post


Link to post
Share on other sites

Experimental for 0.24.2 is working well for me under x86, thank you WaveFP.

Oh. You may want a quick word with Jeb. Looks like he's trying to charge people 800,000 for the 62.5 Inline Radiator, cheeky monkey ;)

Share this post


Link to post
Share on other sites

I noticed this mod overwrites a few files and adds a second OpenResourceSystem dll file in the ORS folder created by MKS and Karbonite. Is anyone who's using either of those mods having problems with resource extraction?

Testing right now but I think interstellar is somehow preventing Karbonite's extractor and converter from functioning properly.

Edited by The Pink Ranger

Share this post


Link to post
Share on other sites
I noticed this mod overwrites a few files and adds a second OpenResourceSystem dll file in the ORS folder created by MKS and Karbonite. Is anyone who's using either of those mods having problems with resource extraction?

Testing right now but I think interstellar is somehow preventing Karbonite's extractor and converter from functioning properly.

It probably is because I think Karbonite uses its own version of OpenResource, but I know RoverDude has talked about compatibility of the two before.

Edited by JeffersonFlight

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.