Fractal_UK

[0.25]KSP Interstellar (Magnetic Nozzles, ISRU Revamp) Version 0.13

Recommended Posts

I seem to recall Wave's ORS is actually better, or more complete, than what came with MKS and Karbonite. And Roverdude was going to just use Wave's in future releases.

Or something along those lines anyways :P It should work perfectly fine though.

Share this post


Link to post
Share on other sites

On a side note -- I guess that means the MKS mod and the experimental Interstellar mod are incompatible as of now? I'd rather play with both of them, but I guess if I don't have a choice, I'd rather use Interstellar.

No MKS will still work with the KSP-I ORS dll, and if you look at the MKS thread RoverDude just updated MKS to .19.3 and part of that update was to include WaveFunction's updated ORS dll so that this kind of thing (having multiple ORS dlls, which causes lots of crashes and much sadness) will stop happening

Edit:​ ok so not just updated it was actually almost a week ago lol

Edited by Akira_R

Share this post


Link to post
Share on other sites

Has any one found a fix for the issue with the tech tree in the science-sandbox game mode? I haven't gotten to any of those nodes yet because I just started but I would like to know if there is a fix before I get to that point :)

Share this post


Link to post
Share on other sites
Has any one found a fix for the issue with the tech tree in the science-sandbox game mode? I haven't gotten to any of those nodes yet because I just started but I would like to know if there is a fix before I get to that point :)

This is exactly what I came here to ask for. You read my mind. I'd like a solution for the science mode and the Interstellar Tech Tree, we can't seem to load the custom tree in it.

Share this post


Link to post
Share on other sites

Hello, I have a few buggy problems. It would be great if someone had a solution to them.

Some of the big interstellar parts, such as science lab and reactors disappear physically as soon as the vessel is loaded on the launchpad. The parts attached on top of it fall through it and smack into the ground. I think it is related to 0.24 because before that they worked just fine.

And when its not destroyed on the pad, the science lab doesnt want to reprocess nuclear fuels.

Thx

Edited by Warp11

Share this post


Link to post
Share on other sites
Hello, I have a few buggy problems. It would be great if someone had a solution to them.

Some of the big interstellar parts, such as science lab and reactors disappear physically as soon as the vessel is loaded on the launchpad. The parts attached on top of it fall through it and smack into the ground. I think it is related to 0.24 because before that they worked just fine.

And when its not destroyed on the pad, the science lab doesnt want to reprocess nuclear fuels.

Thx

You need the experimental version of KSPI, look in the signature of WaveFunctionP!

Share this post


Link to post
Share on other sites

Simple question really.

Does anything in KSPI actually use the atmospheric and oceanic resources? I'm looking to maintain compatibility, but these default configs just look... weird, and they are making things more than a bit messy.

TIA

Share this post


Link to post
Share on other sites

give radial and inline radiators a real purpose

Both work good on aircraft and probes that dont have insane solar arrays attached. They are effective in atmosphere and on craft that only have a small amount of wasteheat. Some craft don't even need radiators.

remove treeloader dependance

Unless im mistaken you can use KSPI without treeloader, all the parts should have a default tech node on the stock tree, treeloader just changed where they end up. (it has been a while since i have played without using KSPI techtree)

Fission's lifetime isn't really a perk. The lifetime of a reactor doesn't really have much impact given the typical lifetime of a save, nevermind that you can simply place one with a refinery. And many mechanics that work off of time limits, do not work well since you can always timewarp. Reactor power scaling is plain ridiculous. Simply setting cost based on reactor output means that you have reactors go from a few thousand to hundreds of millions, without even considering the increasing power to weight they offer. And I don't want the game to become all about grinding currency via missions, and I don't want it to be about recovering resources for money.

Agreed.

In most cases scaling something up should make it more cost effective, with the reactors the major cost should be the fuel. The reactors themselves are just large chunks of precision machined metal, the fuel is the expensive and dangerous part.

Simple question really.

Does anything in KSPI actually use the atmospheric and oceanic resources? I'm looking to maintain compatibility, but these default configs just look... weird, and they are making things more than a bit messy.

TIA

Does not surprise me that they may not look that good, a lot of that was made when Fractal_UK first created ORS.

For the most part atmospheric resources aren't used that often, many of the resources that you can get are just to much trouble to get while flying. The oceanic resources are more useful and on some planets you can only get some by getting wet.

If you feel like cleaning it up I cant see Fractal_UK complaining, if he comes back....

Edited by Donziboy2

Share this post


Link to post
Share on other sites

Is there anyway I can activate the interstellar tec tree on a existing save thats uses the old on? I dont want to lose my progress so far and start again.

Share this post


Link to post
Share on other sites

It should work just fine. Tree loader uses its own config, afaik it doesn't affect your persistence file.

Share this post


Link to post
Share on other sites

Still having trouble with the thermal engines in the VAB and in launch. I did the reinstall, deleting all old fires and the replacing with the experimental version but it just hasn't fixed it. Is there any mods that conflict?

Share this post


Link to post
Share on other sites
It should work just fine. Tree loader uses its own config, afaik it doesn't affect your persistence file.

TreeLoader may not offer the "pick a tree" window on a save that already has some progress. If it doesn't give you the option, manually copy tree.cfg from GameData/WarpPlugin to your save folder.

Share this post


Link to post
Share on other sites

Man i give it up... i really hope that fractal_uk will show up again. i tryed the experimtal build up and down to get it to run, downloaded it several times just in case it was a DL corruption, even with a fresh version and without any other mod installed, in 32-Bit, in 64-bit, just the unzipped stuff of experimental build into my game folder, just to make sure, nothing works. It will either crash or freeze up in loading when he trys to load "FNSmallerAugmentedArcJet"

god damn it i want the science lab and the drive techs back *sigh*

Edited by Ferigad

Share this post


Link to post
Share on other sites
Man i give it up... i really hope that fractal_uk will show up again. i tryed the experimtal build up and down to get it to run, downloaded it several times just in case it was a DL corruption, even with a fresh version and without any other mod installed, in 32-Bit, in 64-bit, just the unzipped stuff of experimental build into my game folder, just to make sure, nothing works. It will either crash or freeze up in loading when he trys to load "FNSmallerAugmentedArcJet"

god damn it i want the science lab and the drive techs back *sigh*

Have you tried posting the KSP log or crash logs?

Share this post


Link to post
Share on other sites
Simple question really.

Does anything in KSPI actually use the atmospheric and oceanic resources? I'm looking to maintain compatibility, but these default configs just look... weird, and they are making things more than a bit messy.

TIA

Yes, there are extractor modules for atmo, ocean and land resources.

Share this post


Link to post
Share on other sites
Man i give it up... i really hope that fractal_uk will show up again. i tryed the experimtal build up and down to get it to run, downloaded it several times just in case it was a DL corruption, even with a fresh version and without any other mod installed, in 32-Bit, in 64-bit, just the unzipped stuff of experimental build into my game folder, just to make sure, nothing works. It will either crash or freeze up in loading when he trys to load "FNSmallerAugmentedArcJet"

god damn it i want the science lab and the drive techs back *sigh*

I'm sorry that you are frustrated, but I can do very little without a log.

Share this post


Link to post
Share on other sites
I got your PM. I apologize that I forgot to respond.

I know next to nothing about animations, and I do not have access to the raw models or the required skills to modify them.

:(

I managed to compile the mod and tried to modify the material to add the shader... but that's not possible as I need a surface shader and those can be added only from the Unity editor.

Making it in software raster is an option.. but a very ugly one... maybe I'll

Hopefully Fractal will release the sources of the animations also :)

Anyway, thanks

Share this post


Link to post
Share on other sites

2oktav

I didn't looked at ksp forums last months but accidentally went(?). Fractal didn't have sources of most models.

If I understand correctly you want radiator model isn't it?

It was ages since last time I launched unity and don't clearly remember how all this work but I think I put correct files and hope you can sort out how to use them and it will somehow help http://www./download/m7mr6760czgbr5g/h2.7z

But if I remember correctly such separate animation(to make unfolding animation and separate heat) is not work well, but maybe with help of some dll magic. I allways thought best way to do it is by some way to proceduraly change emissive texture alpha amount(emissive color.a) in runtime

Edited by zzz

Share this post


Link to post
Share on other sites
2oktav

I didn't looked at ksp forums last months but accidentally went(?). Fractal didn't have sources of most models.

If I understand correctly you want radiator model isn't it?

It was ages since last time I launched unity and don't clearly remember how all this work but I think I put correct files and hope you can sort out how to use them and it will somehow help http://www./download/m7mr6760czgbr5g/h2.7z

But if I remember correctly such separate animation(to make unfolding animation and separate heat) is not work well, but maybe with help of some dll magic

wow, great, I'll take a look!

Share this post


Link to post
Share on other sites
I'm sorry that you are frustrated, but I can do very little without a log.

And my frustration is finally over. I have no idear what it was, WaveFunctionP. I finally decided to delete all temps and registry entrys from KSP that where still in their as artifacts and leftovers. Installed fresh, and tested KSP Interstellar, worked on the spot. And then i just installed every mod once a time, started, closed, next mod and so on... now it works all like a charme. I have no idear what the temps or the registrys could have anything to do with it but it finally worked after the 5th fresh reinstall =)

Share this post


Link to post
Share on other sites

Clean install and then reinstalled KSI and still getting the same bug with the thermal rockets.

Share this post


Link to post
Share on other sites

Please update to 0.24

Reactors and stuff keep falling through my craft.

Share this post


Link to post
Share on other sites
Please update to 0.24

Reactors and stuff keep falling through my craft.

Download WaveFunctionP's experimental version. It fixes this issue

Share this post


Link to post
Share on other sites

Is there a way to take this mod, strip away the features you don't want (megajoules, wasteheat, etc) and only have a set selection of features? Cause the waste heat system and dozens of resources you need really ruins the mod for me.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.