NavyFish

[1.4.3] Docking Port Alignment Indicator (Version 6.8.2 - Updated 03/31/18)

Recommended Posts

Any chance for a recompiled version for 1.4.3?

Share this post


Link to post
Share on other sites
11 minutes ago, Gordon Dry said:

@Osul it works in KSP 1.4.3

Manually maybe.

I'm using CKAN, and there it is only for 1.4.2.

Share this post


Link to post
Share on other sites
Posted (edited)

CKAN updated via spacedock, no new packaged released. Hadn't realized 1.4.3 was out

I need to push an update of the distribution with a tweak to handle upcoming MM syntax changes but am not in a position to do so. Expect an (actual) update soonish

Edited by NavyFish
  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, NavyFish said:

CKAN updated via spacedock, no new packaged released.

Great. Thanks for the quick response.

I take it CKAN needs some time to update the repositories?

 

Edit: Now it is updated. :cool:

 

Edit 2: I'm getting a message on startup: "Unsupported KSP version... Please use 1.4.2". Beside that it seems to work flawless.

Edited by Osul

Share this post


Link to post
Share on other sites

Hey, this is one of my "must have" mods and I'm just wondering when it's going to be compatible with 1.4.3.  I don't want to sound winy, but it seems to be taking quite a while to update considering 1.4.2 --> 1.4.3 was really just a collection of bug fixes.

Share this post


Link to post
Share on other sites
8 minutes ago, rayceeya said:

Hey, this is one of my "must have" mods and I'm just wondering when it's going to be compatible with 1.4.3.  I don't want to sound winy, but it seems to be taking quite a while to update considering 1.4.2 --> 1.4.3 was really just a collection of bug fixes.

Try reading up the page a little.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/27/2018 at 5:51 PM, rayceeya said:

Hey, this is one of my "must have" mods and I'm just wondering when it's going to be compatible with 1.4.3.  I don't want to sound winy, but it seems to be taking quite a while to update considering 1.4.2 --> 1.4.3 was really just a collection of bug fixes.

Hi, DPAI is a "must have" plugin for me and I confirm it works fine against KSP 1.4.3 (except the mod icon is often displayed from main menus - but this "problem" isn't new and doesn't cause issue in KSP, however). Installed manually (I don't use CKAN nor MiniAVC).

Edited by DomiKamu

Share this post


Link to post
Share on other sites

@NavyFishThanks so much for this awesome mod; like others, it's a "must have" for me to play and enjoy KSP - and goes very nicely with NEOS which requires lots of docking!

Two tiny niggles:

  • AVC complains because it was built on an earlier version of KSP
  • It throws exceptions in KSP1.4.3 (it still works, it's just messy in the logs when running debug builds).

 

Quote

[EXC 01:04:44.686] UnityException: Internal_Create is not allowed to be called from a MonoBehaviour constructor (or instance field initializer), call it in Awake or Start instead. Called from MonoBehaviour 'DockingPortAlignmentIndicator' on game object 'DockingPortAlignmentIndicator'.
See "Script Serialization" page in the Unity Manual for further details.
    UnityEngine.Texture2D..ctor (Int32 width, Int32 height, TextureFormat format, Boolean mipmap) (at C:/buildslave/unity/build/artifacts/generated/common/runtime/TextureBindings.gen.cs:174)
    NavyFish.DockingPortAlignmentIndicator..cctor ()
    Rethrow as TypeInitializationException: An exception was thrown by the type initializer for NavyFish.DockingPortAlignmentIndicator
    UnityEngine.GameObject:AddComponent(Type)
    AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
    AddonLoader:StartAddons(Startup)
    AddonLoader:OnLevelLoaded(GameScenes)
    AddonLoader:OnSceneLoaded(Scene, LoadSceneMode)
    UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded(Scene, LoadSceneMode)

 

Share this post


Link to post
Share on other sites

Umm, What's the difference between this and the Community Edition(maintained by @linuxgurugamer)? It seems like both are being maintained...

Share this post


Link to post
Share on other sites
26 minutes ago, DunnoAnyThing said:

Umm, What's the difference between this and the Community Edition(maintained by @linuxgurugamer)? It seems like both are being maintained...

This presents a window for docking.  The one I'm maintaining puts a marker on the navball, hence the "Navball Docking Alignment Indicator"

Here is a link to the one I'm maintaining: 

 

 

Share this post


Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

This presents a window for docking.  The one I'm maintaining puts a marker on the navball, hence the "Navball Docking Alignment Indicator"

Here is a link to the one I'm maintaining: 

A-ha! That's a clear difference. Maybe gotta use both and decide what I need.
Thanks for such a quick answer

Share this post


Link to post
Share on other sites

Hi there. I am running the DockingPortAlignment-6.8.2 on a steam KSP version of 1.4.4.2215 (windows 64) and I am getting the display screen

Unsupported KSP version ... Please use version 1.4.2

is it just a simple cfg change or does it need to be recompiled?

I am getting the occasional random crash when playing the game

 

Share this post


Link to post
Share on other sites
Posted (edited)

I just updated via spacedock, no change to the file.  Does this end up incrementing the ksp-avc file as well?  if not I'll have to release a new version, with the version file having a ksp Max version of 1.4.99 or something to that effect.  (that won't happen until next week at the earliest, travel)

On 7/6/2018 at 8:15 PM, IanCanberra said:

Hi there. I am running the DockingPortAlignment-6.8.2 on a steam KSP version of 1.4.4.2215 (windows 64) and I am getting the display screen

Unsupported KSP version ... Please use version 1.4.2

is it just a simple cfg change or does it need to be recompiled?

I am getting the occasional random crash when playing the game

 

 

if you manually edit the .version file in the dpai folder you'll get rid of that nag.  don't know if crashes are related to DPAI without logs

 

On 6/10/2018 at 12:07 PM, micha said:

@NavyFishThanks so much for this awesome mod; like others, it's a "must have" for me to play and enjoy KSP - and goes very nicely with NEOS which requires lots of docking!

Two tiny niggles:

  • AVC complains because it was built on an earlier version of KSP
  • It throws exceptions in KSP1.4.3 (it still works, it's just messy in the logs when running debug builds).

 

 

 

thanks @micha

not something I can fix right now but next time I'm in Dev mode I will have a look. this codebase is literally 6 years old.. I had no idea how to use Unity back then :) amazing it's held up this far!

Edited by NavyFish
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, NavyFish said:

I just updated via spacedock, no change to the file.  Does this end up incrementing the ksp-avc file as well?  if not I'll have to release a new version, with the version file having a ksp Max version of 1.4.99 or something to that effect.  (that won't happen until next week at the earliest, travel)

No, it doesn't.

Share this post


Link to post
Share on other sites
Posted (edited)

It's been a while since I've played or been to the forum (well, I started playing again about 2 months ago, but just got DPAI again recently), but that's not too important....

I started this post to see if DPAI should work with the latest KSP, 1.4.4, but after some trouble shooting, noted below, it started working. Maybe this will help someone else if they have the same problem.

When I first installed it and ran the game, the toolbar icon did appear. Dont think I did any dockingnin that session. The next time I launched the game and tried docking the icon wasnt in the toolbar and the DPAI window didn't come up.

I did some tests, another mod had MM 3.0.7 so I replaced that with 3.0.6 from the DPAI ZIP, that didn't seem to fix it so I deleted and reinstalled DPAI and that seems to work. The window shows up when expected and the icon is there. Tried it twice after closing and reopening the game. The DPAI version I have is 6.8.2.0 if that helps.

Only thing I can figure is maybe something got corrupted in a crash. I suppose log files would help...but since it's working again I wont bother. If it happens again I'll see if I can track down something in the log files. :)

 

Spoiler

{EDIT} Unrelated, but is there a way I can turn notifications of replies to this comment? I didn't think to turn on the option at the time I made the comment. I tried to delete it so I could repost it with the option turned on but can't find an option to delete it. Maybe it doesn't matter and it'll notify me anyway. :P I've got the option for reply notifications turn on now so it shouldn't be a problem next time i leave a comment.

 

Edited by Sma
Added unrelated spoiler question.

Share this post


Link to post
Share on other sites

I wonder if the toolbar icon appearing and disappearing like that could be related to the fact it's still only using one size of icon image, the old 24x24 format. Something else that might need touching when @NavyFish has a chance to look over the code again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now