Jump to content

[1.8.1] Docking Port Alignment Indicator (Version 6.8.5 - Updated 12/14/19)


NavyFish
 Share

Recommended Posts

9 hours ago, Fweds said:

Same problem for me so I have recompiled myself from source code with KSP 1.4, all seems ok, I will continue testing...

Edit : Tests are OK with KSP 1.4 :D 

I just checked the source code license; it allows modifying and re-distributing it provided the original copyright notice language is preserved as specified in the Readme file. It'd be great if you could upload a copy somewhere shared so others could test it.

6 hours ago, munlander1 said:

Pretty sure docking port alignment indicator needs to be updated to be compatible with 1.4. I don't know how long though.

Well, @NavyFish was online about a week ago, right before the update. With luck he'll be able to recompile soon-ish. Until then, time for us all to brush up on doing it the old-fashioned way. :) 

Link to comment
Share on other sites

11 hours ago, LameLefty said:

I just checked the source code license; it allows modifying and re-distributing it provided the original copyright notice language is preserved as specified in the Readme file. It'd be great if you could upload a copy somewhere shared so others could test it.

Well, @NavyFish was online about a week ago, right before the update. With luck he'll be able to recompile soon-ish. Until then, time for us all to brush up on doing it the old-fashioned way. :) 

Ok then, here is the version 6.7.0 modified to v6.8.0 for KSP 1.4 :

** Link removed, no more utility, update is published **

 

 

Edited by Fweds
Link to comment
Share on other sites

Version 6.8.0 - 03/09/18
[updated] Recompiled for KSP 1.4.0
[fixed] Application Launcher Icon no longer hangs around the main menu... for reals this time

Please note, it's not up on Spacdock (and thus not on CKAN), because Spacedock hasn't yet added support for version 1.4.0.  I expect that'll be fixed by tomorrow.

 

@Fweds Now that it's updated please remove your hosted file. I don't want to confuse folks and/or end up supporting multiple codebases. Thank you. 

(Also, in the future.. please indicate 'unofficial' in the title of any recompiled versions for the sake of clarity)

Edited by NavyFish
Link to comment
Share on other sites

4 hours ago, NavyFish said:

 

@Fweds Now that it's updated please remove your hosted file. I don't want to confuse folks and/or end up supporting multiple codebases. Thank you. 

(Also, in the future.. please indicate 'unofficial' in the title of any recompiled versions for the sake of clarity)

Link removed, thanks for update.

No problem in the future, this is my first update of mod myself so... :wink:

Edited by Fweds
Link to comment
Share on other sites

2 hours ago, VITAS said:

Now it does.

I was on a Mountain without cellphone service yesterday :)

Thanks for your awesome site VITAS!  :)

 

2 hours ago, LameLefty said:

Glad you're back, @NavyFish, and thank you! Docking without your tool is so painful now! :)

It's good practice doing it the old fashioned way haha :) 

Link to comment
Share on other sites

12 minutes ago, LameLefty said:

One minor (very minor) nit: the .version file claims it's for KSP 1.3.0 - 1.3.1 and gives you a nag from the AVC plug-in at launch that you can safely ignore. I edited the .version file manually to fix it for my own install.

 

Yeah, derp. I have fixed the files on both spacedock and curse, neither had many downloads yet (probably because of that 'minor' nit). Apologies to anyone who got the bad version file

Edited by NavyFish
Link to comment
Share on other sites

Last time I started ksp via ckan, I also got that same message saying it was for 1.3.0 and I'm on 1.3.1. Weird as I have had this mod for some time now and never got that message before. Should I update to it on ckan even though I'm still running on 1.3.1 (not ready for 1.4.0 yet).

Link to comment
Share on other sites

Hey NavyFish, you might want to update the title of the OP to indicate 1.4 compatibility? Thanks for the update by the way!

12 hours ago, MikeO89 said:

Well I'm on 6.7 and just got that error on last startup using 1.3.1. The error I got was "Docking Port Alignment Indicator. Unsupported KSP versioin. Please use 1.3."

That's just MiniAVC because the version file wasn't updated (probably because it didn't need to be updated for 1.3.1) can safely be ignored

Link to comment
Share on other sites

58 minutes ago, maro said:

WARNING

The download @ https://www.curseforge.com/kerbal/ksp-mods/docking-port-alignment-indicator

contains Trojan Win32/Critet.BS

No, it doesn't.

Windows Defender has been marking a bunch of mod-related .DLL's as containing this Trojan since at least Thursday. ModuleManager.3.0.6.dll; MechJeb2.dll; and Chatterer.dll have all been marked with the same false-positive.

Go ahead and use any online threat-scanner you can find (including Microsoft's own!) and you'll see the files are safe. People are having to tell Defender to ignore the file(s) and/or exclude the GameData folder in order avoid having Defender remove the files outright.

Edited by LameLefty
Link to comment
Share on other sites

26 minutes ago, NavyFish said:

The download contains MM 3.06 so perhaps that's what's doing it.  Literally zero code changes since 6.8.0.

Nope, that's not it. For some reason, Windows Defender is going ape-crap over KSP mods in the last few days. It quite literally thinks DockingPortAlignmentIndicator.dll contains a Trojan, per some sets of the malware definitions. It also reports the same Trojan in Chatter.dll, ModuleManager.3.0.6.dll, and/or MechJeb2.dll and is deleting them all from peoples' GameData folders. 

And that's DESPITE people going to Microsoft's own online file submission/scanning site, reporting a false-positive and seeing their own online tool as marking it clean!

Just more idiocy from Microsoft.

Link to comment
Share on other sites

26 minutes ago, maculator said:

I love this mod and it's just something cosmetic, but when leaving the game to the menu I get this:

cuPzKA1.jpg

(spoiler: top right corner

Did you completely remove the prior version of DPAI?  If not, delete the entire Navyfish folder and drop 6.8.1's in there. I fixed that..

Link to comment
Share on other sites

I'll check if its 6.8.1, but I got it like 30mins ago from spacedock.

Edit: .zip says it'S 6.8.1, so does read me inside the .zip.

 

Edit Edit: Downloaded it again and cleanly replaced the "old" NavyFish folder, solved it.

Edited by maculator
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...