Jump to content

[1.8.1] Docking Port Alignment Indicator (Version 6.8.5 - Updated 12/14/19)


Recommended Posts

17 hours ago, DomiKamu said:

Using French Windows 7 too (us-en KSP) - but this "bug" also concerns English Windows users. Firstly, other mods I'm using don't have this "bug". I admit the game runs fine, but be sure it's abnormal. For me, it's a bug, like any other bugs. I don't understand why it wasn't fixed (despite as indicated in TXT file - since 6.8.0 !). For now, I don't use it why this bug remains unfixed.

The stock toolbar is set to show up in FLIGHT MODE _only_, but it still shows up on the main menu sometimes.  Looks like it's either a bug in the KSP libraries, or a misunderstanding of how the libraries need to be used.
Please note that it doesn't show up _all_ the time so the reason for it showing up sometimes but not always makes it more difficult to figure out what's going on. It will take some time to investigate and fix as the original fix (restricting it to FLIGHT MODE) obviously didn't entirely work.

A very minor cosmetic issue like this one is not exactly high priority. None of us are getting paid for this and we mod in our spare time - people have dayjobs and lives outside modding too. Perhaps if you paid us we could quit our jobs and spend more time on this..?

But if you consider this to be a game-breaking bug for you, please feel free to use another mod instead.  This issue has been reported, and is being investigated.

Further discussion about this issue is just wasting thread space now.

----
@Stone Blue Your argument to default to using the Stock toolbar makes sense to me.  Unless Navyfish vetoes it I'll change the default for the next release, it should only be a couple of lines of code. :)

Link to post
Share on other sites
42 minutes ago, micha said:

Made a test release - https://github.com/mwerle/Docking-Port-Alignment-Indicator/releases/tag/6.8.4.1-mw

Should hopefully fix the Stock Toolbar issue but needs more testing.

Well, I didnt fully test the mod... basically just started up my dev install, and poked around the UI/settings...

Good news is... no apparent peeps in the KSP.log from DPAI, and also a clean bill of health from MADLAD :)

Better news is... icon shows up in stock toolbar by default... and when you *un*check the "Always show in stock toolbar" setting, the icon immediately switches to (*and is immediately visible*) in the (Blizzy) Toolbar ... :O ... you dont even have to mess with the Toolbar settings to make it visible... NOICE!! ...
Thanx Micha, for the sorcery and the quick update ;)

Link to post
Share on other sites
10 hours ago, micha said:

Made a test release - https://github.com/mwerle/Docking-Port-Alignment-Indicator/releases/tag/6.8.4.1-mw

Should hopefully fix the Stock Toolbar issue but needs more testing.

 

Hi micha, I've done few tests this evening by using your DPAI 6.8.4.1 "debug" patch - the icon doesn't appears when returning to main menus. Of course, more tests are perhaps required (I presume), but I hope is a good way!

I use stock bar only (+ ToolbarControl / ClickThroughBlocker, required for lastest Critical Temperature Gauge mod). Last checkbox unchecked (like Stone Blue just above).

Thanks!

Edited by DomiKamu
Link to post
Share on other sites

@micha Again, thanx for the quick updates :)

And again, KSP.log and MADLAD give NO indications of issues. (other than improperly sized textures in DPAI)

One thing tho, DPAI is NOT remembering settings changes between game restarts. Every time I restart the game, the DPAI settings are back to the default. ALL the settings... Even the GUI size setting.

Also, theres an old alternate texture pack that was made by someone for DPAI for KSP 1.0.5, that seems to still work with it, too :)

Its under a
WTFPL Public License, so I'm including a link here, in case @NavyFish wants to add it to the OP, or if anyone else wants to use it.
I dont know who or where it came from (might be buried in a post in this thread, sorry, i dont have time right nao to check), so if anyone knows who posted it/source link, please let me know.
Docking Port Alignment Indicator- Texture Pack v0.2 (1.0.5)

Edited by Stone Blue
Link to post
Share on other sites
21 hours ago, Stone Blue said:

One thing tho, DPAI is NOT remembering settings changes between game restarts. Every time I restart the game, the DPAI settings are back to the default. ALL the settings... Even the GUI size setting.

Sorry, can't repro this. Check if config.xml exists and can be written to?

Link to post
Share on other sites
2 hours ago, micha said:

Sorry, can't repro this. Check if config.xml exists and can be written to?

Strange... now *I* cant repro it either... :face_palm: ...Had restarted three times, with this issue yesterday... Now this morning, it works fine after a few restarts... vOv
Sorry if it ends up being a false report... I guess nothing to worry aboot unless other reports start rolling in... :P

Edited by Stone Blue
Link to post
Share on other sites

Thanks a lot (no, thanks a million) micha!

Your modification (test release 6.8.4.1 mw) seems fine: by using it (stock bar, I never used Blizzy toolbar), no more DPAI icon in KSP menus (main menus) on scenes changes!
From your ZIP , I'm not sure if .pdb files are required or not (I've installed them, however) - perhaps required debug symbols...

Also, thanks for cleaned 6.8.4.2 I've seen above, I'll test it this Sunday. EDITED: both 6.8.4.1 mw and 6.8.4.2 mw work fine!

Great stuff, merci (thanks in French ;) ) - have a merry Christmas in advance.

Edited by DomiKamu
Link to post
Share on other sites

DPAI UPDATED

100%+ credit and thanks go to @micha for this release.  

Version 6.8.5 - 2019-12-24

  • Compiled for KSP 1.8.1
  • [fixed] Stock Toolbar icon showing up in different scenes (main menu).
  • [update] Defaults to using Stock Toolbar.

https://spacedock.info/mod/543/Docking Port Alignment Indicator

https://www.curseforge.com/kerbal/ksp-mods/docking-port-alignment-indicator

Edited by NavyFish
Link to post
Share on other sites
On 12/28/2019 at 3:04 AM, SpaceJaM said:

Hello, I've noticed that, when the checkbox to ignore docked ports is checked, the standard size ports are correctly ignored, but the senior size ports are cycled in the target panel even if they are already docked.

It's not limited to Senior Ports - any port which is attached in the VAB does not get ignored.  Fixed in code pending next release. If anybody wants to test, the pre-release can be downloaded from here.

Link to post
Share on other sites
On 1/4/2020 at 1:40 AM, micha said:

It's not limited to Senior Ports - any port which is attached in the VAB does not get ignored.  Fixed in code pending next release. If anybody wants to test, the pre-release can be downloaded from here.

Thank you!
I did not notice this detail because I never cycled through ports close to station, I'll check for it before downloading the update. Some senior ports were docked at launch (some adaptors from senior to sandard on side docks for future expansion, and one end of each station part was docked to the launcher) 

Link to post
Share on other sites
16 hours ago, Kerbal Pig said:

Does this work with Moardv's Avionics Systems?

Seems to... Depends on if the IVA supports MAS. I preliminarily tried it with G'th's Ultimate Shuttle IVA, and initial testing looks good...

EDIT:... OMG... did I derp, big time... :face_palm:

@micha
Ultimate Shuttle IVA uses a mix of *both* MAS and RPM MFDs... Guess what?... DPAI works on an RPM MFD in that IVA...
So, looking thru both the DPAI and MAS repos, no, it doesnt look like there is a DPAI .cfg for a MAS MFD... :(

So unless some IVA maker made one specific to their IVA, and is squirrelling it away, then I *dont* believe there is DPAI/MAS compatability yet

Edited by Stone Blue
Link to post
Share on other sites
On 1/3/2020 at 7:40 PM, micha said:

It's not limited to Senior Ports - any port which is attached in the VAB does not get ignored.  Fixed in code pending next release. If anybody wants to test, the pre-release can be downloaded from here.

I assume that if you only have one docking port that this issue can be ignored

Link to post
Share on other sites
  • 1 month later...

6.8.6 release is live.

Get it through CKAN, or directly from the official GitHub repository.

Changelog:

[update]  Recompiled for KSP 1.9
[fixed] Docking ports attached in VAB were not being ignored (#3)

EDIT: @NavyFish : Can you please update the top-post? I've already updated the download sites.

Edited by micha
Link to post
Share on other sites
3 hours ago, micha said:

6.8.6 release is live.

Get it through CKAN, or directly from the official GitHub repository.

Changelog:

[update]  Recompiled for KSP 1.9
[fixed] Docking ports attached in VAB were not being ignored (#3)

Did it need to be recompiled for 1.9, or was that just part of the bugfix?

Link to post
Share on other sites
7 hours ago, linuxgurugamer said:

Did it need to be recompiled for 1.9, or was that just part of the bugfix?

Just because of the bugfix - I had already marked the previous version as being compatible with 1.9 before remembering I had a pending bug fix to roll out... 

Perhaps a better changelog entry might have been "Compiled using KSP1.9".

Link to post
Share on other sites
Just now, micha said:

Just because of the bugfix - I had already marked the previous version as being compatible with 1.9 before remembering I had a pending bug fix to roll out... 

Perhaps a better changelog entry might have been "Compiled using KSP1.9".

Thanks.  From what I've heard and seen, most mods won't need to be recompiled.  I just got concerned when I saw your notes

Link to post
Share on other sites

Used this for the first time with 1.9.0. Even though had this installed with 1.8.1, i never docked. Got to say, wow. This mod is so useful, easy to use. Right up there with Alarm Clock. Thanks much for mod.

Been a long time since docked in KSP. One the things noticed when docking on the dark side of the planet, would be a useful to have a new  mod to have spotlights on Clamp ports.

This mod works with 1.9.0 just fine and CKAP shows 1.9.9 compatible, should the forum thread title be updated to show [1.9.9] ?

 

Edited by fragtzack
Link to post
Share on other sites
10 hours ago, fragtzack said:

One the things noticed when docking on the dark side of the planet, would be a useful to have a new  mod to have spotlights on Clamp ports.

Would be nice, but beyond the remit of this mod.  You can always add spotlights to your ship pointing forward.. 

With this mod I can dock without looking at anything other than the DPAI window (once close enough).
 

10 hours ago, fragtzack said:

This mod works with 1.9.0 just fine and CKAP shows 1.9.9 compatible, should the forum thread title be updated to show [1.9.9] ?

Yes, but unfortunately I don't "own" the thread so @NavyFish has to do that..

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...