Jump to content

[0.22] Universe Replacer v4.0


Recommended Posts

Tingle, spacex34, Rareden, and AncientGammoner, how would you feel if I distributed modified versions of your textures?

I've been tweaking my own copies for optimum filesize and appearance, plus compiling what I feel are the best versions of each world.

No problem for me

I wanted to make v 0.2 for my pack but I started another project

Link to post
Share on other sites
Tingle, spacex34, Rareden, and AncientGammoner, how would you feel if I distributed modified versions of your textures?

I've been tweaking my own copies for optimum filesize and appearance, plus compiling what I feel are the best versions of each world.

Don't redistribute mine yet, I'm not done. Also, PNG is going to be the most optimal filetype in the next KSP/Unity update due to it fixing a PNG load/decompress bug which caused PNG's to load very slow. If you are trying to use JPEG, JPEG has slow loading/decompressing times and does not support ALPHA channels which is required for most of the textures. You can read up on some extensive benchmarking and tests I did some time back: http://forum.kerbalspaceprogram.com/showthread.php/44135-0-21-x-Universe-Replacer?p=573064&viewfull=1#post573064 - make sure to read the Update

Link to post
Share on other sites
Don't redistribute mine yet, I'm not done. Also, PNG is going to be the most optimal filetype in the next KSP/Unity update due to it fixing a PNG load/decompress bug which caused PNG's to load very slow. If you are trying to use JPEG, JPEG has slow loading/decompressing times and does not support ALPHA channels which is required for most of the textures. You can read up on some extensive benchmarking and tests I did some time back: http://forum.kerbalspaceprogram.com/showthread.php/44135-0-21-x-Universe-Replacer?p=573064&viewfull=1#post573064 - make sure to read the Update
Thanks for clarification on licensing :) And yeah, I have no intention of touching JPEG. I remember reading the linked post back when you first put it up... hooray for testing!
Link to post
Share on other sites
Mine's always crashing :(

using 8k kerbin clouds and mushroomman's clouds

You're almost certainly running out of memory. Once you hit roughly 3.6GB used the game craps itself. Having lots of mod parts plus large texture packs can do that in a hurry.
Link to post
Share on other sites
hi guys,

i know it might be very simple to install that mod but i got issues with it.

i've just downloaded and install this mod under my KSP/Gamedata/Universereplacer folder and added Sido's texture pack, mushroomman's cloud one and rareden's skybox in it but it wont load in the game.

does all textures have to be in .png? cause i can see some of them in .jpeg

and i only have only one file at a time, like Kerbin1 only but the texture list.txt says "Kerbin1" and "Kerbin2".. so i'm pretty lost atm..

what's exactly the way to make this work plz?

:)

can i get some help please?

Link to post
Share on other sites
can i get some help please?

I don't know what your issue is, but JPEG is fine and "Texture List.txt" contains what textures are replaceable, not which ones are needed. So it sounds like you installed it correctly.

Link to post
Share on other sites
I don't know what your issue is, but JPEG is fine and "Texture List.txt" contains what textures are replaceable, not which ones are needed. So it sounds like you installed it correctly.

yeah that's what i though, but the fact is that the new textures aren't loading in game. kinda weird..

is there anything special or issues that i should know about?

mod compatibility maybe?

Edited by b0bby
Link to post
Share on other sites

Should be compatible with Kethane, Eva Follower seemed to have some issue because they haven't applied the mod compatibility bug fix yet I think. Try running Universe Replacer alone and then see if it works.

Link to post
Share on other sites
Kethane, Eva Follower

i'm using both. thanks for the tip, i'll look for it.

edit: well.. i tried to remove both kethane and eva followers and the textures still aren't loading..

Edited by b0bby
Link to post
Share on other sites

Bobby, when you click on the GameData/Universe Replacer folder... what folders do you see on the first level?

You should see "Plugins" and "Textures"... but I'm betting you see another "GameData" folder instead.

That would happen if you unpacked the .zip or .rar into GameData instead of the top-level KSP directory. Cut and paste the folders within to the proper place and I'll bet it works fine.

Link to post
Share on other sites
Bobby, when you click on the GameData/Universe Replacer folder... what folders do you see on the first level?

You should see "Plugins" and "Textures"... but I'm betting you see another "GameData" folder instead.

That would happen if you unpacked the .zip or .rar into GameData instead of the top-level KSP directory. Cut and paste the folders within to the proper place and I'll bet it works fine.

nope, thanks for the tip also but i'm used to winrar. i've checked this on my first try.

Link to post
Share on other sites
You're almost certainly running out of memory. Once you hit roughly 3.6GB used the game craps itself. Having lots of mod parts plus large texture packs can do that in a hurry.

This thinking only applies to windows users... Linux/OSX has PAE to address larger memory space even on a 32bit process.

I am hoping the next KSP update resolves my problems (and possibly his), I believe the update Tingle mentioned which has to do with png compression and loading may have something to do with it.

Link to post
Share on other sites
i've just downloaded and install this mod under my KSP/Gamedata/Universereplacer folder and added Sido's texture pack, mushroomman's cloud one and rareden's skybox in it but it wont load in the game.

does all textures have to be in .png? cause i can see some of them in .jpeg

and i only have only one file at a time, like Kerbin1 only but the texture list.txt says "Kerbin1" and "Kerbin2".. so i'm pretty lost atm..

what's exactly the way to make this work plz?

:)

hmm well I cannot see anything wrong in the way you have it installed.. here is a pic of my folder structure for you to check yours against :)

g7mp.jpg

Link to post
Share on other sites

I have some problems with this mod. It works fine with one of the new Skybox textures (the game loads up fine, and the new Skybox loads up beautifully ingame) , but I can't get the game to load with the respective planet/moon images in their respective texture folders. It just doesn't want to continue loading (then I press the windows icon on my keyboard and then I get a crash report)

Link to post
Share on other sites
Parts? Nothing to do with this mod. If you want gold probe cores, check AIES mod.

Not true, you can replace stock part textures as well - currently only pods/cores tho, more will be added in the future.

Link to post
Share on other sites
hmm well I cannot see anything wrong in the way you have it installed.. here is a pic of my folder structure for you to check yours against :)

g7mp.jpg

thanks for the picture mister simplicity. sadly, that's exactly how i installed it but it still doesnt work..

here's my mod list:

aDyj0g0l.png

+ subassembly (0.21 version) and ISAmapsat (0.21 version)

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...