Sign in to follow this  
sarbian

MechJeb 2 - Patch test bed release (October 10)

Recommended Posts

I expect that MechJeb can find out if a docking node is changing state, though.

If it can do that, then it would be better for it to wait and disable Smart ASS on both vehicles upon undocking, maybe even turning on SAS as well for both vehicles at that time.

Share this post


Link to post
Share on other sites
I'm in the same boat... does anyone have a copy of the Aug 31 build?

Me too, Usually I do a backup, but was in a hurry to get it installed I didn't.. - please can some kind soul post the Aug 31 build for us :)

Share this post


Link to post
Share on other sites

I am having trouble with the docking autopilot on the Sep 9 build. I engage it and it lines everything up and then does nothing. "moving forward to dock at 0.0m/s". I have speedlimit set at 0.5m/s.

Share this post


Link to post
Share on other sites
Here's a link to the Aug. 31 .dll. good thing I always wait a few days before grabbing new versions.

https://www.dropbox.com/s/d5ovkg0f68wbg1w/MechJeb2.dll

Tell me if this link works, first time using dropbox.

Worked fine. Bless you my son. (actually I have no idea idea of our age differential; I just felt like saying it for some weird reason)

I am having trouble with the docking autopilot on the Sep 9 build. I engage it and it lines everything up and then does nothing. "moving forward to dock at 0.0m/s". I have speedlimit set at 0.5m/s.

Try turning off RCS fuel conservation. (oh, wait... that would be the build that totally disables MJ2 after undocking... you might want to skip that one and grab the DLL posted by Sojourner. He posted it directly above your post....

btw for the first time I tried setting speed limit to 0.0 for the first time then sat back and let MJ2 do everything itself. (for anyone who doesn't know, that effectively tells MJ2 there IS no speed limit.

This was with my very expensive Minmus Kethane orbital mining station that has given me so much trouble because of buggy physics issues with one of the Kethane tanks. I admit it was a little difficult for me to actually sit there doing NOTHING while my shuttle hurled itself at maximum speed (well maximum with RCS) as though Jebediah himself were manning the controls. But it did it! I was impressed... :confused:

Edited by Starwaster

Share this post


Link to post
Share on other sites

I tried using that old build and no dice, I think I also tried setting a speed limit of zero as well. MJ never seems to successfully figure out that he needs to move.

Share this post


Link to post
Share on other sites
I tried using that old build and no dice, I think I also tried setting a speed limit of zero as well. MJ never seems to successfully figure out that he needs to move.

obvious question, but do you have RCS fuel?

Share this post


Link to post
Share on other sites
I tried using that old build and no dice, I think I also tried setting a speed limit of zero as well. MJ never seems to successfully figure out that he needs to move.

yes but did you turn off Conserve RCS Fuel?

if not, turn it off

Share this post


Link to post
Share on other sites
you can turn your tolerance up to around .5 or .8 and that will help with chasing the ball.

Sorry for the late respond. Err where do i set the tolerance??? or are you referring to Tf in altitude adjustment?? i have that set at 0.9 now.

Share this post


Link to post
Share on other sites
Sorry for the late respond. Err where do i set the tolerance??? or are you referring to Tf in altitude adjustment?? i have that set at 0.9 now.

No I think he's talking about the tolerance setting under Maneuver Planning....

Share this post


Link to post
Share on other sites
No I think he's talking about the tolerance setting under Maneuver Planning....

Yes that is what im talking about, sorry for not making that clear

Edited by viperwolf

Share this post


Link to post
Share on other sites

So, maybe I don't fully understand a certain feature, but my mechjeb tab recently disapeared on undocking. Was this intended? If so is there a key function to bring it back. Reloaded game and tab is still missing in SPH/VAB and in flight.

Great work though, keep it alive gents!

Share this post


Link to post
Share on other sites
mechjeb tab recently disapeared on undocking.

Did you un-dock from the rocket section that had the MechJeb part installed or did you update your part configs? If you use the MJ part then it sounds like you undocked from the part of the ship that had MJ on it. I *think* you could edit the .cfg for the command module on the ship you are still flying to add it back in (but I could be wrong there, I haven't tried doing it in flight).

Good luck!

-Dead

Share this post


Link to post
Share on other sites

I should reiterate that it is not working on any other vessels or in the VAB/SPH anymore either, but no, I don't edit CFG files. The station and ship both had a MJ part and when I undocked the ship from the station, MJ tab disapeared for everything.

Share this post


Link to post
Share on other sites
I should reiterate that it is not working on any other vessels or in the VAB/SPH anymore either, but no, I don't edit CFG files. The station and ship both had a MJ part and when I undocked the ship from the station, MJ tab disapeared for everything.

Ahhhhhh, sorry I misunderstood... it sounds like MJ is crashing, can you post your logs? Somebody here might be able to figure out what is going on. I have never experienced a problem like that, I've only had issues like that with MJ after a patch or when adding or removing various mods. It could be a MJ cfg problem but that is only a guess (each MJ ?ship? or is it ?part? has a cfg file in the dll config folder.).

-Dead

Share this post


Link to post
Share on other sites

try going to gamedata/mechjeb2/plugins/plugindata/mehcjeb2 and deleting the mechjeb_settings_global.cfg file. That file will be recreated by mechjeb when you run KSP and controls all the window settings for the addon.

Share this post


Link to post
Share on other sites
I should reiterate that it is not working on any other vessels or in the VAB/SPH anymore either, but no, I don't edit CFG files. The station and ship both had a MJ part and when I undocked the ship from the station, MJ tab disapeared for everything.

Read a few pages back, look for Sojourner's post and grab the August 31st release that he has in his dropbox.

The issue you're experiencing is a direct result of the latest update which attempts to address MJ2 activating and performing maneuvers after undocking. The solution unfortunately results in MJ2 completely being disabled and apparently there's no means in-game of re-enabling it, it got written to the global settings config.

Share this post


Link to post
Share on other sites
try going to gamedata/mechjeb2/plugins/plugindata/mehcjeb2 and deleting the mechjeb_settings_global.cfg file. That file will be recreated by mechjeb when you run KSP and controls all the window settings for the addon.

That did the trick. Thanks. What can cause this, or does it just happen sometimes? Should I see if another mod is doing this or just fix it if it does it again?

Share this post


Link to post
Share on other sites
Read a few pages back, look for Sojourner's post and grab the August 31st release that he has in his dropbox.

The issue you're experiencing is a direct result of the latest update which attempts to address MJ2 activating and performing maneuvers after undocking. The solution unfortunately results in MJ2 completely being disabled and apparently there's no means in-game of re-enabling it, it got written to the global settings config.

Copy that, ill get the previous version.

Share this post


Link to post
Share on other sites
Read a few pages back, look for Sojourner's post and grab the August 31st release that he has in his dropbox.

...

When making suggestions like this it usually helps a lot to provide a direct link to your solution: http://forum.kerbalspaceprogram.com/showthread.php/47317-MechJeb-2-Patch-test-bed-release-%28September-9%29?p=645321&viewfull=1#post645321

Share this post


Link to post
Share on other sites
When making suggestions like this it usually helps a lot to provide a direct link to your solution: http://forum.kerbalspaceprogram.com/showthread.php/47317-MechJeb-2-Patch-test-bed-release-%28September-9%29?p=645321&viewfull=1#post645321

You know, some times I will do exactly that because I'm such a swell guy who's just stupid enough to do people's work for them but I didn't have the link handy and shouldn't HAVE to go looking for that which people can search out themselves

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this