blizzy78

[1.2.0] Precise Node 1.2.4 - Precisely edit your maneuver nodes

Recommended Posts

Will the created nodes be somehow saved when I switch to another vehicle?

Share this post


Link to post
Share on other sites
Will the created nodes be somehow saved when I switch to another vehicle?

No. I can think of a few ways to do it right off hand, the easiest being a PartModule that would be loaded through ModuleManager in order to save nodes with the vessel itself (rather than some overly complicated scheme involving GUIDs and a massive config file), but I'm not entirely sure I want to spend all that time debugging whatever mess that causes.

Maybe... Once I get the next version out the door I might take a crack at it. It's a lot more appealing than adding even more buttons to this already overloaded GUI.

E: Oh, status report. I seem to have dealt with the SQUAD null refs (inadvertently caused by my own misunderstanding of how C# handles variables) but I have to take care of some new errors. Hopefully we'll have a new one this week, no promises.

E2: Question: Now that we have textboxes would anyone have a problem with me removing the 10K time buttons in favor of AN/DN buttons?

Edited by regex

Share this post


Link to post
Share on other sites
E2: Question: Now that we have textboxes would anyone have a problem with me removing the 10K time buttons in favor of AN/DN buttons?

As long as the text boxes are functioning, I think that'd be a good compromise.

Share this post


Link to post
Share on other sites
E2: Question: Now that we have textboxes would anyone have a problem with me removing the 10K time buttons in favor of AN/DN buttons?

I'm not sure I ever used the 10K time buttons, as I don't even know what they are, but adding AN/DN buttons is tops! Or, instead of dedicated buttons for each snap to, a drop down of all the snaps and one button to execute?

Share this post


Link to post
Share on other sites

when I try to download the mod i get "Sorry, we are unable to retrieve the document for viewing or you don't have permission to view the document."

Share this post


Link to post
Share on other sites
when I try to download the mod i get "Sorry, we are unable to retrieve the document for viewing or you don't have permission to view the document."

Try File->Download, worked for me in an incognito window, even with the error.

Share this post


Link to post
Share on other sites

Okay, I think I've taken care of the majority of errors, the textboxes now (seem to) work correctly and there is no more Null Reference spam (that I can see).

Please let me know if anything is broken, thanks again for your patience. I will leave the links to 0.7 and 0.4 around just in case things go bad.

So long as nothing is completely messed up I'm going to let this version simmer for a bit before moving on to new features. Up next I'm considering adding the AN/DN controls and then maybe a PartModule for saving nodes (I'll have to prototype this, but it'll probably work fine).

Share this post


Link to post
Share on other sites
Grats on being showcased in Modding Mondays!!

Thanks, I did not expect that! :)

Share this post


Link to post
Share on other sites

i like this very much.

i often chuckle to myself thinking of how much calculus i am NOT doing while working on setting up a maneuver that changes multiple vectors in a single burn.

Share this post


Link to post
Share on other sites

I did a return mission from Duna this morning and it worked flawlessly. Can't see any issues resurfacing with the text boxes.

Thanks, I did not expect that! :)

Well... it's well-deserved IMO. There's very few mods that I actually consider essential before updating. This, KER and mod-manager are pretty much it. So, in case you don't hear it enough... thankyou.

Without wanting to be crass, have you considered taking donations? I'd sling you a few beer tokens.

Share this post


Link to post
Share on other sites
Well... it's well-deserved IMO. There's very few mods that I actually consider essential before updating. This, KER and mod-manager are pretty much it. So, in case you don't hear it enough... thankyou.

Without wanting to be crass, have you considered taking donations? I'd sling you a few beer tokens.

Nah. I appreciate the gesture but I don't want to feel any more obligated to this mod than I already am; kind words are enough.

Share this post


Link to post
Share on other sites

Yeah, I figured that might be the case. Much appreciation anyway.

Share this post


Link to post
Share on other sites

It isn't quite working for me. I like to make my burns from the map mode because it allows me to see the difference between what the node says and what is actually going on. You can't do an 800m/s burn right at the node so there is a difference. But when I am burning in map mode with this plugin it just moves the node around as if I am still editing it. I tried making the burn while not in map mode, but when I went to check on how it is doing on the map mode it reset the node to what it was when I started.

Is there some way to tell the editor that I am done editing the node and I now want to use the node. And if not, could you add it.

Share this post


Link to post
Share on other sites

Interesting. I'll see if that can be fixed tonight.

E: in the meantime try hiding the window with "p".

Edited by regex

Share this post


Link to post
Share on other sites
It isn't quite working for me. I like to make my burns from the map mode because it allows me to see the difference between what the node says and what is actually going on. You can't do an 800m/s burn right at the node so there is a difference. But when I am burning in map mode with this plugin it just moves the node around as if I am still editing it. I tried making the burn while not in map mode, but when I went to check on how it is doing on the map mode it reset the node to what it was when I started.

Is there some way to tell the editor that I am done editing the node and I now want to use the node. And if not, could you add it.

When you are doing a burn in map mode with this plugin open it just moves the node around as if you are editing it? How is it acting exactly? screenshots? Are you using an older 0.7.5 build? Do you have any other mods installed that edit maneuver nodes (MechJeb, Maneuver Node Improvement, etc...)?

I just got home and immediately checked this; I can't reproduce what you are describing. For 0.8 I made sure to make the node editing policy widget/node first, so any changes to the node itself would take precedence. That should include burns.

I tried leaving the window open using 0.8 and did not encounter this issue. I even went between map and flight view several times during the burn and did not experience anything like what you are describing. Try removing the old directory completely and then re-install from a freshly downloaded 0.8.

Share this post


Link to post
Share on other sites

@ regex: I would like to ask for a very minor improvement.

PreciseNode main window (the one that automatically appears when a node exists in map mode) has those two buttons marked (by default) O and K, that open options and keys panels. Those two tiny buttons remain active while the relative panel is open, so I would expect them to be used to toggle the same panel off. You may smile at that, but it is so more natural to me, I always try to use those buttons, instead of the ones on the panels (quite less visible). What about changing their behaviour to toggle mode (on/off)?

Share this post


Link to post
Share on other sites
You may smile at that

I did, actually, because it makes perfect sense. :) Next version will include this.

Share this post


Link to post
Share on other sites

I'm having a similar issue. When I leave the map up the node constantly refreshes and thus does not count down the burnt fuel from the deltaV counter.

Share this post


Link to post
Share on other sites
I'm having a similar issue. When I leave the map up the node constantly refreshes and thus does not count down the burnt fuel from the deltaV counter.

As I said, I can't reproduce this. You'll need to provide me with more information (see this post.)

Share this post


Link to post
Share on other sites

The only mod that does anything with maneuver nodes is Kerbal Alarm Clock.

It seems to happen when I use the mod to edit a maneuver node.

I also took screenshots.

Before Burn

After Burn

You can see that both my orbit and the projected orbit of the node have moved outward. In the first image only the node orbit is beyond my satellites orbit, and in the second one both orbits are beyond my satellites orbit.

Share this post


Link to post
Share on other sites
The only mod that does anything with maneuver nodes is Kerbal Alarm Clock.

It seems to happen when I use the mod to edit a maneuver node.

I also took screenshots.

What are the other mods you have installed? I see a bunch there, like that one in the lower right and some in Blizzy's toolbar.

Share this post


Link to post
Share on other sites
What are the other mods you have installed? I see a bunch there, like that one in the lower right and some in Blizzy's toolbar.

Toolbar, Deadly Reentry, Flight engineer, Enhanced Nav Ball, Ferram Aerospace Research, Protractor, Remote Tech, Tarsier Space Technology, Kerbal Alarm Clock, and Precise Node.

Share this post


Link to post
Share on other sites

I can confirm this issue. I have found a work around but it is a pain in the but.

Basically after I set the node I will then enter it into Kerbal Alarm Clock and then delete the node so it is restored when the alarm goes off. That 'fixes' the behavior for me, but I need to do that every time and haven't really done any actual testing as such.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.