Jump to content

[1.0] KerbPaint - Paint layering for parts (March 30th, 2016) Community Update


Texel
 Share

Recommended Posts

Thanks for the info guys. I thought this would probably be the case :/ My 1:1 scale shuttle really struggles enough with aerodynamics and weight distribution as it is. I did see a photo of some (what looked like) b9 wings with the carbon carbon leading edge and black shielded underside on the shuttle engines mod page on forums.. http://forum.kerbalspaceprogram.com/threads/55985-0-23-5-16-Mar-Space-Shuttle-Engines-V1-2-Bugfixes-and-minor-improvements

Check the 1st image on the 2nd imgur image feed on that page

.. I'm really bad at posting/linking images :P

Link to comment
Share on other sites

Yeah, B9 has some beautiful wings, but he only did the front edges in carbon. If he had done the bottoms of those wings black to match the fuel tanks, then it would have been epic.

I'm actually thinking about starting on B9 after I get the first LLL addon done, but the thought worries me a little. My computer isn't the fastest, with aggressive texture manager and only LLL installed it takes about 10 minutes to load, and each time I need to make changes to the .cfg files I have to restart the program. B9 is easily twice the size of LLL, so I see a lot of time in my future of staring at loading screens. Still plan to try though. ^_^

Edited by Tenneko Kazeno
Link to comment
Share on other sites

Yeah, B9 has some beautiful wings, but he only did the front edges in carbon. If he had done the bottoms of those wings black to match the fuel tanks, then it would have been epic.

I'm actually thinking about starting on B9 after I get the first LLL addon done, but the thought worries me a little. My computer isn't the fastest, with aggressive texture manager and only LLL installed it takes about 10 minutes to load, and each time I need to make changes to the .cfg files I have to restart the program. B9 is easily twice the size of LLL, so I see a lot of time in my future of staring at loading screens. Still plan to try though. ^_^

Wow that's some pretty epic loading times, yeah I have a similar situation. You should temporarily remove all the mods, and parts from mods in the files that aren't involved in what you're testing to decrease loading times. Obviously this only works so long as you're not testing problems related to inter-mod compatibility but yeah this should help. Btw your parts mod looks mighty tasty if I may say so. When I get back to my PC after Easter break I'll have to give it a tryout! And as always god speed to all those in the endless wait for x64 ksp..

Link to comment
Share on other sites

The Mk1 to Mk2 adapter doesn't paint right for me. All the other parts do, but it only paints the very back part of it, leaving the rest of it untouched. The screenshot above, the red aircraft, the piece I'm talking about is directly connected to his cockpit.

Link to comment
Share on other sites

Is there a way to add a custom color to the defaults/replace the defaults? Or the replace/add to the preset patterns? If anyone could tell me, that would be great, as I have these colors that I really like, but can't be bothered copy/pasting them in game, or setting each part up with them individually. Also, a "Mass Paint" option would be great, i.e. a way to paint every paintable part on your craft... Any replies would be greatly appreciated.

Thanks!

Espresso

Link to comment
Share on other sites

I'm getting issues with the particle effects of the Rockomax BACC Solid Rocket Booster. All the other engines I've tested are fine, but the particles for this solid booster seem to not be transparent - each particle texture is box-y. I've narrowed the issue to Kerbpaint, which is a shame as I really want to use this mod. Maybe check to see if the mod alters these specific particle effects? I'm not familiar enough to fix it myself.

Link to comment
Share on other sites

@Efemeril someone wrote this is not a bug of the mod per se, it happens in Stock as well. This mod only makes it more probable to happen. The solution is to use a mod that changes the VFX of the rocket engines, HotRockets seems to fix it.

Edited by Uzric
Link to comment
Share on other sites

Efemeril: Uzric's answer is correct, I had that happen to me when I first started playing KSP with no mods installed, this mod just makes it far more likely due to how it calls on textures. Hotrockets is a very good improvement anyway, so I recommend everyone get it even if they are not having this problem.

Spartwo: Hmm, I'll take a look, only those two parts though? If any others are acting up could you list which ones and I'll do my best to fix them. Last time it turned out Squad switched which way the shaders were applied to a few parts, so maybe this will be a simple fix. ^_^

Espresso: No, to my knowledge the patterns are hard-coded in the plugin and thus can't be edited. I don't have the programing knowledge needed to change that or add a mass paint ability, though I do agree that would be really cool. Do remember though, applying the same color choice to a part doesn't mean the two parts are the same color due to the underlying texture and how the shaders are applied.

Link to comment
Share on other sites

Espresso: No, to my knowledge the patterns are hard-coded in the plugin and thus can't be edited. I don't have the programing knowledge needed to change that or add a mass paint ability, though I do agree that would be really cool. Do remember though, applying the same color choice to a part doesn't mean the two parts are the same color due to the underlying texture and how the shaders are applied.

Thanks, I know about the Different-color-for-different-parts thing, but was wondering about the other, thanks for getting back to me, as I really appreciate it. a small change in color on the parts wouldn't be the end of the world. If Texel could come and add those features, it'd be great, sadly though, I think he's abandoned the mod... If any other plugin devs are out there and reading this, could you please see if my idea, to be able to change default colors & patterns & add a paint all option, would be doable? Thanks, It would be greatly appreciated!

Link to comment
Share on other sites

Wren: That is a nice looking plane, thanks for posting. Hmm, did the mk1 to mk2 adapters stop working again?

I'll have to take a look at those again. Sorry, I haven't fixed the inflight problems on the cubic struts yet, haven't had any time to work on it.Crunch time for us college students, two weeks left then I''ll have more free time. ^_^

Link to comment
Share on other sites

this doesn't seem to work for me? Upon loading it claims I have an old version of module manager but I have 1.5.6. Strangely every other mod continues to work but right clicking on the objects doesn't bring up a window to paint the obect

You need to delete module manager in GameData/Kerbpaint.

Link to comment
Share on other sites

  • 3 weeks later...

Hi there,

Great mod, I use it everytime I can but it only works for stock parts at it seems. Does anyone knows how to make it work with extra parts such as those coming from other mods ?

I thought finding files let's say textures files divided into three layers (so easy to edit starting with any original texture file) but _Paint files are completely sealed at this stage for me. Are they a kind of .mbm or even.png format ? (that the game handles perfectly) or something completely different ?

Enjoy your flight.

LKS

Link to comment
Share on other sites

Hi there,

Great mod, I use it everytime I can but it only works for stock parts at it seems. Does anyone knows how to make it work with extra parts such as those coming from other mods ?

I thought finding files let's say textures files divided into three layers (so easy to edit starting with any original texture file) but _Paint files are completely sealed at this stage for me. Are they a kind of .mbm or even.png format ? (that the game handles perfectly) or something completely different ?

Enjoy your flight.

LKS

They are renamed .png files - KSP automatically loads png files, so the extension was changed to make them load-on-demand.

Link to comment
Share on other sites

i painted these stock panels myself but why does the lighting change so dramatically when the metal panels are attached in different ways?

stock ksp

modded ksp

when i compare my problem to SWdennis's jaeger this issue doesnt seem to be there for stock panels; i tried them and they are fine. it seems it might be my alterations to the panel that cause the sharp change in lighting. theres just no way he built that without radial, angular attachments of panels SOMEWHERE. what i did was simply cover the panel in a solid green png and changed the model.mu, with hex editor, to accept png. they should all be the same colour changing gradually with angle to the sun; that is not the case.

from the grapevine i was told kerbpaint doesnt work for metal panels. this is the best place to ask and i need to know whether i can fix the lighting or not.

Link to comment
Share on other sites

Okay, this could be a couple issues. All Kerbpaint does is overlay a shader on top of existing textures, using a map created from those textures. So, it is possible that it will conflict with other shader mods. It could be that Kerbpaint is trying to load the shader, but KSP is reloading the .png file causing conflicts. Looking at the pics you put up, it definitely looks like something is confusing KSP's shader plugin. Have you tested these panels with other mods that mess with shaders?

Are you using my addon? If you are the metal panels still worked last time I checked.

As for fixing it, we first have to figure out if this is a Kerbpaint specific problem, or if it is an issue that occurs with any mod that messes with shaders.

Link to comment
Share on other sites

My mistake my friend I was trying to say that I am not using kerbpaint; I manually replaced the texture in the game directory. My thought was you kerbpaint fellows already know so much about painting stock parts that perhaps here is the right place to brainstorm.

This is good news that I am able to use your mod for vanilla metal panels. This situation is not all-together hopeless :)

I'm truly stumped why a texture replacement confuses ksp lighting. All my part cfg files are written so none conflict or use from another metal part but I have made a lot of them so it might be cfg error. Clearly the texture is working fine as I'm getting my desired colour on 75% est of the craft. I thought it was a vanilla ksp problem but when I put the stock panels in the same configuration as my test pictures, it seemed ok with no saturation.

Edited by praise the suuun
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...