Ratzap

[1.05] Fusebox - electric charge tracker and build helper. 1.52 released 24th Jan 16

Recommended Posts

You might check out how Contract Configurator does it. Looks like FlightGlobals.bodies is the list of all celestial bodies in the game, and then there are several methods and variables for querying a celestial body's rotation period (bodyname.rotationPeriod) (half of which is the darkness time, more or less), gravitational parameter (bodyname.gravParameter) (necessary to get orbital period), and then bodyname.orbit.semiMajorAxis to get the SMA.

Also, I don't think Near Future alters solar properties anymore, though I don't know about Interstellar, sorry.

Hey! Someone who reads the thread AND contributes useful information, make yourself comfortable pal ;) Seriously though, I was going to flick through some other mods to see how they handle it and you've saved me the effort - cheers.

Fusebox seems to handle NFT Solar just fine, but it doesn't seem to recognize any of the NFTE reactors (or the USI ones, but now that NFT electrical is out I don't use those anymore). I can confirm that it also doesn't recognize ScanSat power usage.

It worked for SCANsat12.0 when I tested it. What version are you using? Wonder if there's a new one out.

Share this post


Link to post
Share on other sites
Just to say the available version on CKAN is 1.31 (instead of 1.41)

I heard that. Hakan did the CKAN config previously. I'll have to look at it soon and figure out how to keep it rolling.

That said, 1.0.3 should/may be coming out tomorrow. Depending on how much that changes I'll release a newer version sometime toward the end of the week.

Share this post


Link to post
Share on other sites

Just wondering, how can this mod possibly track all power usage? KSPI has a dedicated energy manager for this, but without this, how can you do it?

Share this post


Link to post
Share on other sites
Just wondering, how can this mod possibly track all power usage? KSPI has a dedicated energy manager for this, but without this, how can you do it?

It can't which is why KSPI is not supported. It may be possible once the code change we asked for goes live.

Share this post


Link to post
Share on other sites

Would you consider resizing your icons to a power of 2 resolution? 16x16, 32x32. I seem to have a recurring but worse inconsistent issue where KSP crashes on load when it get to the folder to try to process the icons for your mod. I notice the only thing special about your textures is they are 24x24. This does not always happen and sometime KSP happily load without issue, so I hate to make this special request for an issue that is so ethereal, but i have run out of ideas and have resorted to just deleting the icons for now. Thank you for the amazing mod!

Edited by Svm420

Share this post


Link to post
Share on other sites
Would you consider resizing your icons to a power of 2 resolution? 16x16, 32x32. I seem to have a recurring but worse inconsistent issue where KSP crashes on load when it get to the folder to try to process the icons for your mod. I notice the only thing special about your textures is they are 24x24. This does not always happen and sometime KSP happily load without issue, so I hate to make this special request for an issue that is so ethereal, but i have run out of ideas and have resorted to just deleting the icons for now. Thank you for the amazing mod!

That's pretty bizarre, are you running 64 bit or something? I'll add the icons to the list and see, if they look ok when resized then I don't see why not.

Share this post


Link to post
Share on other sites

Hi, Ratzap, I've features Fusebox in my mod series! Feel free to chuck the video in your first post or use it however your like to explain Fusebox.

Share this post


Link to post
Share on other sites

Ratzap, is the Karbonite generators and Near Future stuff not supported for the same reason as KSPI?

Share this post


Link to post
Share on other sites
Hi, Ratzap, I've features Fusebox in my mod series! Feel free to chuck the video in your first post or use it however your like to explain Fusebox.

That looks good thanks. I'll do something about it when I release the next version.

Ratzap, is the Karbonite generators and Near Future stuff not supported for the same reason as KSPI?

No that's because everything just bumped up 2 KSP versions and people are recompiling. So when Fusebox tries to access their functionality, the DLL versions no longer match and it can't do it. I'll release a new one soon (once the main other mods are updated).

Share this post


Link to post
Share on other sites
No that's because everything just bumped up 2 KSP versions and people are recompiling. So when Fusebox tries to access their functionality, the DLL versions no longer match and it can't do it. I'll release a new one soon (once the main other mods are updated).

I'm still using 1.0.2 right now, along with appropriate versions of mods for that version.

I won't update my KSP till they stabilize again.

Share this post


Link to post
Share on other sites

1.45 released, will try and get CKAN to update as the guy who was doing it seems to have stopped. NF should all be working now (including the variable RTGs but I didn't test them).

Share this post


Link to post
Share on other sites

1.50 released, I finally got around to pulling the solar system parameters from FlightGlobals. The dark time calculator will show pick options for whatever bodies your system has. For your debug pleasure (as it's a new feature) you can look in KSP.log for lines with 'FB - ' in them. That will show what supported mods it found, which planets/moons were added and what your home world is.

Share this post


Link to post
Share on other sites

hi there I just found this fantastic plugin via ckan and thanks to some advertising from remote tech and was wondering if there are any plans to integrate this into the default unity ui when they release the port over to u5 as I have nothing against blitzys tool bar but rather have mem space allocated to other plugins if I can

yours in hope the hawk from za

sorry for the edit but needed to add a thanks as its saved me countless hours already of manual calculations

Share this post


Link to post
Share on other sites

Yes, once the U5 port is done and KSP moves to a new gui I will rewrite Fusebox to support the standard app bar. If blizzy updates I may add support for that too since people seem to want to keep it but that's a big if, he may not bother.

Share this post


Link to post
Share on other sites

I made myself SAFE-400 reactor from old Goodspeed part with WasteHeat, overheat and ponies, and found a deficiency in Fusebox. That is, when my reactor (made from stock ISRU) overheats and efficiency drops, Fusebox always displays 100%, although factual efficiency drop works as advertised (measured by stopwatch).

Share this post


Link to post
Share on other sites
I made myself SAFE-400 reactor from old Goodspeed part with WasteHeat, overheat and ponies, and found a deficiency in Fusebox. That is, when my reactor (made from stock ISRU) overheats and efficiency drops, Fusebox always displays 100%, although factual efficiency drop works as advertised (measured by stopwatch).

Yep, I didn't bother putting in fiddly code to work out efficiency and whether or not an engineer is present etc. Maybe one day.

Share this post


Link to post
Share on other sites
0.4a - Hides when F2 pressed

Well... 1.45 does not. It would be beneficial for taking screenshots if proper hiding on F2 press will be implemented again.

Share this post


Link to post
Share on other sites
Well... 1.45 does not. It would be beneficial for taking screenshots if proper hiding on F2 press will be implemented again.

It hasn't changed and it worked the last time I tested it. I'll look when I get home.

Share this post


Link to post
Share on other sites

F2 works just fine for me. You'll need to be more specific about when it's not working for you. Version you're using, where, what other mods etc.

Share this post


Link to post
Share on other sites

Hi there, I do hate to be a pain but I have this problem 15cedb9488.jpg

Everything says my batteries should be charging, only they aren't. I turned everything off and there are no modded parts that even use electric charge on this satellite.

I see a KAS mission to give it more power, but why should this be necessary, this thing should be charging right?

Also, while I'm at it, dragging your windows is buggy as hell, they can only be dragged a short way before they lose connection with the mouse. Also, changing the style of the windows does not save.

That said, this mod has (up until this point) served me very well, this one is a puzzler though. I use Remote-tech which means that the antennae have been altered by that mod. Could this be the issue? Could it be a Tweakscale issue on the double-size inline batteries maybe?

Edited by Stephanie the Viking

Share this post


Link to post
Share on other sites

You've filtered everything out but the solar panels, so it will only add those up. Click everything red back to green on the filter list and it should get it. Failing that, hover over the resources icon in the app launcher bar in the top right and screenshot so we can see how much KSP thinks is draining. Are you using 1.50 the current release? I have a new one with kOS support but I've not gotten around to packaging it.

The windows are a problem when blizzys toolbar isn't in use. Something else I'm hoping to get fixed in unity 5 when the gui revamp happens.

Share this post


Link to post
Share on other sites

Ok, problem solved.

I'm an idiot because I didn't read the mod description properly. I thought it was turning things on and off, when it's actually just telling me what drain I am currently experiencing and from where.

Sorry man I feel such a fool.

Edited by Stephanie the Viking

Share this post


Link to post
Share on other sites
Ok, problem solved.

I'm an idiot because I didn't read the mod description properly. I thought it was turning things on and off, when it's actually just telling me what drain I am currently experiencing and from where.

Sorry man I feel such a fool.

Hey, Ratzap, maybe I'm just making a wrong assumption like my friend here but I think I'm getting wrong calculations on my antennas consumption: I'm using AntennaRange now and my antennas are sucking too much juice!

I've recently quit using RemoteTech and I think maybe this is the reason: maybe, for some reason, Fusebox is treating my antennas as RemoteTech and not AntennaRange ones.

Can you help me? Where do I fix this?

Share this post


Link to post
Share on other sites
Ok, problem solved.

I'm an idiot because I didn't read the mod description properly. I thought it was turning things on and off, when it's actually just telling me what drain I am currently experiencing and from where.

Sorry man I feel such a fool.

Don't worry about it, all of us have done something like that at some point in our lives. I hope you get what it does now and it's useful to you.

jlcarneiro: Entirely likely. Antenna range doesn't just switch your comms off like RT does. When you go out of range it ramps up the power usage proportionately to how far over you are (and the icon turns yellow I think). Fusebox doesn't get any wind of that so it just reports the 'normal' usage which AR passes to it. For example one dish will just about go to Minmus but it'll turn yellow out there and cost ton of extra EC when transmitting.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.