Diazo

[1.3](Jun04/17) Automate Vertical Velocity and Altitude Control

Recommended Posts

23 hours ago, Diazo said:

snip

 

 

Yeah i read the post. Looks like a great mod. I'm just saying mods shouldnt make you edit stock settings. Especially putting esssential keys in hard to reach in unfamiliar places. 

Share this post


Link to post
Share on other sites
On 26/05/2016 at 9:39 PM, Diazo said:

Note that this doesn't mean the craft is out of control, some mods (including all of mine) remember their settings so if you set a craft to hover with this mod, then go on EVA with a Kerbal, the craft will continue to hover as that was the last command it received.

So I just tried to do this. As soon as Jeb went EVA, the main engines shut down. Fortunately this was a systems test to see if it would work or not, so the craft was only 2m off the launch pad.

Unfortunately, it was 2m off the launch pad, and now I have to build a new launch pad :o

Weirdly enough, the launch pad caught fire / exploded, jeb was thrown over a hundred meters away onto the crawlerway with minor injuries, and the craft itself was discovered landed intact next to the launch pad.

EDIT: Now across three tests, the first two had the engines shut off as soon as the kerbal went EVA (Jeb and Val). The third test, with Jeb again, the engines did not shut off when he went EVA. However the third test was also configured slightly differently, as RealChutes were deployed and the VEL controller was in a constant velocity descent (1.36 ms-1) instead of a zero velocity hover.

Edited by blu3wolf

Share this post


Link to post
Share on other sites

@blu3wolf Weird.

Something must have changed in the last few patches in how non-focus vessels are controlled maybe?

I'll look into this tomorrow (no access to my KSP computer today), but to narrow down where to troubleshoot could I ask you to run a quick test please?

1) Launch a 3 Kerbal pod craft (stock Kerbal X is)

2) EVA one Kerbal and move a safe distance away.

3) Switch back to the vessel and lift-off and hover at the 2m.

4) Switch back and forth between the Kerbal already on EVA using the [ ]  keys. (Instead of going on EVA with a Kerbal from the craft.)

What happens? That will tell me where I need to start investigating.

D.

Edited by Diazo

Share this post


Link to post
Share on other sites

20170204141529_1.jpg

20170204141740_1.jpg

20170204142001_1.jpg

Uhhhh.... Houston, we have a problem, with the stock Kerbal X. This could make troubleshooting interesting. Maybe I should open a thread in the modded support section instead?

EDIT: Ill try to provide more details on a craft that doesnt bug out, if I can find one.

 

Edited by blu3wolf

Share this post


Link to post
Share on other sites

Just did a test flight with the career save, using two command pods. Switching between Jeb (EVA) and Val (Lander) resulted in the Zero Vel mode working as expected.

Unfortunately for reproducibility, the same thing happened in the same test, when Val decided to go EVA. Zero Vel still worked as expected, although once she got out the controller failed to zero the velocity correctly, a slight positive vertical velocity occurred (less than 0.1 ms-1). So Im not sure why it wasnt working before, and is now. The only configuration change that has happened, was updating Kopernicus, SVE-Sunflare and ContractConfigurator.

But I guess its working now, which is good. The reason I got the mod in the first place was me not reading a contract properly, and Ive finished the contract now. The contract required an EVA report while flying low at Kerbin Shores...

I think Ill keep using it though. I can see this being very handy for operating landers, much more precise than Im used to. Thanks for your mod!

Share this post


Link to post
Share on other sites

Hmmm, interesting.

As it's working I'll leave this be for now, if it comes up again I'll look into it at that time to see what's up.

As for the velocity being not quite zero when the Kerbal goes on EVA, I'm going to say that is expected behavior. The vessel and the kerbal are two different objects and the controller has to do a "best-guess" at what the Kerbal's mass is because it is not part of the vessel the controller is running on.

Glad to see the mod works for you, happy KSP'ing.

D.

Share this post


Link to post
Share on other sites

Version 1.32

-KSP 1.3 Compatibility update.

Download from Github.

Now also added to Spacedock.

Still on the old GUI and localization is not implemented yet due to lack of time to work on them due to real life.

There is also an issue where because this mod is still using the old GUI system, some computers freeze for several seconds the first time a window using the old GUI is made visible in the game. This should only happen once per game session the first time an old style window (from any mod) is shown on screen by KSP. Moving to the new GUI in the next version (barring any bugfix releases that come first) will resolve this so I am not going to spend any more time on it right now.

Localization will also be included when the mod moves to the new GUI, but I can't offer any sort of time-line right now.

Happy KSPing all.

D.

Share this post


Link to post
Share on other sites

@Diazo OMG THX YOU! :rep::rep::rep:

That's what I've been looking for! Now my Hover-Crane flies like a feather! :cool:

Share this post


Link to post
Share on other sites

Has anyone tried this in 1.3.1?

If so, and that didn't work. Is there a chance of an update for 1.3.1?

Share this post


Link to post
Share on other sites
8 hours ago, DerGolgo said:

Has anyone tried this in 1.3.1?

If so, and that didn't work. Is there a chance of an update for 1.3.1?

It works in 1.3.1

Share this post


Link to post
Share on other sites

I've adopted this mod and released it for 1.4, new thread is here:

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.