Kickasskyle

[1.02] KW Rocketry v2.7 Available - 1.02 Compatibility! - 16/05/2015

Recommended Posts

My problem is that even after researching the parts in career mode I go to the vehicle assembly building and everything of the Kw I research goes back to not being research so can't use it. The mod works fine in sandbox mode.

Same problem. Most of the parts aren't showing up in the VAB or even the science center. I was going to try updating MM and reinstalling the mod to see if it fixes it. I'll report back later whether it fixes it or not.

Share this post


Link to post
Share on other sites

I just upgraded my install to 0.23 and started over, when I noticed this weird bug:

qioetAb.png

There is a weird gap between the engine and the engine. It doesn't look that way when first loaded; you need to switch focus to somewhere else then go back to trigger this.

I have far too many mods to mention, but (I think) it's happening with a KW tank connected to a KW engine. Help?

Share this post


Link to post
Share on other sites
Same problem. Most of the parts aren't showing up in the VAB or even the science center. I was going to try updating MM and reinstalling the mod to see if it fixes it. I'll report back later whether it fixes it or not.

Yeah I fix it. Turns out there was a older version of Kw in my game folders I didn't see.

Share this post


Link to post
Share on other sites
I just upgraded my install to 0.23 and started over, when I noticed this weird bug:

http://i.imgur.com/qioetAb.png

There is a weird gap between the engine and the engine. It doesn't look that way when first loaded; you need to switch focus to somewhere else then go back to trigger this.

I have far too many mods to mention, but (I think) it's happening with a KW tank connected to a KW engine. Help?

This happens to me with the 3m faring base when I return focus to a rocket with it. The piece shrinks by about 30%.

Share this post


Link to post
Share on other sites
Yeah I fix it. Turns out there was a older version of Kw in my game folders I didn't see.

Mine turned out to be an ID-10T error.

(I failed to unpack the*.ZIP properly)

Share this post


Link to post
Share on other sites
Why inline stabilizator is separated into two halfs?

It's not inline. That's a radial one, intended to be used in pairs.

Share this post


Link to post
Share on other sites
Why inline stabilizator is separated into two halfs?

Turn on 2x symmetry and attach it radially to an appropriately sized rocket and you'll understand it. Took me a second too.

Share this post


Link to post
Share on other sites
Did they fix this for .23

It already works for 0.23.

EDIT: I've been using procedural fairings for some time, and I have therefore always deleted the fairings from this mod. There's just one thing: I've just realized that the fairings from this mod look much better than the ones from Procedural Fairings. I'll try to play around with the textures sometime.

Also, have any of you thought about adding a space shuttle engine, like the one in SSE, but KW style?

Edited by wasmic

Share this post


Link to post
Share on other sites

i had a problem with this mod, if someone can helpme plz.....i dont know why, but i have two of the same engine, and no sound....sorry for my english

edit: i fixed!!hehe, i only need to read the instructions...and delete the extras folder(or not unzip)

Edited by Wiracho

Share this post


Link to post
Share on other sites
It already works for 0.23.

EDIT: I've been using procedural fairings for some time, and I have therefore always deleted the fairings from this mod. There's just one thing: I've just realized that the fairings from this mod look much better than the ones from Procedural Fairings. I'll try to play around with the textures sometime.

Also, have any of you thought about adding a space shuttle engine, like the one in SSE, but KW style?

Already use SSE, the engines are sort of niche but the utility parts are pretty unique and useful. I use the fairings from KW, Nova and Procedural. I laugh when I read, "Well, procedural fairings pretty much cinches it!" The thing is, you aren't always sure what kind of fairing you need and they all work a bit differently, and as far as I can tell you can only do this with NovaPunch (actually using KW and Nova on this rocket, but note the interior section):

internals_zps12efff39.jpg~original

You could do that with maybe a K9 docking bay (a pack I think looks great, but is FAR to niche to be practical in that it clashes with every other part in existence). But it's all about the look you want, and the function you need. Those are the only ones I know of that let you make a hollow rocket.

Share this post


Link to post
Share on other sites
It already works for 0.23.

There are some issues with 0.23 that need to be corrected such as parts shrinking on vessel reload and some bugs with tweakables being available for electric charge on engines when they shouldn't. So it WORKS but there are still issues.

Share this post


Link to post
Share on other sites

Actually the Procedural Fairings mod has support for those types of interstage fairings, you just have to use two of the fairing bases, and turn the top one upside-down.

Share this post


Link to post
Share on other sites
There are some issues with 0.23 that need to be corrected such as parts shrinking on vessel reload and some bugs with tweakables being available for electric charge on engines when they shouldn't. So it WORKS but there are still issues.

I've gone through and changed the electric charge tweakables on the engines, not far now.

In regards to the "shrinking" parts on reload/switching, judging from the very specific size that it shrinks by, I'm thinking it's an issue with KSP and it's model scaling (since the node looks to be in the correct place relative to the size decrease). I've tried to replicating the error without success is there anything special or off about your KSP install/mod choices that you think would mess it up in particular?

Share this post


Link to post
Share on other sites

Is it possible to combine two fairing bases so that you effectively get a 0 ejection force? I'm just building a simple probe launcher, but for worlds with low gravity, such as Minmus, a 500 ejection force alters the orbit dramatically.

I've tried just adding an upside down fairing on top of the payload, but it won't let me place it. I can place a second fairing above the payload facing the same direction, but because of how the panels fit together, the two bases are locked in place relative to each other. So when I decouple the payload, it basically fires out and hits the second base and then sort of tumbles out the side. This is not an elegant solution, so I was wondering if there was anything else I could try.

Share this post


Link to post
Share on other sites

You could just use a docking port for a low-force decouple. If you place a single docking port (during construction) like you would a regular decoupler, you can undock from the payload placed on top of it. Bonus in this case: after the probe is out of the way, fire the fairing decoupler to shoot the port into oblivion. (space, actually. But there isn't that much of a diffference for a lone docking port)

Share this post


Link to post
Share on other sites

Bug Report and Workaround: After installing KW on an in-progress game, my crew portraits showed up as blocks of flashing color. Coincidentally, after changing the resolution from 1920x1200 full screen down to 1600x900 windowed, and then back to maximum the issue has resolved itself and has not recurred (even after restarting the game and starting a new career mode).

Share this post


Link to post
Share on other sites
I've gone through and changed the electric charge tweakables on the engines, not far now.

In regards to the "shrinking" parts on reload/switching, judging from the very specific size that it shrinks by, I'm thinking it's an issue with KSP and it's model scaling (since the node looks to be in the correct place relative to the size decrease). I've tried to replicating the error without success is there anything special or off about your KSP install/mod choices that you think would mess it up in particular?

I honestly can't imagine anything special about my install, to be honest. I run a lot of mods, but most of them are parts packs which shouldn't be affecting KW at all. I thought it might be KJR, but I got the same result with and without it.

I'll see if I can rig up a bare-bones KSP install and replicate this issue.

Share this post


Link to post
Share on other sites
I honestly can't imagine anything special about my install, to be honest. I run a lot of mods, but most of them are parts packs which shouldn't be affecting KW at all. I thought it might be KJR, but I got the same result with and without it.

I'll see if I can rig up a bare-bones KSP install and replicate this issue.

To be honest, I don't see it as a KW issue as it just seems as though the game is having a ~problem~ and is rescaling stuff more than once, it's certainly not an issue I can solve quickly, it would involve re-exporting everything. It does seem to be a rare occurrence and I've also had reports from people saying it's happened with non KW parts as well.

Share this post


Link to post
Share on other sites

I haven't had any issues with KW in particular with parts resizing themselves; but I have had one instance with a LackLuster Labs part (one of the 1x1 cockpits) I fixed it by exiting to the hanger and re-launching the craft. The re-resizing occurred upon reversion from a failed launch back to launch without going back (in my case) to the SPH. Not sure if that general information will help in the slightest (as it's a different part from a completely different pack).

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.