Jump to content

[1.02] KW Rocketry v2.7 Available - 1.02 Compatibility! - 16/05/2015


Recommended Posts

The part's info loads, as does its spot in the catalog. However, the tile itself has no thumbnail. And when I click the part to add it to a ship, it's...invisible, I guess is the best way to put it. The attachment nodes show up and seem to work fine, but there's nothing visible there. If it helps, I do not play on the highest graphics setting.

That's very weird. Open the debug log (alt-F12) while in the VAB. Try to place one of the problem engines -- do you get any errors in the log? Posting your full log on pastebin would be helpful.

Link to post
Share on other sites

Are you using a mod that changes the textures or something ? Or you have it installed wrong check file path should be KSP/GameData/KWRocketry

EDIT- OR are you using RO a mod that rescaling KW ?

Edited by Mecripp2
Link to post
Share on other sites

Somnambulist - I wil try that; I'll have access to my KSP computer this afternoon and will post my log then.

MeCripp - I don't use any rescaling mods, and the only texture mod I use is Active Texture Management, which has never affected KW textures before (not visibly, anyway - you know what I mean).

Link to post
Share on other sites
This mod parts is timeless...

Concerning rocket-parts its my favourite mod. Just shot another craft to the outer kerbolar system, of course with a KW-Launcher.

Only thing, since ohninety and the overhaul of the stock engines the KW-engines might benefit from a little tweaking ... anything planned for onezero ?

K

Link to post
Share on other sites

I did a clean experiment: launched the same rocket with fairing installed and with fairing removed (only fairing base remained), and watched MechJeb Delta-V loss statistics. With fairing I get 811 m/s loss, without fairing 820 m/s, which might be due to slightly changed flight profile with lighter rocket. And this is with very unstreamlined payload.

9m/s definitely do not compensate for extra weight and complexity.

Also I noticed that with Deathly Reentry, fairing does not protect payload from overheating and does not heat itself when I'm going too fast in lower atmosphere.

Is this a 0.90 compatibility issue or was it like this from the beginning?

Link to post
Share on other sites
Is this a 0.90 compatibility issue or was it like this from the beginning?

Stock drag is based solely on mass. Adding fairing increases mass and therefore drag. If you want them to be more than just aestheticly looking you need FAR (and maybe KIDS to balance it).

Edited by Harry Rhodan
Link to post
Share on other sites

Hi everyone!

I have an idea for this mod : why not adding the fairing 2.5 meters in the 3.75 meters size. Like the Ariane V fairing, it will be nice! :)

1429954038-2015-04-25-00003.png

1430079702-2015-04-26-00001.png

You can always change the size with Tweakscale but, the ejection force is not so... well they don't go! :'(

Maybe we can do that for the next 1.0 KSP version! :)

Edited by Space_nico
Link to post
Share on other sites
It's a part pack. It likely won't need updating.

It's possible that the new aerodynamics will require some modifications, but it's hard to say until 1.0 is released. The thrust/Isp of engines may need to be tweaked to account for the fact that thrust now changes with Isp. Most other things should work fine though.

Link to post
Share on other sites

The fairings would most certainly require update - I seriously doubt that new aero has built-in support for mod parts like that of FAR (FAR looks for certain words in part names - "fairing", "shroud", "cargo bay" - and does its magic).

Also, the whole new variable thrust\constant Isp system would probably require some config overhaul.

Link to post
Share on other sites
It's possible that the new aerodynamics will require some modifications, but it's hard to say until 1.0 is released. The thrust/Isp of engines may need to be tweaked to account for the fact that thrust now changes with Isp. Most other things should work fine though.

Besides, most stock engines are going to get nerfed in 0.90 to offset the reduction in delta-v from the improved aerodynamics.

Link to post
Share on other sites
I'm going to take a look at all the balance things once my exams end, but until then you'll have to sit tight. Should be around the 12th or so next month.

Already looking forward to this, KW has been a staple mod for me ever since I started playing KSP :D

Link to post
Share on other sites
I'm going to take a look at all the balance things once my exams end, but until then you'll have to sit tight. Should be around the 12th or so next month.

That's perfect! It should take that long for everyone to get used to everything that they have changed.

Link to post
Share on other sites
Could you not read but 3 posts prior to you rambling. Already said he's going to work on it but don't expect anything for about 2-3 weeks.

Okay, and yeah, sorry, was caught up in the hype, didn't mean to be an ass.

Link to post
Share on other sites
I'm going to take a look at all the balance things once my exams end, but until then you'll have to sit tight. Should be around the 12th or so next month.

Good luck with the exams, and we can wait a bit until you're through with them =)

Link to post
Share on other sites
Anyone reading this: From some LIMITED tests with this and very little else in 1.0, There seems to be a problem with the fuel tanks not being able to attach anything underneath them
Decouplers don't appear to attach to other parts either.
Link to post
Share on other sites
Anyone reading this:

From some LIMITED tests with this and very little else in 1.0,

There seems to be a problem with the fuel tanks not being able to attach anything underneath them

That has happened thus far with every ksp update to kw. This pick will be updated. Post your damage reports but dont expect an update for atleast 2 weeks.

Link to post
Share on other sites

Yep, had a feeling i remembered it from before, and yeah like you said, i def don't expect a breakneck race to fix it, especially first day, just hoping to make sure the problems are up there for review!

Link to post
Share on other sites
There seems to be a problem with the fuel tanks not being able to attach anything underneath them

They made nodes a lot stricter in how they connect in 1.0, which I understand is a good thing but will mean a lot of cfgs shall need tweaking

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...