Jump to content

[1.02] KW Rocketry v2.7 Available - 1.02 Compatibility! - 16/05/2015


Recommended Posts

I tried reading back to find it but couldn't so just going to say it. The remedy for the issues with attaching things to nodes is easily fixed by going to alt F12 menu and go to cheats and tick the very last one that says something about strict part placement. Now I dunno if that's the issues because I'm waiting for the official update but I'm using KAS and the container issue sounded the same and this is how it was fixed! :-) Cheers!

You might also try this:

http://forum.kerbalspaceprogram.com/threads/51037-0-25-KW-Rocketry-v2-6d2-Available-0-25-Compatibility!-16-10-2014?p=1886942&viewfull=1#post1886942

Link to post
Share on other sites
I tried reading back to find it but couldn't so just going to say it. The remedy for the issues with attaching things to nodes is easily fixed by going to alt F12 menu and go to cheats and tick the very last one that says something about strict part placement. Now I dunno if that's the issues because I'm waiting for the official update but I'm using KAS and the container issue sounded the same and this is how it was fixed! :-) Cheers!

That's not a fix, that's a workaround. That's why it's in the debug menu under Cheats. Calling it a fix means people should just leave it like that, which they shouldn't, since it will also affect what other mods have done to properly fix their nodes (which is what Greystork did)

Link to post
Share on other sites
That's not a fix, that's a workaround. That's why it's in the debug menu under Cheats. Calling it a fix means people should just leave it like that, which they shouldn't, since it will also affect what other mods have done to properly fix their nodes (which is what Greystork did)

Actually, warranty45 fixed the nodes. I just moved parts around the tech tree to make them fit into the new 1.0 layout a little better.

EDIT: The issue of balancing the thrust and ISP values for engines, among other things, still remains to be addressed. I think we'll let Winston and KickassKyle, the original makers of KW Rocketry, come out with an official update for those things, however. What warranty45 and I did is really only a temporary field fix.

Edited by greystork
Link to post
Share on other sites
Actually, warranty45 fixed the nodes. I just moved parts around the tech tree to make them fit into the new 1.0 layout a little better.

Not sure if I am doing something wrong, but none of the flat adapters will attach, did those files get fixed also?

Link to post
Share on other sites
Not sure if I am doing something wrong, but none of the flat adapters will attach, did those files get fixed also?

Can you post pictures/list the exact names of all the components that are giving you trouble? I'm not having attachment issues anymore since I fixed the bottom nodes for all parts that had them...

Maybe you still have some "bugged" bottom nodes...

Link to post
Share on other sites

Can i ask a simple question? I don't mean any offence or bad thing, but the question is bothering me for some time, why would such an amazing mod sit on 0.25 OFFICIALLY and it's up to people to update this amazing mod? if the original developer can't or won't want to update this mod, why not pass the torch so someone else to continue his job officially? for example, now for 1.0, i don't know if this mod was updated by people or not, and if yes, i would need to roll back in pages and read every post to find the non official release. i think if someone take it up to himself to start a new forum thread and update this mod officially, all of us would get benefit from it.

Link to post
Share on other sites
Can you post pictures/list the exact names of all the components that are giving you trouble? I'm not having attachment issues anymore since I fixed the bottom nodes for all parts that had them...

Maybe you still have some "bugged" bottom nodes...

I guess they actually do attach but the nodes seem to be in the wrong places and they attach "sunk in" to the parts.

screenshot1_1.png

Link to post
Share on other sites
Can i ask a simple question? I don't mean any offence or bad thing, but the question is bothering me for some time, why would such an amazing mod sit on 0.25 OFFICIALLY and it's up to people to update this amazing mod? if the original developer can't or won't want to update this mod, why not pass the torch so someone else to continue his job officially? for example, now for 1.0, i don't know if this mod was updated by people or not, and if yes, i would need to roll back in pages and read every post to find the non official release. i think if someone take it up to himself to start a new forum thread and update this mod officially, all of us would get benefit from it.

The mod author has already stated that there's gonna be an official update once he sorts out his RL stuff. If that's not fast enough for you, too bad, pick another mod.

Link to post
Share on other sites
Not sure if I am doing something wrong, but none of the flat adapters will attach, did those files get fixed also?

Here is a new zip with the flat adapters fixed:

https://drive.google.com/file/d/0By3dGfWPuRSQZW9VMmF1SGhwRE0/view

For those who have not followed this thread for the last couple of pages, this update contains only the part config files. You will need to have the latest version of KW Rocketry already installed in your GameData folder before applying it. Simply copy the KWRocketry folder, contained in the ZIP file, into your GameData folder and allow it to overwrite all the existing part config files.

Once this update has been applied, it will be necessary to move the KWRocketry folder out of GameData (to a safe place), start, then exit KSP (do NOT enter your saved game, or bad things will happen), and move the KWRocketry folder back into the GameData folder. Otherwise, parts won't get deleted from their previous locations in the tech tree. I am guessing that a version file will remedy those kinds of problems in the future, but since KW Rocketry doesn't come with one in its current state, we're stuck with having to do this.

Link to post
Share on other sites
Here is a new zip with the flat adapters fixed:

https://drive.google.com/file/d/0By3dGfWPuRSQZW9VMmF1SGhwRE0/view

For those who have not followed this thread for the last couple of pages, this update contains only the part config files. You will need to have the latest version of KW Rocketry already installed in your GameData folder before applying it. Simply copy the KWRocketry folder, contained in the ZIP file, into your GameData folder and allow it to overwrite all the existing part config files.

Once this update has been applied, it will be necessary to move the KWRocketry folder out of GameData (to a safe place), start, then exit KSP (do NOT enter your saved game, or bad things will happen), and move the KWRocketry folder back into the GameData folder. Otherwise, parts won't get deleted from their previous locations in the tech tree. I am guessing that a version file will remedy those kinds of problems in the future, but since KW Rocketry doesn't come with one in its current state, we're stuck with having to do this.

Thank you so much. I did not realize how much I use those adapters till they did not work :)

Link to post
Share on other sites
The mod author has already stated that there's gonna be an official update once he sorts out his RL stuff. If that's not fast enough for you, too bad, pick another mod.

Oh sorry, as i mentioned i meant no offence, i was not aware of the fact, and no sir, like every one else, i can wait too lol

Link to post
Share on other sites

Just a small problem report.

Now even the fuel flow is 0, the engine activate audio still works. This may cause some strange things that the engine makes an awesome explosion sound but actually nothing happens under the nozzle. LOL

Maybe you should try something to judge whether the engine will works then play the activate sounds.

Link to post
Share on other sites
Just a small problem report.

Now even the fuel flow is 0, the engine activate audio still works. This may cause some strange things that the engine makes an awesome explosion sound but actually nothing happens under the nozzle. LOL

Maybe you should try something to judge whether the engine will works then play the activate sounds.

The mod is not up to date, all sorts of bugs are possible.

What you are describing is most likely caused by an outdated version of HotRockets. In case you have that mod, you should check with its respective dev thread and update it to the latest version.

Link to post
Share on other sites
Can i ask a simple question? I don't mean any offence or bad thing, but the question is bothering me for some time, why would such an amazing mod sit on 0.25 OFFICIALLY and it's up to people to update this amazing mod? if the original developer can't or won't want to update this mod, why not pass the torch so someone else to continue his job officially? for example, now for 1.0, i don't know if this mod was updated by people or not, and if yes, i would need to roll back in pages and read every post to find the non official release. i think if someone take it up to himself to start a new forum thread and update this mod officially, all of us would get benefit from it.

I know this has been answered, sort of, but I thought I'd add a bit of clarification.

Part mods in general are less affected by many of the changes made from 0.25 through 0.90. As a result, no real work was needed to "bring it up to date". I'd been using this mod since it came out, and from 0.25 on it had been working fine.

Further, mod developers do this with their "free time" (like myself), and cannot always devote the time that many players might "expect" of a developer.

Finally, the mod community here is awesome. So, many of us will "step in" to keep mods current while the original author may be "MIA". In most cases the licensing on most of the mods is in place precisely for that reason, so the the mod can survive beyond the original author.

I know that you meant no offense, and I'm guessing that you simply did not consider these points.

I too, look forward to the official release, but I'm thankful for the efforts made by the commuity so far to keep KW relevant in a post 1.0 world. :D

Link to post
Share on other sites
I know this has been answered, sort of, but I thought I'd add a bit of clarification.

Part mods in general are less affected by many of the changes made from 0.25 through 0.90. As a result, no real work was needed to "bring it up to date". I'd been using this mod since it came out, and from 0.25 on it had been working fine.

Further, mod developers do this with their "free time" (like myself), and cannot always devote the time that many players might "expect" of a developer.

Finally, the mod community here is awesome. So, many of us will "step in" to keep mods current while the original author may be "MIA". In most cases the licensing on most of the mods is in place precisely for that reason, so the the mod can survive beyond the original author.

I know that you meant no offense, and I'm guessing that you simply did not consider these points.

I too, look forward to the official release, but I'm thankful for the efforts made by the commuity so far to keep KW relevant in a post 1.0 world. :D

The complaint might simply be that the dev hasn't changed the compatibility statement up to 0.90, at least, if not 1.0. Even if balance changes are needed (which they are), the parts working is the bottom-line basis for compatibility, and if they do, there's no reason not to advertise it.

I do get the time commitments, though. It's kind of a shame they haven't passed the torch if that's what's stopping them from giving KW some attention.

Link to post
Share on other sites
I was aware of the change and was going to mess about with it.

Ok, just wanted to make sure, looking forward to the update! This mod is key to my KSP build! :)

Link to post
Share on other sites
Is anyone else having the problem in V1.0 where you have to rotate the KWRocketry parts 180 degrees (upside down) in order to attach them, especially fuel tanks?

This has already been discussed and fixed by the community via a patch, until we wait for an official 1.0 update. Please read the thread before posting bug reports/questions.

In addition, the mod is not updated for 0.25, so do not expect everything to work out of the box.

Link to post
Share on other sites
Is anyone else having the problem in V1.0 where you have to rotate the KWRocketry parts 180 degrees (upside down) in order to attach them, especially fuel tanks?

Try going to the Alt F12 menu and check the box at very bottom of cheats tab that allows strict part placement! KAS containers had an issue like this and that fixed it! And guys come on! Stop being so rude o each other on the forum! Moderators especially!

- - - Updated - - -

The mod author has already stated that there's gonna be an official update once he sorts out his RL stuff. If that's not fast enough for you, too bad, pick another mod.

You want to tone it down a notch buddy he was asking a simple question without being rude at all! How do you feel if someone got smart with you for a simple mistake and told you to use another mod! Yes he should read back but hello some people are not hooked on these forums like the majority of you guys and don't know these things! So just like he should read back a few pages and read the first post you should go read up on some manners and if you don't like it use another forum!

- - - Updated - - -

Every time I come to check the forums I see so much rudeness so I just had to say something!

Link to post
Share on other sites
You want to tone it down a notch buddy he was asking a simple question without being rude at all! How do you feel if someone got smart with you for a simple mistake and told you to use another mod! Yes he should read back but hello some people are not hooked on these forums like the majority of you guys and don't know these things! So just like he should read back a few pages and read the first post you should go read up on some manners and if you don't like it use another forum!

- - - Updated - - -

Every time I come to check the forums I see so much rudeness so I just had to say something!

The guy was suggesting that the community should go ahead and update the mod AFTER the original mod author has clearly stated that there's gonna be an official update. Granted, he probably missed the author's post on that issue, but if I didn't know any better, he made that suggestion out of a lack of patience. There's a bunch of people that expect their favorite mods to be updated within hours or days after a game update.

Now, thank you for schooling me on the issue of manners, I'll file your opinion on the matter in an appropriate respository.

Link to post
Share on other sites
Try going to the Alt F12 menu and check the box at very bottom of cheats tab that allows strict part placement! KAS containers had an issue like this and that fixed it!

And while this suggestion might work if you use only one un-updated broken mod, it will break all the mods that have been updated to work with 1.0, because their nodes have been fixed. So this is not a solution, that can be recommended to anyone using other mods too.

In addition, the node reversal is not the only issue with KW, especially in light of the new engine scaling system.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...