Jump to content

[1.02] KW Rocketry v2.7 Available - 1.02 Compatibility! - 16/05/2015


Recommended Posts

Hello everyone!

First of all, Im very very happy that I see some progress here, I was afraid that the mod got abandoned for good. Well, because of that, I created my own version of the mod to use a week or two ago. As Im totally unexperienced at modding (this the first time I do anything like this), it's not using module manager updates (except for the techtree modification).

Modifications:

- Parts snap nicely to each other.

- Rebalanced heat generation on engines, and added heat emission values.

- Rebalanced ISP, especially on lower-end engines to mach the values on stock engines.

- Added launch smoke and surface effects to the engines.

- Added the Experimental Rocketry node to the tech tree.

- Removed fairings all together.

- Changes to descriptions to make them more humorous... well I made it for my own use... :D

You can use it if you like, but remember, this is not an official patch, or version of the mod, so if you encounter any bugs, well, I wont fix them :D

EDIT: This has not been tested for every engine, so surprises can happen.

EDIT2: I'm not using DeadlyReentry, so this version isn't comaptible with it. (Unless you mod it further :))

Link to file:

https://www.dropbox.com/s/i438c5w06dr29po/KW_Rocketry_1.02.zip?dl=0

cool, I'll give it a try, thanks

Link to post
Share on other sites
When I used this mod, there were parts wobbling and clipping through the fairings, need help if this is fixable.

Happens when the payload is too big for the stiffness of the base-to-payload joint or the payload itself is flexible. Used to happen all the time with Procedural Fairings before PF's "auto-struts" feature was extended to add joints between the fairing and the payload.

KW fairings can have struts attached to them, so the no-new-mods fix is to build one side of the fairing, run struts from the inside of the fairing to the top of the payload, then pick up the fairing side and struts and apply symmetry. KJR will give you more stiffness on the base joints so you won't need to strut your fairings as often.

Link to post
Share on other sites
When I try to load KSP when I have KW installed, the loading stops when it loads the first KW part. KSP is using 3.1Gb of RAM at that point. When I remove KW, it load fine.

Hang tight... he is updating this

Link to post
Share on other sites

Am I the only person who thinks that squad's shrouds completely blew KW's and the procedural ones away?

There's no limit on their height, you're not stuck with one width for the whole thing, they work just as well being an interstage instead of a full shroud, they tell you how much they're going to weigh while you're making them, and they're really easy to build around.

The only 2 problems I've seen is how they blow off into non-persistent debris (sorry, I like my kessler syndrome), and that you can't make the bullet shaped and curvy.

Link to post
Share on other sites
Am I the only person who thinks that squad's shrouds completely blew KW's and the procedural ones away?

There's no limit on their height, you're not stuck with one width for the whole thing, they work just as well being an interstage instead of a full shroud, they tell you how much they're going to weigh while you're making them, and they're really easy to build around.

The only 2 problems I've seen is how they blow off into non-persistent debris (sorry, I like my kessler syndrome), and that you can't make the bullet shaped and curvy.

Took me a bit to realize you were talking about fairings and not shrouds over parts when you add a decoupler.

You're right that the stock fairings are pretty good, but I think PFairings and KW fairings can do even better than they can because of the detractors you've mentioned with stock fairings. I'm also a little upset you can't make smooth designs with them.

Link to post
Share on other sites

Man, it's been almost 7 months(as of tomorrow, it will be) since this has been updated. We've seen two updates(technically four, but 1.0.1 and 1.0.2 don't really count) from the game, and 0 from Kyle. I just hope this next update makes the mod a lot smaller, because I too ma having the issue where KSP loads fine until it hits KW Rocketry's textures. I think the problem is that any mods not updated to 1.0 still use the old texture format; the new textures are smaller and more compact, while the old ones are A LOT BIGGER.

Take this little image;

A new KSP texture is like a 0.625 meter part, but the old textures are like a 5 meter part. Doesn't that make it obvious? :)

Link to post
Share on other sites
Man, it's been almost 7 months(as of tomorrow, it will be) since this has been updated. We've seen two updates(technically four, but 1.0.1 and 1.0.2 don't really count) from the game, and 0 from Kyle. I just hope this next update makes the mod a lot smaller, because I too ma having the issue where KSP loads fine until it hits KW Rocketry's textures. I think the problem is that any mods not updated to 1.0 still use the old texture format; the new textures are smaller and more compact, while the old ones are A LOT BIGGER.

Take this little image;

A new KSP texture is like a 0.625 meter part, but the old textures are like a 5 meter part. Doesn't that make it obvious? :)

If texture sizes is what bothers you the most about this mod, use ATM like everyone else.

http://forum.kerbalspaceprogram.com/threads/59005-0-23-5-Release-3-1-Active-Texture-Management-Save-RAM-without-reduction-packs!

It's more of a shame that fairings are not working (no problem with nuFAR, and base game fairings are rather nice anyways), heat management valuess should be added, ground effects are not working, attachement nodes are twisted, and the engines are way overpowered since base game engine values got overhauled. There may be other problems too, but these were the ones that caught my eye at first glance. :D A good chunk of the problems can be fixed with manual wizardry, but you need to dig yourself into modding if you want to fix the other half (and other random bugs).

Link to post
Share on other sites

v2.7 is up on Curseforge and Kerbalstuff as of now.

I modelled a new 5m upper stage engine but it hasn't made it into this release; it is still pending a texture as Kyle was too busy to get it done in time.

Edited by Winston
Link to post
Share on other sites

As Winston said, we've fixed pretty much most of the issues. Now I've got to get 3 hours sleep before I go get a plane and go on holiday for a week, Winston will be watching so if anything goes horrifically wrong he'll be around. For the FAR users who want to use the old fairings, they're in the extras folder.

There were quite a few tweaks to the thermal stuff as well, such as making decouplers hardly conductive to stop mass loads of heat transferring between stages etc. Feedback is always appreciated.

Finally, big thanks to Nathan Kell for making the plugin that allowed us to make emissives work again.

Here's the relevant changelog:

Updated to 2.7

- 1.02 compatibility update.

- Rebalanced ISPs to account for new aerodynamics.

- Rebalanced and changed thermal properties to account for the new system.

- Converted the majority of textures to .dds producing an overall ram saving of about 25%.

- Updated engines with the latest FX modules.

- Fixed node issues brought on by v1.0 update.

- Old FAR compatible fairings moved to extras folder.

- New procedural fairings added until a better alternative is utilised.

- Parts in defunct research nodes have been moved to the next best alternative.

- Subassemblies split into legacy (for old FAR compatible fairings) and default (for the new default procedural fairings).

- Misc Minor bugfixes.

Edited by Kickasskyle
Link to post
Share on other sites
The game seems to hang on loading SRB nose cone 1.25.

Tried with and without ATM.

I've just tested the new version in a fresh install of KSP and it loads fine.

All I can think of to suggest is that you make sure you delete anything KW related before installing the new version.

If that doesn't work you could always go in and cull that part from your install.

Link to post
Share on other sites

Seemed like the whole nosecone folder would not load. Pretty strange, considering it's just parts...

I've seen people make reports like this on other mod threads seldom ever since 1.0 hit.

Well, deleting the KW Nose Cones folder in aero allowed the game to load.

Will try readding them again and seeing if the issue persists.

Link to post
Share on other sites
As Winston said, we've fixed pretty much most of the issues. Now I've got to get 3 hours sleep before I go get a plane and go on holiday for a week, Winston will be watching so if anything goes horrifically wrong he'll be around. For the FAR users who want to use the old fairings, they're in the extras folder.

There were quite a few tweaks to the thermal stuff as well, such as making decouplers hardly conductive to stop mass loads of heat transferring between stages etc. Feedback is always appreciated.

Finally, big thanks to Nathan Kell for making the plugin that allowed us to make emissives work again.

Here's the relevant changelog:

Updated to 2.7

- 1.02 compatibility update.

- Rebalanced ISPs to account for new aerodynamics.

- Rebalanced and changed thermal properties to account for the new system.

- Converted the majority of textures to .dds producing an overall ram saving of about 25%.

- Updated engines with the latest FX modules.

- Fixed node issues brought on by v1.0 update.

- Old FAR compatible fairings moved to extras folder.

- New procedural fairings added until a better alternative is utilised.

- Parts in defunct research nodes have been moved to the next best alternative.

- Subassemblies split into legacy (for old FAR compatible fairings) and default (for the new default procedural fairings).

- Misc Minor bugfixes.

Awesomeness! :D

- - - Updated - - -

Um, is the module animate folder that's in the zip supposed to be outside the main KWrocketry folder? Not sure if that's a separate thing in the gamedata folder or not.

Going to drop that into gamedata just in case, although it looks like something that didn't get compiled correctly or no idea, just seems out of place.

Edit: Oh, nvm, it's there in the zips gamedata.

Edited by smjjames
Link to post
Share on other sites

Here's how it hangs:


PartLoader: Compiling Part 'KWRocketry/Parts/Aero/150mSRBTop/part/KW2mSRBNoseCone'

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

Added sound_rocket_mini to FXGroup running

(Filename: C:/buildslave/unity/build/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 56)

FormatException: Unknown char
at System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000] in <filename unknown>:0

at System.Double.Parse (System.String s) [0x00000] in <filename unknown>:0

at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (object,object[],System.Exception&)

at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
Rethrow as TargetInvocationException: Exception has been thrown by the target of an invocation.
at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0

at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <filename unknown>:0

at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

NullReferenceException: Object reference not set to an instance of an object
at PartLoader.GetDatabaseConfig (.Part p) [0x00000] in <filename unknown>:0

at PartLoader.GetDatabaseConfig (.Part p, System.String nodeName) [0x00000] in <filename unknown>:0

at DragCubeSystem.LoadDragCubes (.Part p) [0x00000] in <filename unknown>:0

at Part+.MoveNext () [0x00000] in <filename unknown>:0

Link to post
Share on other sites
I've just tested the new version in a fresh install of KSP and it loads fine.

All I can think of to suggest is that you make sure you delete anything KW related before installing the new version.

If that doesn't work you could always go in and cull that part from your install.

Deadly Reentry is causing the hang. I'll go report it in the DRE thread.

Link to post
Share on other sites

This will disable the automatic interstage engine fairings.


// Disable KW Engine autofairings

@PART[KW1mengine*|KW*2mengine*|KW3mengine*|KW5mengineTitanV]:AFTER[KWRocketry] {

!MODEL,2 {}
}

Edited by somnambulist
Updated to exclude Griffon Century as it doesn't have a fairing.
Link to post
Share on other sites
This just happened, i can't load the 5m Titan V engine, it's the third time i try reopening the game and it simply doesn't load...

http://i.imgur.com/1r5R6rH.png

Again, I can't replicate this in my fresh install.

How exactly did you install the mod? Did you follow the instructions?

Check in KWRocketry/Parts/Engines/5mEngines and make sure you have all of these files

6vP386K.png

Edited by Winston
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...