onkelsiebdruck

[WIP] Bavarian Aerospace: Tubes! (update9|20|14)

Recommended Posts

The round tubes probably just gave me the illusion of more space.

A mod is not just "can I program this" or "how do I program this" but is also "how does this integrate into the actual game". "How will users use this."

You do make a fair point on crash reports. I'll see about reproducing the jumping crash.

edits:

I am having a hard time reproducing the crash. I have noticed that leaving the area and going off to do other things like launch rockets and closing out the game has cleaned up my messy attachment done with a Kerbal on site. Before leaving the site the newly placed tunnels that were low to the ground would clip under the surface and start bouncing.

Jumping and falling in or around a joint between tunnels and a 4x or 3x side piece tends to leave the Kerbal stuck on his belly, unable to get up, unless I hit 'r' to ready/unready the jetpack. That would seem to be a KSP thing and not a mod thing. This is all at the north pole of Kerbin with cleaned up attachment.

Here's a very specific example of falling and being unable to get up, which is likely a KSP/Kerbal thing and not your mod but I don't know.

http://i41.tinypic.com/15xssbo.jpg

This Kerman was walking down the tunnel on the left and going to the "nt 4x side" piece when he fell over. wasd did nothing. He eventually very slowly slid about until he stood up on his own again. Falling and grabbing a tunnel floor can often get a stuck Kerbal unstuck, but the 4x and 3x pieces do not have this.

Edited by BigD145

Share this post


Link to post
Share on other sites

This Kerman was walking down the tunnel on the left and going to the "nt 4x side" piece when he fell over. wasd did nothing. He eventually very slowly slid about until he stood up on his own again. Falling and grabbing a tunnel floor can often get a stuck Kerbal unstuck, but the 4x and 3x pieces do not have this.

hmm 4x side and 4x are the same parts/mesh with a different node order in the cfg....maybe you just noticed the problem with the side part and it would also happen with the stack 4x.

but i toke a quick look into my colliders in unity...and 3x has a larger (in a y-axis) convex-collider while 4x has only box-colliders. As a quick fix ( i hope) i have modified the box collider of 4x and added as addition a convex collider.

If you like, you can try this https://www.dropbox.com/s/4zlu3yzmjnpsx60/tube-nt-4x.zip ( just replace the .mu-file in the ntshare folder )

Share this post


Link to post
Share on other sites

oh god this is awesome I can't wait for the next update but i must ask will you make an elevator for the newer version of tubes and maybe an adapter between the new and old tubes?

Share this post


Link to post
Share on other sites
hmm 4x side and 4x are the same parts/mesh with a different node order in the cfg....maybe you just noticed the problem with the side part and it would also happen with the stack 4x.

but i toke a quick look into my colliders in unity...and 3x has a larger (in a y-axis) convex-collider while 4x has only box-colliders. As a quick fix ( i hope) i have modified the box collider of 4x and added as addition a convex collider.

If you like, you can try this https://www.dropbox.com/s/4zlu3yzmjnpsx60/tube-nt-4x.zip ( just replace the .mu-file in the ntshare folder )

I just now tried your fix. This is still with the side piece. I only brought side pieces to the pole. If I were on the Mun I would probably build two story bases with the stack.

So, now the Kerbal acts a bit differently. He still falls, but now he falls on his side. His RCS jetpack works better now. He can actually float a little and rotate on any axis on Kerbin with atmosphere. It's easier now to get him to a neighboring tunnel to grab the floor and get to the point where he can stand again. I did all this by walking, running, and jumping through and next to the 4x piece many times.

I will have to try it other places. Kerbal command will be easy. Minmus would also be a good test. But first I have to lose power in my home for a day. Tests will have to wait.

Edited by BigD145

Share this post


Link to post
Share on other sites

@BigD145

I built a huge 10x10 grid with the 4x-side.parts and placed that grid on trusses at the north pole .

After some test, I have an improved version, with hopefully less accidents. But....if you fall, you have now invisible failsafe-ladders ;-) > grab the ladder , hit space and continue your walk.

https://www.dropbox.com/s/rqphyzwdxewmdf7/tube-nt-4x.mu

I really hope that helps. One additional advise, don´t place this part directly on the ground. Even the pole is not 100% flat...

--- -----

oh god this is awesome I can't wait for the next update

Bugfixing and making existing an new parts compatible takes time. An Update with fixes maybe within a week, a larger update next month.

but i must ask will you make an elevator for the newer version

no...sorry....but a vertical side-attachable ladder-part. This is a bit more flexible.

adapter between the new and old tubes?

yes...some kind of universal squaretube to 0.625m adapter with integrated door.

And here the mobile new parts ... not finished of course

k6ga.th.png

klct.jpg

and other new stationary parts are still in 3D-devphase

BTW: for easier building I recommend editor extensions: http://kerbalspaceprogram.com/editor-extensions

than you can turn on and of surfaceattachment

Edited by onkelsiebdruck

Share this post


Link to post
Share on other sites
@BigD145

I really hope that helps. One additional advise, don´t place this part directly on the ground. Even the pole is not 100% flat...

That is not a problem I have found. This is: http://i41.tinypic.com/14in34o.jpg Without a bottom or something a disconnected module will be classified as debris and it will sink into the ground until it disappears. That particular image has a probe core embedded under the door node using no-clip. The probe core and parachutes are the only things keeping it afloat.

At my polar base I had two KAS fuel connector ports down at the bottom of the living modules on opposite sides and didn't even notice things were going to go wrong until I lifted them and moved them to the base with the rover crane. I disconnected one of the two KAS ports, to move it, and the module sank and disappeared. I was trying various ways of getting modules connected together without your command pod bottom piece. KSP is destroying your modules.

Share this post


Link to post
Share on other sites

a craftfile with position or maybe a safegamefile would help, can´t even notice what kind of ground this is in your picture.

PS:

if possible try to use the stock-can ( same size like the modules) in this scenario, what happens with this.

Edited by onkelsiebdruck

Share this post


Link to post
Share on other sites

no...sorry....but a vertical side-attachable ladder-part. This is a bit more flexible.

yes...some kind of universal squaretube to 0.625m adapter with integrated door.

And here the mobile new parts ... not finished of course

k6ga.th.png

and other new stationary parts are still in 3D-devphase

BTW: for easier building I recommend editor extensions: http://kerbalspaceprogram.com/editor-extensions

than you can turn on and of surfaceattachment

ok good to know with the ladders and wow had not expected you to start building those new parts

KEEP UP THE GOOD WORK!!!!! :D

Share this post


Link to post
Share on other sites
a craftfile with position or maybe a safegamefile would help, can´t even notice what kind of ground this is in your picture.

PS:

if possible try to use the stock-can ( same size like the modules) in this scenario, what happens with this.

It's right next to the launch pad. I was going to try again, using the winch to lift the module and Lander Can (reproducing what I did in the past) but the winch gui isn't working at all now. Something is messing with KAS. Bavarian, Kethane, RemoteTech, and MechJeb are the only mods that have been updated recently. Well this is annoying. Even with a Kerbal pilot I cannot use the winch gui. There is no MechJeb on the rover, so maybe RemoteTech is doing things. The sinking was happening with a working KAS winch GUI, so I'll have to see what is going on. My polar rover winch still works but new rovers at Kerbal Command do not.

In the original picture I just hit the decoupler and dropped the module. No Kerbals involved. At the poles I was using the winch to pick up and drop modules.

edit with decoupler only:

Your module still sinks, but only up to about the level of the door node. Landing Can does not sink. The Hitchhiker is a Utility piece like your modules. It does not sink. On the launch pad itself, your module does not sink. Drive towards KAS and it will.

Edited by BigD145

Share this post


Link to post
Share on other sites
do you need kas or any other mods for this?

Some parts use KAS and Firespitter, but its not required . If you don´t have those plugins, you can still use the parts.

So here a little preview of a concept of the announced modular base concept.

The size of the parts is not necessary final. Welding and texturing are also alpha stage.

This is more or less a ingame-test of the concept to simulate partially buried facilities

Share this post


Link to post
Share on other sites

that's awesome

Edit: although have you started making the dirt that will be used to cover the facilities at varying colors for differing terrain or even better have it when true career is implemented be bought on site. another you can do it have it change color based on the terrain which could be done with a plugin,

Edited by Helix935

Share this post


Link to post
Share on other sites

Sorry, I have no logs, and was able to install the mod, but now I cannot walk through to nt100 walkways.when I get home from work later on this morning, I will post up some logs. But, do you have any idea as to why this is happening?

Share this post


Link to post
Share on other sites
But, do you have any idea as to why this is happening?

hmm i can´t see anything, i think my global-screen-monitoring-tool called crystal ball is broken ;-)

Can´t you pass the the nt100 at all, or do you fall over constantly?

In first case, a screenshot would be helpful (maybe something is blocking the entry?) . Second case...wait for a update. Right now i am testing a new version thats better.

Also i noticed that if i clock down my pc the falling-rate is much higher ..even on stock-plates.... i think the collision-detection-system in ksp is a challenge.

Share this post


Link to post
Share on other sites

ok i really, really love this pack but this is just a suggestion can you please at least do something about the seriously creepy iva for the habitat because the staring kerbal has been giving me nightmares recently. Just a suggestion ok

Share this post


Link to post
Share on other sites

@sharpspoonful Try turning on your RCS pack, and tap shift a couple of times as you try to enter. That worked for me.

Share this post


Link to post
Share on other sites

If you first place them down and do not reload physics by leaving and coming back you won't be able to walk past that lip without grabbing the floor of those tunnels, especially if they are partially under the terrain.

Share this post


Link to post
Share on other sites

very good mod,

By cons I'd like to know if you consider lowering the levels of texture

(Something more Kerbal?) For small config?

ca I just have only one of two model. after these crash

sorry for mi bad inglish

Share this post


Link to post
Share on other sites

No offense, but do you mind if I translate that a bit, for posterity's sake?

It seems like while he enjoys the mod, the textures are too high and would possibly like a lower res texture, perhaps more stock alike. His game crashes even with few mods.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.