sumghai

[1.6.x] SDHI Service Module System (V4.0.1 / 25 December 2018)

Recommended Posts

Haven't been around for a few years now... but I'm really happy to see that this thing is still around! It has ferried so many kerbals to and from my space stations through the years.

Edited by wasmic
  • Like 1

Share this post


Link to post
Share on other sites
On 2/4/2019 at 9:29 AM, Cloakedwand72 said:

Any chance of adding this to Ckan 1.6.1? All the dependency's are updated & are on Ckan. Also how do you stage this?

if you want to change it to be a staged decoupler, open SDHI_Crew_Module_Adapter.cfg, find this code:

	MODULE
	{
		name = ModuleAnimatedDecoupler
		ejectionForce = 150
		explosiveNodeID = top
		staged = false
		animationName = SDHI_CMA_Umbilical_arm_swing
		waitForAnimation = true
	}

and change "staged = false" to "staged = true"

Edited by Capt. Hunt

Share this post


Link to post
Share on other sites

I don't recommend modifying the CMA decoupler to be stageable, as it is a deliberate safety feature, and the CMA is supposed to be decoupled via action group instead.

However, if you insist, then please do it via your own MM patch - otherwise, I cannot provide support to those who directly modify SDHI SMS itself.

Share this post


Link to post
Share on other sites
3 hours ago, sumghai said:

I don't recommend modifying the CMA decoupler to be stageable, as it is a deliberate safety feature, and the CMA is supposed to be decoupled via action group instead.

However, if you insist, then please do it via your own MM patch - otherwise, I cannot provide support to those who directly modify SDHI SMS itself.

I agree with @sumghai on this one.  But if you insist on putting the decoupler into staging, here's the MM script to do so.

Spoiler

// MM.SDHI.SMS.20190218a.<date-version>.cfg
// 
// Version 20190218a
//
// Powered by ialdabaoth and sarbian's ModuleManager
//      http://forum.kerbalspaceprogram.com/index.php?/topic/50533--/
// ModuleManager config coding by Jacke
//      http://forum.kerbalspaceprogram.com/index.php?/profile/103694-jacke/
// Copyright 2019 by KSP forum user Jacke
// Licence GNU General Public Licence version 3
//      https://www.gnu.org/licenses/gpl-3.0.en.html
// Licence Creative Commons Attribution-ShareAlike 4.0
//      http://creativecommons.org/licenses/by-sa/4.0/
// Licence Creative Commons Attribution-NonCommercial-ShareAlike 4.0
//      http://creativecommons.org/licenses/by-nc-sa/4.0/
//
// Include this file with Kerbal Space Program
//
// Modifications to SDHI Service Module System
//
// 2019 Feb 18 Mon  MM coding by Jacke
//
// where    GameData/zzzFinal/
// what     SDHI SMS
// files    parts files for SDHI SMS
// nodes    PART's for SDHI SMS
//
@PART[SDHI_Crew_Module_Adapter]:FINAL
{
	@MODULE[ModuleAnimatedDecoupler]
	{
		@staged = true
	}
}
//
// END OF MM.SDHI.SMS.<date-version>.cfg

 

 

Share this post


Link to post
Share on other sites

Has anyone else had issues with the docking port not wanting to dock to the stock port?  I'm not really sure what's going on other than I'm perfectly aligned and was doing 0.2 m/s and they just bounced off each other.

Share this post


Link to post
Share on other sites
7 hours ago, rottielover said:

Has anyone else had issues with the docking port not wanting to dock to the stock port?  I'm not really sure what's going on other than I'm perfectly aligned and was doing 0.2 m/s and they just bounced off each other.

Never. Maybe your stock port isn’t really stock. (Ven’s Restock?)

or maybe your stock port got patched to behave differently 

Share this post


Link to post
Share on other sites

doesn't look like I have Ven's restock, but I am using CKAN and have noted that it's caused me a few conflicts in the past, so I wouldn't rule it out that something else mucked with the stock ports.   I'm just not sure how to tell.   I'll try some experiments and see , maybe it has to do with tweakable everything

Share this post


Link to post
Share on other sites

I've tried again a couple of times,  how do I look into the configs to see if they are the same?

EDIT: let me be more detailed....     I tried a test where I created a new TEST game in sandbox and I hacked grav with two pods    Now the docking ports are working fine.   I have no idea what's going on.

Went back to my 'real" game, and they won't dock.   I tried with several combos in the test, stock port to stock port, SDHI port to stock etc.  all worked in sandbox.    In my career save SDHI won't dock to stock.

Is there some kind of bug or issue with the way you use docking ports in builds?  Like am I not supposed to use them as decouplers if I want to use them as docking ports later?

Edited by rottielover

Share this post


Link to post
Share on other sites

I've a small suggestion for @sumghai Re: the MechJeb MM patch for SDHI: Remove the "rover autopilot", "spaceplane autopilot", and "landing guidance" functionality from the SDHI service module and from the SDHI crew module adaptor.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, StevieC said:

I've a small suggestion for @sumghai Re: the MechJeb MM patch for SDHI: Remove the "rover autopilot", "spaceplane autopilot", and "landing guidance" functionality from the SDHI service module and from the SDHI crew module adaptor.

Make sense! I'll figure out how to do that and line that up for the next update.

Share this post


Link to post
Share on other sites

So just to wrap up my little issue,   I added "undock-inator" and it did not recognise the ports as docking ports,   that raised my suspicions a bit.   I tried re-loading quicksaves,  no effect,  I tried launch the craft new, no effect.

What worked was to remove the docking ports from the craft in the VAB "delete them", add "new" docking ports onto the craft, save it and launch it new.    That seems to have worked.

I still have no clue why this happened or what could have caused it, but at least I got it working.

Share this post


Link to post
Share on other sites

@sumghai Just as a heads up, Nertea's ReStock resizes the top of the Mk 1-3 Command Pod to be 1.25m, and breaks the clean lines of the docking port, and the SMA umbilical port. Now there's a way to patch ReStock with a MM script to whitelist the parts, I just haven't had the time to figure out how to write one. Not asking you to, just bringing it to your attention. 

  • Like 1

Share this post


Link to post
Share on other sites

Any chance of making a larger service module to fit this & the updated Linux guru gamer updated version of the capsule?

 

Edited by sumghai
Removed quote of first post in thread to save space

Share this post


Link to post
Share on other sites

@sharpspoonful @Vince_K I appreciate you guys bringing this issue to my attention. However, I specifically designed this mod for use with the stock Mk1-3 Pod, and I'm not a fan of the philosophy behind ReStock. Therefore, I have no plans to make SDHI SMS support that mod.

@Cloakedwand72 As per the FAQ, I have no plans to support other pod sizes. (Also, please don't quote the entire first post - it makes your post unnecessarily long and hard to read).

  • Like 1

Share this post


Link to post
Share on other sites
37 minutes ago, sumghai said:

@sharpspoonful @Vince_K I appreciate you guys bringing this issue to my attention. However, I specifically designed this mod for use with the stock Mk1-3 Pod, and I'm not a fan of the philosophy behind ReStock. Therefore, I have no plans to make SDHI SMS support that mod.

@Cloakedwand72 As per the FAQ, I have no plans to support other pod sizes. (Also, please don't quote the entire first post - it makes your post unnecessarily long and hard to read).

Ok. Sorry I thought I'd reply in comments rather than PM. I Just get confused with the quotes part on this forum format.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now