sumghai

[1.7.x] SDHI Service Module System (V4.0.2 / 15 April 2019)

Recommended Posts

40 minutes ago, sumghai said:

Now that I'm back from vacation, I can start looking into revamping this mod for KSP 1.4.x.

Due to the numerous changes in the base game and the litany of issues, I suspect the best thing to do would be to remake all the parts from scratch - see my newly-reopened dev thread    for details.

nice, looking forward to seeing this mod updated

Share this post


Link to post
Share on other sites

Sorry for my English, I use online translator. I love this mod very much. All my main ships in versions 1.3.0, 1.3.1 were somehow built using this mod. Now I have installed version 1.4.2 and moved my career game from 1.3.1. And I have this mod in the old version. And it works great, including all the necessary dependencies. It's amazing!  Of course, there are some features, for example, on the new Mk 1-3 command module there is no port to animate the interchange with the service module. But this does not spoil the impression of the game as a whole. I hope sumghai will fix it soon.

P.S. And I tell you a secret: I use not only stock command modules, but also modules from other mods such as 2.5 m ( I have the option of Apollo for the crew of 4 kerbonauts). And they all work!

Share this post


Link to post
Share on other sites

Hi @Sokol_323, as per my comments two posts above yours, I am slowly working on updating these parts for 1.4.x, and will definitely look at fixing the umbilical.

Share this post


Link to post
Share on other sites
3 minutes ago, sumghai said:

Hi @Sokol_323, as per my comments two posts above yours, I am slowly working on updating these parts for 1.4.x, and will definitely look at fixing the umbilical.

in the mean time, aside from a couple of annoying bugs, the mod does work.  The old mk.1-2 pod is still in the game, they took it out of the command pods menu so you can't see it, but you can find it by either searching or using the Kerlington Manufacturer filter.

Share this post


Link to post
Share on other sites
8 hours ago, sumghai said:

Hi @Sokol_323, as per my comments two posts above yours, I am slowly working on updating these parts for 1.4.x, and will definitely look at fixing the umbilical.

Hello! Thank you, I saw this message. And with impatience I will wait for the version of the mod for 1.4.2. I just wanted to say that even the current version works fine now, if you do not pay attention to minor flaws, as I wrote above.

8 hours ago, Capt. Hunt said:

in the mean time, aside from a couple of annoying bugs, the mod does work.  The old mk.1-2 pod is still in the game, they took it out of the command pods menu so you can't see it, but you can find it by either searching or using the Kerlington Manufacturer filter.

Thank you. I know it, but to be honest I could not find where they hid it. Except for the lack of a built-in RCS, I like the Mk1-2 command module more than Mk1-3.

Share this post


Link to post
Share on other sites

From what I can tell, in 1.4.2, they just have the line that tells the game which part type to put it in set to "none," so the manufacturer tab still works.

Share this post


Link to post
Share on other sites

Unfortunately, but for me, the search for the name of the manufacturer does not find Mk1-2 (there is an engine and stuff, but not pod). Also not looking for the name of the Mk1-2. In the Squad parts list there is this module . But where do you find the tape that unlocks him?

Share this post


Link to post
Share on other sites

Hey everyone!

Some of you may have been following my development thread for news and updates on the V4 revamp for KSP 1.4.5.

I'm pleased to announce that I'm almost finished with the revamp, and that I'm now seeking feedback while working on updating all the documentation - I'm particularly interested in how well my mod provides support for third-party mods. Give the following a whirl, and post your thoughts in the dev thread:

Download the Experimental Build for KSP 1.4.5

Edited by sumghai
Added note on where to leave feedback

Share this post


Link to post
Share on other sites
18 minutes ago, sumghai said:

Hey everyone!

Some of you may have been following my development thread for news and updates on the V4 revamp for KSP 1.4.5.

I'm pleased to announce that I'm almost finished with the revamp, and that I'm now seeking feedback while working on updating all the documentation - I'm particularly interested in how well my mod provides support for third-party mods.

Download the Experimental Build for KSP 1.4.5

Do you want bug reports(if any) in here or the dev thread?

Share this post


Link to post
Share on other sites
1 hour ago, Spartan_MiniMe said:

Do you want bug reports(if any) in here or the dev thread? 

I would prefer them in the dev thread, thanks :)

Share this post


Link to post
Share on other sites

Good news! This release can be used with the old version of the mod, so as not to lose those crafting that use the old parts?

Share this post


Link to post
Share on other sites
4 hours ago, Sokol_323 said:

Good news! This release can be used with the old version of the mod, so as not to lose those crafting that use the old parts? 

Short Answer: No.

Long Answer: I did rename most (but not all) of the new parts, but just in case, don't mix and match old and new versions in your game.

Share this post


Link to post
Share on other sites
33 minutes ago, Sokol_323 said:

Forgot to ask: dependencies remain the same? 

Dependencies remain the same - AnimatedDecouplers, ModuleManager and RealChutes.

Share this post


Link to post
Share on other sites

Is it possible to remove the dependence on RealChutes? The fact is that for some reason I have a conflict with this mod even on the stock installation. Older SDHI I have works great without this mod. And I have no problem with other parachutes both stock and from other mods.

I checked the work of the new version of the mod on a clean install, like no comments yet.

Share this post


Link to post
Share on other sites

I apologize in advance. Ghost Explorer doesn't give me a break, so I took the liberty of making a compilation from old and new SDHI. I hope the @sumghai will forgive me for that.

Oddly enough, both mods work on my installation in version 1.4.5. Of course not without conflict. This parachutes and cover for MK1-2. We need to think about how to work around this, but I think that simply editing the configuration files will not be enough. If this does not work, then I have to choose which parts to leave for the game. Edit the mod I will not, I have no rights from the author.

Share this post


Link to post
Share on other sites

So the experiment of compiling old and new SDHI mods was successful. I created an additional folder called SDHI_1 where I installed the files from the old mod. Accordingly, the changed configuration files details by rewriting the path in accordance with a new folder. And it worked: I have now run the two mods together without conflicts. The only thing that is not quite working correctly parachute from the new fashion, but this is due to the lack of my fashion RealChutes. I hope the author will not be angry with me for such liberties.

Why do I need the details of both mods? I have saved a career now almost all vehicles use parts from the old fashion. Therefore, a simple replacement will lead to the collapse of the game, which I absolutely would not want. Perhaps over time, I will remake all the ships using parts of the new version only. But while let it be as it turned out, the more the result suits me as well as possible.

From observations so far, I have revealed the fact that MechJeb will not display the engine parameters of the new service module. This makes it difficult to calculate the Delta V of the entire rocket and ship separately. In the rest of the until without comments.

Share this post


Link to post
Share on other sites
4 hours ago, Sokol_323 said:

I have revealed the fact that MechJeb will not display the engine parameters of the new service module

Yes, I've observed this as well. I'll pop over to the MechJeb thread to see if anything could be done about this.

Share this post


Link to post
Share on other sites

Kerbal Engineer seems to have a similar problem, I'm guessing the reason why is that the engine is on the same part as a decoupler?

I got both the old and new SDHI parts installed simultaneously and working without conflict just by making minor tweaks to part names in the old SDHI cfg files for the heat-shield and the parachute clamp-o-tron

 

Edited by StevieC

Share this post


Link to post
Share on other sites
6 hours ago, sumghai said:

Yes, I've observed this as well. I'll pop over to the MechJeb thread to see if anything could be done about this.

The service module has its engine integrated? Not two separate parts like before?

Share this post


Link to post
Share on other sites
1 hour ago, Starwaster said:

The service module has its engine integrated? Not two separate parts like before?

Yes, the service module now has a built-in engine, but it is not yet possible to get information about its thrust and Delta V in General. According to rough estimates outside the atmosphere something around 1500-2000 Delta V and there is another point: the long-term operation of the engine service module at full power leads to overheating and explosion. At least that's what I had once during the tests.

Share this post


Link to post
Share on other sites
3 hours ago, Starwaster said:

The service module has its engine integrated? Not two separate parts like before?

Integrated, yes.

This is because I didn't like the hokey stock LV-909 model, and I also wanted to prevent other engines from being used with the Service Module.

2 hours ago, Sokol_323 said:

According to rough estimates outside the atmosphere something around 1500-2000 Delta V

That doesn't sound right.

Other than the fact the engine and fuel tank and combined into the same part, the fuel capacity and engine specs are still the same as in V3.2.4 - i.e. a delta-V of around 500~700 m/s.

2 hours ago, Sokol_323 said:

and there is another point: the long-term operation of the engine service module at full power leads to overheating and explosion. At least that's what I had once during the tests.

That doesn't sound right, either. I've never had overheating just by running the engines on full power over long periods of time.

Share this post


Link to post
Share on other sites
4 hours ago, sumghai said:

I also wanted to prevent other engines from being used with the Service Module.

...

'kay...

Share this post


Link to post
Share on other sites
5 hours ago, sumghai said:

This is because I didn't like the hokey stock LV-909 model, and I also wanted to prevent other engines from being used with the Service Module.

But why?

Share this post


Link to post
Share on other sites
17 minutes ago, sharpspoonful said:

But why?

Because then I'd have to accept requests for custom-length fairings to cater for every possible engine choice, which I don't want to do for logistical reasons.

An alternative solution to the missing delta-V issue would be to split the Service Module into the existing Crew Module Adapter (the decoupler formerly known as the Avionics Ring) and a Service Module Propulsion Trunk (fuel tank + engine). 

I personally prefer consolidated parts, but I'd be willing to consider this compromise if the trunk's combined fuel tank + engine registers to MechJeb and Kerbal Engineer's delta-V displays the same way the stock SRBs do right now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.