pizzaoverhead

[1.3] RCS Sound Effects (2017-06-12)

Recommended Posts

Have you tried with RCS Sounds uninstalled? To verify that's the issue?

yeah it only happens with rcs sounds running. I have a feeling it may be to do with either engine configs or as it's the RO files it's interfering with, probably multiple modules for the same item conflicting i.e. the rcs ones. I think there was a problem with it mentioned around RF 4. Also RF5 kinda messed up my tanks in career abit, the stretchy ones are mostly limited to 8000 units and the super stretchys won't unlock after purchasing in R&D :/?

Share this post


Link to post
Share on other sites

pingopete: Did you follow instructions for both RF v5 and Stretchy v9?

Also, I'll investigate: it may be that an update to RCS Sounds broke the compatibility fixes I added to RF.

Share this post


Link to post
Share on other sites

awesome mod! ,I dont have any issues either (so far), and I am not running the real fuels. I do have a ton of mods though and parts that I have done myself...but so far no issues yet. It even works with my custom rcs thrusters. :) so this is a permanent mod for me and I thank you!

Share this post


Link to post
Share on other sites
pingopete: Did you follow instructions for both RF v5 and Stretchy v9?

Also, I'll investigate: it may be that an update to RCS Sounds broke the compatibility fixes I added to RF.

Installed latest of RF, Stretchy, and RCS sounds still getting this problem, latest Stretchy fixed my tank issue though, thanks.

Share this post


Link to post
Share on other sites
Any word on why the new version sounds don't work on interiors even if you disable the exterior option?

I did some checking for that last night. It's a bug. It'll be fixed for the next release. Thanks for the bug report!

Share this post


Link to post
Share on other sites

RCS Sounds version 4.0 for the KSP 0.23.5 ARM pack is now available here. It fixes the internal sounds issue and uses the new version of Module Manager.

Share this post


Link to post
Share on other sites

Hey i had a quick question: While opening the zip file, there's a "modulemanager 2.0.1.dll" file, but the most current one is 1.5.6 . Where does the 2.0.1 file come from?

Edit: 2.0.1 is the updated one, but it wasn't changed in the main post of the modulemanager thread.

Edited by Mokmo

Share this post


Link to post
Share on other sites
I don't like the muddy "farting" sound of the included rcs sounds. So, I whipped up my own version. These would replace the .wav files in \GameData\RcsSounds\Sounds

http://mrblaq.com/kerbal/RCSSounds.zip

Awesome, better than "stock" sounds.

Pizzaoverhead, put these as dafault into mod.

Share this post


Link to post
Share on other sites
Does this work in v0.24?

I am not running into any problems (64 bit install) but it has not been updated officially yet. You could try it out and see what happens.

Share this post


Link to post
Share on other sites
I am not running into any problems (64 bit install) but it has not been updated officially yet. You could try it out and see what happens.

It should work fine; nothing that it touches has changed.

Share this post


Link to post
Share on other sites
Hey i had a quick question: While opening the zip file, there's a "modulemanager 2.0.1.dll" file, but the most current one is 1.5.6 . Where does the 2.0.1 file come from?

Edit: 2.0.1 is the updated one, but it wasn't changed in the main post of the modulemanager thread.

The most recent version should be 2.2.0.

http://forum.kerbalspaceprogram.com/threads/55219-Module-Manager-1-5-6-(Jan-6)

Share this post


Link to post
Share on other sites

I've tried it. It destroys the ability to throttle up and pretty much destroys any keyboard function. :D

Sounds of "farts" can be heard going off one after another.

I'm using 32-bit version of KSP because 64-bit loses framerate.

Share this post


Link to post
Share on other sites

Tried this in 64-bit without issues, however I don't really like the "farting" sounds of the propellant. Just a personal opinion!

Share this post


Link to post
Share on other sites

After I've removed it, keyboard works again and I can actually go to space today.

Share this post


Link to post
Share on other sites

After 0.24.2 update I am getting this errors:

KSP.log


[EXC 23:51:16.241] MissingMethodException: Method not found: 'Part.GetConnectedResources'.
[EXC 23:51:16.243] MissingMethodException: Method not found: 'Part.GetConnectedResources'.
[EXC 23:51:16.245] MissingMethodException: Method not found: 'Part.GetConnectedResources'.
[EXC 23:51:16.246] MissingMethodException: Method not found: 'Part.GetConnectedResources'.

output_log.txt


MissingMethodException: Method not found: 'Part.GetConnectedResources'.
at Part.ModulesOnUpdate () [0x00000] in <filename unknown>:0

at Part.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

MissingMethodException: Method not found: 'Part.GetConnectedResources'.
at Part.ModulesOnUpdate () [0x00000] in <filename unknown>:0

at Part.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

MissingMethodException: Method not found: 'Part.GetConnectedResources'.
at Part.ModulesOnUpdate () [0x00000] in <filename unknown>:0

at Part.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

It's not just this couple of lines, it's more like couple thousand of lines.

RCS is working, but there is no sound.

Removing mod fix the issue.

Share this post


Link to post
Share on other sites
After 0.24.2 update I am getting this errors:

--snip--

It's not just this couple of lines, it's more like couple thousand of lines.

RCS is working, but there is no sound.

Removing mod fix the issue.

Same for me. I was happy to have all my sounds covered between this and ion engine sound mod. Alas. I hope it's fixed soon!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.