ludsoe

[1.2] L-Tech Scientific Industries V4.2

Recommended Posts

Am i able to put it on the curse site?

Not according to the license included in the archive:

License

LTScience: GPL (GNU General Public License)

LTScience Parts: No distribution. Please request author Ludsoe on kerbal space program forums

Share this post


Link to post
Share on other sites
Am i able to put it on the curse site?

I finally got some time away from everything else in my life so I decided to visit KSP again, and found out my mod had no download. Well I solved that problem by posting it on curseforge. (Link may not work for a bit while moderators approve it. Hopefully that will be soon.)

http://www.curse.com/ksp-mods/kerbal/221787-l-tech-scientific-industries

On another note, Before i was consumed by real life. I was working on a update for LTech, Ill pick up where I left off and hopefully get it finished/tested.

Share this post


Link to post
Share on other sites

Found this through the Hullcam VDS mod, looking forward to being able to grab some science from photos mainly.

I assume parameters are tweakable? I don't want to be getting more science than what seems fair.

Share this post


Link to post
Share on other sites

Update News:

V2.15 **Im Back Baby!

*Changed the Sky-Lab to require snacks to generate insight.

*Re-balanced Sky-Lab science returns, and resource weights.

*Updated the Action buttons on the Sky-Lab to automatically hide experiments you lack the resources for.

*Added variables in the camera's cfg's that allow you to change the amount of science/data you obtain from taking a picture.

*Added Tweak-scale Support to the Air-Brake and Storage's.

*Separated all the resources into their own resource containers.

*30% more chance of bugs!

Comment Reply Time!:

I'd like to see science stuff to use while not in orbit, such as experiments to use in high atmosphere of planets, things that require insight and consumables on the surface of planets (life detection experiments?), experiments you can only run while during reentry, things like this, stuff and times not usually exploited by science in KSP. Maybe something you can only use while also using that air brake? In any case, I had forgotten to install this on my last game and missed it a bunch.

Ill look into these, Thanks for the suggestions. The reentry only experiments are an interesting idea. But the land based experiments that use resources are the easiest to implement currently.

Many thanks. Defaulting to zero seems a strange choice.

Your right, Now the sky-lab defaults with some resources.

Enjoying this mod, which so far seems to be 23.5 compatible. A few initial observations:

- Insight is generated far too quickly.

- There should be some diminishing return on repeating experiments regardless of the resource requirements. They're still very easy to spam for science.

- Haven't confirmed yet but does the lab require 4 kerbals to use? If it doesn't, it should. I'd also add a snacks resource which is consumed as insight is generated and once gone, no more insight. Replace snacks.

I liked your snack idea so I implemented it, also the kerbals required in the lab is configurable. Also more kerbals in the lab the faster insight is produced. If you find it too fast, you can also change the rate in the config to something lower.

Found this through the Hullcam VDS mod, looking forward to being able to grab some science from photos mainly.

I assume parameters are tweakable? I don't want to be getting more science than what seems fair.

I added some values in the camera cfgs you can tweak.

Share this post


Link to post
Share on other sites

Oh man, that 30 percent chance of bugs is killer. I cant believe you managed to add that. Awesome.

Seriously though, welcome back!

Share this post


Link to post
Share on other sites

with the latest update the HullCamVDS SciCam part now takes pictures that are only 1Mit in size instead of 70. Did some looking through the configs but not sure what I need to tweak to get the 70Mit transmission size back

Share this post


Link to post
Share on other sites
with the latest update the HullCamVDS SciCam part now takes pictures that are only 1Mit in size instead of 70. Did some looking through the configs but not sure what I need to tweak to get the 70Mit transmission size back

In the HullCamera module for the SciCam add in "picdatval = 3.5" Tweak the number around a little until you get the results you want. Also make sure that you arnt taking pictures of nothing, As a picture of say the space center(or a anomaly) should raise the transmission size.

Share this post


Link to post
Share on other sites

I'm doing a beta, for v219 of L-Tech. As with all Betas I want your feed back, and any bugs you find.

http://www.curse.com/ksp-mods/kerbal/221787-l-tech-scientific-industries#t1:other-downloads

**ToolBar isn't required, but its recommended.

v219 Beta ChangeLog:

*Added ToolBar Support. Replaced the poor configuration I had before for the HullCam Module.

*The SkyLab now has a selection Gui for the experiment you want instead of a action for each one.

*Smaller Parts are KAS activated, and one of the containers is now also a KAS container.

*The cameras now have modules for RasterPropMoniter.

*Added a new SkyLab Experiment that's run on the surface of other planets.

*SkyLab Experiments are no longer hard coded, This system is still new and buggy.

Share this post


Link to post
Share on other sites

I unintentionally deleted my copy of this while updating to the latest version. :( Does anyone have an archive of one of the old (1.4 or earlier) versions? I liked the stripped down extra experiments.

Share this post


Link to post
Share on other sites
I'm doing a beta, for v219 of L-Tech. As with all Betas I want your feed back, and any bugs you find.

http://www.curse.com/ksp-mods/kerbal/221787-l-tech-scientific-industries#t1:other-downloads

**ToolBar isn't required, but its recommended.

v219 Beta ChangeLog:

*Added ToolBar Support. Replaced the poor configuration I had before for the HullCam Module.

*The SkyLab now has a selection Gui for the experiment you want instead of a action for each one.

*Smaller Parts are KAS activated, and one of the containers is now also a KAS container.

*The cameras now have modules for RasterPropMoniter.

*Added a new SkyLab Experiment that's run on the surface of other planets.

*SkyLab Experiments are no longer hard coded, This system is still new and buggy.

Are we still supposed to test this after .24, and do you know if it is 64bit compatible?

Share this post


Link to post
Share on other sites
Are we still supposed to test this after .24, and do you know if it is 64bit compatible?

I have a 0.24.0 Release, but I forgot to update the forum post. Guess i got caught up playing around with 0.24.0. As far I know it works in 64 Bit. Id still like some feed back on the new Experiment Gui for the SkyLab though, I feel there's lots of room for improvement.

V2.20 Change Log:

Updated for 0.24.0.

Added L-Tech Industries agent.

Re-balanced the costs of the resources/parts.

Moved around the parts in the Tech tree.

Share this post


Link to post
Share on other sites

A bug just happened to me. Do you guys know this one?

When i have L-tech installed, the camera stops following the craft and gets stuck in one point, and if i use WASD, the craft starts spinning around the camera, not being the camera. Over 15 G when doing that.

Is it a mod conflict?

Edited by O Nerd

Share this post


Link to post
Share on other sites
A bug just happened to me. Do you guys know this one?

When i have L-tech installed, the camera stops following the craft and gets stuck in one point, and if i use WASD, the craft starts spinning around the camera, not being the camera. Over 15 G when doing that.

Is it a mod conflict?

Do you have any other mods that change how the camera works? Did this happen after activating the take RL picture option? I don't do anything with the camera until you take a actual picture, with the hull-camera's.

Share this post


Link to post
Share on other sites

It didn't happen after taking an RL picture, and other mods that change camera usage... Hm, maybe Rasterprop Monitor?

Also, i will upload the output.log file tomorrow. ^-^

Edited by O Nerd

Share this post


Link to post
Share on other sites
Well I took a look, but im not sure really where to look in the log. But i did notice a error being repeated. Could be related.

HandleD3DDeviceLost

HandleD3DDeviceLost: still lost

Skipped frame because GfxDevice is in invalid state (device lost)

that is when u alt tab out of the game not from any mod

Share this post


Link to post
Share on other sites

I looked at my output log, and found this:

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Tac.SpaceCenterManager[FFF8CE56][137.54]: Start, new game = False

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Tac.AddLifeSupport[1447E740][137.54]: Constructor

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Tac.SpaceCenterManager[FFF8CE56][137.54]: Deleting crew member: Gilkin Kerman

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

NullReferenceException: Object reference not set to an instance of an object

at SkyLabExperiment.OnDestroy () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

(f38267)LazorSystem(4294841352) : IsActiveLazorSystem() : system locked down

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

(f38267)LazorSystem(4294841228) : IsActiveLazorSystem() : system locked down

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

(f38267)LazorSystem(4294841104) : IsActiveLazorSystem() : system locked down

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

7/26/2014 4:30:37 PM,KerbalAlarmClock,Destroying the KerbalAlarmClock-KACSpaceCenter

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

7/26/2014 4:30:37 PM,KerbalAlarmClock,Destroying Toolbar Button

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Tac.TacLifeSupport[FFF8CE58][639.22]: OnDestroy

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

Tac.SpaceCenterManager[FFF8CE56][639.22]: OnDestroy

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

[Kethane] Saving settings

(Filename: C:/BuildAgent/work/d63dfc6385190b60/artifacts/StandalonePlayerGenerated/UnityEngineDebug.cpp Line: 49)

NullReferenceException

at (wrapper managed-to-native) UnityEngine.Component:get_renderer ()

at ScreenSafeUIButton.setTextureState (Int32 st) [0x00000] in <filename unknown>:0

at ScreenSafeUIButton.Unlock () [0x00000] in <filename unknown>:0

at SpaceCenterMain.unlockUI () [0x00000] in <filename unknown>:0

at SpaceCenterMain.onInputLockModified (FromToAction`2 ctrls) [0x00000] in <filename unknown>:0

at EventData`1[GameEvents+FromToAction`2[ControlTypes,ControlTypes]].Fire (FromToAction`2 data) [0x00000] in <filename unknown>:0

at InputLockManager.RemoveControlLock (System.String lockID) [0x00000] in <filename unknown>:0

at SpaceCenterMain.OnDestroy () [0x00000] in <filename unknown>:0

Seems to have something to do with Skylab, even through i don't have it in my spacecraft.

EDIT: Sorry, Skylab actually gave me problems BEFORE, such as clicking on the load save button not giving me the GUI,.

Reinstalling solved it that time, but not on this one.

Edited by O Nerd

Share this post


Link to post
Share on other sites

I'm not sure if this is by design, or is just my install but the Radiation sensor doesn't seem to have any 'diminishing returns' - I've been able to get high 30 science readings from the same biome more than once on different visits which gets quite unbalanced quite quickly. Is it supposed to be doing that, or have I just got a clash between mods somewhere.

Share this post


Link to post
Share on other sites

i encountered this every time using ksp 0.24.2 32bit

NullReferenceException: Object reference not set to an instance of an object

at RenderingManager.AddToPostDrawQueue (Int32 queueSpot, .Callback drawFunction) [0x00000] in <filename unknown>:0

at LTScience.ConfigWindow.Start () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.