Jump to content

[1.2] L-Tech Scientific Industries V4.2


Recommended Posts

10 hours ago, metalpoetza said:

Sorry, I dropped your updated DLL in the folder, and the problem persists.

 

Update: Looks like this one has too few solar panels. The lab is drawing more power than the panels can provide. Let me dock a new section with some gigantors and verify if that may not be causing the problem now.

Ok, I updated it again. I changed some naming, which should fix it. Same link as above

Link to post
Share on other sites
4 hours ago, Olympic1 said:

Ok, I updated it again. I changed some naming, which should fix it. Same link as above

Cool - because the panels didn't make a difference. I'll try the new DLL now.

That seems to have fixed it. Had to stop research and restart it but then it was generating insight again.

Link to post
Share on other sites

I'm having a similar problem to metalpoetza.  Can't seem to generate insight, even after replacing the dll and restarting.  Also, when the Skylab is right clicked the snack resource is not displayed.  When snack containers are right-clicked no window pops up at all.

Edited by Comrade Smartass
Link to post
Share on other sites
5 hours ago, Comrade Smartass said:

I'm having a similar problem to metalpoetza.  Can't seem to generate insight, even after replacing the dll and restarting.  Also, when the Skylab is right clicked the snack resource is not displayed.  When snack containers are right-clicked no window pops up at all.

Did you download the latest release because I removed the MM reference for snacks so it could be defined

Link to post
Share on other sites
1 hour ago, Comrade Smartass said:

I use Ckan.  Can't install MM because it's incompatible with 1.2, and your mod isn't listed as having an available update in Ckan.  I'm currently running v4.0.1

It doesn't depend on MM because I removed the dependency for it untill it's updated for 1.2.

Link to post
Share on other sites
  • 2 weeks later...

!!! Note for people testing out the latest dll on github !!!

There is a problem with using "Take RL picture" which causes the camera to do weird things. I'll need to investigate whats causing this because there were no camera changes mentioned in the patch notes.

Untill then it's adviced to not click this button if you find it annoying.

Link to post
Share on other sites

 

L-Tech Scientific Industries Continued v4.1     -     For KSP 1.2

I temporarily disabled the option "Take RL picture" because there is some weird camera things going on after pressing it. I'll try to fix this ASAP.

Changelog v4.1:

Spoiler
  • Updated for KSP 1.2
  • Added abbreviation and hsp to resources
  • Fixed TweakScale for airbrake
  • Fixed loading RPM modules when not installed
  • Removed unused code
  • Updated access modifiers
  • Fixed possible bug that prevented generating Insight
  • Comment code that spammed log
  • Updated ToolbarWrapper
  • Added Alternate Resource Panel icons
  • Added license into source files

Known Bugs:

  • Skylab experiments overwrite each other.

Downloads:

Link to post
Share on other sites
4 hours ago, veld said:

That would not be confused stock "Gravioli Detector" and "Radiation sensor" I use a slightly different texture.

14516345.png

RadiationSensor folder unzip in \LTech\Parts\Science

(sorry for my English)

 

I'm not the original author and I'm more of a programming person. I could try to model and texture. I'll try some it this weekend.

Link to post
Share on other sites
19 hours ago, Olympic1 said:

I'm not the original author and I'm more of a programming person. I could try to model and texture. I'll try some it this weekend.

I think you may have misinterpreted his post? He's offering up a new texture already so the mod doesn't need a new model

Link to post
Share on other sites
2 hours ago, Drew Kerman said:

I think you may have misinterpreted his post? He's offering up a new texture already so the mod doesn't need a new model

I knew that, but I wanted new models for some time, but lack the skill in Blender. I have more experience in 3DS max.

Link to post
Share on other sites

Sorry that misled, but the model used in earlier versions of the KSP. (Seems to 0.24).
Of all the new-one line in the file and repainted textures.

(I sometimes wonder alter the texture, not more)

12319159.png

 

Edited by veld
Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

not sure if this has been brought up before but...

 

the KEI (Kerbin Environmental Institute) mod has a problem with this one.  basically it will perform all the boring run around KSC every time a new science part is researched by automatically collecting all available research from the KSC biomes.  this mod seems to break that mod and cause it to stop working as soon as you have an L-Tech part available.  I do not know the specifics about the problem but you could talk, to the author and see what the issue is.  it seems like it would be an easy fix from this end.  something about null ID's or some such.

Link to post
Share on other sites
  • 2 months later...

Still happy to see this being updated. A highfive to @Olympic1 and @linuxgurugamer for keeping it alive. :3

And I see that @ludsoe snuck in and updated the OP too - thanks for that, and thanks for getting this mod started. :D

Of course, I'm installing this now, so I'll mention whether it seems to be working in 1.2.2 still. :wink:

 

Link to post
Share on other sites
On 11/4/2016 at 8:26 AM, Bit Fiddler said:

not sure if this has been brought up before but...

 

the KEI (Kerbin Environmental Institute) mod has a problem with this one.  basically it will perform all the boring run around KSC every time a new science part is researched by automatically collecting all available research from the KSC biomes.  this mod seems to break that mod and cause it to stop working as soon as you have an L-Tech part available.  I do not know the specifics about the problem but you could talk, to the author and see what the issue is.  it seems like it would be an easy fix from this end.  something about null ID's or some such.

I just found the problem with this, and while it was a one line fix, finding it took several hours.

To fix manually, add the following to the SkyLabCore module in the SkyLab.cfg:

// This module is also a ModuleScienceExperiment, which means it also
// needs this line:
experimentID = error

 

Link to post
Share on other sites

And, as I'd literally found-and-downloaded KEI as they were discussing this bug, I've already tested this fix - it works! :D

LTechsvsKEI.PNG

 

Of course, WaitWhat and Error are probably L-Tech bugs. :(

(I specifically know that WaitWhat is when something goes weird with cameras - not sure about the Error experiment, but I'll bet it's associated with this. :V)

Link to post
Share on other sites
  • 6 months later...
8 hours ago, Nansuchao said:

Is someone still working on this mod?

hopefully @Olympic1 is able to update it again. I can't recall for sure but I think this adds science gathering to taking photos with cameras and I'm a big fan of it just for that!

Link to post
Share on other sites
  • 4 months later...
On 7/20/2017 at 11:02 PM, Drew Kerman said:

hopefully @Olympic1 is able to update it again. I can't recall for sure but I think this adds science gathering to taking photos with cameras and I'm a big fan of it just for that!

Not only does it add science gathering with photos, but it also adds (basically) screenshot's from your ship's POV.

And it doesn't work with 1.3.1. :(

PartLoader: Compiling Part 'LTech/Parts/Science/ExtCamera/ExtCam1/LT_ExtCam1'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Crash!!!

(I took out all the crash dump-y stuff, but I do have it)

Link to post
Share on other sites
3 minutes ago, Drew Kerman said:

Post it, I'd like to have a look. Thx

https://www.dropbox.com/s/7zqxct6b4snlyf1/LTech Crash 2017-12-01_070412.7z?dl=0
There you go, link to the zipped dump. Let me know if you need it in another format.

ETA: This is just the crash folder itself. I can recreate the crash pretty easily if you need the main output logs/etc.

Edited by etmoonshade
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...