alexustas

[1.4.3]ALCOR,"Advanced Landing Capsule for Orbital Rendezvous" by ASET (08/02/2017)

Recommended Posts

thanks. I did look back and saw the post you quoted, but that didn't tell me if he was still working on it at this time or not and whether he may have passed the reins on to you in the background. Appreciate the clarification! Thanks for pushing this out in the meantime.

Share this post


Link to post
Share on other sites
5 hours ago, Drew Kerman said:

thanks. I did look back and saw the post you quoted, but that didn't tell me if he was still working on it at this time or not and whether he may have passed the reins on to you in the background. Appreciate the clarification! Thanks for pushing this out in the meantime.

Your welcome.

Share this post


Link to post
Share on other sites

@Drew Kerman , and others, yes, alexustas has an update, and he even has a small group of beta testers testing it now... So, an "official" update should be coming Soon™??

Share this post


Link to post
Share on other sites

Its my favorite pod by far. But as it is it take more 5 sec to switch to a vessel have Alcor capsule on it. It might be a bit abusive, 

Share this post


Link to post
Share on other sites
2 hours ago, cgibsonmm said:

 

wish This was still alive!

This mod is very much alive.   Alexustas is working on updates.   LOTS of new goodies coming.      Just my opinion, but I hope that after 1.2 is officially released, we'll see some action.

Share this post


Link to post
Share on other sites
On 3/19/2016 at 10:57 PM, ComatoseJedi said:

Okay, I'm doing this little favor for new comers to the ALCOR and ASET downloads until Alex migrates over to another medium in the OP. Here are download links to the last version of ALCOR and patch, ASET Props, ASET Avionics.

ALCOR Pod 0.9.4

ALCOR IVA Patch 0.9.4

ASET Props 1.3

ASET Avionics 1.0

You will have to install this manually, just like the directions in the OP. If this is a Pete and RePete situation, I do apologize for making this post, but I tend to lean towards 68 pages of information a bit much to thumb through just to find links to mods. 

Just in case this violates something, I did not make this work, credit goes to @alexustas. I was only trying to help :)

 

looking for a still live download of the IVA

Share this post


Link to post
Share on other sites

The ALCOR capsule seems to be working for me quite happily in 1.2 with pretty much all of the IVA functional (e.g., displays, buttons, swivel chair, etc.).

The one issue is that much of the text is showing up with visible color tags (e.g., [#FF0000]). According to the RasterPropMonitor Github page...

Quote

Due to KSP's change from TextMesh to TextMeshPro, the color tags (eg[#00ff00] must be changed to an HTML-style format <color=#00ff00>).

Anyone know if there's an easy way to fix this? I can go into the various cfg files and change the labelText manually but perhaps there's a better way.

 

Share this post


Link to post
Share on other sites
3 hours ago, Movado said:

Anyone know if there's an easy way to fix this? I can go into the various cfg files and change the labelText manually but perhaps there's a better way.

Sorry I do not know the answer to your question, but I'm happy to report that this past Wednesday, after the release of 1.2 and RPM v0.28.0, Alex PM'd the group of testers, and indicated that he was working on an update.  He specifically mentioned the breaking change that you pointed out as one of the things he was working on.  So I am optimistic that an update in the works.

Share this post


Link to post
Share on other sites
8 hours ago, Movado said:

The ALCOR capsule seems to be working for me quite happily in 1.2 with pretty much all of the IVA functional (e.g., displays, buttons, swivel chair, etc.).

The one issue is that much of the text is showing up with visible color tags (e.g., [#FF0000]). According to the RasterPropMonitor Github page...

Anyone know if there's an easy way to fix this? I can go into the various cfg files and change the labelText manually but perhaps there's a better way.

 

Get notepad++. Load up the cfg file. ctrl+h. In the search box use:

\[#([0-9a-fA-F]+)\]

Then in the replace box use:

<color=#\1>

Make sure to set search mode to regular expression.

That should replace it with the correct syntax.

Can even open all files at once and replace it in all of them.

Edited by Ralathon

Share this post


Link to post
Share on other sites
Guest

Still cannot comprehend the scale and complexity of IVA. Absolutely titanic work. Most modders dislike making even stock-alike IVAs, but ALCOR IVA looks like a something unimaginable.

Although I don't use MechJEB, every time I look at IVA and MechJEB support panel, I begin to plan to try use it just to see how all the buttons work.

Comms equipment looks real. RT support is absent (or may be not?), but for crewed capsule it not of much use.

Unreachable standard for SQUAD, regrettably...

Share this post


Link to post
Share on other sites
5 hours ago, Ralathon said:

Get notepad++. Load up the cfg file. ctrl+h. In the search box use:

\[#([0-9a-fA-F]+)\]

Then in the replace box use:

<color=#\1>

Make sure to set search mode to regular expression.

That should replace it with the correct syntax.

Can even open all files at once and replace it in all of them.

Well that fixed most of the tags but rendered most of the displays inoperative (i.e., black screens, no response to button clicks). Considering the somewhat complicated nature of some of the LabelText statements, I'm not surprised it broke.

I'll try fiddling with it and see if there's something I'm overlooking. The regular expression global change of the labels is a good concept.

Share this post


Link to post
Share on other sites
15 hours ago, Ralathon said:

Get notepad++. Load up the cfg file. ctrl+h. In the search box use:

\[#([0-9a-fA-F]+)\]

Then in the replace box use:

<color=#\1>

Make sure to set search mode to regular expression.

That should replace it with the correct syntax.

Can even open all files at once and replace it in all of them.

Please tell me what to look for in the file?
Not in a single file like the combination of symbols does not occur.

Share this post


Link to post
Share on other sites
13 hours ago, Movado said:

Well that fixed most of the tags but rendered most of the displays inoperative (i.e., black screens, no response to button clicks). Considering the somewhat complicated nature of some of the LabelText statements, I'm not surprised it broke.

I'll try fiddling with it and see if there's something I'm overlooking. The regular expression global change of the labels is a good concept.

It's probably breaking stuff because it's recognizing something else as color tags. Any other identifiers to help narrow it down? Else you'll have to replace them one by one and check yourself if the adjustment is applicable. (Also, double check that the config is correct. I'd expect a </color> tag or something at the end if its based on HTML.)

4 hours ago, veld said:

Please tell me what to look for in the file?
Not in a single file like the combination of symbols does not occur.

You probably didn't tick the 'Regular Expression' box in search mode. Else it obviously isn't going to work.

Edited by Ralathon

Share this post


Link to post
Share on other sites
18 hours ago, Ralathon said:

 

You probably didn't tick the 'Regular Expression' box in search mode. Else it obviously isn't going to work.

Sorry, I incorrectly stated an essence (because I use a machine translator).
What specifically .cfg file should be opened?

 

,,,,,,,,,,,, eh, tuplyu, (machine translator, even this does not translate, not to mention other words)

Everything worked out. Thank you.
(If one is necessary)
unzip in Gamedata
 

 

Edited by veld

Share this post


Link to post
Share on other sites

I tried to do the regex replace and it worked somewhat. There are a bunch of others I can't figure out how to change. So many .cgf files! Ugh...

Share this post


Link to post
Share on other sites

Hello,
That's 48 hours that I look at your discution after hours of research on the web for the same problem. A big thank you from a small French very happy and passionate as you KSP. The problem is partially set but I see a very clear improvement. Congratulations and thank you for this impressive work I imagine the view explanations. (Sorry too  translation software and I just created this account specifically for thank you) good luck to all

 
 
 
 
 
 
Edited by REDKILLER_55

Share this post


Link to post
Share on other sites

Hi, I'm getting loads of error when switching to any craft with ALCOR attached, it seems to be some texture missing, is there a fix?

Here is that part of the log, 

Quote

[LOG 20:46:23.087] [FLIGHT GLOBALS]: Switching To Vessel Untitled Space Craft Lander ---------------------- 
[LOG 20:46:23.090] [PlanetariumCamera]: Focus: Untitled Space Craft Lander
[LOG 20:46:23.205] [Progress Node Reached]: RecordsAltitude
[ERR 20:46:23.234] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.235] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.236] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.237] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.238] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.239] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.249] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.249] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.250] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.250] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.252] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.253] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.263] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.263] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.263] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.264] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.266] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.267] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.356] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.357] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.358] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.358] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.360] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.361] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.371] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.371] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.372] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.373] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.374] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.375] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.384] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.385] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:23.386] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.387] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.389] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.390] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.397] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.397] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.398] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.399] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.406] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.406] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.407] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.408] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:23.426] [JSIPropTextureShift]: Exception configuring prop BeveragePackage_AppleCider (#93) with transform FoodPackLable01Obj1Obj.  Check its configuration.

[ERR 20:46:23.427] [JSIPropTextureShift]: Exception configuring prop BeveragePackage_AppleCider (#93) with transform FoodPackLable02Obj1Obj.  Check its configuration.

[ERR 20:46:23.489] [RasterPropMonitor]: Interlay texture ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02 could not be loaded.

[ERR 20:46:23.490] [RasterPropMonitor]: Interlay texture ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02 could not be loaded.

[ERR 20:46:23.492] [RasterPropMonitor]: Interlay texture ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02 could not be loaded.

[ERR 20:46:23.492] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.493] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:23.494] [RasterPropMonitor]: Interlay texture ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02 could not be loaded.

[LOG 20:46:24.588] Active Vessel is moving (sqrVel = 0.177525508085696). Cannot save.
[LOG 20:46:24.588] [FLIGHT GLOBALS]: Switching To Vessel Untitled Space Craft ---------------------- 
[LOG 20:46:24.590] [PlanetariumCamera]: Focus: Untitled Space Craft
[LOG 20:46:24.595] Camera Mode: AUTO
[ERR 20:46:24.732] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.733] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.733] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.734] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.736] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.737] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.747] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.747] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.748] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.749] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.750] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.751] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.761] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.762] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.762] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.763] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.765] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.765] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.775] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.776] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.777] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.777] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.779] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.780] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.789] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.790] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.790] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.791] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.792] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.793] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.803] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.804] Cannot find an InternalModule of typename 'DPAI_RPM'

[ERR 20:46:24.804] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.805] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.807] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.807] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.814] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.815] Cannot find an InternalModule of typename 'JSISCANsatRPM'

[ERR 20:46:24.816] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.816] Cannot find an InternalModule of typename 'InternalVesselView'

[ERR 20:46:24.824] Cannot find an InternalModule of typename 'JSISCANsatRPM'

 

Share this post


Link to post
Share on other sites

All that is related to RPM errors have you loaded all the dependencies and what version of KSP are you using I suggest you take a look at the below link

 

Share this post


Link to post
Share on other sites

Its the stable release of 1.2 with the latest RPM and ALCOR from this link

On 2016-09-12 at 9:42 AM, linuxgurugamer said:

 Here is a fully working, updated ALCOR: https://www.dropbox.com/s/56y9bp7lb1qtqoy/ASET.zip?dl=0

I've been getting the same kind of errors and causing 5ish second delay for vessel switching with ALCOR since the 1.1.2 update.

Only Squad,ASET,JSI and MM is in my gamedata, I dont think I've missed any other dependencies have I?

 

Edit:

I don't think the main issue here has to do with the other mods(scansat, docking port indicator etc) its the Interlay textures. This is the log I get after installing all of scansat, VesselView, DPI.

[LOG 23:03:26.310] [FLIGHT GLOBALS]: Switching To Vessel Untitled Space Craft Lander ---------------------- 
[LOG 23:03:26.312] [PlanetariumCamera]: Focus: Untitled Space Craft Lander
[LOG 23:03:26.427] [Progress Node Reached]: RecordsAltitude
[ERR 23:03:26.568] [JSIPropTextureShift]: Exception configuring prop BeveragePackage_AppleCider (#93) with transform FoodPackLable01Obj1Obj.  Check its configuration.

[ERR 23:03:26.568] [JSIPropTextureShift]: Exception configuring prop BeveragePackage_AppleCider (#93) with transform FoodPackLable02Obj1Obj.  Check its configuration.

[ERR 23:03:26.630] [RasterPropMonitor]: Interlay texture ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02 could not be loaded.

[ERR 23:03:26.631] [RasterPropMonitor]: Interlay texture ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02 could not be loaded.

[ERR 23:03:26.633] [RasterPropMonitor]: Interlay texture ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02 could not be loaded.

[ERR 23:03:26.635] [RasterPropMonitor]: Interlay texture ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02 could not be loaded.

[LOG 23:03:27.213] [SCANsat] Height Map Of [Kerbin] Completed...
[LOG 23:03:27.249] [SCANsat] All Height Maps Generated

 

Edited by Mr.KimJongEel
updated log

Share this post


Link to post
Share on other sites
9 hours ago, Mr.KimJongEel said:

I don't think the main issue here has to do with the other mods(scansat, docking port indicator etc) its the Interlay textures. This is the log I get after installing all of scansat, VesselView, DPI.

It looks like there's a config file that is pointing at the wrong location.  I don't have the release version of ASET Props installed to figure out which one it is, but it is one of the MFD props.  You'll want to search the cfg files for 'ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02' and change that to 'ASET/ASET_Props/MFDs/ALCORMFD40x20/bg02'

The BeveragePackage_AppleCider message is probably a typographical error in the config file.  The only effect it has is that that prop will be mislabeled (it can be fixed most likely by finding its config file and correcting the transform name by comparing it to other, similar props).

As for the other errors you were seeing, those are safe to ignore - they come up when those mods aren't installed.  Unfortunately, they're coming from KSP, not RPM, so RPM can't suppress the message.  They are annoying messages, but not harmful messages.

Share this post


Link to post
Share on other sites
8 hours ago, MOARdV said:

It looks like there's a config file that is pointing at the wrong location.  I don't have the release version of ASET Props installed to figure out which one it is, but it is one of the MFD props.  You'll want to search the cfg files for 'ASET/ALCOR_LanderCapsule/Props/ALCORMFD40x20/bg02' and change that to 'ASET/ASET_Props/MFDs/ALCORMFD40x20/bg02'

The BeveragePackage_AppleCider message is probably a typographical error in the config file.  The only effect it has is that that prop will be mislabeled (it can be fixed most likely by finding its config file and correcting the transform name by comparing it to other, similar props).

Thank you sir! The problem lies in the kOSTerminal.cfg in GameData\ASET\ASET_Props\MFDs\kOSTerminal, replaced all four instances to the correct directory and the delay is now gone.

As for the typo in the other cfg, just delete the "1obj" at the end of the line fixes the error.

Share this post


Link to post
Share on other sites
21 hours ago, Alexzii said:

Help please I do not know what to dot, My game is so  http://prntscr.com/cxv8pc  http://prntscr.com/cxv9jt    pls help me

Please read just a few pages earlier. This has been discussed quite a bit and is the result of the upgrade in the RasterPropMonitor mod, which uses a newer format for displaying text. It requires the use of "color=<#FFAAFF>" instead of the previous "[#FFAAFF]". What you're seeing is the old text color tags being interpreted as regular text.

We've been discussing ways to fix this while waiting for an update but so far no easy solution has been found.

So be patient. The next upgrade to this mod will likely fix that issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now