alexustas

[1.4.3]ALCOR,"Advanced Landing Capsule for Orbital Rendezvous" by ASET (08/02/2017)

Recommended Posts

Works in 1.4.4 flawless

Thanks @alexustas& @MOARdVfor the amazing result of ur hard work.bk

edit: first test 1.4.5 everythings nominal

-just in case

Edited by Burning Kan

Share this post


Link to post
Share on other sites

Hi, beatiful work, Im in love but I can´t use the landing legs don´t work with the current version?

cheers

 

Atom90

Edited by Atom90

Share this post


Link to post
Share on other sites
14 hours ago, Atom90 said:

landing legs don´t work

just a dirty fix so be warned suppension not work ,will paste the right/better cfg after investigation in the meentime replace the cfg with this:

Spoiler

PART
{


// --- general parameters ---
    name = ASET_LL
    module = Part
    author = AlexUstas

 

// --- node definitions ---

node_attach = 0.0, 0.0, 0.0, 1.0, 0, 0, 2

// --- editor parameters ---
    TechRequired = advLanding
    entryCost = 4100
    cost = 340
    category = Ground
    subcategory = 0
    title = ASET Landing Leg
    manufacturer = A.S.E.T.
    description =
// attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision
    attachRules = 0,1,0,0,0

// --- standard part parameters ---
    mass = 0.10
    dragModelType = default
    maximum_drag = 0.2
    minimum_drag = 0.2
    angularDrag = 2
    crashTolerance = 15
    bulkheadProfiles = srf

    maxTemp = 1200

//CoMOffset = 0, 0, 0

    breakingForce = 800
    breakingTorque = 800


    MODULE
    {
        
        name = ModuleAnimateGeneric

        animationName = KLLDeployAnim
        wheelColliderName = wheelCollider
        suspensionTransformName = Piston
        orientFootToGround = false
        landingFootName = FootHing
        // Axis is aligned forward instead of up
        alignFootUp = false
        suspensionUpperLimit = 0.65
        impactTolerance = 6500
        springRatio = 6
        damperRatio = 1.5
        boostRatio = 0.7
    }
    MODULE
    {
        name = ModuleWheelDeployment
        baseModuleIndex = 0
        
        animationTrfName = leg
        animationStateName = newlandingleg
        deployedPosition = 1
        deployTargetTransformName = deployTgt
        retractTransformName = piston
        
        TsubSys = 0.83
        
        extendDurationFactor = 0.5
        retractDuractionFactor = 0.3

    }
    MODULE
    {
        name = ModuleWheelLock
        maxTorque = 500
    }
    MODULE
    {
        name = ModuleWheelBogey
        baseModuleIndex = 0
        
        bogeyTransformName = foot
        deployModuleIndex = 2
        
        maxPitch = 160
        minPitch = -160
        restPitch = 0
        pitchResponse = 100
        
        bogeyAxis = 1, 0, 0
        bogeyUpAxis = 0, 0, -1
    }
    MODULE
    {
        name = ModuleWheelDamage
        baseModuleIndex = 0
        
        stressTolerance = 99999999
        impactTolerance = 600
        deflectionMagnitude = 1
        deflectionSharpness = 2.0
        slipMagnitude = 0
        slipSharpness = 2.0
        explodeMultiplier = 1.0
    }
    MODULE
    {
        name = FXModuleLookAtConstraint
        CONSTRAINLOOKFX
        {
            targetName = locator23
            rotatorsName = locator22
        }

        CONSTRAINLOOKFX
        {
            targetName = locator22
            rotatorsName = locator23
        }

        CONSTRAINLOOKFX
        {
            targetName = locator17
            rotatorsName = locator19
        }

        CONSTRAINLOOKFX
        {
            targetName = locator19
            rotatorsName = locator17
        }

    }

}

 

 

Share this post


Link to post
Share on other sites

Hello, I for some reason can't get Alcor to work. I install it just like the instructions say but it doesn't show up in the VAB

Thanks in advance for the help.

Gav

Edit: The camera shows up, but not the Lander can.

Edited by DarthGav

Share this post


Link to post
Share on other sites

@DarthGav try again step by step to install on a fresh ksp(all should be in "gamedata/aset" exept of jsi[rasterprobmonitor])

If that not bring the solution ,can u post a screenshot of ur gamedatafolder

Like i sayed few posts above Alcor run perfect exept the legs(working on a cfg)

Share this post


Link to post
Share on other sites
Spoiler

PART
{


// --- general parameters ---
    name = ASET_LL
    module = Part
    author = AlexUstas

// --- node definitions ---

node_attach = 0.0, 0.0, 0.0, 1.0, 0, 0, 2

// --- editor parameters ---
    TechRequired = advLanding
    entryCost = 4100
    cost = 340
    category = Utility
    subcategory = 0
    title = ASET Landing Leg
    manufacturer = A.S.E.T.
    description = 
// attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision
    attachRules = 0,1,0,0,0

// --- standard part parameters ---
    mass = 0.10
    dragModelType = default
    maximum_drag = 0.2
    minimum_drag = 0.2
    angularDrag = 2
    crashTolerance = 15
    bulkheadProfiles = srf

    maxTemp = 1200

//CoMOffset = 0, 0, 0

    breakingForce = 800
    breakingTorque = 800

MODULE
    {
        name = ModuleAnimateGeneric
        animationName = KLLDeployAnim
        isOneShot = false
        startEventGUIName = Extend 
        endEventGUIName = Retract 
        actionGUIName = Toggle 
        allowAnimationWhileShielded = False
    }
//    MODULE
//    {
//        
//        name = ModuleLandingLeg
//
//        animationName = KLLDeployAnim
//        wheelColliderName = wheelCollider
//        suspensionTransformName = Piston
//        orientFootToGround = false
//        landingFootName = FootHing
//        // Axis is aligned forward instead of up
//        alignFootUp = false
//        suspensionUpperLimit = 0.65
//        impactTolerance = 6500
//        suspensionOffset = 0, 0,0
//        suspensionSpring = 5
//        suspensionDamper = 0
//    }

    MODULE
    {
        name = FXModuleLookAtConstraint
        CONSTRAINLOOKFX
        {
            targetName = locator23
            rotatorsName = locator22
        }

        CONSTRAINLOOKFX
        {
            targetName = locator22
            rotatorsName = locator23
        }

        CONSTRAINLOOKFX
        {
            targetName = locator17
            rotatorsName = locator19
        }

        CONSTRAINLOOKFX
        {
            targetName = locator19
            rotatorsName = locator17
        }

    }
MODULE
    {
        name = USI_InertialDampener
    }
}

heres a config that will get the legs working for the most part. just cant start with them extended. 

still trying to figure out getting the suspension working but will probably have to have some model changes to get that working. 

Share this post


Link to post
Share on other sites

What do the buttons in a panel above Enviromental control do? MDM PL1 and the others next to it? also the buttons above the Junk Systems logo on left side, with fuel pumps etc? i cant seem to notice anything happening when i turn them on or off

Share this post


Link to post
Share on other sites
On 12/12/2018 at 10:20 AM, Amahlaka said:

What do the buttons in a panel above Enviromental control do? MDM PL1 and the others next to it? also the buttons above the Junk Systems logo on left side, with fuel pumps etc? i cant seem to notice anything happening when i turn them on or off

Those are dummy switches for decoration only.

Share this post


Link to post
Share on other sites
Posted (edited)
On 12/15/2018 at 1:49 AM, theonegalen said:

Those are dummy switches for decoration only.

hmmm... seems those would be perfect candidates for supporting any of the fuel transfer mods... ie TAC Fuel Balancer, GPO Speed Fuel Pump...etc

Edited by Stone Blue

Share this post


Link to post
Share on other sites
21 hours ago, Stone Blue said:

hmmm... seems those would be perfect candidates for supporting any of the fuel transfer mods... ie TAC Fuel Balancer, GPO Speed Fuel Pump...etc

I don't believe any of those mods are supported by RPM or MAS, unfortunately.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, theonegalen said:

I don't believe any of those mods are supported by RPM or MAS, unfortunately.

Yes... thats what I'm saying... would be great if someone could write-up MAS cfgs to support them... *and I DONT mean MOARdV... he's busy enuff...*
I would, but dayum, after many attempts, and re-reading the MAS documentation *many* times, and reading up on Lua, it is just beyond my intellegence :(

Edited by Stone Blue

Share this post


Link to post
Share on other sites
3 hours ago, Stone Blue said:

Yes... thats what I'm saying... would be great if someone could write-up MAS cfgs to support them... *and I DONT mean MOARdV... he's busy enuff...*
I would, but dayum, after many attempts, and re-reading the MAS documentation *many* times, and reading up on Lua, it is just beyond my intellegence :(

I think it would require more than cfg work. I think it would require C# coding in the main MAS dll. 

Share this post


Link to post
Share on other sites
Posted (edited)
3 minutes ago, theonegalen said:

I think it would require more than cfg work. I think it would require C# coding in the main MAS dll. 

Hmmm... I see LGG talking about looking at the code to have PWB and GPO work together moar harmoniously... maybe he'd consider looking into MAS support, while he's in there, if someone asked nicely? maybe it could be done from PWB/GPO side?

vOv

Edited by Stone Blue

Share this post


Link to post
Share on other sites
On 1/7/2019 at 2:13 PM, Stone Blue said:

Hmmm... I see LGG talking about looking at the code to have PWB and GPO work together moar harmoniously... maybe he'd consider looking into MAS support, while he's in there, if someone asked nicely? maybe it could be done from PWB/GPO side?

vOv

Yeah, I don't see myself adding support to MAS to support them directly (I don't want to deal with the overhead of testing mods I don't use - FAR is currently the only exception, since it's a very stable interface).  However ... the MAS Action Group feature may be able to do it (with limitations).  I can already call arbitrary functions in other modules, provided they don't require parameters (eg, the custom decoupler that BDB uses on the S-IVB LEM adapter, or the Animated Decoupler on the CM/SM decoupler).  If TAC had a PartModule that went on a specific part (or group of parts) that could invoke fuel balancing through a simple 0-parameter public method, MAS could work with it today.

I may be able to generalize the MAS AG in a couple of ways - first, accept a parameter list (assuming the parameters are C# PODT, not enums or objects); second, I may be able to support VesselModules or other MonoBehaviour types that aren't attached to a specific part.  Both of those will need to wait a bit, until I have time to focus on it.  But I'll give myself a reminder to look at it.

Share this post


Link to post
Share on other sites

Hi Everyone

Im still loving this mod but I going more deeply in love I somebody make the landing legs full funcionality and tweakble.

Best landing legs here in KSP

:)

cHEERS

Share this post


Link to post
Share on other sites
On 1/14/2019 at 4:34 PM, Atom90 said:

Hi Everyone

Im still loving this mod but I going more deeply in love I somebody make the landing legs full funcionality and tweakble.

Best landing legs here in KSP

:)

cHEERS

Lander legs?! What?! Where?!

Share this post


Link to post
Share on other sites
8 hours ago, Virtualgenius said:

Page 61 there is a dropbox for them they are the best legs in the game 

That link is quite old (pre-1.2?) and landing legs are one of the parts that don't age well. The most recent link I could find was years later on page 77.

(Click the date: Feburary 12, 2017 under alexustas name) 

 

Share this post


Link to post
Share on other sites
3 hours ago, Tonka Crash said:

That link is quite old (pre-1.2?) and landing legs are one of the parts that don't age well. The most recent link I could find was years later on page 77.

Actually, even *that* post refers to a release tiny bit earlier, than this updated one on the same day, by alexustas himself.
 

So grab *that* one, *AND* this update/fix by Col.Neville, for KSP 1.5.1... posted Nov 1, 2018
Be sure to "Like" both posts :P
 

 

Share this post


Link to post
Share on other sites
15 minutes ago, Stone Blue said:

So grab *that* one, *AND* this update/fix by Col.Neville, for KSP 1.5.1... posted Nov 1, 2018
Be sure to "Like" both posts :P

I've looked at the config files for 3 versions  where I found download links in this thread and Col. Neville's version (#4) is based off the oldest release here. The newest one you link to in the other post (which is the one I thought I'd linked to, oops) looks most like a current Squad LT-2 landing leg.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.