alexustas

[1.4.3]ALCOR,"Advanced Landing Capsule for Orbital Rendezvous" by ASET (08/02/2017)

Recommended Posts

17 minutes ago, Stone Blue said:

@pquade If you havent tried already, copy over *only* the stuff in the /ASET/ folder... Then do fresh install of the dependencies: v4.1.2 of Module Manager, and on the last page or two of the RPM thread, user Tegmil has a v0.30.7 RPM recompile for 1.8.1

Of course, you also want to make sure any of the listed recommended mods for ALCOR, are also updated or have stated 1.8.1 compatability.

Give that a try.

And I think that's a piece of the issue.  Some of the dependancies don't seem to have been updated.  But here take a look at what I'm seeing with my current 1.8.1 testing install.sjKeDwl.png?2

Share this post


Link to post
Share on other sites

Hmmm.. are the RPM MFDs all dead/non-responsive/blank?

Interesting, as I had that same exact issue with Probe Control Room... I dont know why the labels are all missing from eberything

Is this different than what you had happening before? I'm now wondering if theres an issue with Tegmil's unofficial RPM recompile .. vOv

Edited by Stone Blue

Share this post


Link to post
Share on other sites
46 minutes ago, Stone Blue said:

@pquade If you havent tried already, copy over *only* the stuff in the /ASET/ folder... Then do fresh install of the dependencies: v4.1.2 of Module Manager, and on the last page or two of the RPM thread, user Tegmil has a v0.30.7 RPM recompile for 1.8.1

Of course, you also want to make sure any of the listed recommended mods for ALCOR, are also updated or have stated 1.8.1 compatability.

Give that a try.

Well, I sort of feel like I'm getting closer, but it's still not working for me.

I've done fresh installs of RPM and ASET Props and those should be the only ones required, but I still feel like it's missing something since it's not working.

I think I need a checklist and actual links because finding the right versions seems to be more difficult than your description. ;)

Here's an error that's showing up.
cUKUmBO.png

8 minutes ago, Stone Blue said:

Hmmm.. are the RPM MFDs all dead/non-responsive/blank?

Interesting, as I had that same exact issue with Probe Control Room... I dont know why the labels are all missing from eberything

Is this different than what you had happening before? I'm now wondering if theres an issue with Tegmil's unofficial RPM recompile .. vOv

All the MFDs are entirely inoperative.

It seemed to me that buttons are different than the previous screenshot.  Then again, it might just be placebo effect. ;)

In reading what Tegmil did and the results he got.  He mentioned Direct-X.  I guess I should mention I'm OpenGL on a Unix based system install.
 

Share this post


Link to post
Share on other sites

@pquade see my post here in the PCR thread. this may be your issue.
Try deleting the /GameData/JSI/ folder, reinstall the official, but outdated RPM v0.30.6, *THEN* install Tegmil's patch on top, merging/overwriting everything.

If thiings are still not working, you may have to repeat the process, while also deleteing these folders:


/GameData/ASET/ALCOR_Advanced_IVA,

/GameData/ASET/ExtCamRadialVert

/GameData/ASET/ASET_Props

(as well as /GameData/ASET/ASET_Avionics if you have that installed)

Then reinstall the ASET ALCOR & Props mods. (ASET Avionics, as well, if you had that one before)

Share this post


Link to post
Share on other sites
5 hours ago, Stone Blue said:

@pquade see my post here in the PCR thread. this may be your issue.

I'll give it a shot and I'm completely dedicated to wanting to make this work, but none of this is obvious and sorting through all the combined threads to figure it out isn't going to happen for the average person who wants to install all of this stuff.

I think it would be great if somebody could somehow figure out a way to just make it all work just by dragging and dropping the files into the GameData folder like most other mods.  Again, not so much for myself, but for all the other people who might want to install.

Thanks for all of this though.  Hopefull.

Share this post


Link to post
Share on other sites

SUCCESS!  I'm ecstatic since this is my goto lander and rescue cockpit.

Here are the steps that worked for me.

1.  DELETE everything related to ASET and JSI.
2.  Download and install RasterPropMonitor v0.30.6 from here; https://github.com/Mihara/RasterPropMonitor/releases/
3.  Download Tegmil's patch from here; https://www.dropbox.com/s/jycdhbwzxkqcpyj/JSI-ksp181-fixes-2.zip?dl=1

3a.  Open both your installed JSI folder in your GameData folder, open up ALL of the subfolders in that JSI folder then drag and drop (or merge) any files from Tegmil's patch into it in the appropriate subfolders.  DO NOT SIMPLY REPLACE the JSI folders.  It's NOT a replacement.
4.  Start KSP 1.8.x, open a sandbox game, go into the SPH, load up the stock Aeris 3A craft, and launch it to the runway.

4a.  Turn the brakes on and go into IVA mode.  You should see the velocity vector bouncing around on the HUD.  Tilt the camera down and check functionality of the buttons on the MFD.  If MFD is INOP, then goto 1, else goto 5.  (This ensures you have a working RPM before tackling ASET.)

5.  Shut down the game.

6.  Download and install the ALCOR capsule from here; https://spacedock.info/mod/1203/ALCOR
7.  Download and install into “/Gamedata/ASET/" the ALCOR Advanced IVA 0.9.7 from here; https://spacedock.info/mod/1205/ALCOR Advanced IVA

8.  Download and install into “/Gamedata/ASET/" the ASET Props 1.5 from here; https://spacedock.info/mod/1204/ASET Props

9.  Start KSP 1.8.x, open a sandbox game, go into the VAB.  Build an ALCORE capsule, put a kerbal into it, and launch it to the pad.  Go into IVA and check functionality of some buttons.  I tend to turn on the cabin lights and check the ALCOR cameras on the MFDs  If they work, it works!

Download some of the other awesome IVAs that work with these mods!

Mk1 Cockpit' IVA Replacement by ASET

https://spacedock.info/mod/1214/ 'Mk1 Cockpit' IVA Replacement by ASET

'MK1-2' IVA Replacement by ASET
https://spacedock.info/mod/1206/'MK1-2' IVA Replacement by ASET

Mk1 Lander Can' IVA Replacement by ASET
https://spacedock.info/mod/1208/Mk1 Lander Can' IVA Replacement by ASET

Edited by pquade

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.