Starwaster

[1.6.1] Deadly Reentry v7.7.2, May somethingth, 2019 (The Rachel Edition)

Recommended Posts

Ok, after playing around with multiple values last night, I'm finding that a value of 1.09 for shockwaveExponent makes for a good "game" (not realism) setting with stock KSP.

Parts begin to really start to burn up around the same time as the vanilla reentry effects kick in (they still heat up significantly before then but the "danger zone" really kicks in around the same time as the effects) , and you'll still tend lose all your unshielded parts even on a decent reentry angle returning from LKO, so the gameplay considerations of having to deal with reentry remain largely intact. Higher values tend to result in your ship burning up higher in the atmosphere (I think you were right there Nathan and there's an atmospheric pressure dependency on the effect), while lower values tend to result in some unshielded parts surviving reentry (particularly engines which have a higher heat tolerance, and can be used as improvised heat shields as a result).

Now to start playing around with the shield values to find a corresponding balance :)

Edited by FlowerChild

Share this post


Link to post
Share on other sites

I'm running into a bit of an issue here where it seems like the UI for the game stops recognizes clicks on buildings and such after a vessel burns up on reentry and you click on "return to space center". Afterwards, the only button that seems to still work is "quit" and when you return to the main menu, all controls are frozen as well.

Anyone else encountering this? I am trying to figure out if it's a local issue, a known vanilla bug, or something to do with DR.

Share this post


Link to post
Share on other sites
I'm running into a bit of an issue here where it seems like the UI for the game stops recognizes clicks on buildings and such after a vessel burns up on reentry and you click on "return to space center". Afterwards, the only button that seems to still work is "quit" and when you return to the main menu, all controls are frozen as well.

Anyone else encountering this? I am trying to figure out if it's a local issue, a known vanilla bug, or something to do with DR.

this happens randomly even with no mods.

Share this post


Link to post
Share on other sites
this happens randomly even with no mods.

Strange. I can replicate it 100% of the time burning up on reentry and have run repeated tests to make sure that's the source, whereas vessel destruction from other causes doesn't seem to trigger it.

Share this post


Link to post
Share on other sites
Strange. I can replicate it 100% of the time burning up on reentry and have run repeated tests to make sure that's the source, whereas vessel destruction from other causes doesn't seem to trigger it.

I can replicate it 100% as well but I have also seen it happen with and without DRE ( haven't done a full stock game since .17 but I noticed this bug started in 0.21).

Share this post


Link to post
Share on other sites
I can replicate it 100% as well but I have also seen it happen with and without DRE ( haven't done a full stock game since .17 but I noticed this bug started in 0.21).

Nathan confirmed this as a bug in another thread (or perhaps an earlier page). Happens when the ship explodes and sometimes if it burns up. Best solution I've found is to Quick load (F9) to a quick save.. oh and don't forget to F5 frequently ;)

Share this post


Link to post
Share on other sites

what's a good setting for real solar system? I got the heat at 20 right now and i still can't reenter a 1 man pod with heat shield

Share this post


Link to post
Share on other sites
what's a good setting for real solar system? I got the heat at 20 right now and i still can't reenter a 1 man pod with heat shield

Use the default settings. Remember that your periapsis needs to be at 70, when you start to enter the atmosphere pay attention to your vertical airspeed. You can see the dial in the cockpit view. if it goes below -100 you will burn up. Use your pods RCS to rotate it so the weighted side points in a direction that gives it lift. But not too much lift or you will bounce back out. Try to stay above 50,000 meters as long as possible. You should be below 4000m/s before you can go lower than that. once under 4000m/s rotate your pod continuously and evenly so that the upward lift cancels out with the downward lift. This will give you a ballistic reentry which should now be survivable as long as your Head shield still has some ablative material left. pop your drogue at 7000 meters then cut it when your speed is under 250m/s and open your main parachute.

Edited by Zander

Share this post


Link to post
Share on other sites

ah i see... so I just suck then...

thanks

just for reference, what kind of speeds can the shield take? And what kind of temperature does it

Share this post


Link to post
Share on other sites

First post due to the awesomeness of this mod + life sized Kerbin.

I am totally loving this mod, amazing work Nathan, this plus life sized Kerbin makes the game even more amazing.

I have a problem. My Mk1 pod is literally useless without a heat-shield being added to it and adding in a second heat-shield (so a heat-shield on top of the built in heat-shield) barely worked for me in spite of doing a proper re-entry. At LKO with a 300km ap re-entry to a 25km pe. Velocity was 6km/s at atmosphere interface. The ablative heat-shield reached a max of 925c then at 2.8km/s my ablation resource went from about 220 to nothing in about 6 seconds and exploded. The built in heat-shield for the pod lasted about a second and is useless for me.

I have made one successful re-entry but my ablative resource had reached zero and it was just luck that my temps had dropped to sub 520 c that allowed Jeb to survive.

I don't want it easy :) I would just like to know what settings I should have so that when I do a correct re-entry I can actually survive it.

There are several conflicting things said in this thread or not stated as to whether the settings listed are for stock or life sized so please, please, please, please, please, can you post all the settings needed for life sized Kerbin, either in a single post stating these are for life sized or add them to your post on the first page. So we can see what .cfg settings we should be using on the Mk1 Pod and the 1.25m heat-shield for the life sized Kerbin version.

Thank you in advance and amazing work buddy :)

Share this post


Link to post
Share on other sites

Shouldn't the ablative resource deplete during the fiery part of the re-entry and then stop when it is merely being heated?

As far as I understand it, that's the point of the shield being ablative, ie: as the shield is ablated it reduces the heat due to the shield being, boiled, burnt away plus the localized Leidenfrost effect of the cushion of superheated air in front of the shield?

Is there any plans for more spectacular re-entry effects? I definitely feel something is missing as the effect looks the same (only slightly more intense) no matter what speed the craft is travelling at once the effects are happening. Shouldn't one expect smoke and flames plus a huge contrail similar to what happens during launch?

Keep up the good work man!!

Share this post


Link to post
Share on other sites

pretty sure if you're going in at 25km pe you're dead...

after they pointed out these things, I tried a couple of reentries at about 60+ Pe and some reentries that involves "bouncing" out of atmos and coming back

all 1.25m pods with 2 parachutes and 1 heat shield, they survived

just try a higher Pe I suppose

I don't want it easy I would just like to know what settings I should have so that when I do a correct re-entry I can actually survive it.

stock settings, it's doable! :)

Share this post


Link to post
Share on other sites

Hey gunny.

Either I didn't explain myself properly or you didn't read my post properly, probably the first :)

  • Stock settings are for stock Kerbin as far as I am aware, not the life-sized Kerbin. What do need to modify them to for life-sized Kerbin (as Nathan in an earlier post pointed out we needed to do)

  • My angle is fine, my heat is fine, my material ablates not when it is under re-entry heat but afterwards. It slowly ablates during the actual fiery part as one would expect but it totally depletes when the shield has cooled down by 400 C. This can't be right?

  • The Mk1 pod with built in heat-shield does not work at all, period. Like literally lasts one second.

That is why I wanted to get a complete list of settings in one post to make sure all my settings are right :)

Either way, this mod + life size is frickin' awesome as hell!

Kass

Edited by Kass

Share this post


Link to post
Share on other sites

for me i always come in at a 20-30km area for reentry and all sheilds seem to work fine. Kass u sure your settings are right? so far everything has worked fine for me. to lose all of the sheilding suddenly cant think of anything but either gforce issue or MM is messing up.

btw nathan could u put out some configs u recommend say for hard game,the realo kerbin, and such. i suck at tryign to get the values i want and btw anyone found good settings for the rescale kerbin yet.

Share this post


Link to post
Share on other sites
for me i always come in at a 20-30km area for reentry and all sheilds seem to work fine. Kass u sure your settings are right? so far everything has worked fine for me. to lose all of the sheilding suddenly cant think of anything but either gforce issue or MM is messing up.

btw nathan could u put out some configs u recommend say for hard game,the realo kerbin, and such. i suck at tryign to get the values i want and btw anyone found good settings for the rescale kerbin yet.

Yeah weird huh?

That's what I'm asking for. So I can compare and see wtf is going on :)

Share this post


Link to post
Share on other sites

which sheild is it thats doing it maybe its getting wrong value or something?

Share this post


Link to post
Share on other sites

Doing re-entry right now. I've got a save game and just doing it over and over until it wants to play ball.

Coming in with a Command Pod Mk 1 > Heat-Shield 1.25m. Starting from a delta v of 5.8km/s, 120km ap to 70km pe although obviously these start to drop on atmospheric interface.

I think I might be able to control my rate of descent to enable myself to stay above 50km until I'm slow enough as per Sanders post #184. However, I've mucked it up a couple of times and each time my 1.25m heatshield blows, the one built into the Command Pod Mk1 pops about 1 second later.

I thought the idea was that I didn't need a heat-shield for that pod as it has a built in one yet so far, every-time I've done this, it has been useless? :(

Share this post


Link to post
Share on other sites

Bloody exciting doing this though!!!

Combined with the FScience mod, meaning that you can transfer science results to a command pod giving real meaning to getting back down. Always seemed a bit dodgy having to bring back the whole science apparatus to get 100% science unless it was some kind of surface sample.

For example I now have science Jr., mystery goo, an eva report and crew report all stored in my command pod, so I better get them back down ok :)

Share this post


Link to post
Share on other sites

hopely he can get some of those old heatshields and get a chance to add them to this for more variry ofheat sheilds.

just noticed why is my geforce set to 30000 shouldnt it be 30 or so like that?

Edited by sidfu

Share this post


Link to post
Share on other sites

naw... at no point did I mean the build in shield (didn't even know it had a built in shield until now...)

still, stock settings (25 heat multiplyer) with 2 stage reentry (bounce out, etc) works ok here

Share this post


Link to post
Share on other sites

@Nathan While trying to see if I could figure out what was causing the frozen interface issue when a rocket blows up due to overheating (it's getting rather tiresome as I run repeated tests to balance values), I dug into the DR code a bit and noticed this:

                    if (damage >= 1.0f && !dead)
{
dead = true;
FlightLogger.eventLog.Add("[" + FormatTime(vessel.missionTime) + "] "
+ part.partInfo.title + " exceeded g-force tolerance.");
part.explode();
}

You'll notice that unlike the overheating code, it doesn't bomb out of the function after the call to explode, and then potentially goes on to process g-force effects on any contained crew.

Not sure if it's directly related to the interface freezing effect, but I thought I should point it out as I suspect it could result in now invalid data in an exploded part being processed further, which likely isn't a good thing ;)

Edited by FlowerChild

Share this post


Link to post
Share on other sites

ive had this issue to today moment ship blue up couldnt select any building or anything.

Share this post


Link to post
Share on other sites

Flowerchild: That shouldn't actually make a difference regarding the clicking bug, because that happens on part.explode() (and happens when you die of heat, not just Gs). But you're right that for cleanness I should stop there, though the next section will only ever run that one time and won't do anything since the crew is already dead.

Now, regarding configuring DRE and reentries.

Here are the config options, basically:

1. Playing on Stock Kerbin, want traditional DRE functionality: don't change anything

2. Playing on Stock Kerbin, want realisitc levels of heat on reentry (i.e. faking an 8km/sec reentry): set the shockwave exponent and multiplier to taste; I suggest exponent 1.15 to start.

3. Playing on Real-scale Kerbin, want stock-Kerbin-level reentry heat: set _heat_ multiplier to 12 or so.

4. Playing on Real-scale Kerbin, want realistic heating. Change nothing in DRE settings.

Again, to reiterate: DO NOT CHANGE ANY SETTINGS if you are using rescaled Kerbin and want realistic heating.

In case 2 and case 4, you will also have to use modified heat shields. I will release an addon pack soon. For now, for each heat shield part.cfg, and for all heatshield entries in the DeadlyReentry folder's CFGs (DeadlyReentry, DR_HOME, and DR_B9), replace the second key = line in dissipation {} with 800 and 7xOriginal.

Example: Mk1 pod shield in DeadlyReentry.cfg has this:


key = 500 180 // maximum dissipation at 500 degrees C

replace with


key = 800 1260

Note that the Mk1 pod does have a built-in heat shield. You can tell because when you mouseover the part in the VAB part selector window, it says "Heat shield (directional)"

The Mk1-2 Pod, however, does not. You will have to add a 2.5m heat shield.

sidfu: what do you mean by geforce? There are like six crewG settings. (also, geforce is a brand of Nvidia graphics cards. I think you mean G force)

Regarding reentry approaches: First, use FAR. Second, try for a periapsis that will provide you with a maximum of 9Gs reentry decel. You don't want much less than that or you'll be heating too long; you don't want any more than that or your crew will die.

Note that it will differ per craft since with FAR your drag will differ per craft.

When I was using Realscale Gemini (whose heatshield is configured correctly for real-scale Kerbin) coming in from ~350km, I used a 9km periapsis. That gave me a hair over 9G decel for a few seconds, sustained peak around 8Gs. I ran out of heatshield just as I went under mach 2.

I mean, you could try with a very high Pe (like 80km), but my guess is you'll burn up, unless your heatshield is very good.

Share this post


Link to post
Share on other sites
Flowerchild: That shouldn't actually make a difference regarding the clicking bug, because that happens on part.explode() (and happens when you die of heat, not just Gs). But you're right that for cleanness I should stop there, though the next section will only ever run that one time and won't do anything since the crew is already dead.

Fair enough man. I didn't think it was necessarily related but just wanted to pass it along in case it was causing any other issues.

The clicking bug is a rather odd one, as I'm blowing up parts in my own plug-in, and it doesn't seem to cause the same UI problems. Specifically, I'm blowing up pressurized airplane cockpits when they enter vacuum, and I'm always able to return to the KSC UI without issues afterwards. Other than the above though, I couldn't find any notable differences between the way DR is doing it, and the way I am.

Edited by FlowerChild

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.