Starwaster

[1.8.1] Deadly Reentry v7.7.4 The Maat Edition, Nov 6th, 2019

Recommended Posts

thanks im still learning all the ways to do things. playing arund lets me learn alot.

Share this post


Link to post
Share on other sites

Hello everyone and ofc Nathan! Im not able to write well in english, so i try to speak shortly. My problem is in conflict DeadlyReentry 7.0-7.2.0 with Ferram Aerospace (im sure), for 1.0.4. When i try to play with both mods my control surfaces havent lift power, but they can turning (with DR 7.0.2). When i try FAR with DR 7.0 and 7.1.0, my game start lagging like 5-6 fps (but control surfaces still can turning, and provides lift). After many hours spends on tests i found problem in ModularFlightIntegrator. So i delete this folder and try play in game. This time i havent lagging, all was clear. But CS (control surfaces) stop turning. So what i trying to say about all this: 1) FAR with DR 7.0 and 7.1.0=i have 5-6 fps with works cs. 2) 1 without MFI=45-50 fps with doesnt turning cs. 3)FAR with DR 7.2.0=cs can turn but havent lift. 4) 3 without MFI=cs can't turn.

PLEASE solve this problem or give me an advise.

Share this post


Link to post
Share on other sites
Hello everyone and ofc Nathan! Im not able to write well in english, so i try to speak shortly. My problem is in conflict DeadlyReentry 7.0-7.2.0 with Ferram Aerospace (im sure), for 1.0.4. When i try to play with both mods my control surfaces havent lift power, but they can turning (with DR 7.0.2). When i try FAR with DR 7.0 and 7.1.0, my game start lagging like 5-6 fps (but control surfaces still can turning, and provides lift). After many hours spends on tests i found problem in ModularFlightIntegrator. So i delete this folder and try play in game. This time i havent lagging, all was clear. But CS (control surfaces) stop turning. So what i trying to say about all this: 1) FAR with DR 7.0 and 7.1.0=i have 5-6 fps with works cs. 2) 1 without MFI=45-50 fps with doesnt turning cs. 3)FAR with DR 7.2.0=cs can turn but havent lift. 4) 3 without MFI=cs can't turn.

PLEASE solve this problem or give me an advise.

Yes, there is a known conflict between the version of MFI used in Deadly Reentry v7.2.0 and Ferram Aerospace Research v0.15.3.1. The solution is to download and use Deadly Reentry version 7.2.1, which does not use MFI. You should be safe to use the version of MFI which comes with FAR.

Share this post


Link to post
Share on other sites
Hello everyone and ofc Nathan! Im not able to write well in english, so i try to speak shortly. My problem is in conflict DeadlyReentry 7.0-7.2.0 with Ferram Aerospace (im sure), for 1.0.4. When i try to play with both mods my control surfaces havent lift power, but they can turning (with DR 7.0.2). When i try FAR with DR 7.0 and 7.1.0, my game start lagging like 5-6 fps (but control surfaces still can turning, and provides lift). After many hours spends on tests i found problem in ModularFlightIntegrator. So i delete this folder and try play in game. This time i havent lagging, all was clear. But CS (control surfaces) stop turning. So what i trying to say about all this: 1) FAR with DR 7.0 and 7.1.0=i have 5-6 fps with works cs. 2) 1 without MFI=45-50 fps with doesnt turning cs. 3)FAR with DR 7.2.0=cs can turn but havent lift. 4) 3 without MFI=cs can't turn.

PLEASE solve this problem or give me an advise.

latest version of Deadly Reentry is actually 7.2.1 and has had all traces of Modular Flight Integrator removed for the foreseeable future.

Make sure you have the latest version by downloading from here: https://github.com/Starwaster/DeadlyReentry/releases/latest

As for FAR, Modular Flight Integrator is a MUST. You MUST have it. I suggest reinstalling FAR. Do not remove Modular Flight Integrator. If you suspect a problem then report it. Preferably to Ferram or to Sarbian but I can take a look at it too and work with Sarbian if there is an issue.

Most likely though is that the last copy of DRE had a bad compile of MFI, so use the one that comes with FAR. (hence why I recommend re-installation)

Share this post


Link to post
Share on other sites
Most likely though is that the last copy of DRE had a bad compile of MFI, so use the one that comes with FAR. (hence why I recommend re-installation)

Wasn't there something about MFI 1.1 not being backwards compatible for mods expecting 1.0, thus leading to the release of 1.1.1, which is supposed to be backwards compatible?

Share this post


Link to post
Share on other sites
Wasn't there something about MFI 1.1 not being backwards compatible for mods expecting 1.0, thus leading to the release of 1.1.1, which is supposed to be backwards compatible?

And I was still on MFI 1.1.0 as I was pushing towards DRE release. I think 1.1.1 came out in that hour. Rather than push things back further for something that DRE wasn't using at the time I just removed it until I get to a point where I'll need it again.

Share this post


Link to post
Share on other sites
latest version of Deadly Reentry is actually 7.2.1 and has had all traces of Modular Flight Integrator removed for the foreseeable future.

Make sure you have the latest version by downloading from here: https://github.com/Starwaster/DeadlyReentry/releases/latest

As for FAR, Modular Flight Integrator is a MUST. You MUST have it. I suggest reinstalling FAR. Do not remove Modular Flight Integrator. If you suspect a problem then report it. Preferably to Ferram or to Sarbian but I can take a look at it too and work with Sarbian if there is an issue.

Most likely though is that the last copy of DRE had a bad compile of MFI, so use the one that comes with FAR. (hence why I recommend re-installation)

Okay, thats is real solution of my problem! Thank you Very Very much, Starwaster. I can't playing without some mods, including your.

Share this post


Link to post
Share on other sites

Can you help me please? What slider need to change for more reentry heating? Stock DR, even with 120% difficulty, cant satisfied me!

Share this post


Link to post
Share on other sites
Can you help me please? What slider need to change for more reentry heating? Stock DR, even with 120% difficulty, cant satisfied me!

reduce conductivity to 1. That will cause heat to build up instead of spreading around your ship

Share this post


Link to post
Share on other sites
Those are the ones you specified and a few extra.
Muchos gracias! And thank You for keeping DRE alive.

If per chance You also can put together similar short list of what ModuleConductionMultiplier & ModuleAblator (and its counterparts) tunables do, that would be superb.

Share this post


Link to post
Share on other sites
reduce conductivity to 1. That will cause heat to build up instead of spreading around your ship

Well its not really helped me. I found myself settings - all sliders in 'thermal' double x1.5.

Share this post


Link to post
Share on other sites

I have KSP 1.0.2 installed (judging from posts around the net, I'm rather nervous upgrading to 1.0.4) and am using Deadly Reentry 7.2.1. Reentry "starts" (flames and drag) begin at about 30 km, whereas in DRE 7.2.0, the effects began at around 50 km. Is this an issue, because entry interface is behaving like what I recollect from the stock game, and I like my reentry beginning around 50 km (makes for a much longer and more thrilling ride to landing). Thank you, Starwasher, for making such an amazing mod, and I await your response!

Share this post


Link to post
Share on other sites
Well its not really helped me. I found myself settings - all sliders in 'thermal' double x1.5.

It might be the case that there's nothing I can do to make things satisfactorily difficult for you.

Regarding difficulty, one fact of the situation is that if you do everything right then you should survive. If you make mistakes you die.

No matter how hot I make it, nothing changes that. A hotter reentry isn't really more difficult. At the end of the day it boils down to 'do it right and live' or 'do it wrong and die'

I have KSP 1.0.2 installed (judging from posts around the net, I'm rather nervous upgrading to 1.0.4) and am using Deadly Reentry 7.2.1. Reentry "starts" (flames and drag) begin at about 30 km, whereas in DRE 7.2.0, the effects began at around 50 km. Is this an issue, because entry interface is behaving like what I recollect from the stock game, and I like my reentry beginning around 50 km (makes for a much longer and more thrilling ride to landing). Thank you, Starwasher, for making such an amazing mod, and I await your response!

Actual heating starts even before the fiery FX. I'm not sure what you can do in 1.0.2 to alter FX to make them start earlier; it's my understanding that it's limited in that regard. It's supposed to be easier to deal with in 1.0.4 but at present I have yet to look into it.

Also, I'll relay your thanks to this 'Starwasher' person. If I ever find him.

Share this post


Link to post
Share on other sites
Actual heating starts even before the fiery FX. I'm not sure what you can do in 1.0.2 to alter FX to make them start earlier; it's my understanding that it's limited in that regard. It's supposed to be easier to deal with in 1.0.4 but at present I have yet to look into it.

Also, I'll relay your thanks to this 'Starwasher' person. If I ever find him.

Hmm... I wonder why "reentry" started for me around 50 km, then. Oh well, as long it isn't a problem, I'm a happy camper. Perhaps it was FAR and DRE socializing that made reentry effects begin at 50km?

And in regards to my blatant blindness, my apologies, good sir. In my defense, I wear glasses, so... yeah.

Share this post


Link to post
Share on other sites
I have KSP 1.0.2 installed (judging from posts around the net, I'm rather nervous upgrading to 1.0.4) and am using Deadly Reentry 7.2.1. Reentry "starts" (flames and drag) begin at about 30 km, whereas in DRE 7.2.0, the effects began at around 50 km. Is this an issue, because entry interface is behaving like what I recollect from the stock game, and I like my reentry beginning around 50 km (makes for a much longer and more thrilling ride to landing). Thank you, Starwasher, for making such an amazing mod, and I await your response!

I was eating before so I didn't pay enough attention to realize the significance of those numbers.

7.2.x is really not a good fit for 1.0.2 and shouldn't even be allowed to run with it.

The reason is that DRE 7.1.x implemented features to make things properly blazingly hot. ('skin' heating, which separates part temperatures into external/internal)

KSP 1.0.3 now uses those same features so

DRE 7.2.0 had those features removed since they are now stock. The latest version tweaks part configs to adjust things like max temps (both internal and external), various conductivity values, etc. But it really needs the skin mechanics to make things properly dangerous.

So you should definitely either upgrade KSP to 1.0.4 or downgrade Deadly Reentry to 7.1

Share this post


Link to post
Share on other sites
So you should definitely either upgrade KSP to 1.0.4 or downgrade Deadly Reentry to 7.1

Alrighty, then. I suppose I shall have to upgrade; thank you, Starwaster:D.

Share this post


Link to post
Share on other sites

Is there some trick to getting DRE to work with RSS and FAR? I can't get a pod through the atmosphere at all. I've run with as many as 3 shields and they still all blow up. The first one is almost spent by the time I get through the first 10km of atmosphere.

Share this post


Link to post
Share on other sites
Is there some trick to getting DRE to work with RSS and FAR? I can't get a pod through the atmosphere at all. I've run with as many as 3 shields and they still all blow up. The first one is almost spent by the time I get through the first 10km of atmosphere.

I'll have to look into it. I have yet to do much with RSS since 1.0.4 but likely the shields need RSS specific configuration.

Have you tried Realism Overhaul? There should be some shields rated for RSS in it.

Share this post


Link to post
Share on other sites

RSS itself now alters physics on FIRST, so if DRE then alters them they'll be back to "making 2000m/s feel like 7000m/s" physics stats. Not sure how best to proceed, should you maybe NEEDS[!RealSolarSystem] when changing convection params?

Share this post


Link to post
Share on other sites
RSS itself now alters physics on FIRST, so if DRE then alters them they'll be back to "making 2000m/s feel like 7000m/s" physics stats. Not sure how best to proceed, should you maybe NEEDS[!RealSolarSystem] when changing convection params?

No, I'm being pretty nice to physics this time around.

I only touched one thing: conduction (cut it down to 3.33, so it's about 1/6th stock. Heat will build up in the skin that much faster instead of bleeding into the interior)

And of course, max temps, heat shields, skin things and such.

Shields... too tired to think about what I did to shields. Maybe made them too weak. I'll look at that in the morning.

Share this post


Link to post
Share on other sites
Why did you misspell maleficent? :wink:

I actually answered that in the FAQ though I might have left out the part where I mentioned that Melificent was my cat. The misspelling is deliberate and changes the meaning of the name. You can see a picture of Melificent in the game if you click the DRE icon in any scene

Share this post


Link to post
Share on other sites

Posted in Procedural parts thread but maybe someone here has an idea for a quick fix.

Seem to be having an issue where procedural fuel tanks nose cones and decouplers (possibly others haven't checked) don't have their skin temp change during re-entry. This results in them barely heating up and acting as massive heatsinks for the rest of the ship, making it very resistant to re entry heat. I'm FAR 15.4 if that could be causing the issue.

Any idea what i need to change in their part cfg to get it working again?

Share this post


Link to post
Share on other sites
Posted in Procedural parts thread but maybe someone here has an idea for a quick fix.

Seem to be having an issue where procedural fuel tanks nose cones and decouplers (possibly others haven't checked) don't have their skin temp change during re-entry. This results in them barely heating up and acting as massive heatsinks for the rest of the ship, making it very resistant to re entry heat. I'm FAR 15.4 if that could be causing the issue.

Any idea what i need to change in their part cfg to get it working again?

I'm taking a look at it but so far I don't see anything in there that should cause problems...

EDIT:

Unable to reproduce any problems with heating.

I made a stack consisting of a 5m KWR tank (mid sized one; V-15) as a control + equivalently sized procedural fuel tank, decoupler and nose cone. All of them had appropriate thermalMass / skinThermalMass for their part mass. All of them overheated and exploded almost at the same time when put through reentry. (it was much steeper than I planned to test with but I'm satisfied with the results)

I have heard of problems with FAR and calculated surface area which affects radiative area and convection which could cause parts to heat faster or slower than they should but as far as I know, that issue was fixed. Check the FAR thread, check change logs and make sure you're up to date. There's a dev version or usually is so try using that instead.

Edited by Starwaster

Share this post


Link to post
Share on other sites

Confirm what you are getting appears to be a FAR bug with not applying drag. I used hyperedit to put a tank in orbit with AP 1Mm PE 22km and it flew through that atmosphere barely altering its orbit.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.