pizzaoverhead

[1.5.X] Rover Wheel Sounds v2.3 (2016-10-24)

Recommended Posts

Was expecting a little more squeaky sound for the little wheel. As in

Was a little disappointed :P

Share this post


Link to post
Share on other sites

I'm not entirely sure about uploading this until I know it's compatible for 0.90., but I WILL comment positively on how much I LOVE the bassy humming rev the Rugged Wheels make. Makes noises like a proper truck, man... all it needs is the hydraulic "hiss pop" when it stops suddenly.

Edited by Dire_Squid

Share this post


Link to post
Share on other sites
Yes. (That's what the [0.90] in the thread title means :wink:)

Erm, yes. I didn't totally miss that. :(

Share this post


Link to post
Share on other sites

Pizzaoverhead, and anyone who's interested, I added sound effects to RoverDude's awesome packrat rover just add this to the MM config included in the download of rover wheel sounds:

@PART[PackRat_MiniWheel]

{

MODULE

{

name = WheelSounds

wheelSoundVolume = 1

wheelSoundFile = WheelSounds/Sounds/RoveMaxS1

}

}

You can use any of the sounds files you want, I just picked the one I liked.

Share this post


Link to post
Share on other sites
1.0 Compatibility?

It's kinda unusual to see requests for 0.90 compatibility and 1.0 compatibility on the same page :D

Share this post


Link to post
Share on other sites
It's kinda unusual to see requests for 0.90 compatibility and 1.0 compatibility on the same page :D

Errr yeah, this is a quite simple mod so should be easy enough. I wonder how thing simple as this hasn't been made stock yet. This and RCS, sound effects, clouds and etc.

Share this post


Link to post
Share on other sites
1.0 Compatibility?

Still going strong!

It's kinda unusual to see requests for 0.90 compatibility and 1.0 compatibility on the same page :D
Errr yeah, this is a quite simple mod so should be easy enough. I wonder how thing simple as this hasn't been made stock yet. This and RCS, sound effects, clouds and etc.

Yeah, this mod is simple enough that the only thing likely to break it is if Squad decide to re-do the physics of wheels.

the current version works for me in 1.0 :D

Thanks for the report!

Share this post


Link to post
Share on other sites
request: optional (cfg file is fine) - sound on/off in vacuum

Pizzaoverhead will you fix Atmospheric Sound Enhancement to make this a reality? :( CMON MAN. :cool:

Share this post


Link to post
Share on other sites

Thank you for this mod. Handy for driving large distances... Can put the auto pilot on and do some cleaning in my house... I can now hear if something goes wrong (mostly downhill).

Share this post


Link to post
Share on other sites

Does not seem to play nice with MechJeb Rover Speed Controls. Always wants to go max speed regardless of settings in MJ rover control window. Crashed into follow target at max speed rather than breaking gently to a stop upon arrival. MechJeb rover controls were used successfully prior to installation of Wheel Sounds mod. I love the sounds though!

Share this post


Link to post
Share on other sites

I replaced the sound of the medium rover wheel, with that of the big one.

And this is the result:

Share this post


Link to post
Share on other sites

I do like this mod, simple but does the job. KSP is so silent without all your sound mods, and the sound mods of others :-)

Only issue I've found is that if a wheel is not touching the ground, it's RPM keeps going up and up, and the sound goes up with it to silly levels, Though that's squad's fault really for not having an RPM limit on the wheels.

And not really worth fixxing it, as KSP 1.1 is redoing the wheels soon with the Vehicle Physics Pro wheel/suspension system

And is going to break this mod anyway (Please update it for 1.1 if squad have not already done a better job with the wheel sounds!)

Edited by GorillaZilla

Share this post


Link to post
Share on other sites

Hi. I've been having some exception spam in my logs when I drive a rover saying

NullReferenceException: Object reference not set to an  instance of an object
at WheelSounds.WheelSounds.OnUpdate () [0x00000] in <filename unknown>:0

at Part.ModulesOnUpdate () [0x00000] in <filename unknown>:0

at Part.Update () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Any idea why this could be?

Share this post


Link to post
Share on other sites

Using this mod, I created the first synthesizer.

And many thanks, Pizzaoverhead!

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.