Jump to content

[1.5.X] Rover Wheel Sounds v2.3 (2016-10-24)


Recommended Posts

i needed to add this to the "ModuleManager_WheelSounds.cfg" to make the folding wheels from the DLC work:

@PART[roverWheelM1-F]
{
    MODULE
    {
        name = WheelSounds
        wheelSoundVolume = 1
        wheelSoundPitch = 0.5
        wheelSoundFile = WheelSounds/Sounds/KerbalMotionTR-2L
        skidSoundVolume = 0
        skidSoundPitch = 1
        skidSoundFile = WheelSounds/Sounds/gravelSkid
        damageSoundVolume = 1
        damageSoundFile = WheelSounds/Sounds/wheelDamage
        soundInVacuum = false
    }

 

Link to post
Share on other sites
On 3/24/2018 at 9:10 AM, MadMansGun said:

i needed to add this to the "ModuleManager_WheelSounds.cfg" to make the folding wheels from the DLC work:

@PART[roverWheelM1-F]
{
    MODULE
    {
        name = WheelSounds
        wheelSoundVolume = 1
        wheelSoundPitch = 0.5
        wheelSoundFile = WheelSounds/Sounds/KerbalMotionTR-2L
        skidSoundVolume = 0
        skidSoundPitch = 1
        skidSoundFile = WheelSounds/Sounds/gravelSkid
        damageSoundVolume = 1
        damageSoundFile = WheelSounds/Sounds/wheelDamage
        soundInVacuum = false
    }

 

Anyone who uses this, make sure to add another closing bracket } at the end of the config, or it won't work properly.

Link to post
Share on other sites
  • 3 weeks later...

Also, this worked to add sounds to the new wheels for the Grounded mod:

Just a stupid/quick hack to apply the sounds to the 3 new wheels in that mod. I made no tweaks to differentiate between the wheel sizes (they're mostly just slight variations in tire size) Place in the Wheel Sounds cfg, or a new one anywhere else. :wink:

@PART[wheelReg]
{
	MODULE
	{
		name = WheelSounds
		wheelSoundVolume = 1
		wheelSoundPitch = 0.5
		wheelSoundFile = WheelSounds/Sounds/KerbalMotionTR-2L
		skidSoundVolume = 0
		skidSoundPitch = 1
		skidSoundFile = WheelSounds/Sounds/gravelSkid
		damageSoundVolume = 1
		damageSoundFile = WheelSounds/Sounds/wheelDamage
		soundInVacuum = false
	}
}

@PART[wheelReg2]
{
	MODULE
	{
		name = WheelSounds
		wheelSoundVolume = 1
		wheelSoundPitch = 0.5
		wheelSoundFile = WheelSounds/Sounds/KerbalMotionTR-2L
		skidSoundVolume = 0
		skidSoundPitch = 1
		skidSoundFile = WheelSounds/Sounds/gravelSkid
		damageSoundVolume = 1
		damageSoundFile = WheelSounds/Sounds/wheelDamage
		soundInVacuum = false
	}
}

@PART[wheelReg3]
{
	MODULE
	{
		name = WheelSounds
		wheelSoundVolume = 1
		wheelSoundPitch = 0.5
		wheelSoundFile = WheelSounds/Sounds/KerbalMotionTR-2L
		skidSoundVolume = 0
		skidSoundPitch = 1
		skidSoundFile = WheelSounds/Sounds/gravelSkid
		damageSoundVolume = 1
		damageSoundFile = WheelSounds/Sounds/wheelDamage
		soundInVacuum = false
	}
}

Enjoy!

Link to post
Share on other sites
3 minutes ago, JH4C said:

If anyone wants to add the rover wheels from SXT, the part name is TGWheel. I just duplicated the TR-2L settings and it seems to be working fine.

Groovy. Any more of these, and I'll suggest we fire up a mini mod of added wheels. Custom tweaking the audio and settings to make everything unique would be a whole 'nother ballgame :)

Link to post
Share on other sites
  • 5 months later...

AMAZING mod!  Still works great in 1.4 for me...

Driving was so lifeless without the motor sounds and scrabbley noise when you skid...    Really breathed new life into the game for me and my nephew as we drive vehicles a lot messing around with cranes and stuff.   Thankyou Pizza, bought you some coffee!

Now if only Collision FX worked in 1.4 too,  that was my other Go too mod to compliment wheel sounds :-)

Edited by GorillaZilla
Link to post
Share on other sites
24 minutes ago, JH4C said:

Thread title implies this has been recompiled for 1.5.x but neither of the provided "active" download links work; Curse denies the page exists, and GitHub hasn't been updated in a couple of years. @pizzaoverhead you may need to update the OP with new links.

CKAN seems to be pointing here: https://github.com/pizzaoverhead/WheelSounds

Which is the "current" version. I think the 1.5 was added to the topic title since it does seem to work fine in 1.5*. 

It's only tagged to work with 1.2, so your eyes aren't deceiving you. ;)

Edited by Beetlecat
Link to post
Share on other sites
  • 6 months later...

i know..i know..this mod isnt updated to 1.7...but..I did get an exception and I think its from this mod. Doesnt seem to cause much problems...just thought id mention it.

ksplog: https://1drv.ms/u/s!AjOhSRn-M-XfjwCVauuJzNadegpa

 

Spoiler

[EXC 23:00:22.357] TypeLoadException: Could not load type 'System.Runtime.Versioning.TargetFrameworkAttribute' from assembly 'WheelSounds'.
    System.MonoCustomAttrs.GetCustomAttributesBase (ICustomAttributeProvider obj, System.Type attributeType)
    System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType, Boolean inherit)
    System.Reflection.Assembly.GetCustomAttributes (System.Type attributeType, Boolean inherit)
    Kopernicus.LogAggregatorWorker.Awake ()
    UnityEngine.GameObject:AddComponent(Type)
    AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
    AddonLoader:StartAddons(Startup)
    <LoadObjects>c__Iterator1:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    <CreateDatabase>c__Iterator0:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    GameDatabase:StartLoad()
    <LoadSystems>c__Iterator0:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    LoadingScreen:Start()

 

Link to post
Share on other sites
  • 2 weeks later...

Is this mod alive?  Seems like the natural place to put sounds for the new DLC robotics parts - servos, rotors, pistons etc.  Seems like such a massive oversight not to have anything, but what else is new

Link to post
Share on other sites
On 5/18/2019 at 5:41 AM, Jesusthebird said:

i know..i know..this mod isnt updated to 1.7...but..I did get an exception and I think its from this mod. Doesnt seem to cause much problems...just thought id mention it.

ksplog: https://1drv.ms/u/s!AjOhSRn-M-XfjwCVauuJzNadegpa

 

  Hide contents

[EXC 23:00:22.357] TypeLoadException: Could not load type 'System.Runtime.Versioning.TargetFrameworkAttribute' from assembly 'WheelSounds'.
    System.MonoCustomAttrs.GetCustomAttributesBase (ICustomAttributeProvider obj, System.Type attributeType)
    System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType, Boolean inherit)
    System.Reflection.Assembly.GetCustomAttributes (System.Type attributeType, Boolean inherit)
    Kopernicus.LogAggregatorWorker.Awake ()
    UnityEngine.GameObject:AddComponent(Type)
    AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
    AddonLoader:StartAddons(Startup)
    <LoadObjects>c__Iterator1:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    <CreateDatabase>c__Iterator0:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    GameDatabase:StartLoad()
    <LoadSystems>c__Iterator0:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    LoadingScreen:Start()

 

Yep, that's this mod. It's reached the point where it needs to be recompiled to be compatible with the latest KSP versions.

On 6/1/2019 at 12:32 AM, fourfa said:

Is this mod alive?  Seems like the natural place to put sounds for the new DLC robotics parts - servos, rotors, pistons etc.  Seems like such a massive oversight not to have anything, but what else is new

It's not currently working, but nor is it entirely dead. If anyone has any suggestions for sounds to use for the new parts, I'll see if I can get them added. https://freesound.org/ is a great place to look, but I have very little time nowadays.

Link to post
Share on other sites
  • 2 weeks later...
On 5/31/2019 at 4:32 PM, fourfa said:

Is this mod alive?  Seems like the natural place to put sounds for the new DLC robotics parts - servos, rotors, pistons etc.  Seems like such a massive oversight not to have anything, but what else is new

I agree-- the very first time I used the new parts I was struck by how SILENT everything was. It's easy to feel spoiled by all these wonderful "little" mods like RWS and Chatterer. I had thought to ask the dev of Dock Rotate, since they had some really nice, subtle motor noises-- turns out they were lifted straight from IR. :)

On 6/4/2019 at 1:18 AM, pizzaoverhead said:

It's not currently working, but nor is it entirely dead. If anyone has any suggestions for sounds to use for the new parts, I'll see if I can get them added. https://freesound.org/ is a great place to look, but I have very little time nowadays.

I'm hoping Squad/bob put enough hooks on the robot parts to be able to add sounds to them easily. A quick look/listen through freesound.org could reveal some good stuff.

We've also added a few random mod-patches adding the initial RW Sounds to mods over the last few pages. I'd love to gather those into a pack of configs that could be included in this mod >:D

Edited by Beetlecat
Link to post
Share on other sites
  • 5 months later...
  • 4 weeks later...
On 11/21/2019 at 12:02 AM, DoctorDavinci said:

At the request of @PyjackMeat I have set up the project and compiled a working version of this mod

https://github.com/DoctorDavinci/WheelSounds/releases/tag/0.1.1.1

Cooked against KSP 1.8.1

WOW! Thanks for the recompile! Really missed the rover sounds, game isn't just the same without them!

Link to post
Share on other sites
On 11/20/2019 at 10:02 PM, DoctorDavinci said:

At the request of @PyjackMeat I have set up the project and compiled a working version of this mod

https://github.com/DoctorDavinci/WheelSounds/releases/tag/0.1.1.1

Cooked against KSP 1.8.1

Are you adopting it, or is this just a one-time rebuild?

Link to post
Share on other sites

I've combined all the new wheel sounds into a single file, see below

Spoiler
// Contributed by @MadMansGun
@PART[roverWheelM1-F]
{
    MODULE
    {
        name = WheelSounds
        wheelSoundVolume = 1
        wheelSoundPitch = 0.5
        wheelSoundFile = WheelSounds/Sounds/KerbalMotionTR-2L
        skidSoundVolume = 0
        skidSoundPitch = 1
        skidSoundFile = WheelSounds/Sounds/gravelSkid
        damageSoundVolume = 1
        damageSoundFile = WheelSounds/Sounds/wheelDamage
        soundInVacuum = false
    }
}

// Contributed by @Beetlecat
@PART[wheelReg]
{
	MODULE
	{
		name = WheelSounds
		wheelSoundVolume = 1
		wheelSoundPitch = 0.5
		wheelSoundFile = WheelSounds/Sounds/KerbalMotionTR-2L
		skidSoundVolume = 0
		skidSoundPitch = 1
		skidSoundFile = WheelSounds/Sounds/gravelSkid
		damageSoundVolume = 1
		damageSoundFile = WheelSounds/Sounds/wheelDamage
		soundInVacuum = false
	}
}

@PART[wheelReg2]
{
	MODULE
	{
		name = WheelSounds
		wheelSoundVolume = 1
		wheelSoundPitch = 0.5
		wheelSoundFile = WheelSounds/Sounds/KerbalMotionTR-2L
		skidSoundVolume = 0
		skidSoundPitch = 1
		skidSoundFile = WheelSounds/Sounds/gravelSkid
		damageSoundVolume = 1
		damageSoundFile = WheelSounds/Sounds/wheelDamage
		soundInVacuum = false
	}
}

@PART[wheelReg3]
{
	MODULE
	{
		name = WheelSounds
		wheelSoundVolume = 1
		wheelSoundPitch = 0.5
		wheelSoundFile = WheelSounds/Sounds/KerbalMotionTR-2L
		skidSoundVolume = 0
		skidSoundPitch = 1
		skidSoundFile = WheelSounds/Sounds/gravelSkid
		damageSoundVolume = 1
		damageSoundFile = WheelSounds/Sounds/wheelDamage
		soundInVacuum = false
	}
}

// Suggested by @JH4C, written by Linuxgurugamer
@PART[TGWheel]
{
	MODULE
	{
		name = WheelSounds
		wheelSoundVolume = 3
		wheelSoundPitch = 1
		wheelSoundFile = WheelSounds/Sounds/type2
		skidSoundVolume = 0
		skidSoundPitch = 1
		skidSoundFile = WheelSounds/Sounds/gravelSkid
		damageSoundVolume = 1
		damageSoundFile = WheelSounds/Sounds/wheelDamage
		soundInVacuum = false
	}
}

// Contributed by @canisin (2017)
@PART[*]:HAS[@MODULE[WheelSounds],[email protected][ModuleWheelMotorSteering]]:NEEDS[WheelSounds]:FINAL
{
    @MODULE[WheelSounds]
    {
        skidSoundVolume = 0.3
    }
}

@PART[*]:HAS[@MODULE[WheelSounds]]:NEEDS[WheelSounds]:FINAL
{
    @MODULE[WheelSounds]
    {
        soundInVacuum = true
    }
}

 

 

I'm looking to see if I can have this work with KSPWheel as well.  If I can, I'll be considering adopting this mod.

Silly me, I forgot that KSPWheel has it's own sounds

I'm still considering adopting it, if I do, it will get a new name to avoid conflicting with either @DoctorDavinci's version or @pizzaoverhead's version

Edited by linuxgurugamer
Link to post
Share on other sites
  • 2 months later...
  • 5 months later...
On 3/26/2018 at 4:25 PM, Azimech said:

I've made a little mod. Now stock propellers have sound.

 

Small bug report: it seems custom volume and pitch settings are being ignored in 1.4.x

Did you ever publish/release anything for these stock/BG rotors with sound?

 

[edit] apparently not -- they flew the coop ;)

Edited by Beetlecat
Link to post
Share on other sites
  • 1 month later...
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...