NathanKell

[1.2] Real Solar System v12.0 Dec 8

Recommended Posts

Having the same problem here... Kerbin is the second farthest from the sun. I just did a fresh install. Weird.

Also having this issue, Kerbin furthest out, Noted that several planets still have moons that they shouldn't:

http://imgur.com/a/ly9tX

Compilation of unchanged worlds:

Duna

Ike

Dres

Jool

Laythe

Vall

Tylo

Pol

Bop

Eeloo

Minmus

Gilly

Output log is uploaded to mega:

https://mega.co.nz/#!Uh1iSJQT!vsAenWGK-NF2If3rtNpKeTKeqlAlxnxWVgFTvlR8kdo

Edit:

Removing 'bonus planets' install didn't help, nor did re-installing from a fresh RSS download. Still seeing the same issues.

Mods in use:

Toolbar

AJE

CrossFeedEnabler

CustomBiomes

DeadlyReentry

Dmagic Orbital Science

EngineIgnitor

FerramAerospaceResearch

KAS

KerbalJointReinforcement

MechJeb

ModuleRCSFX

HotRockets

NavyFish Docking

PartCatalog

Procedural Wings

Procedural Fairings

Procedural Parts

RCS Build Aid

RealChute

Real Fuels

Realism Overhaul

Real Solar System

RemoteTech

TAC Fuel Balancer

TACLSS

TweakScale

Universal Storage

Edited by Felger
More Info

Share this post


Link to post
Share on other sites

Thanks to you actually providing logs, I can tell you you're out of VRAM. Even if you're not out of process RAM, you ran out of RAM on your graphics card. You'll need to use lower-resolution textures for the planets, and maybe remove some part packs (not that there's much to remove) or use a higher level of ATM.

Share this post


Link to post
Share on other sites
Thanks to you actually providing logs, I can tell you you're out of VRAM. Even if you're not out of process RAM, you ran out of RAM on your graphics card. You'll need to use lower-resolution textures for the planets, and maybe remove some part packs (not that there's much to remove) or use a higher level of ATM.

......

whut?

Someone provided logs?

Share this post


Link to post
Share on other sites

Why is the sun so small in RSS, as compared to the real life sun?

jdX2aQq.jpg

1280px-STS-129_Zvezda_sunrise.jpg

Is it not scaled properly in game?

Share this post


Link to post
Share on other sites
Thanks to you actually providing logs, I can tell you you're out of VRAM. Even if you're not out of process RAM, you ran out of RAM on your graphics card. You'll need to use lower-resolution textures for the planets, and maybe remove some part packs (not that there's much to remove) or use a higher level of ATM.

The odd thing is that prior to 0.25 I was running RSS + Realism Overhaul + a host of other mods, using the 8k textures as well as eve and never saw this behavior. When I get a chance I'll try a lower resolution planet texture set.

On the bright side, this gives me an excuse to upgrade my video card!

Share this post


Link to post
Share on other sites

Yes. .25 *does* take up a good bit more memory--think of all the new assets Squad added (new kerbals, new building, new building interior, GUI art, etc).

I have not edited the sun's flare effect. As I understand it, you can replace it in one of the assets packs.

Share this post


Link to post
Share on other sites

I'm not asking about the flare, I'd like to know if the sun is scaled up to match the real size like the rest of the planets. Because it doesn't look like it is.

Share this post


Link to post
Share on other sites
I'm not asking about the flare, I'd like to know if the sun is scaled up to match the real size like the rest of the planets. Because it doesn't look like it is.

Speaking as a photographer, it looks right to me. The sun and moon are tiny in the sky (and both are the same visual size from Earth). Try to take a picture of the moon with a regular camera and you'll be shocked by just how little it is. :)

Share this post


Link to post
Share on other sites

Quick question because I haven't played the game really since .23 so it's been a while, but what's the key combo to bring up the RSS config menu to tweak the sky colors in-game? Took a quick look at the FAQ and readme and didn't see it noted anywhere.

Share this post


Link to post
Share on other sites

Hi Nathan,

Got another question:

Have you been able to change the in game clock so it shows 24 hour days 365day years? If so how did you do it? I'd like to change the year to match the 64k year (I'm going with 6 hour days so no change there).

Thanks in advance!

Share this post


Link to post
Share on other sites

KSP has that setting in its own settings menu, but the choices are hard-coded to to be either the Kerbin default, or 24h day, 365 day year. If you want a custom display it has to be coded itself (as a separate window), or try to overwrite on LateUpdate every time a time/date is written anywhere.

Share this post


Link to post
Share on other sites
Yes. .25 *does* take up a good bit more memory--think of all the new assets Squad added (new kerbals, new building, new building interior, GUI art, etc).

I have not edited the sun's flare effect. As I understand it, you can replace it in one of the assets packs.

An update on the misconfig on planet orbits. Switching to the lower resolution planet textures seems to have done it, however, in troubleshooting it I've run across a funny (for context, I have 2GB of VRAM, with 2 more shared from system RAM)

With full resolution (8192x4096) planet textures I have the oddly placed bodies (Minmus orbiting Kerbin, etc). However, I only seem to be using ~740MB of VRAM. (Screenshots: http://i.imgur.com/UieIhPf.png & http://i.imgur.com/sGzuVOv.png)

With the low(ish) resolution (2048x1024) planet textures all the planets are in their proper location, and I'm using about half the VRAM, ~350-420 MB of VRAM (Screenshots: http://i.imgur.com/LN4VWNj.png & http://i.imgur.com/pTZBILc.png)

Probably not necessary, but I uploaded a second output log for the 'fixed' setup here

Checking at 4096 it still seems to load all the planets correctly, using ~635MB VRAM.

So I'm left with a conundrum, the ultra-high textures don't seem to be using anywhere near all of my VRAM (Not even half the available VRAM), and yet the Output_Log.txt claims to be running out of VRAM (Verified myself on this go-round to make sure signature was still the same).

The 4096 and 2048 seem to run just fine, no entries on VRAM except to state that I have ~1999MB of VRAM available.

I'm happy to run with the lower textures, but I'm curious if there's anything I can do to fix this?

Share this post


Link to post
Share on other sites
KSP has that setting in its own settings menu, but the choices are hard-coded to to be either the Kerbin default, or 24h day, 365 day year. If you want a custom display it has to be coded itself (as a separate window), or try to overwrite on LateUpdate every time a time/date is written anywhere.

Thanks, guess I'll stick with Kerbin default.

Share this post


Link to post
Share on other sites

Sorry, I really have no idea about unity <-> video card interaction :\

All I can suggest is try replacing the 8192 textures *one at a time*, starting with the planet you visit the least, with the 4096s.

Share this post


Link to post
Share on other sites
Sorry, I really have no idea about unity <-> video card interaction :\

All I can suggest is try replacing the 8192 textures *one at a time*, starting with the planet you visit the least, with the 4096s.

One final update on the issue: Forcing OpenGL seems to have solved it. (set the launch option on the shortcut to something like "D:\Games\Kerbal Space Program RSS 25\KSP.exe" -force-opengl), for whatever reason it allowed me to load the 8192 textures, my VRAM is now at 1525MB in use so it seems that the odd limitation is limited to the DirectX version.

Share this post


Link to post
Share on other sites

Changelog

v8.1

*Completely revised loading system to use coroutines, added GUI. RSS will now load at the main menu, over a period of time to allow garbage collection to run. RAM usage should no longer spike as badly. Many thanks to stupid_chris for getting me set up with coroutines, and to Sarbian for help fixing some remaining issues. While loading may take slightly longer, you should be able to use more textures/parts, and you now get a handy GUI to track status.

*Support calling textures from GameDatabase for the scaled space textures (SSColor, SSBump). This allows use combined with Sarbian's DDSLoader.

*Added FOR[] for the LaunchSites MM patch

*Updated to Custom Biomes 1.6.7

Share this post


Link to post
Share on other sites

congrats on release nate!

Edit: BTW, KSP-AVC is amazing, took me 1 minute to update lol.

Edit 2: I've been having some small problems. First, in the main menu the Earth has another texture. Second, in game on the map screen, Earth is shiny black. http://imgur.com/a/4B3Zf

Did you change the texture download thing? I installed from last version, which worked fine. I'm downloading again to test.

Edited by coldblade2000

Share this post


Link to post
Share on other sites

Can confirm, it's either highly reflective or the texture's been replaced by the skybox. Saw it with and without TextureReplacer replacing the skybox.

Redownloading the texture didn't seem to help.

Share this post


Link to post
Share on other sites

What the...

jrandom, thanks for the log!

EDIT: Can confirm. Was hidden from me before because I was using the new system. Apologies. Fixing.

Edited by NathanKell

Share this post


Link to post
Share on other sites

Oh man, this may be the stupidest thing I've ever done. I deleted the texture after I finished loading it, rather than just killing my reference to it.

8.1.1 fixes that.

EDIT: up.

v8.1.1

*Fixed stupidity where I deleted textures after loading them.

Edited by NathanKell

Share this post


Link to post
Share on other sites

Quick question. does this plugin have all the planets and their moons? I saw all the planets on the list except Neptune but i am more concerned about the moons?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.