NathanKell

[1.2] Real Solar System v12.0 Dec 8

Recommended Posts

I have updated my 1.3 patch for RSS.

 Names should now appear correct throughout the game, and with other mods.

Get it here

note: you no longer need the RSSVE patch. Just be sure to use scatterer v0.0300 for 1.2.2 as RSSVE is not updated for 1.3 yet.

Edited by Galileo

Share this post


Link to post
Share on other sites
2 hours ago, Galileo said:

I have updated my 1.3 patch for RSS.

 

Neat, very cool, and convenient.

Thank you very much for your work, I appreciate it a lot.

Share this post


Link to post
Share on other sites

Wasn't there a 3.2 - 4x something sized real solar system somewhere?

Share this post


Link to post
Share on other sites

Between Galileo's patch and the official release, is anything likely to break in a basic RSS install besides ships getting moved to different planets? (Which I know how to fix my saves for.)

Share this post


Link to post
Share on other sites
On 8/2/2017 at 1:08 PM, KerbMav said:

Wasn't there a 3.2 - 4x something sized real solar system somewhere?

There is a patch for a 2.5x Ssrss on the Ssrss thread. May have to go back a page or two.

Share this post


Link to post
Share on other sites

Hello comrades!

I've been playing KSP for around a month, and when I saw this mod on gameplays and went to check it out, it seemed amazing!

I installed the mod correctly, and put the 1.3 patch into Gamedata as the directions say. But I still come up with a message saying RSS Is incompatible with KSP v. 1.3. If somebody could tell me how to fix this issue, it would mean a lot to me~! >3<

Thanks,

-Yuri

Share this post


Link to post
Share on other sites

You need to get Kopernicus for KSP 1.3 and use that, not the Kopernicus version in the RSS download. Same for ModularFlightIntegrator and Module Manager, which are both included with Kopernicus.

Share this post


Link to post
Share on other sites

So, let me ask to clarify;

You want me to delete the Kopernicus inside the RSS Folder and replace it with the updated Copernicus, as well as ModularFlightIntergrator?

Thanks for replying though, I really appreciate it!

edit: I do have The updated Kopernicus and MFI Mods in my GameData folder and it still won't load.

Edited by Yuri_Gagarin

Share this post


Link to post
Share on other sites
16 hours ago, Yuri_Gagarin said:

But I still come up with a message saying RSS Is incompatible with KSP v. 1.3.

That is normal since RSS has not been updated for KSP 1.3. Considering that the KSP 1.2.2 version has some problems when used under KSP 1.3 (without some patching) i would really suggest to try and play using the KSP 1.2 version. Or be patient and await the next RSS version that will be compatible.

Share this post


Link to post
Share on other sites
12 hours ago, Yuri_Gagarin said:

So, let me ask to clarify;

You want me to delete the Kopernicus inside the RSS Folder and replace it with the updated Copernicus, as well as ModularFlightIntergrator?

Thanks for replying though, I really appreciate it!

edit: I do have The updated Kopernicus and MFI Mods in my GameData folder and it still won't load.

Did you download the RSS_Textures in the OP

Edited by Galileo

Share this post


Link to post
Share on other sites
On 8/6/2017 at 9:47 PM, Yuri_Gagarin said:

Hello comrades!

I've been playing KSP for around a month, and when I saw this mod on gameplays and went to check it out, it seemed amazing!

I installed the mod correctly, and put the 1.3 patch into Gamedata as the directions say. But I still come up with a message saying RSS Is incompatible with KSP v. 1.3. If somebody could tell me how to fix this issue, it would mean a lot to me~! >3<

Thanks,

-Yuri

sorry to interrupt you need RSS folder and texture folder 2k or 4k or 8k i advise 4k and the don't use Kopernicus the last version you can download it here in forum from the page of Kopernicus it lead you to download page and you need ModuleManager the last version do not use the version inside the RSS folder remove it and download the last one from the page of ModuleManager in forum and place both ModuleManager and Kopernicus inside gamedata folder and also RSS and RSS-Textures this to also inside the gamedata folder and then get patch 1.3 fix for RSS system place it inside gamedata folder 

and if you get incompatible ignore it i have the message but when i got inside the game the planet were solar system and KSP was on earth i think the problem is because the game think the version of the RSS is for KSP 1.2 not 1.3 so get to the game and then get inside the Tracking Station and see if the planet size and name are solar system not kerbol system i think you should get it working and enjoy the space the real solar system feels like the real world but its really hard. getting to other planets is really difficult a lot more delta V is require to reach other planets and i am talking about unmanned the manned mission that is different story and much harder 

good luck out there in space 

Share this post


Link to post
Share on other sites

Is it technically, legally okay for me to make a project using some/all RSS textures, but have people download the textures separately like they would to install RSS?

Share this post


Link to post
Share on other sites
54 minutes ago, Mrcarrot said:

Is it technically, legally okay for me to make a project using some/all RSS textures, but have people download the textures separately like they would to install RSS?

The licence is CC BY NC SA. I'll break it down one part at a time. CC stands for Creative Commons, the name of the group that created this licence. BY means if you use some stuff from this you have to say "this stuff was made by _____" and is referred to as atribution. NC (non-commercial) means that you cannot use stuff from this in anything related to making money. SA stands for share-alike and means that any work from this mod must always stay under the same licence. To sum it up, with the type of CC licence RSS is under, the only limitation related to using parts of it is that you can't profit from it. 

Share this post


Link to post
Share on other sites
On 8/7/2017 at 5:27 AM, Phineas Freak said:

That is normal since RSS has not been updated for KSP 1.3. Considering that the KSP 1.2.2 version has some problems when used under KSP 1.3 (without some patching) i would really suggest to try and play using the KSP 1.2 version. Or be patient and await the next RSS version that will be compatible.

I hope I'm not asking something that has been answered before, but I'm getting ready to transfer my 1.2.2 "universe" to 1.3 and there is a lot of information out there to process while "upgrading."

Is RSS for 1.3 expected to break saves? If it is I might just keep going with my old 1.2.2, then edit and cheat things back into shape when 1.3 is out, instead of going to the trouble twice.

Share this post


Link to post
Share on other sites
14 minutes ago, Mandella said:

I hope I'm not asking something that has been answered before, but I'm getting ready to transfer my 1.2.2 "universe" to 1.3 and there is a lot of information out there to process while "upgrading."

Is RSS for 1.3 expected to break saves? If it is I might just keep going with my old 1.2.2, then edit and cheat things back into shape when 1.3 is out, instead of going to the trouble twice.

Hello @Mandella,

RSS for 1.3 ***might*** break certain parts of saves. We are adding Ceres and Vesta, as well as the 5 moons of Uranus. Ships that are in orbit, or on their way somewhere might not be where you expect them to be. If you do not have things interplanetary, it should not be a problem.

Share this post


Link to post
Share on other sites
On 15.8.2017 at 6:12 PM, pap1723 said:

....We are adding Ceres and Vesta, as well as the 5 moons of Uranus...

Now that is great news. So can we expect a full 1.3 release??

Many thanks to each and all involved in keeping this lovely mod alive and even keep on improving it.

 

Share this post


Link to post
Share on other sites

I am using this with Sigma Dimensions (My own 0.64 patch, making it the same size as 6.4 scale Kerbol),@Galileo's  1.3 patch, RSSVE Lite, 1.3 Kopernicus (and dependicies),  1.3 EVE, tweakscale, Real Fuels  (with RFstock CFGS) , and assorted part mods. With the 4k textures. Everything goes fine, until I try to start or load a save. Then it just says "Loading"  Forever.   Any ideas

Share this post


Link to post
Share on other sites
3 hours ago, Holdground said:

Where do you put the 1.3 fix config file at to make it compatible again

Anywhere in your gamedata folder.

Share this post


Link to post
Share on other sites

Ok well when ever I lunch my game I get Incompatible mods detected ( these mods are incompatible with ksp 0.1.3 KerbalJoint Reinforcement, RealSolarSystem). I have put the RSS 1.3 fix in my game data folder and got the most up to date kopernicus 1.3.0-5. So needless to say RSS isn't working do you guys have any ideas. Also I don't know if this is part of it but Kopernicus is using module manager .2.8.0 and RSS has .2.7.5. In addition I'm only using the .2.7.5 due to .2.8.0 crashes my game. Pleas see attached photos for current game mod list.

Game%20data_zpszemzsoj3.jpg

Ksp%20Folder_zpsgvn5rn5t.jpg

Edited by Holdground

Share this post


Link to post
Share on other sites

First -
RSS is cool.. and SSRSS is cool too.  Even though I am been playing stock for the past couple of years, I haven't gotten bored of doing what I am doing.

I took on a small task:  Historical missions and I ran into snag, I don't know how to land on Venus.

I can survive reentry, but the pressure of Venus blew up my lander.

Suggestions ?  Can I decrease the pressure?  Is there a mod pad that had more resistant parts that might be close to Venera looking type?

Thanks. and sorry, I posted something similar is SSRSS.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.