ferram4

[1.3] Kerbal Joint Reinforcement v3.3.3 7/24/17

Recommended Posts

25 minutes ago, AdmiralSirJohn said:

Thx for the log! I didn't found anything wrong related to KJR, but noticed that the latests TweakScale withdrew itself from some parts due known (serious) problems:

[WRN 23:23:59.925] [TweakScale] Removing TweakScale support for CAIRF.
[ERR 23:23:59.925] [TweakScale] Part CAIRF didn't passed the sanity check due using FSbuoyancy module - see issue #9 https://github.com/net-lisias-ksp/TweakScale/issues/9.

I also found a lot of missing props (that thingies that we put inside cockpits):

[....]
[LOG 23:23:48.311] Cannot find InternalProp 'LifeSupportMonitor'
[LOG 23:23:48.311] Cannot find InternalProp 'ASET_RotationCtrl_V2'
[....]

You probably would want to read the Near Future Thread to find what you need to add these props to your KSP.

— — — 

Since this is not (apparently) related to KJR, may I ask you to send me such logs in private messages? So people willing to know about KJR would not be bored  reading about things unrelated! :)

Share this post


Link to post
Share on other sites

Nevermind, more testing required.

Edited by steve_v

Share this post


Link to post
Share on other sites

is there a version of KJR that works with 1.6.1 using ferrams original code I have tried following this thread but its really confusing on what your supposed to use, I would just like to keep it simple and download the original version that works for 1.6.1

Share this post


Link to post
Share on other sites
9 minutes ago, Virtualgenius said:

I would just like to keep it simple and download the original version that works for 1.6.1

There is no "original" version that works for 1.6.1. There are a couple of forks mentioned in this thread though, so I suggest you use one of those.

Share this post


Link to post
Share on other sites

Lisias' fork works well.  My problems seem to have sprung from just having too many parts on my station.

Share this post


Link to post
Share on other sites
2 hours ago, Virtualgenius said:

is there a version of KJR that works with 1.6.1 using ferrams original code I have tried following this thread but its really confusing on what your supposed to use, I would just like to keep it simple and download the original version that works for 1.6.1

@Lisias covered the two forks of KJR here, but only his has a version for 1.6.1.

 

Share this post


Link to post
Share on other sites

the dependency listed isnt optional either..he sent me a link to the latest version...lemme grab it.

https://github.com/net-lisias-ksp/KSPAPIExtensions/releases/tag/PRERELEASE%2F2.1.0.8

also, you'll need kjr itself https://forum.kerbalspaceprogram.com/index.php?/topic/50911-13-kerbal-joint-reinforcement-v333-72417/&page=98&tab=comments#comment-3513010 the link you need off this page is https://github.com/net-lisias-ksp/Kerbal-Joint-Reinforcement/releases/tag/RELEASE%2F3.4.0.4 

 

you should have KSPAPIExtensions, 000_KSPe.DLL, and kerbal joint reenforcement in your game data folder.

please copy/paste the folders themselves, not the contents of the folders.

you SHOULD have something like this in your game data folder: https://gyazo.com/39e48cf6542b195f155bb942d1ce3545 please note. again, you need these 3 in your game data folder for KJR to work: KSPAPIExtensions, 000_KSPe.DLL, and kerbal joint reenforcement

you should also have this in your PluginData folder https://gyazo.com/ce0e373efaf17bab2d38e3f7f32ce174
lisias was able to get a friend of mine, and myself up and running as a result.

Share this post


Link to post
Share on other sites
9 hours ago, Virtualgenius said:

is there a version of KJR that works with 1.6.1 using ferrams original code I have tried following this thread but its really confusing on what your supposed to use, I would just like to keep it simple and download the original version that works for 1.6.1

I'm still using wolferado's modified dll in version 1.6.1 (page 89) and it is still working fine for me. Has not failed me since I started using it in 1.5 when original didn't work anymore (and crafts started noodleing). I'm not changing this puppy until something borks. It's rock solid, just like the original.

Edited by MikeO89

Share this post


Link to post
Share on other sites
On 2/2/2019 at 5:43 PM, MikeO89 said:

I'm still using wolferado's modified dll in version 1.6.1 (page 89) and it is still working fine for me. Has not failed me since I started using it in 1.5 when original didn't work anymore (and crafts started noodleing). I'm not changing this puppy until something borks. It's rock solid, just like the original.

KSP-RO's fork fixed a glitch with some really heavy vessels losing the PRELAUNCH status while still clamped - apparently this happens when the vessel goes to rails and then back. I didn't managed to reproduced it on the Meiru's code (merged on my fork) - he revamped the Clamps code, perhaps he just got rid of the very possibility of the issue, instead of fixing it when it happens (moar testing needed! :P ).

But one thing that MeiruMeiru's code does better is that it's faster. You can build bigger vessels, or run it on potato machines, and still be playable. If you have perfromance issues on the "classic" KJR, try my fork to see what you get.

 

Edited by Lisias
bad grammars. =P

Share this post


Link to post
Share on other sites

Currently preparing a heavily modded install of 1.6.1 (+KJR/Lisias), so far mostly CKAN. And it's not looking pretty... Sigh.
Log:
https://mega.nz/#!gwASGQiS!U1gy5zRXOUYqC9MNIy8pNFuvo46AZmF5sWgL5Xtvuyo

It's completely shot, KJR has no chance of working. Don't even know where to start, so much is broken. Maybe a CKAN issue, too. Exceptions galore.
Log ends with a test vessel blowing up on launch xD
Edit: hm, why was B9_Aerospace_WingStuff in there to begin with. That's a mess. Seems to work now.

Edited by Zah

Share this post


Link to post
Share on other sites
33 minutes ago, davidy12 said:

Is there a version of this that works?

I'm happy with Lisias' version on KSP 1.6.1. Description how to install is a little bit up this page:

 

 

Share this post


Link to post
Share on other sites
4 minutes ago, AdmiralSirJohn said:

Seems like Lights Out now breaks Lisias' version of KJR.

How so? I've been using both since @linuxgurugamer released Lights Out a couple of days ago with no issues.

Share this post


Link to post
Share on other sites
1 hour ago, AdmiralSirJohn said:

Dunno, but my Ghidorah Heavy went all rubbery when it was installed, but flew just fine once I deleted it.

MISREAD THE PROBLEM. <DELETED>

About the "Seems like Lights Out now breaks Lisias' version of KJR." comment, I will investigate.

Just to be sure: you are talking about this one?

https://github.com/linuxgurugamer/LightsOut

Just checked, saw nothing that could do that by code - probably a falty DLL or unsatisfied dependency - situations that triggers an bug on the C# runtime that kills KSPe, that then kills KJR/L.

Doens't appears to be a unsatisfied dependency, as anything in the code is tied to any other DLL other than KSP's ones. But the thing was compiled to 1.6.1, so, perhaps, we have one of that situations where something changed on the newer KSP that borks older ones (as that thing on the textures loading). I will check this by night,  but until the moment, there's nothing perceptible on Lights Out that could cause this problem.

FOUND IT! Lights Out needs Toolbar Control  (it's being linked against it on the csproj file), but this dependency is not being stated on the AssemblyInfo.cs using 

[assembly: KSPAssemblyDependency("ToolbarController", 1, 0)]

as the ToolbarControl OP says to do. Ask the maintainer to fix that.

Edited by Lisias
misread things.

Share this post


Link to post
Share on other sites

That's the one, I think.  It's "Lights Out Relit" on Spacedock.

Ah, okay.  That's easily fixed.  Will report back.

Edited by AdmiralSirJohn

Share this post


Link to post
Share on other sites
11 minutes ago, AdmiralSirJohn said:

That's the one, I think.  It's "Lights Out Relit" on Spacedock.

Install Toolbar Control and see if this fixes the problem. My guess is yes, but I will be sure only by night.

Edited by Lisias
tyops, as usulla.

Share this post


Link to post
Share on other sites

Not really  a bug, since the OP and CKAN both state the need for it as a dependency.  I'll update it in a future release

Share this post


Link to post
Share on other sites

Is there a working version of Lisias KJR for 1.5.x ?

Share this post


Link to post
Share on other sites
7 hours ago, Marq said:

Is there a working version of Lisias KJR for 1.5.x ?

KJR/L is known to work from 1.3.1 to 1.6.1 . I don't do too much testing on 1.3.x and on 1.5.x, but I do it on 1.4.1 and on 1.6.1 regularly. (and I fired it up twice on 1.2.2, by the way.).

Share this post


Link to post
Share on other sites

I'm using Kerbal Joint Reinforcement so I can use an aircraft carrier, but my planes explode when they are near the aircraft carrier 

Share this post


Link to post
Share on other sites
2 hours ago, Jamiester23 said:

I'm using Kerbal Joint Reinforcement so I can use an aircraft carrier, but my planes explode when they are near the aircraft carrier 

On a blind guess, you have too parts "alive" at the same time and something is not being able to catch, leading to physics kicking in before the joints can be rewired. Reproduce the problem and publish the KSP.log so we can see who's the Screaming Victim and then can start to investigate.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.