Jump to content

[1.3] Kerbal Joint Reinforcement v3.3.3 7/24/17


Recommended Posts

35 minutes ago, Lisias said:

On a blind guess, you have too parts "alive" at the same time and something is not being able to catch, leading to physics kicking in before the joints can be rewired. Reproduce the problem and publish the KSP.log so we can see who's the Screaming Victim and then can start to investigate.

 Okay, here's the log file   https://www.dropbox.com/s/mdlszj699xpflx8/KSP.log?dl=0

Link to post
Share on other sites
29 minutes ago, Jamiester23 said:

Well, I found 000_KSPe  on your log, and also found a Exception on DLL loading:

[ERR 16:06:37.713] AssemblyLoader: Exception loading 'NextStarIndustries': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0

This corrupts somehow something on Mono's runtime, and this something kills KSPe on its very basic features, killing anything that depends on KSPe in a chain reaction. Since I didn't found any Exceptions related to KerbalJointReinforcement (that it's being loaded), I conclude that you are using that DLL recompiled by… Who's the guy? I forgot… Anyway, it's Ferram4's latest recompiled to work on 1.6. :) 

In a way or another, I think you should fix the "NextStarIndustries" problem. If KJR/L ends up being the solution for your problems, it will borks due this.

Now, about the issue under our nose, your machine is not exactly a potato, its 2.6 to 3.5GHz frequency should had be able to handle this. So I'm not sure KJR/L would help you on this.

What I found on the log, however, follows:

[LOG 16:17:07.653] [F: 21666]: R8winglet collided into EHInimitz (Nimitz) - relative velocity: 101.1924 - impact momentum: 11956300.0
[LOG 16:17:07.653] R8winglet Exploded!! - blast awesomeness: 0.1
[LOG 16:17:07.653] [R8winglet]: Deactivated
[LOG 16:17:07.669] 1 explosions created.
[WRN 16:17:08.582] [StageInfo]: Simulation Time exceeded!
[WRN 16:17:08.785] [StageInfo]: Simulation Time exceeded!

It appears that you had "heavy landed" on your wingtip. :D However, if by any reason you were still flying at range when the Nimitz got off rails, we have a hard nut to crack now.

The WRN about the simulation it's expected when a lot of parts are on the scene and things explode. Everything and the kitchen's sink starts to reevaluate the surviving assets, and this is a somewhat costly operation. When something explodes in the sequence, the evaluation restarts, and so on.

Link to post
Share on other sites
2 hours ago, Lisias said:

Well, I found 000_KSPe  on your log, and also found a Exception on DLL loading:

[ERR 16:06:37.713] AssemblyLoader: Exception loading 'NextStarIndustries': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0

This corrupts somehow something on Mono's runtime, and this something kills KSPe on its very basic features, killing anything that depends on KSPe in a chain reaction. Since I didn't found any Exceptions related to KerbalJointReinforcement (that it's being loaded), I conclude that you are using that DLL recompiled by… Who's the guy? I forgot… Anyway, it's Ferram4's latest recompiled to work on 1.6. :) 

In a way or another, I think you should fix the "NextStarIndustries" problem. If KJR/L ends up being the solution for your problems, it will borks due this.

Now, about the issue under our nose, your machine is not exactly a potato, its 2.6 to 3.5GHz frequency should had be able to handle this. So I'm not sure KJR/L would help you on this.

What I found on the log, however, follows:

[LOG 16:17:07.653] [F: 21666]: R8winglet collided into EHInimitz (Nimitz) - relative velocity: 101.1924 - impact momentum: 11956300.0
[LOG 16:17:07.653] R8winglet Exploded!! - blast awesomeness: 0.1
[LOG 16:17:07.653] [R8winglet]: Deactivated
[LOG 16:17:07.669] 1 explosions created.
[WRN 16:17:08.582] [StageInfo]: Simulation Time exceeded!
[WRN 16:17:08.785] [StageInfo]: Simulation Time exceeded!

It appears that you had "heavy landed" on your wingtip. :D However, if by any reason you were still flying at range when the Nimitz got off rails, we have a hard nut to crack now.

The WRN about the simulation it's expected when a lot of parts are on the scene and things explode. Everything and the kitchen's sink starts to reevaluate the surviving assets, and this is a somewhat costly operation. When something explodes in the sequence, the evaluation restarts, and so on.

I've just removed NextStarIndustries, so that's one problem fixed (I hope)

So should I change the DLL to another one? With the planes exploding, it happens before I touch the Nimitz 

 

Oh can you send me the .DLL file that works?

 

Edited by Jamiester23
Link to post
Share on other sites
2 hours ago, Jamiester23 said:

Oh can you send me the .DLL file that works?

Let's be conservative. Try this one first. You need to install the Ferram4's latest. Then you delete the original DLL and unzip this one overwriting files if needed.

If things didn't work out for you, publish another log, and then try this one: 
https://github.com/net-lisias-ksp/Kerbal-Joint-Reinforcement/releases/tag/RELEASE%2F3.4.0.4

 

Link to post
Share on other sites
On 3/3/2019 at 7:56 PM, Lisias said:

Let's be conservative. Try this one first. You need to install the Ferram4's latest. Then you delete the original DLL and unzip this one overwriting files if needed.

If things didn't work out for you, publish another log, and then try this one: 
https://github.com/net-lisias-ksp/Kerbal-Joint-Reinforcement/releases/tag/RELEASE%2F3.4.0.4

 

The first one didn't work here's the log https://www.dropbox.com/s/mdlszj699xpflx8/KSP.log?dl=0

I'm about to try the second one.

 

AH never mind it's the Nimitz mod/file that's the problem, I tried the ship from 'Aircraft Carrier Accessorises'   and didn't explode

Edited by Jamiester23
Link to post
Share on other sites

So what's the diffirence between ferram's and lisias' versions?

Does the latest official version work with 1.6?

Edited by Gapone
Link to post
Share on other sites
31 minutes ago, Gapone said:

So what's the diffirence between ferram's and lisias' versions?

Ferrams version is the original one. Lisias one is the recompiled one for 1.6.

32 minutes ago, Gapone said:

Does the latest official version work with 1.6?

No, and that`s the reason for Lisias recompile.

Link to post
Share on other sites
1 minute ago, Cheesecake said:

Ferrams version is the original one. Lisias one is the recompiled one for 1.6.

With additional code by Rudolf Meyer merged up, so it's not exactly the Ferram's "stock' code. :)

(on a personal note, it's better)

On page 89 (if memory serves me right), there's a recompile made by a fellow Kerbonaut (and the memory DOES NOT serves me on his name) that is the Ferram's code untouched, except by being able to run on any KSP version.

Link to post
Share on other sites
9 hours ago, Lisias said:

On page 89 (if memory serves me right), there's a recompile made by a fellow Kerbonaut (and the memory DOES NOT serves me on his name) that is the Ferram's code untouched, except by being able to run on any KSP version.

Wolderado? And why are you reworking the code where there is a functional one?

Link to post
Share on other sites
2 hours ago, Gapone said:

Wolderado? And why are you reworking the code where there is a functional one?

 

12 hours ago, Lisias said:

With additional code by Rudolf Meyer merged up, so it's not exactly the Ferram's "stock' code. :)

(on a personal note, it's better)

 

Link to post
Share on other sites
1 hour ago, Shizen said:

What is that?

Spoiler

"Rudolf Meyer" is a fellow kerbonaut that writes code and plays KSP (and sometimes, both at the same time). Code is a finite and ordered sequence of text that can be understood by a compiler, and the result is something that your computer understands in order to fulfil (or not!) a task.

"Code written by Rudolf Meyer" is when Rudolf is the one that writes the code.

"Merge" is when code written by someone else is, well, merged into another code in order to fix (or create) a problem.

"Additional code written by Rudolf Meyer merged up" is when Rudolf writes some code that then is merged together with someone's else code, and then both code fixes (or creates) problems.

:) 

Spoiler

(yeah… tough week. I needed to play a prank to get over it. :P )

 Real answer:

Spoiler
Spoiler
Spoiler

Yeah. Another prank. :)

Spoiler

Rudolf optimized and fixed some KJR performance and features, allowing it to run on slower computers or with more complex crafts.

 

 

 

 

Link to post
Share on other sites
2 minutes ago, Shizen said:

 

@Lisias Is your version on Ckan or do i have to manual install

 

Manual only. It relies on things that are not ready to the mainstream yet (KSPe), and, frankly, I'm more a code integrator than developer for this thing. I can keep it working, but pushing it further demands a lot of time that I can't spend right now. 

There are people better than me on this (KJR) that are considering taking it. Until he made his mind, I think it's better to avoid confusion on the mainstream. 

What makes KJR/L great was not written by me. :)

Link to post
Share on other sites

is it possible for me to add ModuleAnimatedDecoupler to the joints that are reinforced?  I tried adding it as decouplerStiffeningExtensionType5 (replacing the entry that was there), but it doesnt seem to work.  I am trying to prevent bouncing in the joint between the crew adapter and heatshield from the SDHI mod, and the decoupler is not a standard one (which is likely why its not already strengthened by this mod, at least in my thinking).

Link to post
Share on other sites

been trying to get the 1.6.1 test version to working but I cant decompile the package using the tools it just doesn't work any chance someone can send me a drop box of it already decompiled ready to use.

thanks 

Link to post
Share on other sites
  • 2 weeks later...
10 hours ago, Claym0re said:

Does anyone know if this works with infernal robotics in 1.5.1? The wings on my F14 are really flopping around.

only with IR next and only if my code is in the version you use... the original KJR has bugs that don't allow it to work properly with IR/IR next

but... wings attached with IR parts is always a problem and will not really be solveable in a general way (I once tried to find solutions for that, but all I found was, that I can proof that it's not possible... except adding some kind of "damper"... but that's a strange solution that might not even work and I didn't try that)...

Link to post
Share on other sites
On 12/29/2018 at 5:30 PM, Lisias said:

Download this: 
https://github.com/net-lisias-ksp/KSPAPIExtensions/releases/tag/PRERELEASE%2F2.1.0.5]

Then read this:
https://github.com/net-lisias-ksp/KSPAPIExtensions/blob/dev/INSTALL.md

 

And download this:
https://github.com/net-lisias-ksp/Kerbal-Joint-Reinforcement/releases/tag/RELEASE%2F3.4.0.4

And after, read this:
https://github.com/net-lisias-ksp/Kerbal-Joint-Reinforcement/blob/master/INSTALL.md

[NOTE: you need to download and install both add'ons (KJR/L and KSPAPIExtensions/L aka KSPe) to have a working installment. ]

  Reveal hidden contents

How you unpack things depends of the O.S you are using. Since I'm on a UNIX machine, I make heavy use of the terminal and Midnight Commander - this little devil open zip files as they were directories, allowing me to copy things as we did on the old times with Norton Commander. :) 

large.png

What Operating System are you using?

— — — POST EDIT — — — 

People on Windows could use this:
https://sourceforge.net/projects/mcwin32/

Be cautious: this is a very powerful tool - and as every powerful tool, it can be a hazard when improperly handled.

 

i did the following installation, for something hopefully close to 1.6.1 compatible KJR, but i get a horrible glitch, on loading in with a big plane with MK4 fuselage system and the fusion aerospike from KSP-IE, the whole vessel collapses, except the parts look technically connected since the fuel lines are still attached. pic:

  l0r4GI.jpg

i think this is similar too someone elses problem but im using a different set of parts than he explained in his error log

when testing, removing all KSP-IE parts still leaves the error occuring, but nothing actually disassembling.  

https://gist.github.com/fecf592398e081463d82a141ef1d7021

ksp log

@Lisias can you help? idk what mod could be disabling KSP-E (if thats what causing this behavior)

 

edit: going through my log brings me MultiAnimator failing too load, which is an essential dependacy plugin of other mods. is there just a version of KJR that doesnt use KSP api extensions? no offense, but it seems sorta fragile, like i dont remember these things being issues when i last played (a long time ago, granted, but still), and with a mod heavy set up i feel like its almost gauranteed KSP api extensions is gonna have lots of incompatabilities. 

 

EDIT 2: i found the issue! it was atillas mods, 

 this, and his hangar mod, and his AT tools, were causing issues.

maybe next you could make these mods functional with 1.6.1? :wink:

 

Edited by 123nick
Link to post
Share on other sites
5 hours ago, 123nick said:

https://gist.github.com/fecf592398e081463d82a141ef1d7021

ksp log

@Lisias can you help? idk what mod could be disabling KSP-E (if thats what causing this behavior)

The gist is truncated, it ends still on the model loading - way before the problem happening. :( 

<.....>
[LOG 16:32:50.738] Load(Model): Bluedog_DB/FX/PlumeParty/Engines/Hypergolic/VacFizzleFumeBlue
[LOG 16:32:50.741] Load(Model): Bluedog_DB/FX/PlumeParty/Engines/Hypergolic/VacFizzleFumeRed
[LOG 16:32:50.744] Load(Model): Bluedog_DB/FX/PlumeParty/Engines/Hypergolic/VacFizzleFumeYellow

BUT… I known KSPe and KJR very well to known when they borks, and by the screenshot, it appears that KJR is borking due a missing class. KSPe also does it, by the way - anything goes wrong on loading a DLL, and KSPe and everything that uses it borks relentlessly due a bug on the Mono's runtime (no workaround available to this time except to guarantee that every DLL is being loaded correctly).

ALERT: ugly error log ahead. :) 

Spoiler
[ERR 16:31:03.175] ADDON BINDER: Cannot resolve assembly: 001_AnisotropicPartResizer, Culture=neutral, PublicKeyToken=null

[ERR 16:31:03.175] ADDON BINDER: Cannot resolve assembly: 001_AnisotropicPartResizer, Culture=neutral, PublicKeyToken=null

[ERR 16:31:03.177] AssemblyLoader: Exception loading 'MultiAnimators': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.IO.FileNotFoundException: Could not load file or assembly '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null'

 System.IO.FileNotFoundException: Could not load file or assembly '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null'

 System.IO.FileNotFoundException: Could not load file or assembly '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null'

[ERR 16:31:03.232] ADDON BINDER: Cannot resolve assembly: ConfigurableContainers, Culture=neutral, PublicKeyToken=null

[ERR 16:31:03.232] ADDON BINDER: Cannot resolve assembly: ConfigurableContainers, Culture=neutral, PublicKeyToken=null

[ERR 16:31:03.233] AssemblyLoader: Exception loading 'Hangar': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'AtHangar.AsteroidMassConverter' from assembly 'Hangar, Version=3.3.4.5, Culture=neutral, PublicKeyToken=null'.

 System.IO.FileNotFoundException: Could not load file or assembly '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null'

 System.IO.FileNotFoundException: Could not load file or assembly '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null'

 System.IO.FileNotFoundException: Could not load file or assembly '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null'

 System.TypeLoadException: Could not load type 'AtHangar.HangarStorageDynamic' from assembly 'Hangar, Version=3.3.4.5, Culture=neutral, PublicKeyToken=null'.

 System.IO.FileNotFoundException: Could not load file or assembly '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null'

 System.IO.FileNotFoundException: Could not load file or assembly '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null'

 System.IO.FileNotFoundException: Could not load file or assembly '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
File name: '001_AnisotropicPartResizer, Version=1.2.0.4, Culture=neutral, PublicKeyToken=null'

 System.TypeLoadException: Could not load type '<>c' from assembly 'Hangar, Version=3.3.4.5, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<delayed_update_state>d__14' from assembly 'Hangar, Version=3.3.4.5, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'TankWindows' from assembly 'Hangar, Version=3.3.4.5, Culture=neutral, PublicKeyToken=null'.

 

001_AnisotropicPartResizer is missing, and something else needs it to run (MultiAnimators). This is the exact fault combination that is known to bork KSPe, that so borks KJR, that so borks on your vessel.

The easy solution: delete everything that is borking with an "ERR ADDON BINDER" on your KSP.log :

  • MultiAnimators
  • Hangar

The ideal solution: install correctly the Add'Ons that provides the following features:

  • 001_AnisotropicPartResizer
  • ConfigurableContainers
  • TankWindows

This last option should fix the problem I detected (instead of getting rid of the victims of the trouble!), and with a intact Mono's runtime, KSPe will work as expected, and everything that needs KSPe will work - including KJR and your vessel. :) 

Of course, new DLL erros may arise or be existent - I don't have the full log to check. But the most common errors are logged on the very beginning of the KSP Load, so I this will be probably enough. :)

Good luck!

(If anything else happens, I suggest to check the KSP.log before uploading, to be sure the whole thing is there! Copying the KSP.log with KSP still running, sometimes, leads to this problem due internal cache not being flushed - but on this case, there're too much missing to be this case… anyway, it's a useful advice). 

 

Link to post
Share on other sites

Yeah, thanks for the advice. The issues seems to have gone away after removing atillas mods, and trying it,  and i can no longer find errors about dlls failing to be loaded anymore in the log and ksp-E is working fine. I just wish these old mods would be updatable too, and compatible, so their plugins are also functional

Link to post
Share on other sites
4 minutes ago, icecold951 said:

What is the status on this in the latest 1.6+ version? I'm seeing people say it works, others with trouble. I myself find it isn't working. The game is useless without this, as struts hammer the sim rate.

I have yet to get Lisias' version to work for me.  However, the Meiru release has worked decent for me (I still have one station that's wobbly - but it's a big station)

https://github.com/linuxgurugamer/Kerbal-Joint-Reinforcement/releases/tag/3.3.3.2

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...