ferram4

[1.3] Kerbal Joint Reinforcement v3.3.3 7/24/17

Recommended Posts

Does this mod make docking ports stronger or is it just regular part connections? I'm just wondering if there's anything that makes docking stronger to get rid of the wobble without having to place struts while in orbit..

Share this post


Link to post
Share on other sites

Docking port joints are the same as any other joint. Nothing special there, and they are also affected.

Unfortunately, the size and mass of docking ports relative to what's connected to them still means that the connections are somewhat flexible.

Share this post


Link to post
Share on other sites

Hi ferram! I don't know if this has been reported for the latest version--if it has, I apologize for the repeat; I did try to Google this instance having happened before, and checked the past few pages since the latest version of KJR launched.

Just loaded the latest KJR (to be sure it was downloaded just today) into a 32bit 0.25 KSP (Steam-launched). I loaded a 838-ton ship onto the pad, with 8 launch clamps supporting. Time warped to a launch-on-rendezvous with a space station and, coming out of warp, the pad blew up. It did so after every revert-to-launch I tried.

Took off the launch clamps, and tried the timewarp again. The pad did not blow up.

Uninstalled KJR (left the other mods in place), and tried the same vehicle again, with the launch clamps. The pad did not blow up.

Here's the KSP log for when the pad blows up, if it's any help: http://s000.tinyupload.com/index.php?file_id=93355287245421764847

Hope either (a) there's a fix for this, and/or (B) you probably will find something I might have done wrong or mistakenly, in which case I will certainly heed that lesson.

Thanks! :)

Share this post


Link to post
Share on other sites

Using KSP 0.25x32 KJR 2.4.4 (and fair number of mods)

this error occurred while exiting the vessel, was stationary landed on the moon i switched between ground vessel and orbit one once (the vessel exploded kerbal survived) reloading the save fixed the problem

KeyNotFoundException: The given key was not present in the dictionary.

at System.Collections.Generic.Dictionary`2[Vessel,System.Int32].get_Item (.Vessel key) [0x00000] in <filename unknown>:0

at KerbalJointReinforcement.KerbalJointReinforcement.FixedUpdate () [0x00000] in <filename unknown>:0

and the logs

https://www.dropbox.com/s/pdasmzrtcut5l7e/KSP%200.25KJR.rar?dl=0

hope it helps

Share this post


Link to post
Share on other sites
What can part makers do to cheat to make things more rigid?

Must be something in the xml ... I changed the mass limit down already. Maybe there's a more detailed explanation buried somewhere in this topic. Otherwise it's probably a lot of trial & error.

For me, since I'm scaling down to cm and mm sizes, I want connections to be as rigid as possible independent of both mass and volume.

Share this post


Link to post
Share on other sites

Hey ferram,thanks for the amazing mod.I didn't really understand the Joint Strength Values part of the config.If I would like to have my parts connected solid, which float should I fiddle with.I want this to fly my new super flying B9 Aircraft Carrier :P

Share this post


Link to post
Share on other sites

I'm having a weird issue which I've managed to fix by removing KerbalJointReinforcement (I'm using 2.4.4 version)

Many of my planes\rockets are having serious problems with being rigid, take a look at this stock Ravenspear Mk.4

ReOzE9dl.jpg

Large modded ships are even worse...

WgH0Y5Ml.jpg

Any idea how to fix this?

Share this post


Link to post
Share on other sites

If you don't have one anywhere in GameData, then...obviously you don't have to delete it, because you don't have one.

Share this post


Link to post
Share on other sites

Strangely, i'm getting recent bugs wherein while time warping, the game tries to re-intialize KJR Physics (complete with a useful message), and severely moves my orbit. So an approach to Minmus goes from 10 km to 200 km, or more.

Not sure how this bug came about....maybe in the most recent version? It always accompanies a message about KJR Physics, so this should have something to do with it.

Share this post


Link to post
Share on other sites

If you post your output_log file we might be able to tell you what's going on. Next time it occurs, just exit the game as quick as possible and then put it up.

Share this post


Link to post
Share on other sites

I'll do that eventually, but I did find the mod conflict--KJR and "Load on Demand". For some reason, it causes KJR to force you out of time acceleration and kind of bogs the physics about. Very odd, I'll mention it in the LoD thread. No idea what could be causing it, but it's a WIP mod, so no worries.

Share this post


Link to post
Share on other sites

KJR has no influence on whether you are in or out of timewarp. It will do its job when you come out of timewarp, which might be why you're considering a conflict, but KJR is responding as expected (and properly) to being forced out of timewarp. What is forcing you out of timewarp is not caused by KJR, as it has no influence on when timewarp occurs.

You know, this is what happens when I bother to add a message about what's going on. To remove further confusion, it's getting removed in the next release.

Share this post


Link to post
Share on other sites
You know, this is what happens when I bother to add a message about what's going on. To remove further confusion, it's getting removed in the next release.

As someone who reads and appreciates informational data, I'd appreciate if the "KJR stabilizing physics load..." line is kept (I presume this is what you're talking about).

I've noticed (and fully understand the need for) that KJR locks controls while the physics is getting slowly loaded up, and I've always used that line as to when I'll have control of whatever I'm flying.

Edited by King Arthur
Apparently I'd missed a word.

Share this post


Link to post
Share on other sites

I agree with King Arthur I use it exactly the same way, it lets you know when you have control again, please dont remove it as its also a really good indication that KJR is performing as intended

Share this post


Link to post
Share on other sites

Yep, I'll second (third?) what these gays are saying. :) I like having the notification appear as the ship loads on the pad, or is coming out of time warp. It lets me know that my ship won't spontaneously explode in the next few seconds. :D Well, not because of a physics issue, anyway. Lol. :P

Share this post


Link to post
Share on other sites

I'm having this odd issue recently and I'm not entirely sure what is causing it, I'd thought this thread might be a good place to start.

separation of SRB's from radial decouplers is causing the stack decouplers in my rocket to break.

I'm ascending fine, I separate the SRB's and they clear the rocket but at the same time any stack decouplers in my rocket just collapse on themselves.

I have quite a few mods that could be involved here like the stock fixes, tweakscale, kerbal joint reinforcement, possibly even deadly re-entry.

I just wondered if anyone had come across anything similar and could help narrow it down?

Share this post


Link to post
Share on other sites

Sounds like a problem with a sudden change in TWR and accelleration during separation of the SRBs. I doubt KJR would be suspect here, since if anything KJR would be helping you keep everything stay nicely connected.

Share this post


Link to post
Share on other sites
Sounds like a problem with a sudden change in TWR and accelleration during separation of the SRBs. I doubt KJR would be suspect here, since if anything KJR would be helping you keep everything stay nicely connected.

you're probably right.

odd that it's just started happening, I think maybe it was around the time I put the stock bug fixes on so maybe it's something there.

Thanks King Arthur :)

Share this post


Link to post
Share on other sites

I have a problem. I run Realism overhaul with KJE(which is obvious actually) and no matter at all what i do the connection of decoupler with lower stage wobbles violently to the point of being unplayable at all- insane stuts shcemes help but not much and it happens even at low TWR. Note that this doesnt happen when in the same rocket i attach the stage directly without decoupler. Setting attach node strength and decoupler strength to 10 in cfg file didnt help.

Share this post


Link to post
Share on other sites

Sorry to bother @ferram4 but I have another bit of an issue that I could not find the solution to anywhere in the thread(although I'm pretty sure it has been dealt with if my memory serves me right).

I'm developing a rocket. 1st stage, second stage and a crew vehicle. All those parts work fine on their own. When I connect the 1st and 2nd stage with a test payload it launches and works fine. When I tested the crew vehicle with only the 1st stage it was fine. No fps drop or anything. However, the moment I added the second stage as well(only an increase of 11 parts, I tested one with only 7 as well) my fps dropped drastically. The major problem is this however:

1. Staging doesn't work. Whenever I stage it only stages one part in the next stage list at a time. So I have to press spacebar three times to release two launch clamps. This is even worse when I need to drop the first stage and the retro rockets can't fire etc. etc.

2. The same goes for action groups. I have to press "Abort" three times to release the pod, activate the LES and arm the parachute.

Removing KJR fixed the problem(both the fps drop and staging issue) but RSS/RO is unplayable without it. I'm trying some new designs to see if it is a specific part causing the problem but seeing as everything works fine separately I doubt it. I'm using 2.4.4 and latest updates of everything.

Here is the ksp.log from one test launch(the game crashed this time). I'll check the in-game log too in a moment.

EDIT 2:

Here is the full output_log.txt

Edited by ANWRocketMan

Share this post


Link to post
Share on other sites
KJR has no influence on whether you are in or out of timewarp. It will do its job when you come out of timewarp, which might be why you're considering a conflict, but KJR is responding as expected (and properly) to being forced out of timewarp. What is forcing you out of timewarp is not caused by KJR, as it has no influence on when timewarp occurs.

You know, this is what happens when I bother to add a message about what's going on. To remove further confusion, it's getting removed in the next release.

I wouldn't be surprised if I'm just way off base when it comes to how things work behind the scenes.

In any case, the issue remains--something is causing a ship in time acceleration at rather unusual times, far away from the influence of gravity, and then the the orbit gets messed up a bit accordingly (as oppose to a recalculation of a few dozen meters, it ends up being a few dozen kilometers). KJR could be entirely unrelated, and the message just incidental.

I'll post an output_log and someone much better informed can take a look at it if they're feeling generous.

Share this post


Link to post
Share on other sites

Hi,

I do not know, if this bug has already been posted. but...

Using KJR with RealSolarsSyste, and RealismOberhaul activating the first stage doesn't work correctly. Sometimes hitting SPACE to activate the whole stage, only one engine and/or one clamp is getting started/released. I have to press SPACE multiple times to activate all parts of the first stage making a successful launch nearly impossible.

By removing mod by mod I found that KJR is the mod responsible for this.

Anybody else with the same problem?

Share this post


Link to post
Share on other sites
Hi,

I do not know, if this bug has already been posted. but...

Using KJR with RealSolarsSyste, and RealismOberhaul activating the first stage doesn't work correctly. Sometimes hitting SPACE to activate the whole stage, only one engine and/or one clamp is getting started/released. I have to press SPACE multiple times to activate all parts of the first stage making a successful launch nearly impossible.

By removing mod by mod I found that KJR is the mod responsible for this.

Anybody else with the same problem?

I am having to press "stage" for every radial engine jettison, yes....is this a KJR issue!?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.