ferram4

[1.3] Kerbal Joint Reinforcement v3.3.3 7/24/17

Recommended Posts

1 hour ago, Drew Kerman said:

I've seen you post this every time you report a problem. Why?? If you can't find them, read this. If you don't have a place to upload them, use pastebin.

I don't want to make an excuse but I have technical problem with copying logs... I can't copy log files from KSP_x64_Data folder. It says some process is using that file and I can't find which process is using that file on cmd... I've searched forum for this problem, but nobody had same problem with me. It's silly to ask this question here, but can anybody help this problem? I really want to be helpful for modders but it is very sad that I can't...

Share this post


Link to post
Share on other sites
24 minutes ago, Quodios Kerman said:

IIt says some process is using that file and I can't find which process is using that file on cmd... I've searched forum for this problem, but nobody had same problem with me. It's silly to ask this question here, but can anybody help this problem? I really want to be helpful for modders but it is very sad that I can't...

My first thought is you are trying to move the log file, not just copy it.

Another is: I have had this issue, but when trying to save an edited .cfg file. It seems Windows "SmartScreen" is latching on to certain files for some reason I can't fathom, so, security related, I guess.

My work around is to open aforementioned file, do my edit, open Task Manager, kill the Smart screen process, then save the file. I haven't found out how to kill smart screen for good. I'm sure there is a way, but, well, let's face it, I'm kinda lazy on the weekends.

Maybe this is why you haven't been able to move a log. But I don't see why you couldn't copy a log, though.

EDIT: THIS link will explain how to turn Smart Screen off.

Edited by Argyle MHF
Added link

Share this post


Link to post
Share on other sites

@Quodios Kerman: I have tested the vehicle, both with AtmosphereAutopilot installed and without and I notice nothing out of the ordinary.  Vehicle bounces on its suspension a little coming out of timewarp, but that's merely the effect of gravity suddenly being turned on and off.  If something nastier is happening, I'm not able to find it.

Logs might help, but regardless of whether I have them or not if I can't reproduce the issue there's nothing to be done.

Share this post


Link to post
Share on other sites
On 10/20/2016 at 8:14 PM, ferram4 said:

@rooster: Well, I tried something that might fix it that's in the latest dev build if you wanna give it a shot.  I think it should work quite well.

 

OMG, THANK YOU FOR THIS.  You have fixed my game.  I had a contract to expand my base, but the Kraken kept eating it.  Thanks!

273FB0E049730D19B51654A961053E9416E2D757

Share this post


Link to post
Share on other sites
9 hours ago, Argyle MHF said:

My first thought is you are trying to move the log file, not just copy it.

Another is: I have had this issue, but when trying to save an edited .cfg file. It seems Windows "SmartScreen" is latching on to certain files for some reason I can't fathom, so, security related, I guess.

My work around is to open aforementioned file, do my edit, open Task Manager, kill the Smart screen process, then save the file. I haven't found out how to kill smart screen for good. I'm sure there is a way, but, well, let's face it, I'm kinda lazy on the weekends.

Maybe this is why you haven't been able to move a log. But I don't see why you couldn't copy a log, though.

EDIT: THIS link will explain how to turn Smart Screen off.

I knew that smart screen might make problem, so I've already terminated that task in taskmgr, but it also did not worked. So I just reinstalled Windows, and now problem is solved. Maybe while I was making new partition and installing KSP in it, internal problem was occured. Thanks @Argyle MHF, for suggesting solutions by using your precious time :)

9 hours ago, ferram4 said:

@Quodios Kerman: I have tested the vehicle, both with AtmosphereAutopilot installed and without and I notice nothing out of the ordinary.  Vehicle bounces on its suspension a little coming out of timewarp, but that's merely the effect of gravity suddenly being turned on and off.  If something nastier is happening, I'm not able to find it.

Logs might help, but regardless of whether I have them or not if I can't reproduce the issue there's nothing to be done.

I reinstalled and I also couldn't reproduce problem. Maybe that was my pc's error. Thank you for replying and I feel sorry for making you to waste time. I do love this mod! Thanks, @ferram4

Share this post


Link to post
Share on other sites

@ferram4  I've been playing with the 1.2 Dev version of Kerbal Joint Reinforcement (KJR) and I've noticed an issue when using KJR in conjunction with Roverdude's Konstruction Mod. Konstruction is a mod which has weldable construction ports which once connected, can be removed, resulting in a permanent joint between the parent parts of the two ports. It's a great way to help part count on stations, I've found. 

Unfortunately KJR does not play nice with Konstruction. When KJR is installed and the ports from Konstruction are activated the docking ports disappear, but the parts are positioned incorrectly, with gaps where the ports used to be instead of a clean joint. Also, it appears dependent parts don't move along with the parent part like they are supposed to. Here is a picture to help you see what I'm seeing. Here is my log file.

I posted already about this issue in the Konstruction thread and Roverdude indicated it would need to be solved on the KJR side. I understand if it's not something you have the time or desire to fix, but any help provided is certainly appreciated. Thank you for all your time and hard work, you make some awesome mods! 

 

Share this post


Link to post
Share on other sites

@nebuchadnezzar: And I assume that you are using the very, very latest version of the KJR dev, as it was noted that the latest one is supposed to have a fix for that issue?  I'm guessing that you have not considering I mentioned earlier in the thread that any issues involving Konstruction were my problem and to post them here rather than bother RoverDude.  Confirm that you are using the dev version uploaded a few days ago, and if that's not it, then I need a test case of a vehicle just before the welding is triggered.

Share this post


Link to post
Share on other sites

Some anecdotal commentary: The latest dev version is working great! the sticky docking ports are gone, and things that would shake themselves to bits in the past are not twitching even slightly. I can post a pick of the monstrosity I have built in Kerbin orbit when I get home form work, but I put everything that would induce wobbliness on it and it is rock solid. There has always been a point in past stations where at a certain size, wobbly. This one is well past that. I intend to add more bits until I get tired or it wobbles.

I did notice what I would call "flex" during one of the launches, but considering it was a stack of 4 {docking port+pod+tank+terrier+decoupler} Kerbin return drop ships on top of a stack of 2x 3.75m fuel tanks, on top of a 3 stage booster, I actually expected a lot worse. Flex is ok.

Good job, ferram4! I think you got this one licked.

Thank you!!

Share this post


Link to post
Share on other sites

Just checking - I hit the link for the latest dev version and then hit d/l which gave me the plugin file rather than a zip - To make it work I will need to create the Folder structure, right?  (Gamedata/KerbalJointReinforcement/Plugin)  Or can I stick it anywhere?

Share this post


Link to post
Share on other sites
22 hours ago, Asharad said:

OMG, THANK YOU FOR THIS.  You have fixed my game.  I had a contract to expand my base, but the Kraken kept eating it.  Thanks!

273FB0E049730D19B51654A961053E9416E2D757

Well, at least you've got enough propellant.

Share this post


Link to post
Share on other sites

@DirtyFace83: No, what you're going to do is head to the main download links because...

KJR v3.3.0 is released with KSP 1.2 compatibility, changes that reduce physics wobble issues on stations and bases, and confirmed compatibility with the Konstruction mod.  Have fun!

Also, anyone who comes in and says that they found a bug in the dev build now will get a stern talking to about their sense of timing. :P

Share this post


Link to post
Share on other sites

@Asharad I know it's somewhat off topic but I feel like I have to ask: what exactly do you need all of that monopropellant and all of those RCS ports for? Did you assemble that base using the same methods that one would use to construct a station?

Share this post


Link to post
Share on other sites

@ferram4 I think i have a bug, (do to my lack of internet conection im unable at this point to post a report)

Ive resantly been doing launcher tests on eve so i cando my first eve and back manned mission, and a odd bug pops up, half way up my acent I hear a explosion, KJR says loading default preset and my ship kicks hard in one direction and then as soon as i correct it, it kicks almost as hard in the other, im wondering if its my lower stage hitting eves surface and confusing kJR, ill post a more detail bug report with pictures when i can, sorry for the inconvenience      

 

Crap.. XD Guess im getting a stern talking too

Edited by Tidus Klein

Share this post


Link to post
Share on other sites
3 hours ago, ferram4 said:

KJR v3.3.0 is released with KSP 1.2 compatibility, changes that reduce physics wobble issues on stations and bases, and confirmed compatibility with the Konstruction mod.  Have fun!

Great! Does that mean we can expect a FAR release for 1.2 soon? :wink:

Share this post


Link to post
Share on other sites

YYYYEEEEEESSSSSS!!!!!!!! Thanks Ferram4!!!!!! I had no noticeable issues with the dev-build but now installing the new release.

Share this post


Link to post
Share on other sites

BUG

Easily obtained in the following way... Enter in sandbox mode, take stock rocket "Kerbal X", start... Open console, and in moment upload "Launch Stability Enhancer" from memory, on 2,5km distance, have Kraken. Rocket will shake. Small rockets and vessels have very hard shake. Bug  is the place to be in moment load/upload from memory parts and other gaming moments.

This bug was have on master(pre) version this mod. On release version bug continue. Vessels have shake on start and in orbit. Please, fix it.  In the name of Cthulhu!!!! 

Forgive me for English. I'm not very good at English.

Share this post


Link to post
Share on other sites
4 hours ago, ferram4 said:

@DirtyFace83: No, what you're going to do is head to the main download links because...

KJR v3.3.0 is released with KSP 1.2 compatibility, changes that reduce physics wobble issues on stations and bases, and confirmed compatibility with the Konstruction mod.  Have fun!

Also, anyone who comes in and says that they found a bug in the dev build now will get a stern talking to about their sense of timing. :P

Yay!!

Share this post


Link to post
Share on other sites
7 hours ago, ferram4 said:

@DirtyFace83: No, what you're going to do is head to the main download links because...

KJR v3.3.0 is released with KSP 1.2 compatibility, changes that reduce physics wobble issues on stations and bases, and confirmed compatibility with the Konstruction mod.  Have fun!

Yay!

Quote

Also, anyone who comes in and says that they found a bug in the dev build now will get a stern talking to about their sense of timing. :P

Damn straight.  People should be finding bugs in the release version now.  :wink:

 

Share this post


Link to post
Share on other sites
9 hours ago, ferram4 said:

@DirtyFace83: No, what you're going to do is head to the main download links because...

KJR v3.3.0 is released with KSP 1.2 compatibility, changes that reduce physics wobble issues on stations and bases, and confirmed compatibility with the Konstruction mod.  Have fun!

Also, anyone who comes in and says that they found a bug in the dev build now will get a stern talking to about their sense of timing. :P

Thanks Ferram, just thought I should let you know that the date of the update is incorrect, it should be 10/27/16 (or for us contrary UK residents 27/10/16)

Edited by MartGonzo

Share this post


Link to post
Share on other sites

so seeing this thread now with people talking about how 1.2 broke their stations and such, but KJR fixed them.... 

 

I just have to ask, if it is not too long and painful of an explanation, how does KJR differ from the new stock tweaks?   other than the gradual application of gravity I mean, that part is obvious.   what I mean is how does the joint strength differ from the 2 new options.

 

I have always used KJR, but I assumed these new options in 1.2 would make it somewhat redundant.  but I guess not from seeing the posts in this thread, as they cant all be from the gradual gravity bit can they?

Share this post


Link to post
Share on other sites

Hallelujah!    I've been DYING to get this back.   I've got a supermassive launch in the works (30k tons on the pad), and the physics start up has been whipsawing me all over the place.

Share this post


Link to post
Share on other sites

@rebel-1: Yep, I see it too.  Dammit, I'll look into it.  It's certainly not a joint thing otherwise it wouldn't get that far.

@Tidus Klein: I'll bet it's the same as rebel's issue.  Probably.

@MartGonzo: I can read calendars, I swear.

@Bit Fiddler: KJR in general makes all joints stiffer, which stock doesn't do.  It also applies the extra struting that stock has as an option automatically and across parts of the vehicle that it detects will likely be overly flexible rather than just to the heaviest part as with stock.  It's easier and generally more effective than manually deciding where the extra joints are needed.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.