ferram4

[1.3] Kerbal Joint Reinforcement v3.3.3 7/24/17

Recommended Posts

O.K., waiting good news... And stable version. 

Share this post


Link to post
Share on other sites

I think I may have experienced the same bug as Rebel-1 while flying around Kerbin. As the plane ascends and descends through 130-150m ASL there is a severe pitch oscillation (aka a "bump"). Severity is dependent on speed. Example of test plane shown below:

frupzfoh.png

The effect is still present with engine gimbals locked and reaction torque disabled (ie flying on areo control surfaces only). Flying manually with no SAS autostab. makes no difference either, so I don't think it is a control conflict issue.

Makes it difficult to land as it happens just on final approach, with not much time to recover, and Harrier/Kestrel type VTOLS just go loopy!

Unfortunately I'm fairly sure it is caused by KJR as I have tried it on a standalone vanilla install. (x64). Hope this extra info helps in your bug hunt.

Sincere apologies for by bad manners in reporting in at this time :wink:

Edited by percyPrune

Share this post


Link to post
Share on other sites

Thanks for the official release @ferram4 !   I already had the dev build from github, but this is a must have mod for this game. Even the new joint system can't match KJR.

Share this post


Link to post
Share on other sites

Thank you, thank you, thank you, much love! Playing 10x kerbin and I was just now complaining in my head about the random unrepeatable structural failures I keep having. Seems like 1.2 likes 7m+ parts even less :(

Share this post


Link to post
Share on other sites

I installed the newest version of Joint Reinforcement and now my vessels explode upon rendezvous... 

They stopped once I uninstalled KJR... what can I do about this?

Share this post


Link to post
Share on other sites

@rebel-1 @percyPrune 

does your ships use any cliped parts at all? I know on my eve lander i have some parts that are clipped into each other a little bit in order to fit in the fairing.

Share this post


Link to post
Share on other sites

I was having a weird Rapid Unplanned disassembly issue last night whenever a ship with clipped parts was changing SOI while active, could it be related ? Logs don't show much... 

Share this post


Link to post
Share on other sites
2 hours ago, percyPrune said:

I think I may have experienced the same bug as Rebel-1 while flying around Kerbin. As the plane ascends and descends through 130-150m ASL there is a severe pitch oscillation (aka a "bump"). Severity is dependent on speed. Example of test plane shown below:

frupzfoh.png

The effect is still present with engine gimbals locked and reaction torque disabled (ie flying on areo control surfaces only). Flying manually with no SAS autostab. makes no difference either, so I don't think it is a control conflict issue.

Makes it difficult to land as it happens just on final approach, with not much time to recover, and Harrier/Kestrel type VTOLS just go loopy!

Unfortunately I'm fairly sure it is caused by KJR as I have tried it on a standalone vanilla install. (x64). Hope this extra info helps in your bug hunt.

Sincere apologies for by bad manners in reporting in at this time :wink:

I have the same problem with my rockets, when ascending about 50 m/s i see a big bump and i reach an orbit the bumps occurs make sas unstable.

Share this post


Link to post
Share on other sites

I think clipped parts manifest more as a persistent phantom force. The bump being discussed is a one time thing that tends to tilt the craft 45 degrees. 

Share this post


Link to post
Share on other sites

I have experienced the bug described by percyPrune and others while launching the stock KebalX rocket to test my modded game. Rocket was at about 35 km and maybe 45 degree tilt when it suddenly changed heading for no apparent reason.

Edited by Vrana

Share this post


Link to post
Share on other sites

My ship explodes every time at SOI Change on the way to Moho. After removing KJR 3.3.0 it works again.

Share this post


Link to post
Share on other sites
55 minutes ago, Kolago said:

My ship explodes every time at SOI Change on the way to Moho. After removing KJR 3.3.0 it works again.

Possibly related to this, I've noticed that ships often pick up some spin on crossing an SoI boundary.   I think this started after I installed the latest KJR. 

Share this post


Link to post
Share on other sites

What appears to be happening is some kind of shenanigans with multi-part joints and Krakensbane.  Krakensbane has been made a fair bit more flexible in when it is activated in 1.2, and the switch seems to cause issues.  I'm not sure exactly why this is happening though, but I'm sure I'll find it soon enough.

Edit: There is now another dev build that should have this fixed.  I question why I'm even linking this and saying anything considering that the entire point of dev builds didn't work out here and I had to push out a release to get a report on a critical bug.

Edited by ferram4

Share this post


Link to post
Share on other sites
11 hours ago, ferram4 said:

What appears to be happening is some kind of shenanigans with multi-part joints and Krakensbane.  Krakensbane has been made a fair bit more flexible in when it is activated in 1.2, and the switch seems to cause issues.  I'm not sure exactly why this is happening though, but I'm sure I'll find it soon enough.

Edit: There is now another dev build that should have this fixed.  I question why I'm even linking this and saying anything considering that the entire point of dev builds didn't work out here and I had to push out a release to get a report on a critical bug.

This version seems to work. Bug is not observed. Have yet to test. Thanks.

Share this post


Link to post
Share on other sites

Ok. I'm having a problem with rendezvous, and ships blowing up. It goes like this. I set up a rendezvous with a target vessel from far out. As I get close and begin final approach, at around 100-200m the target vessel spontaneously blows up. This happens every time with Kerbal Join Reinforcement installed. Without, no explosion. But the stock reinforcement sucks, so I'd rather use KJR. But anyways, It does this any time you go EVA too. All nearby vessels explode.

I have figured out a workaround for rendezvous. I approach to about 300m. Stop. Switch to the target vessel. Switch back, and then close in for docking. No explosion.

This makes me think it's something happening as physics switch on for that target vessel at that range as I approach.

Share this post


Link to post
Share on other sites

I had only two errors. It looks like that they are already fixed !
Correct loading of the probe on the surface of the Mun . . . (no jumps).
No accidental rotation of the rocket during flight.
Thx

Share this post


Link to post
Share on other sites
6 hours ago, Cobrag0318 said:

Ok. I'm having a problem with rendezvous, and ships blowing up. It goes like this. I set up a rendezvous with a target vessel from far out. As I get close and begin final approach, at around 100-200m the target vessel spontaneously blows up. This happens every time with Kerbal Join Reinforcement installed. Without, no explosion. But the stock reinforcement sucks, so I'd rather use KJR. But anyways, It does this any time you go EVA too. All nearby vessels explode.

I have figured out a workaround for rendezvous. I approach to about 300m. Stop. Switch to the target vessel. Switch back, and then close in for docking. No explosion.

This makes me think it's something happening as physics switch on for that target vessel at that range as I approach.

@Cobrag0318 are you using the most recent dev build?

Share this post


Link to post
Share on other sites

@Cobrag0318: Try out the dev build linked above if you haven't already.  I believe it's the same problem as everyone else has been having and given how finicky some station / orbital vehicles can be I'd like to know that your particular issue is fixed before I push out a new release and have to do it again if it turns out to be something different.

Share this post


Link to post
Share on other sites
9 minutes ago, ferram4 said:

@Cobrag0318: Try out the dev build linked above if you haven't already.  I believe it's the same problem as everyone else has been having and given how finicky some station / orbital vehicles can be I'd like to know that your particular issue is fixed before I push out a new release and have to do it again if it turns out to be something different.

Testing build on my work. No problem. And now, testing build at home. Two test fly over Kerbin, OK. Try tomorrow fly by other planets. Today it's time for bed, wife is calling.  Thanks for the quick work.

Share this post


Link to post
Share on other sites

No. When the release build for 1.2 posted to ckan, I switched from the dev build before to that. I will say the that dev build did it as well. I will grab the newest and see how well it works. :-)

Share this post


Link to post
Share on other sites

Ok, updated the dll to the new version, and Approaching to a target vessel, Check! Approaching from EVA, Check! Initiating EVA from vessel, Check! Looks good man. I'll take the time to retrospectively mention, this mod is one of the most important mods me and my buddy usse. He was about to quit KSP if 1.2 had broken KJR and it didn't get fixed. Stop playing the game altogether because your mod was broken. LoL I'm glad KSP tried to incorporate some similar concept, but their implementation need some tweaking and polishing. My ships fared better than his, and my other buddy, who like to make huge ships. But even with my ships, it makes a definite improvement.

:cool:

Share this post


Link to post
Share on other sites

Well, then in that case, KJR v3.3.1 is now out with a fix to that issue, thank you to everyone who confirmed the issue was fixed.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.