Jump to content

KMP v0.1.5.1 [0.23] [alpha] [inactive]


Recommended Posts

I'm hosting an interim server until some other server operators get a chance to update:

chrisand.no-ip.info port 2076

It's a forced stock only server - This is more restrictive than the default setup.

I only have 25mbit/5mbit, so your mileage may vary.

daita's server is not a release server *yet*.

EDIT: If you are lazy and don't want to play around with your game data too much, and aren't too afraid of the command line, here's a CLI program to sort out all your troubles connecting to different servers:

http://chrisand.no-ip.info:82/kmp/testing/modcontrol/

The source is available here: https://github.com/godarklight/KMPModClient

Edited by godarklight
Link to post
Share on other sites

I get this error while trying to boot

[00:07:12] [Error] : System.IO.FileLoadException: Could not load file or assembly 'MySql.Data, Version=6.4.3.0, Culture=neutral, PublicKeyToken=20449f9ba87f7ae2' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

File name: 'MySql.Data, Version=6.4.3.0, Culture=neutral, PublicKeyToken=20449f9ba87f7ae2'

at KMPServer.Server.clearState()

at KMPServer.Server.hostingLoop()

at KMPServer.ServerMain.hostServer(ConfigStore settings)

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Not sure what to do.

I'm running Windows Server 2012. In the Registry there is no Fusion entry key to edit. Is it part of Microsoft's sdk or VS?

Edited by DestructDez1
more info.
Link to post
Share on other sites

Looks like gimp packaged the server a little incorrectly.

To host a server, you will need to rename "MySql.data.dll" to "MySql.Data.dll"

EDIT: It might be more than that for windows... Checking it out on virtualbox now..

EDIT 2: Thanks destructdez for pointing me to the right spot:

Go here and click "Raw" https://github.com/TehGimp/KerbalMultiPlayer/blob/master/MySql.Data.dll

The MySql.Data.dll file has changed :-/

Edited by godarklight
Link to post
Share on other sites
Looks like gimp packaged the server a little incorrectly.

To host a server, you will need to rename "MySql.data.dll" to "MySql.Data.dll"

EDIT: It might be more than that for windows... Checking it out on virtualbox now..

EDIT 2: Thanks destructdez for pointing me to the right spot:

Go here and click "Raw" https://github.com/TehGimp/KerbalMultiPlayer/blob/master/MySql.Data.dll

The MySql.Data.dll file has changed :-/

I can confirm that. ;)

I am not sure changing to mysql will reset everything right?

Link to post
Share on other sites

@Spycoclown Changing to mysql will result in a server wipe, sort of. (the sqllite databases would be simply unused until you turn off mysql).

@KvickFlygarn87: I'm hosting an interim server at chrisand.no-ip.info 2076 (EDIT: It restarts if it does 20 ghost-checks due to a CPU load bug).

@lmw5201: A sync loop sounds very odd indeed, the server-sided-mod-check should only mess with parts (It will kick you if you have "bad things" loaded however). I'll give it a shot, The sync loop sounds more like a generic bug and not really "Real solar system" specific.

So... It appears there's a few bugs... I've listed everything I could find on the bug tracker.

I don't mean this in a bad way, but... RIP L.O.G.

Edited by godarklight
Link to post
Share on other sites
How to enable mods/parts in KMP 1.5.0, as the readme.txt way by editing Client side "part list.txt" keeps saying "probhibited items" and can't launch.

hi.

This is how I made mods work..:

1). visit http://forum.kerbalspaceprogram.com/threads/57284 and download that java software.

- Run the software and choose all of the mods folders you like to "include" and save the output text file on your desktop so it is easy to find.

2). Open the new text file and copy the long list of mods.

3). Find your kmp server folder ( you need to have run the server one time minimum since it create a file you need. ). AND i recommend that you make a New server that was never used before.

4). Find the text document named "KMPModControl" and open it.

5). At the bottom of the file there is a long list with part names. Remove the entire list of names and PASTE the new list with all of the new names you made in step 1.

6). Now you are ready to go with mods

The following example will start a new game as a career.

1). Start your Kmpserver.exe ( run as admin )

2). type

/mode career

3). type

/start

I hope this answer your question ;-)

Link to post
Share on other sites
How to enable mods/parts in KMP 1.5.0, as the readme.txt way by editing Client side "part list.txt" keeps saying "probhibited items" and can't launch.
hi.

This is how I made mods work..:

1). visit http://forum.kerbalspaceprogram.com/threads/57284 and download that java software.

- Run the software and choose all of the mods folders you like to "include" and save the output text file on your desktop so it is easy to find.

2). Open the new text file and copy the long list of mods.

3). Find your kmp server folder ( you need to have run the server one time minimum since it create a file you need. ). AND i recommend that you make a New server that was never used before.

4). Find the text document named "KMPModControl" and open it.

5). At the bottom of the file there is a long list with part names. Remove the entire list of names and PASTE the new list with all of the new names you made in step 1.

6). Now you are ready to go with mods

I hope this answer your question ;-)

Oh, server side restriction..

x:/kmp_server/ and add parts to KMPModControl.txt .. got it, ty.

Link to post
Share on other sites

@lmw5201: A sync loop sounds very odd indeed, the server-sided-mod-check should only mess with parts (It will kick you if you have "bad things" loaded however). I'll give it a shot, The sync loop sounds more like a generic bug and not really "Real solar system" specific.

Problem fixed!!! 'Sync loop' was just inappropriate serverside mod setting's fault. No more sync loop with Real solar system mod. Thanks!

Link to post
Share on other sites

Hi.

We have just finished a MP game with the new 1.5.0 and i have some questions that i hope you guys can answer ;-)

The server run 1.5.0, and we play with a few mods ( mecjeb, kas, kethane,KMP,squad )

Server run in career mode, and all of the mods load fine and are available as expected ect.

1). When playing career is it normal that the players individual unlock their own tech tree, and are not able to "share" their research points with each other ?

2). If I turn off the server ( /quit ) and turn it on a few hours later, then the very first thing that I notice are that all of the ships that we deleted in the past have returned. For example when I load our game there are 25 ships that

need to be deleted manual again. Is this normal or do I maybe have to write a special server command when I start the server ??

I start my server with the commands

/mode career

/start

Thank you all for answers in advance ;-)

Link to post
Share on other sites

@Everyone, The KMPPartList.txt file is no longer used, it should be safe to delete.

The client downloads KMPModControl.txt from the server. It ends up in the client folder as a convinience thing (I discussed putting it in memory instead, but ryan came up with a good point: Client's can see the exact config of the server).

This also makes server mod configs "borrow/stealable" as well - which is a *good* thing.

You guys should not be getting sync loops. It should kick you out of the server, return you to the main menu screen and very clearly say (For example): "Disconnected: Missing MechJeb2".

I've never heard of/seen a sync loop. I've seen syncs then end half way (The vessel counter doesn't increment). And I've also seen fake game connects (like this, but during the inital connect): http://tinypic.com/view.php?pic=1441fq&s=5#.UsZr8f6PVqM

Link to post
Share on other sites

@fresh_sms, This is probably the best I can give you:

https://github.com/TehGimp/KerbalMultiPlayer/blob/master/KMPServer/Server.cs#L3534-L3544

To use MySQL, type these before a server start:

/set useMySQL true

/set mySQLConnString Server=localhost;Database=KMP;Uid=KMP;Pwd=KMPPass;

Then just your normal /start command.

You will have to create a KMP user, create KMP's database, and grant privs to KMP. The server will create the tables when it first runs.

EDIT: My interim server is back up - chrisand.no-ip.info 2076, I'm going to do some profiling on the server (I think the CPU load is too high).

EDIT 2:

@Peder

1. Each player has their own tech tree. There's an idea kicking around (nothing implemented yet) to allow giving of science points, or full co-op sharing like you suggested.

2. Sometimes deleting vessels does not work. I recommend /set autoDekessler true (or just run /dekessler). It removes old debris.

To force-delete a ship, you have to find its GUID with /listships, and then /deletevessel guid. I'll try to make it easier in 0.1.6 with name matching.

Edited by godarklight
Link to post
Share on other sites
@fresh_sms, This is probably the best I can give you:

https://github.com/TehGimp/KerbalMultiPlayer/blob/master/KMPServer/Server.cs#L3534-L3544

To use MySQL, type these before a server start:

/set useMySQL true

/set mySQLConnString Server=localhost;Database=KMP;Uid=KMP;Pwd=KMPPass;

Then just your normal /start command.

You will have to create a KMP user, create KMP's database, and grant privs to KMP. The server will create the tables when it first runs.

EDIT: My interim server is back up - chrisand.no-ip.info 2076, I'm going to do some profiling on the server (I think the CPU load is too high).

EDIT 2:

@Peder

1. Each player has their own tech tree. There's an idea kicking around (nothing implemented yet) to allow giving of science points, or full co-op sharing like you suggested.

2. Sometimes deleting vessels does not work. I recommend /set autoDekessler true (or just run /dekessler). It removes old debris.

To force-delete a ship, you have to find its GUID with /listships, and then /deletevessel guid. I'll try to make it easier in 0.1.6 with name matching.

thank so much

string is mean that string!!

very thanks

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...