Jump to content

[1.1.2][1-1-2] May 13-2016 EnvironmentalVisualEnhancements


Recommended Posts

3 minutes ago, Berlin said:

Ahh well thanks for setting me straight!  Its getting confusing with all the fixes lol I love that you guys work so closely together though. I try to keep up best I can. Next time I'll leave the help to the experts ;)

Noo please, continue to help haha. I could be wrong, who knows, not me, it's been too long of a day, where's my bed.

Link to post
Share on other sites

Hi @rbray89, first of all: thanks for your efforts, as always.

I've been observing the cloud system for awhile. And I've noted that the cloud particles spawn/speeds are "linked" to the main texture. While this is fine for the stock configs, the particles blinks when you use bigger/faster cloud detail textures. In many cases this spoils the "consistence" of the clouds.

My question is: would be possible, in future versions, to have a switch to change the "particle link" between the main texture and the detail texture?

I think that be able to link the particles to the detail, instead to the main texture, could do a great change in favour of realism, changing the blinking of the particles to a more natural "cloud evolution", based in the detail texture, but with the effect defined by the main thexture.

In any case, thanks again for all!

Link to post
Share on other sites
2 hours ago, Proot said:

Hi @rbray89, first of all: thanks for your efforts, as always.

I've been observing the cloud system for awhile. And I've noted that the cloud particles spawn/speeds are "linked" to the main texture. While this is fine for the stock configs, the particles blinks when you use bigger/faster cloud detail textures. In many cases this spoils the "consistence" of the clouds.

My question is: would be possible, in future versions, to have a switch to change the "particle link" between the main texture and the detail texture?

I think that be able to link the particles to the detail, instead to the main texture, could do a great change in favour of realism, changing the blinking of the particles to a more natural "cloud evolution", based in the detail texture, but with the effect defined by the main thexture.

In any case, thanks again for all!

Ah, I see, you'd like the particles to move with the detail rather than the main layer. I think that should be doable.

Link to post
Share on other sites

Tried a search but I seem to be going around in circles...

Is there a City Lights main.dds file for RSS lying around.

I noticed that on the main.dds alpha channel the cities are of Kerbin... Which explains why there were cities in the North Atlantic

 

Link to post
Share on other sites
3 hours ago, Proot said:

Hi @rbray89, first of all: thanks for your efforts, as always.

I've been observing the cloud system for awhile. And I've noted that the cloud particles spawn/speeds are "linked" to the main texture. While this is fine for the stock configs, the particles blinks when you use bigger/faster cloud detail textures. In many cases this spoils the "consistence" of the clouds.

My question is: would be possible, in future versions, to have a switch to change the "particle link" between the main texture and the detail texture?

I think that be able to link the particles to the detail, instead to the main texture, could do a great change in favour of realism, changing the blinking of the particles to a more natural "cloud evolution", based in the detail texture, but with the effect defined by the main thexture.

In any case, thanks again for all!

Done. New option for volume called followDetail

Link to post
Share on other sites

Very fast!! And now looks much, much better!! Infinite thanks @rbray89!!

I don't know if I'm missing something but seems like in this last version the particles keeps rotating even at rotation 0.

And by the way... what does and how works "noiseScale" in layerVolume?

Link to post
Share on other sites
2 minutes ago, Proot said:

Very fast!! And now looks much, much better!! Infinite thanks @rbray89!!

I don't know if I'm missing something but seems like in this last version the particles keeps rotating even at rotation 0.

And by the way... what does and how works "noiseScale" in layerVolume?

Hmmm... I think I know where the rotation is coming from.

noiseScale and the position of the particles is plugged into a perlin function to determine size, orientation, and placement. It helps add "Randomness" to particles, but lets us move the particle grid around while still getting the same particle params.

Link to post
Share on other sites

Call me an idiot for not knowing this already, but do I download both the main release and the config files? Or just the main release?

Nvm, my eyes decided to actually work and I saw on the github page that I need to download both.

Edited by Noob21
Link to post
Share on other sites
2 hours ago, Noob21 said:

Call me an idiot for not knowing this already, but do I download both the main release and the config files? Or just the main release?

Nvm, my eyes decided to actually work and I saw on the github page that I need to download both.

Aha, I'm glad you did because you just solved my problem... I couldn't get the mod to work! lol

 

Was wondering where the crap the BoulderCo folder was 

Link to post
Share on other sites
14 minutes ago, Moose Rocket Science said:

hold up, are those the old parts from pre-0.16???????????

Pre 0.18, and yes. I get a nostalgiaboner from them. Just look up the Kerbal Historical Institute mod. It has all the old versions of parts that have been phased out.

Link to post
Share on other sites
1 hour ago, Berlin said:

please see the very first page of this thread. There is a download link for 1.1.

I had tried that one, but for some reason it didn't wanted to work. I uninstalled it and installed it again and now it works, thanks :)

Link to post
Share on other sites

This mod is certainly filling in the eye-candy needs. It also decided to colonize the mun! I'd take it that it wasn't the idea! It is only visible in-game and not from the map.

QP4LH8O.png

Latest versions of EVE 1.1 pre-release (checked on 15-4, 21:37 GMT +1)

(I do not post many things on forums and was very happy when I found out how to add an image. I didn't find out how to upload my log file so I am terribly sorry for that but if I find out how I will.)

Edited by mafkaas300
Link to post
Share on other sites
1 hour ago, mafkaas300 said:

This mod is certainly filling in the eye-candy needs. It also decided to colonize the mun! I'd take it that it wasn't the idea! It is only visible in-game and not from the map.

Latest versions of EVE 1.1 pre-release (checked on 15-4, 21:37 GMT +1)

(I do not post many things on forums and was very happy when I found out how to add an image. I didn't find out how to upload my log file so I am terribly sorry for that but if I find out how I will.)

Use gist.git.com to upload your log file (copy and paste it to there) and share the link here.

Hmmm... You say it is only visible in the ship view? Very interesting. I thought I knew the root cause, but it seems to be a trickier problem to fix than I thought... I'm working on a more permanent fix right now by upgrading the overlay system I have in place now.

Link to post
Share on other sites
On 15-4-2016 at 10:55 PM, rbray89 said:

Use gist.git.com to upload your log file (copy and paste it to there) and share the link here.

Hmmm... You say it is only visible in the ship view? Very interesting. I thought I knew the root cause, but it seems to be a trickier problem to fix than I thought... I'm working on a more permanent fix right now by upgrading the overlay system I have in place now.

Hmm, I tried to log the events from the lights being created on the Mun but now the disappeared! I noticed the base game was updated so maybe there was something not ok in KSP 1.1 itself.

Anyhow, may it happen again I know now how to upload a logfile with it.

 

Edit: After reloading, which happened 2 minutes after this message, the lights on Mun were back. I haven't been to other planets yet to find out if it happened there

Log file: https://gist.github.com/anonymous/f14a5559d7e5ca555597ec31c257305f

Edited by mafkaas300
Link to post
Share on other sites

For what it's worth, last night I had city lights spawning on Minmus. No logs or anything - just anecdotal support for those reporting the oddities. My ancient computer really can't handle this mod anyway, sadly. I was just playing with it a bit to see how it looks with 1.1 before uninstalling it again to make my game playable. 

Link to post
Share on other sites

Update pushed for 1.1 See OP for link.

Slightly better performance with city lights, City lights *Might* be fixed now. If not, they will 100% be fixed in next release.

Eclipses won't draw over transparent objects. Eclipses should affect the Space center (and other PQS entities) 

Particles can be attached to the detail texture, particle rotation will be correct now.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...