Jump to content

[1.11.X] RealChute Parachute Systems v1.4.8.2 | 21/01/21


Recommended Posts

Hi, I have RP-1 for KSP 1.8.1, and after the last update, chute GUI stopped opening. And it works with the previous version of the mod. It should be marked as incompatible for older game versions, I guess.

P.S. Also, any chance of changing the GUI? It looks really old, has weird vertical scale (too many scrollable blocks inside each other) and having it in action groups is really strange.

Edited by desert
Link to post
Share on other sites
6 hours ago, desert said:

.S. Also, any chance of changing the GUI?

Read the OP.  The mod author has mentioned that they are not devoting much, if any, time to continued development of RealChutes, so the chances are pretty small.

Link to post
Share on other sites

Not sure if it's just me or some other mod I have but if I have even the simplest of crafts in the VAB with a RealChute on it any kind of fuel tank changes (playing with the fuel sliders) kills FPS.
The more chutes I have, the worst it can get, even dropping to 2FPS.

The size of the ship actually doesn't affect this at all just the number of chutes.

Before I test this out without any other mods and getting logs, is anyone else experiencing this on 1.11?

Edited by Captain828
Link to post
Share on other sites
1 hour ago, Captain828 said:

Before I test this out without any other mods and getting logs, is anyone else experiencing this on 1.11?

I'm not.

5 hours ago, Brigadier said:

Read the OP.  The mod author has mentioned that they are not devoting much, if any, time to continued development of RealChutes, so the chances are pretty small.

Well, there is a reference to RealChute 2, but I don't know if that's still in work or not. Maybe @stupid_chris will tell us.

Otherwise, I'm happy the mod is still supported as much as it is. I'd rather have a quirky user interface than no realchute at all.

Link to post
Share on other sites
18 hours ago, desert said:

Hi, I have RP-1 for KSP 1.8.1, and after the last update, chute GUI stopped opening. And it works with the previous version of the mod. It should be marked as incompatible for older game versions, I guess.

P.S. Also, any chance of changing the GUI? It looks really old, has weird vertical scale (too many scrollable blocks inside each other) and having it in action groups is really strange.

Because the update is not compatible for KSP 1.8. If you are on 1.8, stay on the previous version of the mod. It doesn't say it's compatible. I'm not currently developing RealChute in it's current state, and I'm sure as hell not touching the rat's nest that is the current UI code. RealChute 2 is on indefinite hold as of right now, but new UI is within the scope of it.

8 hours ago, Captain828 said:

Not sure if it's just me or some other mod I have but if I have even the simplest of crafts in the VAB with a RealChute on it any kind of fuel tank changes (playing with the fuel sliders) kills FPS.
The more chutes I have, the worst it can get, even dropping to 2FPS.

The size of the ship actually doesn't affect this at all just the number of chutes.

Before I test this out without any other mods and getting logs, is anyone else experiencing this on 1.11?

Make sure you have the right version of RealChute installed, and updated versions of the other mods.

Link to post
Share on other sites
14 hours ago, stupid_chris said:

Make sure you have the right version of RealChute installed, and updated versions of the other mods.

I did have all the latest versions.

After a careful check and redownload of all 100+ mods I use, I've found the culprit being StageRecovery.

With something as simple as this
https://www.dropbox.com/s/8arkhxymmaiv1yd/screenshot 2021-01-26 23.33.21.png?dl=0
when I play around with the fuel sliders:

  • SR + RC chutes: below 10FPS
  • SR with no chutes (RC installed): minimal input lag (and maybe 1-2FPS drop if I play with the fuel sliders like a mad man)
  • SR + stock chutes (RC not installed):  silky smooth
  • SR with no chutes (RC not installed): silky smooth
  • just RC: silky smooth

From a glance it seems clear that it's trying to do some more complicated calculus for RC chutes.

I will post my findings to the SR mod as well.
I'm surprised no one else has found this issue - @stupid_chris can you replicate this?

Link to post
Share on other sites
1 hour ago, Captain828 said:

I'm surprised no one else has found this issue

I'm running 130+ mods, including RC and SR/FMRS and not seeing your lag.  Are you playing around with RC/SR without removing all other mods, perhaps?  You might find that your test doesn't identify the actual cause, just a coincidence. 

Since you haven't fully described your diagnostic process, I might be off base.  Start with a fresh KSP, then add only RC, SR and any dependencies.  Add mods in groups until the symptoms reappear.

See this topic for suggestions on how to report problems.  There may be spam in your log file, for example.

Edit:  Completely missed the fact that you're running KSP 1.11 which could explain why I'm not experiencing this lag.  Still, the troubleshooting process stands.

Edited by Brigadier
Last line caveat.
Link to post
Share on other sites
1 hour ago, Brigadier said:

I'm running 130+ mods, including RC and SR/FMRS and not seeing your lag.  Are you playing around with RC/SR without removing all other mods, perhaps?  You might find that your test doesn't identify the actual cause, just a coincidence. 

Since you haven't fully described your diagnostic process, I might be off base.  Start with a fresh KSP, then add only RC, SR and any dependencies.  Add mods in groups until the symptoms reappear.

Yeah, sorry about that, I wanted to keep my reply short for brevity sake but I see now I should have been more explicit: while I first experienced this when I had my full collection of mods, I then went one by one to find the culprit.
In the end I found it was from StageRecovery that was doing some expensive calculations for every change in the VAB when RealChutes were present.
I then double checked by, again, removing all mods and testing with just these two which resulted in what I wrote above.

For the logs, I checked before and they had nothing of help in them.

Link to post
Share on other sites
6 hours ago, Captain828 said:

I'm surprised no one else has found this issue - @stupid_chris can you replicate this?

It's been mentioned a couple of times already, but I'm not actively working on RealChute at the moment. If StageRecovery is causing issues by interacting with RealChute, I can't do much about it even if I wanted to.

Link to post
Share on other sites
  • 1 month later...
  • 2 weeks later...

Hello everyone, can someone explain to me how I connect the parachutes of my different mods with RealChute? I've already tried, with me either the parachutes are activated in the VAB or the "Chut info window" are shown only small so that you can not see anything. Thanks in advance

Link to post
Share on other sites
  • 1 month later...

Is there anyway to get parachutes from other mods  like fasa, bluedog, taero, sounding rockets ect to work with Realchutes when i use those chutes the chute will appear to deploy but never expand and I crash.

 

Ideally  i wondering if there is a universal parachute patch instead of editing each part separately

Link to post
Share on other sites
2 hours ago, Scottmm78 said:

Is there anyway to get parachutes from other mods  like fasa, bluedog, taero, sounding rockets ect to work with Realchutes when i use those chutes the chute will appear to deploy but never expand and I crash.

 

Ideally  i wondering if there is a universal parachute patch instead of editing each part separately

There isn't. Parachutes have to be patched manually with ModuleManager.

Link to post
Share on other sites

I had a patch file for FASA and Procedural Chutes. I need to find it cause I'm using both. 

I should update it to check for FASA automatically and give it to @stupid_chris

Link to post
Share on other sites
2 hours ago, Probus said:

I had a patch file for FASA and Procedural Chutes. I need to find it cause I'm using both. 

 

If you find it could I get a copy to use as a template for the other mods I use please?

Link to post
Share on other sites
16 minutes ago, Scottmm78 said:

If you find it could I get a copy to use as a template for the other mods I use please?

You can already use the stock MM patch bundled with RealChute as a template

Link to post
Share on other sites

Greetings. Having problem with realchute in KSP (russian version)
Windows 10 64. KSP version 1.11.2 
Realchute and Realchute material extensions mods from CKAN

Problem is when i deployed a chute (either stock or realchute) and trying to repack it with engineer (i tryed to create kerbal-engineer lvl5 to reproduce bug) - it's said that i need engineer "lvl *" to repack.
It's due to option "only engineers in career mode can repack" or something like this. 
So if i enable option "only-engineer"  with lvl 0, for example, chute can't be repacked with message "only engineer can repack" without level.

This happens on russian vsersion of KSP. If i change language to English - everything works fine. Problem only with localized version of KSP.

I'm attaching player.log with reproducing this bug right after game start to minimaze strings in it.

player.log

Edited by Hunweibyn
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...