stupid_chris

[1.7] RealChute Parachute Systems v1.4.7.4 | 13/04/19

Recommended Posts

57 minutes ago, Starwaster said:

Not all chute parts do it. There's only one that I know of that does it. It's the one that is stack mounted and has two chutes in it and has an attach node on top. 

Cool.  Somehow I have it activated on my single unit chutes I did for the NAR MEM.  I probably copied the wrong code bits.  :D   Never really sure if it did anything, which now makes sense.

Share this post


Link to post
Share on other sites

@stupid_chris:

BUG: with the latest RC version, all stock parachutes drag as if semi-deployed before activation.  RC chutes work correctly. No physics-altering mods installed,.

I checked everything but could not find the root cause (part files, MM patches for RC and Tweakscale, compared to 1.3 configs - everything looks the same).

 

I wonder if anyone else experienced this?

Share this post


Link to post
Share on other sites

I am doing some fun experimenting and I'm wondering what stats I need to change to make chutes indestructible from aero and heat forces upon deployment.  I've messed with the breakingForce and torqueForce stats in the parts files, but not sure what limits I should/am able to put. 

Share this post


Link to post
Share on other sites
On 1/2/2018 at 7:47 PM, Tau137 said:

@stupid_chris:

BUG: with the latest RC version, all stock parachutes drag as if semi-deployed before activation.  RC chutes work correctly. No physics-altering mods installed,.

I checked everything but could not find the root cause (part files, MM patches for RC and Tweakscale, compared to 1.3 configs - everything looks the same).

 

I wonder if anyone else experienced this?

Absolutely can't reproduce this on my side. Remove every other mod and try this on a clean new game, if it still happens I'll take some logs and see whats up!

1 hour ago, Sarxis said:

I am doing some fun experimenting and I'm wondering what stats I need to change to make chutes indestructible from aero and heat forces upon deployment.  I've messed with the breakingForce and torqueForce stats in the parts files, but not sure what limits I should/am able to put. 

Change the maxTemp in the materials config, in the RealChute folder

Share this post


Link to post
Share on other sites
11 hours ago, stupid_chris said:

Absolutely can't reproduce this on my side. Remove every other mod and try this on a clean new game, if it still happens I'll take some logs and see whats up!

Change the maxTemp in the materials config, in the RealChute folder

Found it - TweakableEverything (parachute config and dll).  Removed, as there is no need for it with RC.  Thank you!

Share this post


Link to post
Share on other sites

Hello

Has RealChutes a variable for a kOS-Script that is the state of the parachute (dangerous,risky,ok).

I want to bring a rover to Eve, and check the state before deploy the Parachutes.

Eve destroyed my last rover because i have set the parachute deploy too high, and the Reentry-fire destroyed it. And with the signaldelay from RemoteTech it's hard to deploy it at the right point.

Share this post


Link to post
Share on other sites
55 minutes ago, Tau137 said:

Found it - TweakableEverything (parachute config and dll).  Removed, as there is no need for it with RC.  Thank you!

Ummm, if you looked at the configs, you would see that TweakableParachutes isn't installed if RealChutes is.  Look at the moduleManager.configcache file:


@PART[*]:HAS[@MODULE[ModuleParachute]]:FOR[TweakableEverything]:NEEDS[!RealChute,!FerramAerospaceResearch]
{
	MODULE
	{
		name = ModuleTweakableParachute
		deploymentFactor = 1
		semiDeploymentFactor = 2
	}
}

I'm postring results of some tests in the TweakableEverything thread

Share this post


Link to post
Share on other sites
2 minutes ago, linuxgurugamer said:

Ummm, if you looked at the configs, you would see that TweakableParachutes isn't installed if RealChutes is.  Look at the moduleManager.configcache file:



@PART[*]:HAS[@MODULE[ModuleParachute]]:FOR[TweakableEverything]:NEEDS[!RealChute,!FerramAerospaceResearch]
{
	MODULE
	{
		name = ModuleTweakableParachute
		deploymentFactor = 1
		semiDeploymentFactor = 2
	}
}

I'm postring results of some tests in the TweakableEverything thread

I have been suspecting that there is something odd about latest MM 3.0.1 (have been having issues with patches not being applied, error where were none before), but.... yes, need more testing, logs etc...

Share this post


Link to post
Share on other sites
6 minutes ago, Tau137 said:

I have been suspecting that there is something odd about latest MM 3.0.1 (have been having issues with patches not being applied, error where were none before), but.... yes, need more testing, logs etc...

At least in this case, nothing to do with MM.

The latest MM is a bit more strict on the syntax, errors which were ignored earlier are now being enforced.

@Tau137

See my post in the TweakableEverything thread about this and my tests

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
6 hours ago, linuxgurugamer said:

Ummm, if you looked at the configs, you would see that TweakableParachutes isn't installed if RealChutes is.  Look at the moduleManager.configcache file:



@PART[*]:HAS[@MODULE[ModuleParachute]]:FOR[TweakableEverything]:NEEDS[!RealChute,!FerramAerospaceResearch]
{
	MODULE
	{
		name = ModuleTweakableParachute
		deploymentFactor = 1
		semiDeploymentFactor = 2
	}
}

I'm postring results of some tests in the TweakableEverything thread

That means it has no state for kOS?

But can i use a original Parachute as indicator for the state, and read this out?

Share this post


Link to post
Share on other sites
Just now, SwissSpace93 said:

That means it has no state for kOS?

But can i use a original Parachute as indicator for the state, and read this out?

Huh?  Where did kOS come from? And waht do you mean about the “state”?

what it says is that the ModuleTweakableParachute will NOT be installed if either RealChute or FAR is installed

Share this post


Link to post
Share on other sites

I want to write a kOS-Script for my Eve Rover.

It must check the state of the Parachutes (info Menu "deploy safety"), because i want to know when it is safe to deploy the Parachutes. 

I can actually deploy Parachutes in a Dangerous deploy safety, when the Vessel is on The Reentry-Fire. The RealChutes are Deploying at the altitude i setup, even if the Vessel in Reentry. And heated up then the parachutes get destroyed! (KSP 1.3.0)

There is no Safetycheck to prevent this, but deploying in Space dont works and give a Message. I can deploy The Parachutes everytime in the Atmosphere and it get destroyed from the Heat.

Share this post


Link to post
Share on other sites

Anyone have a working config for adding realchute support to the two chutes in @RoverDude survival pack?  DERP_POD and DERP_RadialPara.  I tried copying another config, but had no luck getting it to work correctly.  I found some forum posts from 2014 talking about having problems between RealChutes and the DERP parts, but surely both mods have undergone some changes since then and hopefully whatever the problem was has been eliminated.   

 

This is the cfg for the derp pod...

PART
{
// --- general parameters ---
name = DERP_POD
module = Part
author = RoverDude

MODEL
{
	model = UmbraSpaceIndustries/SrvPack/DERP2/Assets/DERP_POD
	scale = 1,1,1
}
rescaleFactor = 1


// --- node definitions ---
// definition format is Position X, Position Y, Position Z, Up X, Up Y, Up Z, size
node_stack_bottom = 0.0, -0.05, 0.0, 0.0, -1, 0.0, 0

// --- FX definitions ---
	sound_parachute_open = activate
	sound_parachute_single = deploy
// --- editor parameters ---
TechRequired = survivability
entryCost = 5000
cost = 250
category = Pods
subcategory = 0
title = DERP Inflatable Escape Pod
description = Deployable Emergency Reentry Pod. A small inflatable escape pod with integrated parachute.  Survival not guaranteed.  Includes stores of packaged supplies, batteries, and a monopropellant tank.  Reaction wheels are controlled by bouncing against the sides of the pod vigorously.
// attachment rules: stack, srfAttach, allowStack, allowSrfAttach, allowCollision
attachRules = 1,0,0,0,0
breakingForce = 500
breakingTorque = 500
// --- standard part parameters ---
mass = 0.1
dragModelType = default
angularDrag = .25
crashTolerance = 45
maxTemp = 3400
bulkheadProfiles = size0
maximum_drag = .20
minimum_drag = .15
CoMOffset = 0,0,0
//bodyLiftMultiplier = 0
stageOffset = -1


	MODULE
	{
		name = LifeBoat
		dampenFactor = .75
		dampenSpeed = 35
	}

	MODULE
	{
		name = ModuleStoredResource
		ResourceName = Supplies
		Amount = 15
	}
	MODULE
	{
		name = ModuleStoredResource
		ResourceName = MonoPropellant
		Amount = 10
	}	
	

    vesselType = Ship
    MODULE
    {
        name = ModuleCommand
        minimumCrew = 1
    }

    INTERNAL
    {
        name = mk1PodCockpit
    }

    MODULE
    {
        name = ModuleSAS
    }

    MODULE
    {
        name = ModuleReactionWheel

        PitchTorque = 0.1
        YawTorque = 0.1
        RollTorque = 0.1

        RESOURCE
        {
            name = ElectricCharge
            rate = 0.01
        }
    }

    RESOURCE
    {
        name = ElectricCharge
        amount = 50
        maxAmount = 50
    }

	MODULE
	{
		name = ModuleAblator
		ablativeResource = Ablator
		lossExp = -9000
		lossConst = 20
		pyrolysisLossFactor = 10000
		reentryConductivity = 0.01
		ablationTempThresh = 500
	}

	MODULE
	{
		name = ModuleScienceContainer
	
		reviewActionName = Review Stored Data
		storeActionName = Store Experiments
		evaOnlyStorage = True
		storageRange = 1.3
	}
	
	ResourceName
	{
		name = Ablator
		amount = 50
		maxAmount = 50
	}

MODULE
{
  	name = ModuleParachute
	invertCanopy = true
	autoCutSpeed = 0.5
	capName = ParaCap
	canopyName = String
	semiDeployedAnimation =  PodChutePartial
	fullyDeployedAnimation = PodChuteFull
	stowedDrag = 0.22
	semiDeployedDrag = 2
	fullyDeployedDrag = 300
	minAirPressureToOpen = 0.02
	clampMinAirPressure = 0.02
	deployAltitude = 2500
	deploymentSpeed = 0.16667
	semiDeploymentSpeed = 0.5
	chuteMaxTemp = 2200
	chuteThermalMassPerArea = 0.08
}


	MODULE
	{
		name = ModuleDragModifier
		dragCubeName = SEMIDEPLOYED
		dragModifier = 4
	}
	MODULE
	{
		name = ModuleDragModifier
		dragCubeName = DEPLOYED
		dragModifier = 8
	}
	
	
}

 

So I tried do this but it just throws an error when the parachute is deployed.  

@PART[DERP_POD]:FOR[RealChute]
{

	@category = none
	@mass = 0.05
	!sound_parachute_open
	!sound_parachute_single

	!MODULE[ModuleParachute]{}

	MODULE
	{
		name = RealChuteModule
		caseMass = 0.05
		timer = 0
		mustGoDown = true
		cutSpeed = 0.5
		spareChutes = 0

		PARACHUTE
		{
			material = Nylon
			preDeployedDiameter = 1.2
			deployedDiameter = 25
			minIsPressure = false
			minPressure = 6000
			deploymentAlt = 600
			cutAlt = -1
			preDeploymentSpeed = 1
			deploymentSpeed = 4
			preDeploymentAnimation = PodChutePartial
			deploymentAnimation = PodChuteFull
			parachuteName = String
			capName = ParaCap
		}
	}

	MODULE
	{
		name = ProceduralChute
	}

	EFFECTS
	{
		rcpredeploy
		{
			AUDIO
			{
				channel = Ship
				clip = sound_parachute_open
				volume = 1
			}
		}

		rcdeploy
		{
			AUDIO
			{
				channel = Ship
				clip = sound_parachute_single
				volume = 1
			}
		}

		rccut
		{
			AUDIO
			{
				channel = Ship
				clip = RealChute/Sounds/sound_parachute_cut
				volume = 1
			}
		}

		rcrepack
		{
			AUDIO
			{
				channel = Ship
				clip = RealChute/Sounds/sound_parachute_repack
				volume = 1
			}
		}
	}
}

 

[EXC 06:11:13.177] NullReferenceException: Object reference not set to an instance of an object
	RealChute.Parachute.PreDeploy ()
	RealChute.Parachute.UpdateParachute ()
	RealChute.RealChuteModule+<>c.<FixedUpdate>b__97_2 (RealChute.Parachute p)
	System.Collections.Generic.List`1[RealChute.Parachute].ForEach (System.Action`1 action)
	RealChute.RealChuteModule.FixedUpdate ()

 

Any ideas on what else I can try?

Share this post


Link to post
Share on other sites

I can't get realchutes to work. Everytime I load, it stops loading at one point. Could anybody please help me?

Here is a mod list

BDB

Comorant Aeronology

Trajectories

Better Burn Time

EVE

SVE

Scatterer

RCS Build Aid

KSP Interstellar Extended

Module Manager

and some other I can't remember.

Share this post


Link to post
Share on other sites
6 hours ago, JEB'S DESTINY said:

I can't get realchutes to work. Everytime I load, it stops loading at one point. Could anybody please help me?

Here is a mod list

BDB

Comorant Aeronology

Trajectories

Better Burn Time

EVE

SVE

Scatterer

RCS Build Aid

KSP Interstellar Extended

Module Manager

and some other I can't remember.

On the very first page is a list on what you need to get support (for example, logs) and how to find those things (like, where to find your logs). Your post doesn't give enough information for anyone to help you. You don't have what version of KSP, or when your getting an error, or what the error message is. You didn't even list the mods you had but provided a few and that you can't remember the others. Is that list all but one of your mods or do you have 200 others? 

I'm not the mod developer, but I try to help out other players when I can. Remember that mod authors don't get paid for their hard work. If you want help, please spend the time to at least read the first post, provide what the author asks for, and be patient. Help us help you. 

Share this post


Link to post
Share on other sites

Well, I'm playing on version 1.3.1, and it stops on the loading bar at BDB mercury parachutes.

Share this post


Link to post
Share on other sites
54 minutes ago, JEB'S DESTINY said:

Well, I'm playing on version 1.3.1, and it stops on the loading bar at BDB mercury parachutes.

That's a step in the right direction! Alas, you still need to copy down a full list of the mods you are using and grab the logs - shut down KSP *immediately* after the freeze occurs, then go find them! Once you have them, upload them to any of many free hosting sites and post the link here so people can have a look.

Good luck!

Share this post


Link to post
Share on other sites
8 hours ago, JEB'S DESTINY said:

Should I install with a clean version of KSP?

Not at this stage, no. It's the quickest and easiest solution, but you might well end up with the same problem later and still no wiser as to what is causing it.

Share this post


Link to post
Share on other sites
On 5/26/2016 at 9:37 AM, Insanitic said:

So I have a weird problem with parachutes cutting midair automatically

Over land, the parachutes work perfectly. The chutes cut ONLY once I touch the ground. 

But over water, no matter what I do with the settings, the chutes cut mid air at around 30 to 50 metres, making my craft plummet and disintegrate into the water. 

Has anyone else experienced this? There are no null exceptions error messages or anything in the debug log. 

Here's my mod list:

  Reveal hidden contents

000_Toolbar                         
[+] 000_USITools                        
[+] AJE                                 
[+] B9AnimationModules                  
[+] B9PartSwitch                        
[+] B9_Aerospace                        
[+] BodyLoader                          
[+] Chatterer                           
[+] CommunityResourcePack               
[+] ContractConfigurator                
[+] ContractPacks                       
[+] CrossFeedEnabler                    
[+] DecayingRTGs                        
[+] DistantObject                       
[+] DMagicOrbitalScience                
[+] DMagicScienceAnimate                
[+] DMagicUtilities                     
[+] EditorExtensionsRedux               
[+] EngineLight                         
[+] EnvironmentalVisualEnhancements     
[+] FerramAerospaceResearch             
[+] Firespitter                         
[+] FShangarExtender                    
[+] FuelTanksPlus                       
[+] FuelWings                           
[+] InterstellarFuelSwitch              
[+] JSI                                 
[+] KAS                                 
[+] KerbalEngineer                      
[+] KerbalJointReinforcement            
[+] KerbalScienceFoundation             
[+] Kerbaltek                           
[+] KIS                                 
[+] Kopernicus                          
[+] KWRocketry                          
[+] MagicSmokeIndustries                
[+] ModularFlightIntegrator             
[+] ModularFuelTanks                    
[+] MyFlag                              
[+] NavBallDockingAlignmentIndicator    
[+] NavyFish                            
[+] NearFutureConstruction              
[+] NearFutureElectrical                
[+] NearFutureProps                     
[+] NearFuturePropulsion                
[+] NearFutureSolar                     
[+] NearFutureSpacecraft                
[+] OPM                                 
[+] ProceduralDynamics                  
[+] ProceduralFairings                  
[+] ProceduralParts                     
[+] RealChute                           
[+] RealPlume                           
[+] RealPlume-Stock                     
[+] RemoteTech                          
[+] REPOSoftTech                        
[+] RLA_Stockalike                      
[+] RW Saturatable                      
[+] SCANsat                             
[+] scatterer                           
[+] ShipManifest                        
[+] Sigma                               
[+] SmokeScreen                         
[+] SolverEngines                       
[+] StageRecovery                       
[+] StationScience                      
[+] StockBugFixPlus                     
[+] StockVisualEnhancements             
[+] SurfaceExperimentPackage            
[+] Tantares                            
[+] TantaresLV                          
[+] TextureReplacer                     
[+] ThrottleControlledAvionics          
[+] ThunderAerospace                    
[+] Trajectories                        
[+] TriggerTech                         
[+] TweakScale                          
[+] UmbraSpaceIndustries                
[+] UniversalStorage                    
[+] VenStockRevamp                      
[+] [x] Science!                        
 

 

Well it's been a year, and it doesn't look like anybody replied to this guy. I'm having the same problem -- my chutes always cut at around 30m, regardless of speed. I set them to arm, they deploy just fine, and I'm floating down at anywhere from 3 to 6 m/s. Then, at 30m, like clockwork every time, the chutes cut, and everybody dies.

I've tried tweaking the settings on the chutes, but to no avail. I'm on 1.3.1, using RealChute 1.4.5.

Share this post


Link to post
Share on other sites
8 hours ago, requimrar said:

Well it's been a year, and it doesn't look like anybody replied to this guy. I'm having the same problem -- my chutes always cut at around 30m, regardless of speed. I set them to arm, they deploy just fine, and I'm floating down at anywhere from 3 to 6 m/s. Then, at 30m, like clockwork every time, the chutes cut, and everybody dies.

I've tried tweaking the settings on the chutes, but to no avail. I'm on 1.3.1, using RealChute 1.4.5.

The most likely reason there was no reply is that there isn't enough to go on. No log, no ModuleManager.ConfigCache file... just two guys (NOW... back then it was one guy) saying they have this problem. That makes this an edge case. And Chris doesn't even want to try to support unless logs are provided. That's his call and he's not alone among modders. He even says explicitly in big bold red underlined letters on the front post that he requires logs to do support. It's not the end user's place to second guess that and decide not to provide logs.

Maybe if this happened more often and there were SOMETHING to indicate a starting point but there's not. Where do you suggest to start looking for the cause? Pretend you're the modder in charge and think about the information being provided.

P.S. Not trying to rag on you but seriously... given the lack of data here, where the heck do you start.

P.P.S. Suggestion. Start with a clean install with just Module Manager and Real Chute. Duplicate the problem. If it's duplicated, logs, ModuleManager.ConfigCache and a save file. If you can't duplicate it, re-add one mod at a time until the problem happens. Reproduce the problem with the absolute minimum amount of mods to make it happen (assuming it doesn't happen with stock + RC) and then provide those files. Then MAYBE someone can try to figure something out for you.

Edited by Starwaster

Share this post


Link to post
Share on other sites

Before I ask for support, I want to make sure I'm using this mod correctly - if someone could tell me my assumptions are right, that would be appreciated.

I'm trying to use parachutes to recover the first stage of a rocket, and have added a drogue chute and a main chute (separate parts) to the booster.

Both chutes stage when the booster decouples - this deploys the drogue, and arms the main chute (main is set to "Must go down to deploy", drogue is not).

When the booster starts descending, the main chute SHOULD deploy as well?

This should work whether or not the booster has a probe core, I assume?

 

edit: OK, I found the problem - the parachute isn't deploying because realchutes thinks it's in a fairing, although it's just attached to the side of the booster - the problem only occurs when using realchute parts, not the stock parts with realchute options.

In case it's useful, log attached here: https://drive.google.com/open?id=1gxjklVT9eb8pW9Mr4vtlppaPbFyHOyPR -

Edited by S4qFBxkFFg

Share this post


Link to post
Share on other sites

For some time I have not been able to find any of the parachutes using the VAB search box and it seems some other people are having the same issue, so today I took some time to search in the code and found the problem.
All parachutes are set to "category = none" and, for some reason that I don't know, makes them unsearchable. To solve that I changed all categories to the game default "category = Utility".

This change had no negative side effects in my game, but I have some other mods like Community Category Kit and I don't know if there is a reason for those lines, so further testing might be necessary. Below are the files that I made these changes.

RealChute\Parts\cone_double_chute.cfg
RealChute\Parts\radial_chute.cfg
RealChute\Parts\stack_chute.cfg
RealChute\Parts\cone_chute.cfg

category = Utility

RealChute\ModuleManager\Stock_RealChute_MM.cfg

(delete all lines with) @category = none

I hope it helps.

Share this post


Link to post
Share on other sites
13 hours ago, GFX5000i said:

For some time I have not been able to find any of the parachutes using the VAB search box and it seems some other people are having the same issue, so today I took some time to search in the code and found the problem.
All parachutes are set to "category = none" and, for some reason that I don't know, makes them unsearchable. To solve that I changed all categories to the game default "category = Utility".

This change had no negative side effects in my game, but I have some other mods like Community Category Kit and I don't know if there is a reason for those lines, so further testing might be necessary. Below are the files that I made these changes.

Real Chute creates a category for parachutes. It sets the category to none in the config file to prevent chutes from showing up twice. 

If one of your other mods is doing something with PartCategorizer in a way that prevents RC from creating is category or deleting it then RC chutes won't appear at all.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.