stupid_chris

[1.7] RealChute Parachute Systems v1.4.7.4 | 13/04/19

Recommended Posts

6 hours ago, Tai said:

Hmm...  The previous version worked fine on the same localization, but thanks for the advice, I'll try.

UPD: Yes. It worked. Сhange of localization helped.  

UPD#2 "Filter By Module" works with my localization and i can use RealChute parachutes. @Starwaster tnx

Well as @stupid_chris says, something changed in the update... I'm trying to wrap my head around exactly where and what but I need more coffee....

Share this post


Link to post
Share on other sites

If you place these chutes inside the new MH SM-6A Service Module part then even after you set that part's Enable Cutaway to ON or alternatively bind jettison shrouds to an action key or even do both these things then the chutes will not deploy due to still being seen as "parachute is inside fairings".

Edited by Kaa253

Share this post


Link to post
Share on other sites
39 minutes ago, Kaa253 said:

If you place these chutes inside the new MH SM-6A Service Module part then even after you set that part's Enable Cutaway to ON or alternatively bind jettison shrouds to an action key or even do both these things then the chutes will not deploy due to still being seen as "parachute is inside fairings".

Sounds like an issue with their shielding system. Real Chutes doesn't decide whether or not its parts are shielded. That's between KSP and whatever given mod is doing the shielding.

All RC does is look at a property that says shielded or not shielded (part.ShieldedFromAirstream) and behaves accordingly.

@stupid_chris On another note, it looks like something changed with screen messaging because I'm not seeing those. I'll see if I can look into that a little later.

Share this post


Link to post
Share on other sites
Just now, Starwaster said:

That's between KSP and whatever given mod is doing the shielding.

The problem is that the "mod" in this case is Squad's Making History DLC. I just stick the chute on the outside of SM-6A Service Module part and its fine. Actually I tuck it in under the docking port.

Share this post


Link to post
Share on other sites
43 minutes ago, Kaa253 said:

The problem is that the "mod" in this case is Squad's Making History DLC. I just stick the chute on the outside of SM-6A Service Module part and its fine. Actually I tuck it in under the docking port.

Then I stand corrected on the 'mod' portion but stand by the statement in general :) 

I don't have the DLC btw so can't test anything to do with it :( 

Share this post


Link to post
Share on other sites

I just hope it doesn't cause you too much grief from every second person reporting it as this is the new DLC "stock" part with the bad shielding descriptor and my guess is it is a generally attractive place to go stick parachutes inside. If the code works the way you say and I am absolutely sure it does then it would presumably count as a stock bug.

kH4kpKL.png

Share this post


Link to post
Share on other sites
2 minutes ago, Kaa253 said:

I just hope it doesn't cause you too much grief from every second person reporting it as this is the new DLC "stock" part with the bad shielding descriptor and my guess is it is a generally attractive place to go stick parachutes inside. If the code works the way you say and I am absolutely sure it does then it would presumably count as a stock bug.

 

Can you describe for me how you set it up in the VAB?

For instance is it like the original stock fairings where you  have to build the panels or do you attach them as separate pieces?

Also, how do the stock chutes behave when placed inside?

Lastly, can you send me your ModuleManager.ConfigCache file? If I can SEE how the part is configured, maybe I can figure out some kind of workaround...

Share this post


Link to post
Share on other sites

I installed RealChute into a stock un-modded copy of KSP 1.4.1 that I keep for testing mod bugs.
To my surprise I could not reproduce the problem to begin with.
Then I discovered the specific conditions required to reproduce the bug are a little, but significantly, different from what I understood yesterday.

The new "service module" has a shroud on/off button in the VAB to allow installing parts inside. Also in the VAB in the actions for that part there is "Jettison Shroud" two of them, one for the each of the shrouds pair. These can be bound to an action key. In flight there is an "Enable cutaway" on/off button. This in-flight view does not actually jettison the shroud it only enables visibility of what is inside (something like the IVA view toggle perhaps). So it could cause confusion as it looks like the shroud is gone but it is still there just rendered invisible.

Now the final and important part of the puzzle. It is definitely a stock bug. If you use the action key to jettison the shrouds then the game shows the animation of the shrouds being jettisoned but the jettisoned state is apparently not being set as the chutes (both stock and/or RealChutes) will complain of still being stowed! However if you jettison the shrouds through staging (i.e. spacebar) then the chutes will deploy just fine!

I have created a report on the Squad bug tracker https://bugs.kerbalspaceprogram.com/issues/18202. Hopefully I have got the steps to reproduce precisely defined now. Sorry to have effectively accused RealChutes of a bug when the problem is really with Squad and my insufficiently careful bug testing. Yesterday I didn't recognise that I had not reproduced the conditions exactly the same to see that it affects stock chutes just the same.

 

Edited by Kaa253

Share this post


Link to post
Share on other sites

Has anyone with realchute installed played any of the DLC missions?  The second mission for me won't actually deploy the chutes.  They never show red/yellow/green, and make the noise to deploy, but don't actually do anything.  Wondering if anyone else has seen this?

Share this post


Link to post
Share on other sites
3 minutes ago, mavric1298 said:

Has anyone with realchute installed played any of the DLC missions?  The second mission for me won't actually deploy the chutes.  They never show red/yellow/green, and make the noise to deploy, but don't actually do anything.  Wondering if anyone else has seen this?

LOGS

Share this post


Link to post
Share on other sites

@Starwaster Squad needs to stop doing microhanges to their API every single update <.< I don't really have time to dig into something complicated either right now :| If it works without localization it'll have to do

Share this post


Link to post
Share on other sites

When a 1.4.2 with Making History DLC RealChute is made, may I request a texture variant for the stack chute be made to match the MK2 two kerbal command pod?  

Edited by jpkerman

Share this post


Link to post
Share on other sites

@stupid_chris

Could it be, that real chutes sometimes do not take their configuration with them? I almost lost a EVE lander because it suddenly had the chutes on default settings vs carbon chutes at max size. But I am not totally sure if I maybe really accidently forgot to configure them, that time. I will do some testing, if I find some spare time.
Things that could be problematic are for example (a) copy a chute in editor (b) taking it from a subassembly (c) remount it in flight to another vessel with kis (d) selecting multiple (non symmetric) chutes in the editor with action groups extended and tweak the parameters (e) unmount it with KIS and put it into KIS inventory.
That it's not possible to keep the configuration on (e) I can imagine. But in the other cases it would be great if the chute can keep it's configuration.

 

Share this post


Link to post
Share on other sites

Hey guys, 

Have a question regarding the mod. Am I stupid or is there no way to change to predeployment pressure when you are in VAB? It is extremely tedious to fix it every time you go to launchpad.. I have to change this for 10+ chutes everytime I'm on the launchpad..

Would it be possible to add the function? In VAB all I get when I click the "toggle info" is just that, info. Would save ALOT of time if you could change the setting for just 1 chute then copy that chute to other placements and have the settings saved with the saved ship.

Other than that, LOVE this mod m8 - cheers

Edited by Schmelge

Share this post


Link to post
Share on other sites
3 hours ago, Schmelge said:

Hey guys, 

Have a question regarding the mod. Am I stupid or is there no way to change to predeployment pressure when you are in VAB? It is extremely tedious to fix it every time you go to launchpad.. I have to change this for 10+ chutes everytime I'm on the launchpad..

Would it be possible to add the function? In VAB all I get when I click the "toggle info" is just that, info. Would save ALOT of time if you could change the setting for just 1 chute then copy that chute to other placements and have the settings saved with the saved ship.

Other than that, LOVE this mod m8 - cheers

Click on the Action Group editor button in the VAB/SPH and then click the chute part you want to edit. If you are playing career mode then your VAB/SPH must be upgraded before you can use the AG editor edit the chutes.

Share this post


Link to post
Share on other sites
9 hours ago, Starwaster said:

Click on the Action Group editor button in the VAB/SPH and then click the chute part you want to edit. If you are playing career mode then your VAB/SPH must be upgraded before you can use the AG editor edit the chutes.

Omg.. Thank you so very very much man!!! I had no idea. Is there a manual somewhere for realchute? like a wiki or something that goes through every setting in the mod? Would be very handy.

again, thanks, this solved my whole dilemma! 

Share this post


Link to post
Share on other sites
4 hours ago, Schmelge said:

Omg.. Thank you so very very much man!!! I had no idea. Is there a manual somewhere for realchute? like a wiki or something that goes through every setting in the mod? Would be very handy.

again, thanks, this solved my whole dilemma! 

No wiki (well there is but it only has a little section on updating to a save breaking version of RC)

But the first post has a FAQ and I think this was the very first question man. Or maybe the second

And a video that shows you how to do these things.

Always always read the FAQ. Or one day you might ask question and instead of Nice Starwaster you might get Evil Starwaster who simply replies, "Hey, space is a tough place where wimps eat flaming plasma death."

Or I might do that anyway because, you know... cool quote and all.

Share this post


Link to post
Share on other sites
14 hours ago, Starwaster said:

No wiki (well there is but it only has a little section on updating to a save breaking version of RC)

But the first post has a FAQ and I think this was the very first question man. Or maybe the second

And a video that shows you how to do these things.

Always always read the FAQ. Or one day you might ask question and instead of Nice Starwaster you might get Evil Starwaster who simply replies, "Hey, space is a tough place where wimps eat flaming plasma death."

Or I might do that anyway because, you know... cool quote and all.

It was literally the first question in FAQ... I appologize for my universe sized stupidness.

And yes it was a pretty cool quote :P

Share this post


Link to post
Share on other sites

Two things here:

a) Noticed that it has been reported multiple times already, not sure if it was actually noticed, but parts material settings are not being copied to symmetrical parts when it copies all the other settings.  Same issue when mounting a single chute, adjusting its settings, then picking it up in build mode, and placing it back down with symmetry - all of the non-material settings are saved, but material defaults to Nylon on all but the first selected/placed chute.  I can add logs as well if needed next time I run the game, but as it had already been mentioned I was primarily looking to see if it had actually been looked into at all yet, as there is no issue report on Github for it. (again, I can create one there with logs after I run again).

b) How are/were the values for the various materials calculated originally?  What prompted me to look closer was the text description for Silk being "weak" and "cheap", when in actuality it is just the reverse :P  The reason that most military chutes swapped from Silk to Nylon was due to supply shortages of natural silk during WW2, and Nylon was "the next best thing" available at the time - and the only reason we KEPT using Nylon is because it is drastically CHEAPER than Silk.  (Yes, Nylon has a higher "total failure" temperature as well, but it has a "full effectiveness" temperature significantly LOWER than silk - silk tends to work nearly 100% until just short of failure from temperature, and then critically disintegrate all at once...) 

Silk is also STRONGER than Nylon per weight/thickness as well - an equivalent canopy load rating made from silk is about 2/3 the mass of the same load capability in Nylon, and significantly "thinner" (one issue that I think might have caused some of the discrepancy in the values used - while parachute silk cloth does have a higher mass per CUBIC meter than the ripstop Nylon used for parachute cloth, it has a lower mass per SQUARE meter, because it is thinner for the same strength...).

Finally, ALL of the actual values used for density, max temp, and specific heat appear to be off in the listed materials definitions - not just in relation to each other, but also in relation to real-world material values.  And yes, I know that KSP gets "nerfed" in a lot of its mass values especially, but I thought that this was being done in the case mass (which was described to include all the "other stuff" besides the canopy itself).

If desired, I could work out all the math for all the materials (I only directly looked at Silk and Nylon so far) based on the material information from the US Naval Weapons Center "Parachute Recovery Systems Design Manual" - it has full specs and requirements for not only Nylon, Silk, and Kevlar, but also for Cotton Canvas, Rayon, Dacron, Nomex, E Glass, and Graphite (which is particularly interesting because of its complete lack of stretching under tension and a useful temperature up to 2,760 C - hellaciously expensive and slightly heavier than kevlar though).  The same source has a bunch of information on masses for the other components in the system, effectiveness of various shapes, etc etc, but the only thing that I can see directly being applicable is the canopy materials info, since we don't have multiple canopy shapes implemented, and case mass is already a sort of fudge-factor for KSP anyway...

Share this post


Link to post
Share on other sites

Is there a way to have the lines on the drogue chute longer? The distance of the main chute looks perfect but to me the drogue looks way too close to the vehicle. Would look way better to have it out at least halfway between the vehicle and the main chute distance wise. Would be super cool if the line length was adjustable.

Edited by MikeO89

Share this post


Link to post
Share on other sites

Is there any way to permanently disable the "parachute is in fairings" limitation? I'm running FAR so the stock aero shielding is somewhat irrelevant, but I keep getting this if I place radial chutes too close to engine shrouds or cargo bays.
I can remove the shielded state from the save file with sed, but it's a bit bothersome when I'm in the middle of landing a spaceplane and my drag chutes refuse to deploy...
I don't see a shieldedCanActivate or shieldedCanDeploy line in the part configs as I do with engines & landing gear,  is there something similar for RealChuteModule that I can get at with modulemanager?
KSP 1.3.1 & RealChute 1.4.5, FWIW.

Share this post


Link to post
Share on other sites

I had a crazy idea for a parachute design for a rocket.. an this involves the "Parasail type that come with the Personal parachutes.. What if there were a way to attack a chute that would function like the personal parachute and allow us to steer a  rocket to a safe landing..

 

I know sounds crazy.. but, you never know!

Share this post


Link to post
Share on other sites

Hello. I installed this mod and the first Mk26 chute seems to take a hell of a lot more to slow down the capsule (like +5k meters). Is this normal?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.