stupid_chris

[1.7] RealChute Parachute Systems v1.4.7.4 | 13/04/19

Recommended Posts

I have a question. Is there something in this plugin that could cause the text area at the top center of the screen in the VAB/SPH to disappear, and not allow text entry? If I click on the area it pulls down the gray window for writing a craft description, but I still can't type anything there, nor can I type a ship name. The save button works fine, but I need to have more ships available to me than just one 'Untitled Space Craft'. :)

The only reason I mention it here is that this problem started when the game updated to 0.23 AND when I installed RealChute (as well as a few other new-to-me mods) at the same time.

Anyway, is anyone else having a similar problem? I'm not saying I'm SURE that it's this mod, I'm just saying it MIGHT be, since the problem started around the same time as I started using this one.

I have quite a few other mods as well, so I'm simply starting my investigation here. :)

Later.

are you in windowed mode? what happens if you press alt-Enter

Share this post


Link to post
Share on other sites
are you in windowed mode? what happens if you press alt-Enter

Nope, fullscreen. I don't ever play games in windowed mode, so I've never really used alt-enter. I have no idea what happens. :)

Share this post


Link to post
Share on other sites

I'm experiencing situations where chutes don't deploy or disarm after being armed. Possibly after hitting deployment altitude. Not quite sure about that because I didn't see when it happened....

(version 0.3.2.1)

Share this post


Link to post
Share on other sites
I'm experiencing situations where chutes don't deploy or disarm after being armed. Possibly after hitting deployment altitude. Not quite sure about that because I didn't see when it happened....

(version 0.3.2.1)

I think I just had this happen too. I was getting awfully close to the ground and they weren't deployed even for predeployment. Had to manually arm them again then they popped. I already staged them and they didn't go.

Share this post


Link to post
Share on other sites
Might be a bug, probably just me, any time i have any of the chutes selected and drag over a part that's on some amount of symmetry, the game crashes. It's when the game automatically switches my symmetry to match what i'm hovering the mouse over. Like I start with 1x, and with a chute being held, i drag to some 4x symmetry tanks and when it goes to switch to 4x, it freezes and never unfreezes.

also I can't set any full deployment altitudes lower than 1500. they start lower than that, but when i try to drag lower than 1500 it just goes to zero.

otherwise much better than stock chutes for sure.

For the first part, I'll need a little more info than this, as well as your KSP log and your output_log.txt

For the second part, that's tweakables themselves, I can't do anything about it unfortunately. It'S a bug in the game.

I have a question. Is there something in this plugin that could cause the text area at the top center of the screen in the VAB/SPH to disappear, and not allow text entry? If I click on the area it pulls down the gray window for writing a craft description, but I still can't type anything there, nor can I type a ship name. The save button works fine, but I need to have more ships available to me than just one 'Untitled Space Craft'. :)

The only reason I mention it here is that this problem started when the game updated to 0.23 AND when I installed RealChute (as well as a few other new-to-me mods) at the same time.

Anyway, is anyone else having a similar problem? I'm not saying I'm SURE that it's this mod, I'm just saying it MIGHT be, since the problem started around the same time as I started using this one.

I have quite a few other mods as well, so I'm simply starting my investigation here. :)

Later.

Same as above, I'll need your output_log.txt and your KSP log, as well as a little more info for me to try to reproduce it.

Love the new version Chris. I also have the trouble with adjusting the deployment altitude tweakable. Is there a fine control for adjusting tweakables that anyone knows of?

Tweakables are made this way unfortunately, I did the best I could to allow as much control as I wanted, but the system is very innacurate in itself.

I'm experiencing situations where chutes don't deploy or disarm after being armed. Possibly after hitting deployment altitude. Not quite sure about that because I didn't see when it happened....

(version 0.3.2.1)

I think I just had this happen too. I was getting awfully close to the ground and they weren't deployed even for predeployment. Had to manually arm them again then they popped. I already staged them and they didn't go.

Again, both logs would be greatly appreciated, as well as which parachute is faulty here, a few screenies of the problem and as much info as you can gather. I can't pin down bugs from only this info unfortunately.

Share this post


Link to post
Share on other sites

Chris I'll get it to you later tonight along with the config file of the chute but honestly, the output log is pretty sparse around that time. Otherwise I'd have included any relevant output.

Share this post


Link to post
Share on other sites
Chris I'll get it to you later tonight along with the config file of the chute but honestly, the output log is pretty sparse around that time. Otherwise I'd have included any relevant output.

It mostly feels like a manual/tweakables/perception error to me. I haven't touched deployment code over the last update. But anyway, the KSP log would allow me to see when the parts were activated/deactivated, everything is stored in there, and the output_log would indicate any nullref, so without them I can't determine much.

Share this post


Link to post
Share on other sites

My game doesn't actually crash, it just freezes forever and I have to force quit it. Can I still get crash logs?

Here's what I do to make it happen. I start with something like this

screenshot10_zps681f1f90.png

then I can add the chutes with 1x symmetry so i would have to put one on each tank. this works fine and nothing bad happens

screenshot11_zps1f2ae865.png

I can even add them at 4x symmetry and it's fine. as long as the symmetry option matches what it's going on, 4x to 4 tanks here. these add just fine.

screenshot13_zpsf573822b.png

But, if I try and take them a any other option besides 4x such that the game changes my option to match what i hover over, it'll freeze. so here's one chute at 2x

screenshot15_zpscdf04866.png

and then i go to add and it changes to 4x to match the tanks, and it gets stuck like this.

screenshot13_zpsf573822b.png

I'm on OSX (most recent mavericks) so I get rainbow wheel and it never unfreezes so I have to force quit it. Haven't tried linux version. it's not really an issue as long as I avoid it. It usually gets me when I'm not intending to add to something and I happen to hover over it and cause the freeze.

i'll have to try to recreate the no chutes opening thing. I tried again and it didn't happen this time. It was the blue radial chute that was doing it. My craft had mod parts on it when it happened though, the one i just tried didnt so, who knows. that's not too big a deal as I can always just set an action group or do it manually. The stage with the chutes is activated but they don't change to the armed color. It was probably below 40,000m which is the initial deployment. But I just went and deployed them at like 1000m and they worked so i'm not sure what I did to make that happen.

Edited by kanelives

Share this post


Link to post
Share on other sites

I'll look into that. Your logs would be appreciated, those are always generated, a crash file is not necessary.

EDIT:

Okay, I repeated exactly as you did above and it didn't crash. Trying doing the same thing but with other parts. Try as many as you are willing to and see if you can get that to repeat with other parts. I'm guessing it's either another mod doing that, or two mods conflicting.but over here, MJ + RealChute + KER is nominal.

Edited by stupid_chris

Share this post


Link to post
Share on other sites
Forgive me, but did you remove some of the parachute models?

I can't seem to find this one. -snip-

That is not a RealChute model my friend, this is the parachute from sumghai's SDHI service module :)

Share this post


Link to post
Share on other sites

This is what the mod is really missing. Did you make a compatible version of this for your mod and with your chute effects? If not, can you? Also, I had an issue with converting the stock parachutes to realchutes, they didn't have the effects or second state (the cap didn't disappear to show the "store chute here" part).

Share this post


Link to post
Share on other sites
This is what the mod is really missing. Did you make a compatible version of this for your mod and with your chute effects? If not, can you? Also, I had an issue with converting the stock parachutes to realchutes, they didn't have the effects or second state (the cap didn't disappear to show the "store chute here" part).

you probably have to set the capname to whatever the transform is that the stock parts use

Share this post


Link to post
Share on other sites

Hi, I would like to report a few bugs:

1. The small stack chutes have their model distorted (they are too tall), and stacking two small stack chutes results in some unsightly clipping (the nodes are inside the model).

Setting

scale = 0.425, 0.425, 0.425

instead of scale = 0.425, 0.6, 0.425 in the relevant cfgs fixes this, with no obvious adverse effects.

2. stacking large stack chutes results in some unsightly clipping (same as above, but the model is not distorted).

Setting


node_stack_top = 0.0, 0.1534, 0.0, 0.0, -1.0, 0.0, 0
node_stack_bottom = 0.0, -0.1534, 0.0, 0.0, -1.0, 0.0, 0
node_attach = 0.0, -0.1534, 0.0, 0.0, 1.0, 0.0

instead of the current +/- 0.1304 fixes this with no obvious adverse effects.

3. The parachute covers on both small and large stack chutes are swapped: pre-deploying the main parachute jettisons the 2nd cover, and pre-deploying the 2nd parachute jettisons the main cover.

4. While the small main stack parachutes are fine, the large main stack parachutes still clip (having dual triple parachutes looks very weird anyway, perhaps this part could use single canopies instead of triple ones).

5. When cutting one of the parachutes on a stack parachute, the parachute line will remain at an angle to the vertical.

6. Changing the diameter has no effect on the diameter of the parachute model. This is probably intended/known, but then you mentioned this feature in this post (I like the idea by the way. I don't think square rooting the value would make much sense though (m^(1/2) ?)).

7. I think the System.Threading.Tasks namespace is unused in RealChuteModule.cs.

I would have filed them on github, but then the relevant configs for bugs 1 through 4 are not up to date.

Share this post


Link to post
Share on other sites
This is what the mod is really missing. Did you make a compatible version of this for your mod and with your chute effects? If not, can you? Also, I had an issue with converting the stock parachutes to realchutes, they didn't have the effects or second state (the cap didn't disappear to show the "store chute here" part).

sumghai's SDHI service module is already compatible and dependant on RealChute so no need to :) If you want to make the stock parachute compatible with RealChute, just use the included stock MM file.

-snip-

Alright let's go through steps:

1: Intended, Else the models just looked way too small to be logical.

2: Intended as well, allows for better merging on top of pods.

3: Barely a detail, but I'll fix it.

4: There's no god way to pull the parachutes from each other, for now it's barely a forced orientation, I can't do much about it. I was hesitating between two single canopies or two triple canopies, I'll look over in the future if I want to swap back, the single canopies were overly large for their job.

5: Can you expand on the idea? If you mean that when cutting one parachute, it doesn't turn over to the other side, I haven't seen that.

6: No it doesn't because it's not implemented.

7: Yeah it's not, like a bunch of things, doesn't really change anything.

Share this post


Link to post
Share on other sites

WOuld you mind doing a quick MM file for THIS mod? I would do it myself but I'm not at my PC right now and it would be neat if you could do the file :)

Share this post


Link to post
Share on other sites

1: Intended, Else the models just looked way too small to be logical.

Could the attachment nodes perhaps be moved in proportion then? Something like


node_stack_top = 0.0, 0.0920, 0.0, 0.0, -1.0, 0.0, 0
node_stack_bottom = 0.0, -0.0920, 0.0, 0.0, -1.0, 0.0, 0

I understand actually remodeling the parachutes to be taller would be quite tedious, but the flickering caused by the clipping (e.g. when stacking Mk I pod - stack mains - stack drogues) is quite ugly. The Mk I pod merges well with these parachutes without having the attachment nodes inside the model. Screenshots:

Javascript is disabled. View full album

2: Intended as well, allows for better merging on top of pods.

Good point. Would


node_stack_top = 0.0, 0.1534, 0.0, 0.0, -1.0, 0.0, 0
node_stack_bottom = 0.0, -0.1304, 0.0, 0.0, -1.0, 0.0, 0

be an acceptable solution? This allows for good merging between the parachute and the pod, and nearly no clipping when stacking stack parachutes.

3: Barely a detail, but I'll fix it.

Thanks! In the same vein, albeit possibly harder to fix: activating the combo nosecone chute below the drogue cutoff altitude results in the main parachute being deployed through the cover, as this cover is jettisoned when the drogues deploy.

4: There's no god way to pull the parachutes from each other, for now it's barely a forced orientation, I can't do much about it. I was hesitating between two single canopies or two triple canopies, I'll look over in the future if I want to swap back, the single canopies were overly large for their job.

I think two single canopies are the way to go. I don't know of any spacecraft that landed/splashed down on six parachutes.

5: Can you expand on the idea? If you mean that when cutting one parachute, it doesn't turn over to the other side, I haven't seen that.

This is a direct result of the 'forced orientation' thing: the pod does hang from the bottom of the parachute line, it's just that the parachute line is kept at an angle from the vertical. This is probably better than clipping parachutes, I simply wanted to bring it to your attention. Screenshots to clarify my confusing explanations:

Javascript is disabled. View full album

6: No it doesn't because it's not implemented.

This is would indeed explain why it doesn't :).

7: Yeah it's not, like a bunch of things, doesn't really change anything.

This is true (unless you are, like me, too lazy to update from VS2008 and don't have System.Threading. Time to find the VS2012 installer).

Share this post


Link to post
Share on other sites

I'll take note of those stack nodes changes, they do make sense to me.

As for the parachutes hanging weirdly, it is indeed a result of the forced orientation thing. What happens is that this forced orientation is fixed in space and doesn't turn with the craft. I'm currently working on a better way to do that, but quaternions are a really messy thing. I can see about removing this orientation once one of the parachutes is cut.

Share this post


Link to post
Share on other sites
quaternions are a really messy thing.

They are, and this is coming from a student in mathematics.

Share this post


Link to post
Share on other sites

Hey guys, I had a few reports of some people having the MechJeb or KER giving "infinite" mass in the display, even though the mass was normal. Apparently recompiling the plugin fixes it, so if you have that problem, head to the OP, there's a download link to a .dll that should fix it.

Share this post


Link to post
Share on other sites

Yep, that fixed my issue. I did notice that the file size of the .dll went from 28672 bytes to 93,399 bytes.

EDIT...never mind...didn't pay attention. The mass is working because the module is no longer working at all. It's just reading the "mass =" of the parts .cfg file. There is no longer any parachute at all in the part.

Edited by RedAV8R

Share this post


Link to post
Share on other sites
Yep, that fixed my issue. I did notice that the file size of the .dll went from 28672 bytes to 93,399 bytes.

EDIT...never mind...didn't pay attention. The mass is working because the module is no longer working at all. It's just reading the "mass =" of the parts .cfg file. There is no longer any parachute at all in the part.

You had a bad download then, the .dll in the download is 28kb :P

Share this post


Link to post
Share on other sites

Nice to see MM files now in the main download. One question though, why are you putting them in other mods' folders? That's not needed, and you just made sure many Mac users will wipe out their mod installs when they follow Windows instructions. Module manager can read it from your own folder, so try to keep RC files in RC folder.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.