rbray89

[1.0][Release-5-0][April 28, 2015] Active Texture Management - Save RAM!

Recommended Posts

When I load the basic version it reduces the textures in the toolbar mod so badly I can't read them and it blacks some of them out completely making them unrecognizable so my question is How can I change the toolbar textures back and let the toolbar use it's normal textures yet reap the results of the other memory saving things this mod does?

It's happening to me as well. Has anyone found a fix or a way to disable Active-Texture-Management from modifying the toolbar? I don't think it's needed to lower the toolbar icons resolution.

Share this post


Link to post
Share on other sites

So, a point of clarification... If I convert all textures to .dds and use the dds loader will ATM still work?

Edited by Bit Fiddler

Share this post


Link to post
Share on other sites

This IS supposed to be placed in GameData like other mods, correct?

Also, am I correct in thinking the version that does NOT have the word "Basic" is the "Aggressive" version?

Edited by JenBurdoo

Share this post


Link to post
Share on other sites
It's happening to me as well. Has anyone found a fix or a way to disable Active-Texture-Management from modifying the toolbar? I don't think it's needed to lower the toolbar icons resolution.

I'm away from my computer, so apologies for asking you all to go on a bit of a scavenger hunt. :)

The answer, Arch, is yes. I noticed that after I installed the newest version of BahamutoD's Armory mod, the toolbar icon was crisp and sharp, even with ATM aggressive installed. So just for grins I took a look at the ATM MM file that came with it (I can't remember if it stays in the BDArmory folder or if it goes into the BoulderCo folder with most other ATM configs, sorry), and decided to copy the same settings to my MechJeb ATM config, and it worked! So now I just use those settings for any mod's ATM config file that has toolbar icons.

It's important to note that you have to get the file hierarchy correct in the config so that it points to the right folder within each mod that contains the toolbar icon image data, but if you're comfortable editing config files this shouldn't be too challenging. :)

So, long story short, yes, BahamutoD has found a way to make the toolbar icons nice and sharp. I just copied his technique for my other toolbar-using mods.

I hope this helps. :)

Share this post


Link to post
Share on other sites
does this conflict with astronomer's visual pack (as they both use 'boulderco' folder)

Nope. I use both just fine. They sit side-by-side in different sub-folders.

Share this post


Link to post
Share on other sites

Any words on .dds compatibility? if I convert my textures to .dds will ATM still compress them the same as if they were png or tga etc?

Share this post


Link to post
Share on other sites
Any words on .dds compatibility? if I convert my textures to .dds will ATM still compress them the same as if they were png or tga etc?

not as-of yet... working to make the cache dds though.

Share this post


Link to post
Share on other sites

Rbray, after a lot of checking I've narrowed my non-clickable KSC issues down to ATM, the problem only exists if ATM is installed. The log is being spammed with "GUIContent is null. Use GUIContent.none".

Share this post


Link to post
Share on other sites
You sir... are amazing. NOW I CAN ACTUALLY TURN MY GRAPHICS UP (if only a little :))

speaking of graphics, I'm getting a glitch where i downloaded everything, but all the textures are white- blanks. :huh: i can't stand it

Any help?

Share this post


Link to post
Share on other sites
speaking of graphics, I'm getting a glitch where i downloaded everything, but all the textures are white- blanks. :huh: i can't stand it

Any help?

I see you are new the the forums, welcome :)

Please be calm while we try to diagnose your issues.

For your part, we will need a bit more information. When did this start happening? Do you have other mods, and if so what are they?

Did you install the mod correctly? (HINT: you should have a BoulderCo and ActiveTextureManagement folder in your GameData folder.)

You refer to a "texture pack" what are you referring to here? ATM is not a texture pack. It overrides the KSP texture loader to cache, (and re-size if specified) all the textures for faster loading and full control over your textures.

Share this post


Link to post
Share on other sites

SO far the only Icon I cannot get to look clear is Contracts Window +. I have it set the override to the same thing that I did for the other icons that were going blurry and it doesn't work. Does anyone know what has to change to make Contracts Window toolbar icon clear??

Share this post


Link to post
Share on other sites

Running b9, KW, Near Future, and Basic tex management: 3.5 GiB...

Aggressive: 3.3 GiB (on runway, i don't dare take flight)

KSP running maximal settings, no scatters.

Why? And/Or Help?

Windows 8.1, 64-bit 8GiB GDDR3, Zotac GTX 560 ti 1 GB GDDR5 (teh new one) -Driver 344.75, i5 4 cores 3.4ghz (2400), 498GiB free of 919 HD.

-SHORT VERSION: Battlefield 4 runs 40fps on High graphics, no probs. Why does KSP with either version of this mod this mod use more ram than a 60GiB game?

Edited by TheFireRodan

Share this post


Link to post
Share on other sites
SO far the only Icon I cannot get to look clear is Contracts Window +. I have it set the override to the same thing that I did for the other icons that were going blurry and it doesn't work. Does anyone know what has to change to make Contracts Window toolbar icon clear??

Seems like you're generating mipmaps for toolbar icons. Icons must not have mipmaps because if you don't use the full texture quality, KSP uses one if the higher mipmaps instead of the original resolution, hence the blurry icons.

EDIT: I thought I was on DDSLoader thread.

Edited by shaw

Share this post


Link to post
Share on other sites

Okay I'm a bit confused here. Is this mod currently working with the latest version or is it having problems? I've completely deleted and redownload KSP. I have no mods installed. Just need to know if this is working as I will not install anything unless this mod works. It's a life saver!

Share this post


Link to post
Share on other sites
have you tried running with -force-opengl?

how would that ever help a RAM issue? especially if minecraft is any sort of reference. *shudder*

-Issue Solved. I tweaked for a half hour and got my ram down to 2.7-2.9GiB.

Edited by TheFireRodan

Share this post


Link to post
Share on other sites
-SHORT VERSION: Battlefield 4 runs 40fps on High graphics, no probs. Why does KSP with either version of this mod this mod use more ram than a 60GiB game?

Why are you comparing Frostbite to Unity?

Also, that seems to be a rather high memory useage for just B9, KW and this Near Future mod. Is NF that big of a package? Sorry, I'm totally unfamiliar with it. I use just over 30 mods, not counting dependencies, including some big ones such as the current BA, EVE (both high def), B9, KW, Interstellar, Infernal Robotics etc, and I only hit 2.5gb ish, without any texture management beyond what Texture Replacer (BA dependency) incurs as default.

It seems you have "tweaked" the issue, but please don't expect Unity to run as well as the likes of Frostbite or Cry Engine.

Share this post


Link to post
Share on other sites
how would that ever help a RAM issue? especially if minecraft is any sort of reference. *shudder*

-Issue Solved. I tweaked for a half hour and got my ram down to 2.7-2.9GiB.

because what we are talking about here is RAM used for the 3D Rendering Engine. and OpenGL uses less RAM to process 3D rendering than DX9. DX9 is the default render for KSP, but you can force it to run under OpenGL or DX11 for that matter, and it will reduce your memory usage drastically. both are done the same way...

create a shortcut to KSP if you do not already have one. and then on the line that says target: type this...

{your KSP install path}\KSP.exe -force-opengl

or

{your KSP install path}\KSP.exe -force-d3d11

you can also tag on to the end another switch "-popupwindow" to force KSP to run as a borderless window.

i.e.

{your KSP install path}\KSP.exe -force-opengl -popupwindow

with either of these 2 methods you will use quite a bit less RAM and allow you to load another mod or 2. or maybe turn EVE up to better quality or maybe just reduce the scaling factor in ATM to get all textures to a better quality.

Edited by Bit Fiddler

Share this post


Link to post
Share on other sites
I see you are new the the forums, welcome :)

Please be calm while we try to diagnose your issues.

For your part, we will need a bit more information. When did this start happening? Do you have other mods, and if so what are they?

Did you install the mod correctly? (HINT: you should have a BoulderCo and ActiveTextureManagement folder in your GameData folder.)

You refer to a "texture pack" what are you referring to here? ATM is not a texture pack. It overrides the KSP texture loader to cache, (and re-size if specified) all the textures for faster loading and full control over your textures.

I'm having a similar issue, except that the lack of texture is only being applied to a few parts. Said parts are 3 of Squad's probe cores (Hexcan and both the1.25m ring and 2.5m ring) and two of the xenon tanks under the propulsion tab (radial and iirc the medium sized cylinder tanks). I am using the 7-4 (not the basic, which I think means I have the aggressive version) release, and there isn't an error log to document to go with this.... I first noticed this glitch while working on installing RSS/RSO but I have tried this on my regular .25 game install as well (with the same parts turning up without their textures). While I do have a slew of other mods, these parts were fine until after I installed ATM-- I've been using the 64bit version for my standard game and I haven't needed it until I tried firing up the 32bit side (part of my troubleshooting other issues with RSS/RO :P).

At any rate, I love the mod and I've considered it a must have until I started messing with the 64bit game. I'm not sure what else is relevant right now, but I'll answer any questions to help fix this.

Share this post


Link to post
Share on other sites
Why are you comparing Frostbite to Unity?

Also, that seems to be a rather high memory useage for just B9, KW and this Near Future mod. Is NF that big of a package? Sorry, I'm totally unfamiliar with it. I use just over 30 mods, not counting dependencies, including some big ones such as the current BA, EVE (both high def), B9, KW, Interstellar, Infernal Robotics etc, and I only hit 2.5gb ish, without any texture management beyond what Texture Replacer (BA dependency) incurs as default.

It seems you have "tweaked" the issue, but please don't expect Unity to run as well as the likes of Frostbite or Cry Engine.

My point was purely memory usage, as my BF4 client doesn't use 3.5 GiB regularly, despite the textures being multiple times higher res. I don't expect different engines to run at the same speed, assassin's creed unity says it all. Its just, for any game, that is insanely high ram usage coming from seemingly nowhere.

Share this post


Link to post
Share on other sites
My point was purely memory usage, as my BF4 client doesn't use 3.5 GiB regularly, despite the textures being multiple times higher res. I don't expect different engines to run at the same speed, assassin's creed unity says it all. Its just, for any game, that is insanely high ram usage coming from seemingly nowhere.

BF4 although it has 60 Gig of assets, will only need to load the assets for a given map or level. KSP on the other hand has to load all of the assets into memory because the entire game is 1 huge map/level. KSP has to have all of the assets ready to go in case they are needed.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.