Jump to content

[1.0][Release-5-0][April 28, 2015] Active Texture Management - Save RAM!


Recommended Posts

I have like 20 mods, and when I install this one (no matter if its basic or aggressive), it turns 99% of the textures white, including, but not limited to: parts and most icons, excluding, but not limited to: planets, KSC, terrain, water and ̶a̶s̶t̶r̶o̶n̶a̶u̶t̶s̶ kerbonauts. Also, I cannot choose a flag. When I remove it, it's ok. I don't know if it's conflicting with something or what, but when I don't have other mods (only this one) it works just fine.

If there's a way to fix it or some information is needed, please reply.

Link to post
Share on other sites
I have like 20 mods...

If there's a way to fix it or some information is needed, please reply.

I think we need to know what version of KSP you're running, first and foremost. I used ATM with .90 and it worked pretty much flawlessly. I never had the issues you're seeing. But I also ran 25-50 mods through several different setups, so it may also be helpful to know what other mods you might have that alter textures or texture management?

Link to post
Share on other sites
I have just installed astronomers visual pack, this works with that right?

In a word, yes. Not only does ATM work with Astronomers Visual Pack, from what I remember it's almost required to have ATM in order to have enough ram freed up to use the visual pack.

Of course, that could be another visual pack that I'm thinking of, but it's still a good idea.

Link to post
Share on other sites
In a word, yes. Not only does ATM work with Astronomers Visual Pack, from what I remember it's almost required to have ATM in order to have enough ram freed up to use the visual pack.

Of course, that could be another visual pack that I'm thinking of, but it's still a good idea.

Thankyou. I do have a bunch of other mods installed so i dont know if it will work. Can i use ATM and opengl at the same time?

Link to post
Share on other sites
I've been using ATM up through the .90 release(s), and it worked great. It doesn't help much in 1.02, however, as everyone has already talked about. What worked for me, using a GTX-660 Nvidia card, was the -force-d3d11 flag at the end of the shortcut's target. Dropped from 3.6GB RAM usage at startup (right at the x86 version of the game's limit, in Win7 x64, for reference) to 1.8GB! Chopped memory usage IN HALF, outright.

For other graphics cards, this may not be helpful. Forcing OpenGL may work instead.

Am I correct to assume that the game defaults to DX9? Is that why the DX11 flag works so well?

SAVIOR!! Big thanks man. I just tried that and got my ram down from slightly over 3,6GB which was crashing within a few minutes of startup. Just applied as the startup parameter on steam and its now only taking ~2,3GB (I have a lot of mods installed).

Really recommend people to try this.

Link to post
Share on other sites

It does not crash on my install.

Check to be sure your "Squad/Spaces/LargeCrewedLabInternals/Glass" file is not corrupted. I don't know how you did your install, (I have an original download game folder which I copy and used the copied game to play with.) but either get another copy of that file from Steam, or your back up copy of the game and try again.

Or add Squad/Spaces/LargeCrewedLabInternals/Glass to the ATM Configs file for Squad.

(I don't know what I am doing in the configs or I would just do up the lines you need to add, Maybe someone who knows what they are doing can post the lines to add to the Squad.cfg file to exclude the glass.png from being compressed by ATM.

Link to post
Share on other sites
I tried it and it still crashed.

Creating an exclusion in the ATM configs for the file did work though.

Great, glad to hear the exclusion worked... I have had to create a couple of exclusions for my game. (which was copy another config and edit it and hope it was right.) IF you get bad toolbar icons, ATM is the cause and you need to make exclusions for those icons..

Link to post
Share on other sites

While I've sent a couple of pull requests to fix ATM icons, it seems to me that in the 1.0 world of mostly DDS textures, ATM has become more trouble than it's worth, I fear. I'm still very grateful for the effort put into it, since it was a great boon in earlier releases.

Link to post
Share on other sites

Is it possible to make ATM ignore certain testures? Currently it breaks almost all GUI icons that are added by mods, and IVAs like ALCOR and KSO have blurry text on their dash panels, which makes them unusable.

It still saves much RAM, mainly by recompressing. Can't play without it - not that I have much mods, but still... And OpenGL is incompatible with Scatterer, which I am addicted to.

Link to post
Share on other sites
Is it possible to make ATM ignore certain testures? Currently it breaks almost all GUI icons that are added by mods, and IVAs like ALCOR and KSO have blurry text on their dash panels, which makes them unusable.

It still saves much RAM, mainly by recompressing. Can't play without it - not that I have much mods, but still... And OpenGL is incompatible with Scatterer, which I am addicted to.

Yes, by editing the corresponding config to make an exclusion.

If there isn't a config for the mod, make one.

Link to post
Share on other sites
I have like 20 mods, and when I install this one (no matter if its basic or aggressive), it turns 99% of the textures white, including, but not limited to: parts and most icons, excluding, but not limited to: planets, KSC, terrain, water and ̶a̶s̶t̶r̶o̶n̶a̶u̶t̶s̶ kerbonauts. Also, I cannot choose a flag. When I remove it, it's ok. I don't know if it's conflicting with something or what, but when I don't have other mods (only this one) it works just fine.

If there's a way to fix it or some information is needed, please reply.

I have like 58 mods 4/5 of them are larger, and I have only one white texture for 1 small mod icon. Without this mod I probably won't start this game at all:kiss:

If I were you I'll start again with active texture management, add 1 mod at a time, start the game, wait for ATM do his job,

I did with mine, add like 10 little mods at a time and wait for ATM do his job

Link to post
Share on other sites
I've been using ATM up through the .90 release(s), and it worked great. It doesn't help much in 1.02, however, as everyone has already talked about. What worked for me, using a GTX-660 Nvidia card, was the -force-d3d11 flag at the end of the shortcut's target. Dropped from 3.6GB RAM usage at startup (right at the x86 version of the game's limit, in Win7 x64, for reference) to 1.8GB! Chopped memory usage IN HALF, outright.

For other graphics cards, this may not be helpful. Forcing OpenGL may work instead.

Am I correct to assume that the game defaults to DX9? Is that why the DX11 flag works so well?

Seems to work for me as well (GTX 780 Ti on 1.0.2). So far no crashes. Thx bud!

Edited by Rusk
Link to post
Share on other sites

hi

First, thank you for this MOD

Second, can you please explain this setting?

###  Offload the texture from RAM into Graphics memory.
### this will mean the textures cannot be sampled by
### the scripts, but saves a LOT of memory. MBMs are
### not readable by default.
make_not_readable = false

WHAT exactly do we not make readable? GPU RAM? Whether I use true or false it goesn't change a thing. My nVidia GTX970 uses only 365MB or RAM, only. Whereas system RAM size grows up to 6GB. How exactly can I force KSP to use GPU RAM instead of system RAM?

Third: how can i prevent icons to be resized?

CAppu6F.png

I used these parameters of minimum size to be 256 and compress=false to avoid icons to be resized and it just doesn't work:

###  Specifies a maximum dimension for both width and height
### of textures, AFTER any scalling. ie. if this is set to
### 256, and you have a 1024X1024 texture and scale set to 2,
### the resulting texture will be 256x256. Use it without
### scalling to only shrink larger textures.
max_size = 0
min_size = 256
### Compression flag. Compress all textures that
### can be. This includes textures in packs that don't
### have config files. Will reduce quality slightly.
### Not recomended for normal maps.
compress = false

Worse, as you can see some icons are resized and some are not. This is weird.

Since as far as I know there is no manual or wiki, can you please specify in your first post the parameters values of ActiveTextureManagerConfig.cfg ?

BTW I am curious to know why I am the first to ask for that :)

Quatro: can you please update the first post too explaining when we have to purge the ActiveTextureManagement\textureCache ?

Do we have to do it each time we add a plugin or is it dynamic?

Do we have to do it each time we modify ActiveTextureManagerConfig.cfg or is it dynamic? I think it is not dynamic.

thanks for the help!

You mod is so useful and a must have, I wish it becomes stock one day

THANK YOU for making the game playable again :)

Edited by scavenger
Link to post
Share on other sites
This mod almost doesnt work (different is +/- couple of MB RAM) so i have a question: is there any other mod for texture compression?

This mod, while working, is not really necessary on the current version of KSP, since the game and most mods are now using dds for the texture storage.

The only other thing I could suggest would be to use the -force-opengl option. On my game, with >90 mods, the memory usage at initial startup goes down from 3.7 gig to about 2 gig

Link to post
Share on other sites
This mod, while working, is not really necessary on the current version of KSP, since the game and most mods are now using dds for the texture storage.

The only other thing I could suggest would be to use the -force-opengl option. On my game, with >90 mods, the memory usage at initial startup goes down from 3.7 gig to about 2 gig

Yeah, but opengl has poor performance, I have 2x less frames at big ships, so I need another way to compress textures (especially dds)

And with 2 mods (Environmental Visual Enhancements and Kopernicus) you have more than 3 GB RAM, other mods only add couple of MB RAM

Edited by popos1
Link to post
Share on other sites
Another way, it's Force d3d11. With the Direct X 11 you share most of the textures works with yours GPU. It works for me better than OpenGL, but with poor performances.

It works for me as well as DX9 (in usage of RAM but performanse is worse than the DX9 but not too much)

Edited by popos1
Link to post
Share on other sites

I just wanted to give a big thanks to this mod's developer, because it alone has allowed me to play KSP again.

I haven't played KSP that much in the last few months, since beta. With 1.0.4 downloaded, I started up KSP with no mods. I noticed right away that, even with the graphics settings turned down to the minimum, I was getting very poor performance. Mind you, my circa-2008 laptop (Dell XPS-M1530, 3GB RAM) didn't get me great performance even back in 0.24, but it was perfectly playable. Now, though, the lag was horrendous. I guess that the increased scope of the game has increased its RAM footprint since beta. The worst slowdowns happened whenever Kerbin was in view. When looking into the sky and when in the map screen, the framerate jumped dramatically.

I couldn't determine my FPS accurately (switching between situations that caused and relieved slowdowns, the debug-menu FPS counter did not respond much), but it was slow enough that I could actually count the frames myself. I estimated that during slowdowns, I was pulling a whopping 8 FPS. Yes, eight--not quite a slideshow, but it made launches take an unacceptably long amount of time.

Nonetheless, I wanted to play around with the new aero, parts, and other improvements made since beta, so I persevered despite the lag. Several launches later, when switching to the launchpad screen, the game crashed. I looked at the error log, and saw a familiar report: mono.dll caused an Access Violation (0xc0000005); 95% memory in use. I ran out of RAM. (I used to run into this issue with the Outer Planet Mod installed in beta.)

Back in 2008 when I got my laptop, there were real concerns that 64-bit Windows Vista would cause driver issues, so I opted for 32-bit Vista. I've since come to regret this decision, especially when I found out that KSP's Unity has problems with 32-bit Windows and Dual-Core processors, which happens to be just my situation (Core-2 Duo). I happen to have a dual-boot installation of 64-bit Linux Mint, so I tried to run KSP under that OS. In addition to being 64-bit, Linux Mint has a comparatively small memory footprint, so there was more free RAM to go around. KSP launched successfully, and I had much more free RAM available. Unfortunately, it ran even slower than in Windows. Even navigating the title screen menu was painfully slow. I guess this is because, in Linux, Unity runs on a sort of emulation mode, and is thus slower.

Another fix for the 32-bit Windows/Dual-Core issue is to make sure that extended ram support was turned on. After some investigation, I found out that it already was turned on.

I was about ready to give up on trying to play KSP again; I thought that my laptop just wouldn't cut it anymore with the newest KSP. There was one last hope, though: Active Texture Management. Recent posts in this thread generally say that it doesn't do much for stock KSP, so I didn't think that it would do anything. It was worth a shot, though.

ATM installed and a couple minutes later, KSP was up and running. This time, it was smooth as butter! I played for a few hours today, and thus far, there are no more issues.

Recent posts say that ATM doesn't do much for stock KSP. I'm here to report that, in my case, this assessment cannot be further from the truth. For me, the difference was night and day. I can play KSP again!

Edited by bv1
Paragraph formatting
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...