rbray89

[1.0][Release-5-0][April 28, 2015] Active Texture Management - Save RAM!

Recommended Posts

Just Google it: Nathen Active Texture Management Config. Sorry but I'm on mobile, it's difficult to link the thread.

Share this post


Link to post
Share on other sites

I was stupid - tried this mod in 1.0.4, although I clearly don't need it.

Running in OpenGL is a much better option.

But.. How do I undo what it's done to my base textures? They are all very poor quality now.

I tried re-adding it to my gamedata and putting everything to False, even in the global file.

It's clearly not acting on my textures now, but it wont restore the old ones.

Any help?

Share this post


Link to post
Share on other sites
But.. How do I undo what it's done to my base textures? They are all very poor quality now.

I tried re-adding it to my gamedata and putting everything to False, even in the global file.

It's clearly not acting on my textures now, but it wont restore the old ones.

Any help?

As far as I know, ATM keeps a cache of the textures that it downgraded in a cache folder inside the ATM directory. You need only remove ATM from your GameData folder to revert the changes. If I am wrong, somebody please correct me, but I do believe that is how you go about undoing the changes that ATM makes.

Share this post


Link to post
Share on other sites

Is there any way I can tell ATM NOT TO COMPRESS textures smaller than certain size?

I am a mod friendly player and frequently install new mods so I'm sort of tired adding config files for each mod manually

Share this post


Link to post
Share on other sites
Is there any way I can tell ATM NOT TO COMPRESS textures smaller than certain size?

I am a mod friendly player and frequently install new mods so I'm sort of tired adding config files for each mod manually

Submit pull requests to github to fix the mods you use? I did when I used ATM. (PS, rbray, I've got an open one for Connected Living Space).

Share this post


Link to post
Share on other sites
Submit pull requests to github to fix the mods you use? I did when I used ATM. (PS, rbray, I've got an open one for Connected Living Space).

That's no what I'm asking. I can write a simple config file myself. It's that I don't want to. I want to be able to tell ATM not to bother with small PNG files (icons) at all.

Share this post


Link to post
Share on other sites
That's no what I'm asking. I can write a simple config file myself. It's that I don't want to. I want to be able to tell ATM not to bother with small PNG files (icons) at all.

I agree that would be nice... but it hasn't happened, for all that ATM has smooshed icons forever. All I'm saying is, if you write a simple config file yourself, spare other people having to bother, just as I hope I have done for some mods you use.

Share this post


Link to post
Share on other sites

Can someone explain why my textures remain blurred even after I removed ATM and completely deleted its folder from /GameData folder (removed texturecache). Most textures are displayed normally now, but some of them (Chatterer icon, RealChute and Targetron) are still blurred. I deinstalled those mods with CKAN, cleaned their folders and re-installed them again - the icons are still blurred, what's happenning?

Share this post


Link to post
Share on other sites

Hello world !

Nice as a mod, but I see no difference.

My KSP and its mods , launch , uses 3127 Mb RAM, with or without the Active Manager Texture BASIC X86

It's works with a version of Windows 7 x64 ?

I must make special handling after installation (via CKAN ) ?

I must continue to use -force -opengl on ksp.exe ?

Thank you and sorry for my bad english...

Share this post


Link to post
Share on other sites

Has anyone else suggested making this a standalone application so it doesn't have to deal with KSP's ram limits itself? If not, could be a good idea.

Share this post


Link to post
Share on other sites
As mentioned above, ATM does little in the 1.0 world. You're better off trimming unwanted parts: http://forum.kerbalspaceprogram.com/threads/101309-Script-AutoPruner-v1-1-Prune-those-parts-that-suck-up-your-RAM!-%282015-018%29 may help

not completely true. My 1.0.4 install will crash on load without ATM to manage the planetary textures - all planetary texture packs are still mostly non-DDS since no one has been willing to completely update them while the next EVE version remains in heavy development. Any older mods that still work in 1.0.4 (mostly part mods) will also have non DDS textures that you'll want ATM for - especially the ones that still use TGA files!

Share this post


Link to post
Share on other sites
Can someone explain why my textures remain blurred even after I removed ATM ...?

Check Settings->Texture Quality is at Full Res?

Share this post


Link to post
Share on other sites

Is there any precedent for the game to yell at you for "Too many heap sections" while it's loading while using this mod?

*EDIT* Yeah, I'm getting an error that says "Fatal error in gc: Too many heap sections." Here's the error files:

https://www.dropbox.com/sh/af3ux4tp69u6ycf/AAAJzLljyhCgETFXx306A3cBa?dl=0

Can anyone make heads or tails of this?

Edited by Fox62

Share this post


Link to post
Share on other sites

I really can't play without this mod with my larger load order, but it keeps making all the Infernal Robotics textures black. Is there a way to fix this? Can we expect an update on that? The guys over at Infernal Robotics say the fault lies with this mod, though I'm not entirely sure what is happening. I also tried the 'fix' stated on their thread, but that didn't work.

Edited by Budz42

Share this post


Link to post
Share on other sites
I really can't play without this mod with my larger load order, but it keeps making all the Infernal Robotics textures black. Is there a way to fix this? Can we expect an update on that? The guys over at Infernal Robotics say the fault lies with this mod, though I'm not entirely sure what is happening. I also tried the 'fix' stated on their thread, but that didn't work.

You can use ATM configuration files to completely exclude IR from consideration.

Share this post


Link to post
Share on other sites

Is this safe to run in 1.0.4?

Haven't it downloaded but I've a feeling I'm gonna need it at this rate!

Share this post


Link to post
Share on other sites
You can use ATM configuration files to completely exclude IR from consideration.

The 'fix' he referenced included a config to make ATM ignore IR but that doesn't actually seem to work, I don't have the link handy but it was a recent discussion on the IR thread

Is this safe to run in 1.0.4?

Haven't it downloaded but I've a feeling I'm gonna need it at this rate!

Works just fine, cept for the IR issue noted above

Share this post


Link to post
Share on other sites
Is this safe to run in 1.0.4?

Haven't it downloaded but I've a feeling I'm gonna need it at this rate!

Is it safe to run? Yes (if you don't mind it mangling your icons). Does it do much? No, unless you have mods with the older non-DDS textures and don't convert them yourself (which is easy).

The 'fix' he referenced included a config to make ATM ignore IR but that doesn't actually seem to work, I don't have the link handy but it was a recent discussion on the IR thread

I would write my own if I used IR and ATM. ATM config files are not very deep magic.

Share this post


Link to post
Share on other sites
(if you don't mind it mangling your icons)

This only happens if you use the Aggressive version. The Basic version by default (which are the configs I use) will not compress things enough to notice any change to your icons

I would write my own if I used IR and ATM. ATM config files are not very deep magic.

It's been tried (this is from the IR Rework OP FAQ), apparently there's something on ATM's end that needs to be fixed. I tried it myself before even seeing that config and it didn't work. Some workarounds are included. This is the fix I believe Budz42 was referring too

Share this post


Link to post
Share on other sites
This only happens if you use the Aggressive version. The Basic version by default (which are the configs I use) will not compress things enough to notice any change to your icons

Oh really? Then why did I write https://github.com/rbray89/ActiveTextureManagement/commit/8216c3b6ace916551d236f6ccf6eb774dd7e1ce0 ?

Hint: I've never used the Aggressive version. If the Basic version doesn't smoosh your icons, it's because of some combination of the KSP "Texture Quality" setting (which does affect the behaviour) and configuration files in ATM written for you (by people like me).

It's been tried (this is from the IR Rework OP FAQ), apparently there's something on ATM's end that needs to be fixed.

I didn't look into that at the time because ATM was becoming increasingly irrelevant in the new world of DDS textures, but that ATM configuration is obviously bogus both because of the spurious whitespace and because those regexes don't recurse into subdirectories (like the ones where the textures actually are).

So, I suspect what I first said is true: ATM config files are not very deep magic.

PS: rbray, I've had another open pull request for a while fixing CLS's icon... and I have a sneaky suspicion, even though I don't use IR, I'm going to end up fixing this one, too.

Edited by damerell

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.